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Documentation

Documentation
The following manuals describe DesignFreeQ for Microsoft Windows  
Apple IOS.

Before using this manual, however, you will need to install DesignFreeQ  
Instructions are contained in the Getting Started part of  the Tutorial that 
came with DesignFreeQ. After installation, we  encourage you to con-
tinue on with the tutorial exercises included in that manual. This will 
familiarize you with the tools, features and commands of  DesignFreeQ 
and enable you to  maximize your productivity in the shortest amount of  
time.

Manual Layout
The DesignFreeQ documentation consists of  the following:

 • Reference Guide
 • Getting Started and Tutorials 

The graphics used in these manuals alternately display the supported 
platforms.

Reference Guide
This manual describes how to use DesignFreeQ including all its perti-
nent tools and commands. If  you want information on a particular tool 
or command, simply look it up in the Index. Finally there is a Task Index 
which groups various tasks according to their functions.

Parametrics
This Reference Guide also includes an in-depth look at the integrated Par-
ametrics, that may be a new feature to you. You can use DesignFreeQ to 
perform your daily tasks without understanding Parametrics, but if  you do 
a lot of  repetitive drawing or modifications of  existing drawings, you will 
find this feature an invaluable time saver. It is particularly useful if  you 
are a member of  a design team that works on the same parts.

3D Modelling
The second part of  this Reference Guide describes the 3D modelling pro-
cess in DesignFreeQ. 

Even DesignFreeQ offers a seamless transition from 2D to 3D, you 
should already know how to use the 2D tools and commands that are de-
scribed in detail in the first part of  this manual.

Tips and advanced user 
notes are displayed in the 
margin throughout the 
manual. You don’t need to 
know this infor mation to run 
DesignFreeQ. If you are a 
novice user, you may want 
to skip it entirely. 
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Appendices
At the end of  this manual you find several appendices with additional in-
formation about specific settings for some DesignFreeQ components.

Operators and Units
This section describes all Operators and Units which are  accepted by all 
DesignFreeQ entry boxes.

Special Characters
This section lists all the special characters and symbols you can use in 
DesignFreeQ which are not directly available from the keyboard.

Date Interfaces
This appendix contains additional information about the Data Interfaces 
integrated into DesignFreeQ.

Plotter Fonts
This section lists all plotter fonts available in DesignFreeQ that you can 
use in addition to the PostScript and TrueType fonts that are installed on 
your computer.

Hatch patterns
DesignFreeQ contains a library with many ISO and DIN hatch patterns. 
This appendix lists all with DesignFreeQ available hatch patterns and 
describes as how you can define your own hatch patterns and add them 
as .pat files to the DesignFreeQ hatch library.

Registration
The Customer Services are described in the Appendices section. This appen-
dix provides technical support, registration and update information. We'd 
really like to encourage you to return the registration card for Design-
FreeQ, conveniently located inside your software box. 

For such a minor investment of  time, you'll become a registered custom-
er. Only by registering DesignFreeQ, are you entitled to receive Tele-
phone product support and Free updates.
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Creating Geometry

Creating Geometry 
This chapter describes how to create the geometric objects that are the 
building blocks for your designs. It also describes how the Design Naviga-
tor helps you design faster and easier. The following topics are contained 
in this chapter:

 • Drawing Techniques
 • Drafting Aids
 • Drawing Tools

This chapter requires that you know how to open or save a file or how to 
use a Zoom-tool. If  you are unfamiliar with Windows programs see the Get-
ting Started section in the Tutorial.

Function Palette
Drawing begins with the Tool palette, located at the left of  the Design-
FreeQ drawing area shown below:

 

The Tool palette has six sub palettes of  tools that you can use to create 
geometric objects. These six tools are the drawing tools.

 

You will find more about the 
 functionality of the Design 
Navigator in Chapter 3.
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Drawing Techniques
Most drawing tools allow two methods of  creating an object: clicking and 
dragging.

Clicking This method allows you to create objects by clicking 
points with the mouse. The benefit of  this technique is 
that you can perform unrelated activities, such as zoom-
ing, while you are creating the geometry.

Dragging  The drag method allows you to indicate two points by 
dragging from one to the other. Press and hold down 
the mouse button to set the first point. Next, drag the 
mouse to the location for the next point and release 
the mouse button. The benefit of  this technique is that 
a rubberband image appears during the construction to 
show you how the object will appear once you release 
the mouse button.

You can use either or both methods to construct most objects.

To help make object creation easier, DesignFreeQ's tools contain a fea-
ture we call Smart Pointers. As you work with a tool, the tool icons show 
you the points you must indicate to create an object with the tool.

 

Each dot on the icon represents a point you must place either by clicking 
or by dragging. In addition, the Smart Pointer indicates the order for des-
ignating points as you are drawing the geometry.

Creating a line by clicking 
1. Select the Single Line tool from the Tool palette.

 

2. Move the pointer to the drawing area and click to set the starting 
point of  the line.

3. Move the pointer to the desired location for the endpoint of  the 
line and click.

 

Click at the beginning point of the line

Click at the endpoint of the line

 The line is drawn between the two point.

 

 Immediately after construction, you can make changes in the Status 
Line to alter the length or position of  the line. If  the geometry isn’t 
satisfactory, just press the Backspace key.

Creating a line by dragging
1. Click the Single Line tool in the Tool palette.

 

2. Move the pointer into the drawing area.

3. Press and hold down the mouse button at the desired location for 
the starting point of  the line.

4. With the mouse button still held down, move the mouse to the de-
sired location for the endpoint of  the line.

 

Press and hold the mouse button
at the starting point of the line.

Drag the mouse until the line is the length
you want. Release the mouse button.

5. Release the mouse button to set the endpoint.

If you use the clicking 
 method to draw a line no 
rubberband line guides you.

Notice that  when you drag 
 between points, a rubber-
band line guides you. If you 
use the clicking method, 
you can perform unrelated 
activities, such as zooming, 
between clicks.
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 Immediately after construction, you can make changes in the Status 
Line to alter the length or position of  the line. If  the geometry is 
not satisfactory, just press the Backspace key.

Drafting Aids
For creating geometry objects the DesignFreeQ user interface provides 
the following drafting aids:

 • Drawing area
 • Message Line
 • Smart Mouse Pointer
 • Status Line
 • Drawing Tools

Drawing Area
All objects are created, modified and annotated on the drawing area. You 
can imagine this drawing area as an infinite large sheet of  paper on which 
you can create any type of  geometry object at its original size. Using the 
Scroll bars on the left and lower side of  the drawing window you can 
move the sheet up and down or right and left. You can display different 
parts of  the drawing sheet by dragging the slider of  a scroll bar to the 
approximate location.

Message Line
The Message Line across the top of  the drawing area provides concise 
instructions for the use of  the current tool.

For example, after selecting the Center-Point Circle tool, the Message 
Line appears as illustrated below:

 

Center-Point Circle: Pick center. [Option = Copy previous]

The instructions in the Message Line for some tools also indicate op-
tional activities. For example, if you hold down the Control (Windows) or 
Option (Macintosh) key while using the Center-Point Circle tool, the 
next mouse click creates a copy of  the last circle with the center placed 
where you clicked.

Smart Pointer 
When you select a tool and move the pointer into the drawing area, the 
pointer shape is representative of  the tool. 

Some of  the pointers, like the single line pointer, are simple cross-hairs. 
Others, such as the Opposite-Point Circle pointer, resemble the tool 
itself.

The pointer, called a smart pointer, displays indicators for multi-step pro-
cedures. Each smart pointer has a dot, the hot spot, showing the next point 
you should specify. The dot changes position on the pointer during each 
step of  the construction.

  

Hot Spot

The smart pointer shows you where to click next.

For example, the Opposite-Point Circle pointer illustrated above shows 
that the first click of  the mouse places a point on one edge of  the circle 
you’re creating. After you click a location, the hot spot moves to the oth-
er side of  the pointer, showing that the next click places a point on the 
opposite edge of  the circle.

 

Your first click

The hot spot moves to the other side of the 
smart pointer to indicate the next step.

After you click the second location, the circle appears. The hot spot 
moves back to its original position on the pointer so that you can create 
another circle.
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The Status Line
Whenever you select a tool from the Tool palette, the Status Line appears 
along the bottom of  the drawing area. It contains boxes giving informa-
tion about the current construction. For example, when the Single or 
Connected Line tool is the current tool, the Status Line  contains boxes 
for the x, y and z coordinates of  the beginning point and the x, y and z 
values for the endpoint of  the line. It also contains the value of  the length 
and angle of  he line.

 -.425X -.432Y 8.25 0dY 8.25dX 0L A

You can use the Status Line in three ways:

 • To create an object with keyboard entries only.
 • To edit an object that was just created and is still selected.
 • To create an additional object using the current tool.

Whenever you construct an object, the status box containing the specifi-
cation that you are most likely to change is selected (the box is highlight-
ed).

For example, when you draw a line with the Single Line tool, the 
Length box is highlighted so you can enter a value for the length. Just 
type a value. When you press Enter the line is redrawn at the new length.  

Using the Status Line
If  you want to make an entry in a different status box, you can use one 
of  four selection methods:

 • Press the Tab key to cycle the selection highlight through the 
status boxes from left to right.

 • Click inside the status box and the pointer becomes an I-beam 
text cursor.

 • Click the box label to select the entire contents of  the box.

 • Double-click inside the status box to select the entire contents 
of  the box.

Using the Status Line with Drawing Tools
Once you have drawn an object, you can adjust its specifications such as 
length, angle, and location in the status Line. You must make these changes 
immediately, before you construct another object, select a different tool, 
or choose a command. You can make only one series of  changes in the 
status line (in as many boxes as necessary); after you press the Enter key 
DesignFreeQ redraws the object to your specifications. Once you have 
pressed the Enter key, you must make subsequent changes with the Edit 
Objects command in the Edit menu.

Try the following exercises to create and change a single line with the 
Status Line.

Altering geometry in progress with status boxes
1. Select the Single Line tool.

2. Click 2 locations in the drawing area.
 The length (L) box is highlighted in the status line.

3. Type 3.
 The 3 is entered directly in the L box.

4. Press the Tab key to select the next status box.
 The angle (A) box is now highlighted.

5. Enter 15.

6. Press the Enter key.
 Pressing the Enter key completes the data entry for this object.  

The line is redrawn 3 units long and at a 15° angle.

Creating additional geometry with status boxes
1. With the Single Line tool still selected from the previous example, 

click 2 more points. 

You can set the number of 
decimal places or fractional 
round off with the precision 
entry in the Units dialog 
box from Preferences in the 
Layout menu.

You can enter up to 10 
characters in each Entry 
field of the Status line. 
Notice how each method 
affects the selection of the 
contents of the status box. 
Clicking once inside the box 
places the cursor where you 
clicked. If you double-click 
inside the box, the entire 
entry is selected so you can 
change it.  
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2. Type 4.

3. Press the Tab key and type 25.

4. Press Enter.
 Another line is drawn. 

Creating new geometry with status boxes
1. Select the Selection tool so the Single Line status box clears.

2. Click the Single Line tool again.
 The X status box is active, showing that you can enter a value for 

the X coordinate of  the beginning point of  the line.

3. Type 0.
 Note: Do not press Enter until you reach step #10.

4. Press the Tab key.
 The Y box is highlighted. 

5. Type 0. 

6. Press the Tab key.
 The dX box is highlighted. The dX value is the delta X, the numeric 

difference between the beginning and ending X coordinate.

7. Type 2.

8. Press the Tab key.
 The dY box is highlighted. 

9. Type 2.

10. Press the Enter key.
 The line is drawn.

Creating Geometry Offset from a Point
If  you want to create some geometry that is offset from an existing 
point, you can use the Status Line to specify the offset.

Creating geometry offset from a point
1. Select the tool you want to use.

2. Move the pointer over the control point from which you want the off-
set.

3. Click once to lock onto that point.

4. Click in the appropriate X or Y box in the Status Line, placing the 
text cursor at the end of  the entry.

5. Type the offset (such as + 3") and press Enter.

6. Continue with your construction.

Drawing Tools
The following section describes the drawing tools found on the  
Tool palette.

Line Tools

The Line tools on the Tool palette create line segments, connected lines, lines 
parallel to existing lines, smart walls and points. As you create a line, the 
coordinate locations, line length, and angle from horizontal  appear in the 
Status Line.

The line is drawn with the current pen specifications for color, weight, and 
pattern. 

Single Line Tool

This tool draws a line between two points. You can click or drag to draw 
a line.

Using the Single Line tool
• Click two endpoints of  the line.

 Or: 

You must remember that 
when you press the Enter 
key, DesignFreeQ 
constructs the object based 
on the specifications in 
the status boxes. Pressing 
Enter a second time in the 
above example would create 
a  second line with the same 
values. Since the lines have 
the same values, the second 
line overlays the first line 
and you can’t see it. 

The angle and the length 
of the line are calculated 
by the values you have 
 specified. If you specify 
values for the angle and the 
length of the line you don't 
have to enter values in the 
dx and dy status fields and 
vice versa.
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• Drag to indicate the endpoints of  the line; press at the beginning 
and release at the end of  the line. As you drag, you see a rubberband 
line that previews your construction.

Notice that after completing a line the Message Line says Ctrl= copy 
(Macintosh: Option=copy). This indicates that if  you hold down the Ctrl-
key (Macintosh: Option key) and click once in the drawing area, a line will 
appear that is identical to the one just drawn. The location of  the click 
designates the location of  the first point.

 X Y dYdX L A

The Status Line allows you to specify the X, Y coordinates of  the begin-
ning, the relative location of  the end (delta X and  delta Y), the line length, 
and the angle from horizontal. Once a line is drawn, the line Length is 
the selected status box.

Drawing a line perpendicular to another object
1. Construct the line (or spline).

2. Move the pointer to the object until a Design Navigator on notation 
appears.

3. Drag straight away from the object in a perpendicular direction.

4. Drag the extent of  the line.

Drawing a line tangent to or perpendicular to a curve
1. Construct an arc, circle, or ellipse.

2. Choose the Single Line tool.  

3. Move the pointer to the arc until a Design Navigator on notation 
appears. The Design Navigator notation must be on rather than 
endpoint, quadrant, or midpoint.

4. Drag in the appropriate direction (straight out for perpendicular or 
at an angle for tangent) until the Design Navigator perpendicular 
or tangent notation appears.  

5. When the Design Navigator locks on to perpendicular or tangent, 
you can then drag the line around the arc to the  location you want 
and extend the line to the length you want.

Point Tool

This tool creates single points.

Using the Point tool
1. Select the Point tool from the drawing palette. 
2. Click on the drawing area to create a point. The point is indicated by 

a simple cross. Each mouse click creates a single point. If  you click 
twice the same position you create a second point on top of  the first 
one.

 Another way to create a point is by creating a line and setting its 
length to zero. Set the starting point of  the line with the mouse, 
then type 0 in the Length entry field of  the status line and press the 
Enter key.

 

The status line allows you to specify the X, Y and Z coordinates of  the 
point.

Connected Lines Tool

This tool draws lines in which the endpoint of  one line segment is the 
beginning point of  the next.

Using the Connected Lines tool
1. Click or drag to indicate the endpoints of  the line segments.
 If  you click a point and then change your mind, press the Escape 

key to remove the last line. Pressing the Delete or Backspace 
key or choosing Undo removes all connected lines in the current 
 construction.

2. Indicate the last point by double-clicking or by choosing another 
tool.
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If  you want to create a connecting arc between two points rather than 
a line, hold down the Ctrl key (Macintosh: Option key) and then click the 
endpoint of  the segment. You must have constructed one line segment 
before you can use the arc function.

 X Y dYdX L A

The status line allows you to specify the X, Y and Z coordinates of  the 
beginning, the relative location of  the end (delta X and  delta Y), the line 
length and the angle from horizontal. Once the line segment is created, line 
Length is the selected status box.

Parallel Lines Tool

This tool constructs lines parallel to existing lines. Use one of  the fol-
lowing methods for creating parallel lines:

Using the Parallel Lines tool
• Select the Parallel Lines tool, drag the line; press to select the line, 

and release to indicate the position for the parallel line. A rubber-
band line moves with the pointer.

 Or

• Select the Parallel Lines tool, click the line you want to duplicate, 
and then enter a delta distance in the status line and press Enter. 
(This method does not allow you to  control on which side of  the 
original line the new line is drawn.)

 d

The status box allows you to specify the distance between the selected 
line and the parallel line.

Smart Wall Tool

This tool works in much the same way as the Single Line tool except 
that it draws double lines or walls. Walls created on the same layer are 
automatically trimmed to where they touch or intersect. 

 

Overlapping lines are 
automatically trimmed at 
the intersections.

As you drag the mouse, the defining side of  the wall falls on the con-
struction line you drag along. The other side of  the wall automatically 
fills in at the thickness you specify in the status line. The position of  the 
automatic wall depends on your last activity. If  the second wall is on the 
wrong side of  the construction line, press the Shift key to flip it.

 Shift key

Using the Smart Wall tool
1. Select the Smart Wall tool.

2. In the status line, specify the thickness (T) of  the wall.

3. Click or drag to indicate the ends of  the wall segment.
 You can press the Shift key to flip the wall to the opposite side.

4. Continue specifying both endpoints for wall segments, as needed.

If  you delete a merged segment, the remaining walls redraw.

 X YT L A

The status line allows you to specify thickness of  the wall, the X, Y, Z 
coordinates of  the beginning point, the wall length and the angle from 
horizontal. Once the wall segment is created, wall Length is the selected 
status box.

The radius of a arc created 
with the Connected line 
tool can be modified with 
Edit objects command.

The second method allows 
you to control the direction 
of the offset by entering + 
or - in front of the indicated 
values. Entering + offsets 
the object to the right or 
downwards on the screen, 
entering - to the left or 
upwards.

Automatic trimming of smart 
walls occurs only when the 
walls are on the same layer.

If you want to fillet or 
chamfer smart walls you 
have to ungroup them with 
the Ungroup command 
in the Arrange menu. It 
is recommended that you 
place all symbols, before 
you ungroup and fillet/
chamfer the walls, since 
ungrouped walls loose their 
smart features such as auto-
matic trimming. Select only 
the wall segments not any 
placed symbols if you want 
to ungroup a wall.
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Wall symbols
Parametrized symbols with an underlying wall segment like the door sym-
bols you find in the Architect Library will automatically cut wall segments 
where they are placed. When you move the symbol along the wall to 
another position the wall will automatically be closed at the old position 
and be cut open at the new position.

If  you want to use the Smart Wall feature for single lines, you have to 
create the lines with the Smart Wall tool and enter 0 for the thickness of  
the wall.

Arc Tools 

You can use the Arc tools on the tool palette to create an arc by any of  
five methods:

 • Center-Point Arc
 • 3-Point Arc
 • Tangent Point Arc

 • 2 Point Arc/Radius

 • Specified Tangent Arc/Radius

As you create each arc, the status line displays entries such as coordinate 
locations, radius, angle from horizontal, and delta angle.

The arc is drawn with the current pen specifications for color, weight, and 
pattern.

Center-Point Arc Tool

This tool draws an arc from three points: the center point, arc beginning 
point, and arc endpoint.

Using the Center-Point Arc tool
1. Click the center point of  the arc.

2. Click the radius and beginning of  the arc.

3. Drag the extent of  the arc, pressing at the beginning point of  the 
arc and releasing at the endpoint.

You can simply click all three points, but the rubberband arc doesn’t 
 appear when you use this method.

To construct an arc greater than 180°, you must drag, rater than click, 
the endpoint.

 X Y R dAA

The status line allows you to specify the X, Y coordinates of  the center of  
the arc, the length of  the radius, the starting angle from horizontal, and the 
delta angle from the start. Radius is the selected status box.

3-Point Arc Tool

This tool draws an arc through the points you select.

Using the 3-Point Arc tool
1. Click the first position on the arc.

2. Drag or click the second and third positions. (Dragging displays 
the rubberband arc.)

The arc is drawn from the first position that you indicate in the  direction 
of  the next point.  

If  you click on an object while holding down the Ctrl key (Macintosh: 
Option key), the arc is drawn tangent to the  specified object rather than 
through the point. You may  combine the placement of  points to create 
an arc through a specific point of  one object and tangent to another 
 object, or an arc tangent to three objects, or any other combination.

 X1 Y1 Y2 X3X2 Y3

The status line indicates the X, Y coordinates for each of  the three points.

Parametrics works with 
some but not all wall 
configurations. If you 
use parametrics, turn on 
the point display (Show 
Points on the Layout 
menu) and dimension 
to the displayed points 
rather than to the lines. 
Keep in mind that double 
walls obscure the fact that 
smart walls are actually 
single lines.

If DesignFreeQ can't create 
the arc tangent to an object 
it will define an alternate 
construction.
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Tangent-Point Arc Tool

This tool draws an arc beginning at the first point you specify. The sec-
ond point you specify is the direction vector, and the third point you 
specify indicates the endpoint of  the arc. Essentially, the Tangent-Point 
Arc tool first creates a line, then creates an arc tangent to the line, then 
erases the line.

Using the Tangent-Point Arc tool
1. Click the starting point.

2. Click the tangent vector. (The arc is tangent to a line drawn from 
the starting point to this point.)

3. Click the endpoint. The arc is drawn between the first and last 
point you click and tangent to the line between the first and second 
points.

 

First Click Second Click

Third Click

The status line allows you to specify the X, Y coordinates of  the endpoints 
of  the arc and he angle of  the tangent line.

 X Y dX dYA

2-Point Arc/Radius Tool

This tool draws an arc between two points with a radius defined in the 
status line. The Radius must be greater than the distance between the two 
arc-endpoints.

Using the 2-Point Arc/Radius tool
1. Enter a value for the Radius in the status line.

2. Click the starting point of  the arc.

3. Click the endpoint of  the arc.

The arc is drawn clockwise between the two points indicated with the 
radius specified in the status line

While holding down the Ctrl key (Macintosh: Option key), the comple-
mentary arc is drawn clockwise between the two points indicated and 
while holding down the Shift key the arc is drawn anticlockwise between 
the two points indicated.
 

The status line indicates the Radius for the arc.

Specified Tangent-Arc/Radius Tool

This tool draws an arc with a given Radius beginning at the first point 
you specify tangent to the object you select (Arc, Circle or Line).

Using the Specified Tangent-Arc/Radius tool
1. Click the starting point.

2. Select an Arc, circle or a Line.

The arc is drawn from the starting point tangent to the object you select-
ed.

 

The status line indicates the Radius for the arc.

Circle Tools

The Circle tools on the tool palette construct circles by any of  four 
methods:

 • Center-Point Circle
 • Opposite-Point Circle
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 • 3-Point Circle
 • Tangent-Point Circle 

Center-Point uses the center and diameter of  the circle. Opposite-Point uses 
the diameter. 3-Point uses three points or can be tangent to existing ob-
jects. Tangent-Point Circle draws a circle tangent to two  objects, using the 
diameter.

The circle is drawn with the current pen specifications for color, weight, 
and pattern.

Center-Point Circle Tool

This tool draws a circle specified by the center point and diameter.

Using the Center-Point Circle tool
• Click two locations; the first click places the center and the second 

determines the radius, or

• Drag, pressing at the center and releasing at a position indicating 
the radius.

If  you drag the points, a rubberband image guides your con struction. You 
can create a copy of  the last circle by holding down the Ctrl key (Mac-
intosh: Option key) and clicking where you want the center for the new 
circle.

 

The status line shows the X, Y coordinates of  the center and the diameter 
of  the circle. Diameter is the selected status box.

Opposite-Point Circle Tool

This tool draws a circle specified by the diameter.

Using the Opposite-Point Circle tool
• Click two locations to indicate the diameter.
 Or:
• Drag, pressing the mouse button at the beginning and releasing it at 

a position that indicates the diameter.

If  you drag the points, a rubberband image guides your  construction.

 X Y dX 10 0 dX 1 dY 1

The status line allows you to specify the X, Y coordinates representing the 
endpoints of  the diameter.

3-Point Circle

This tool draws a circle through the points you select.

Using the 3-Point Circle tool
1. Click the first point on the circle.

2. Drag or click the second and third points. (Dragging displays the 
rubberband circle.)

If  you place any of  the three points on an existing object, the circle is 
drawn through that point. If  you click an object while holding down the 
Ctrl key (Macintosh: Option key), the circle is drawn tangent to the object 
rather than through the indicated point. You may combine the placement 
of  these points to create a circle through a specific point of  one object 
and tangent to another object, or a circle tangent to three objects, or any 
other combination.

If  you drag the first two points, a rubberband image guides your construc-
tion.

 X1 Y1 Y2 X3X2 Y3

The status line indicates the X, Y coordinates for each of  the thee points.

Tangent-Point Circle Tool

This tool draws a circle tangent to the two objects you indicate.  

If you want to drag a circle 
by its center later on, you 
must use the Move tool, 
since the Selection tool 
doesn't display the center of 
the circle when selecting it.
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Using the Tangent-Point Circle tool
1. Click the objects to which the circle is to be tangent.

2. You can enter a diameter for the circle in the status box.

 D .5

Ellipse Tools

These tools on the tool palette construct ellipses inscribed within an 
 invisible rectangle or parallelogram.

• The 2-Point Center Ellipse uses the center point and one corner loca-
tion of  the rectangle.

• The Opposite-Corner Ellipse uses opposite corners of  a rectangle. 

• The 3-Point Center Ellipse uses the center point, the  midpoint of  a 
side and the corner of  the parallelogram.

• The 3-Corner Ellipse uses three corners on a  parallelogram.

You can click or drag to create the ellipse. Dragging creates a rubber-
band ellipse, so you can see the ellipse before it is drawn.

The ellipse is drawn with the current pen specifications for color, weight, 
ad pattern.

2-Point Center Ellipse Tool 

This tool constructs an ellipse inscribed within the rectangle calculated 
from the two specified points: the center point and one corner of  the 
rectangle.

Using the 2-Point Center Ellipse tool
1. Indicate the center of  the ellipse.

2. Indicate the corner of  the rectangle defining the ellipse.

If  the two points are on the vertical or horizontal axis, a straight line is 
drawn.

You can create a copy of  the last ellipse by holding down the Ctrl key 
(Macintosh: Option key and clicking where you want the center.

 L2YX L1 90°A1 A2

The status line allows you to specify the X, Y coordinates of  the center 
point and the length and angle of  the semi-major and semi-minor axes of  
he ellipse.

Opposite-Corner Ellipse Tool

This tool draws an ellipse inscribed in the rectangle specified by the op-
posite corners you indicate.

Using the Opposite-Corner Ellipse tool
1. Indicate one corner of  the rectangle defining the ellipse.

2. Indicate the opposite corner of  the defining rectangle.

If  the two points are on the vertical or horizontal axis, a straight line is 
drawn.

You can create a copy of  the last ellipse by holding down the Ctrl key 
(Macintosh: Option key) and clicking where you want the lower-left point.

 L2YX L1 90°A1 A2

The status line allows you to specify the X, Y coordinates of  the lower-left 
point and the length and angle of  the major and minor axes of  the ellipse.

3-Point Center Ellipse Tool

This tool constructs an ellipse inscribed within the parallelogram cal-
culated from three specified points: the center point, the midpoint of  a 
side, and a corner of  the parallelogram.

Ellipses do not have  
center points by design. 
If you draw lines between 
 opposite vertex points on 
the ellipse, then the inter
section of the two lines will 
be the center of the ellipse. 
For a 2 point Center Ellipse 
(inscribed in a rectangle) the 
Design Navigator's horizon-
tal and vertical temporary 
construction lines will cross 
at the center point once you 
have touched two vertex 
points.
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Using the 3-Point Center Ellipse tool
1. Indicate the center of  the ellipse.

2. Indicate the midpoint of  the side of  the rectangle defining the el-
lipse.

3. Indicate the corner of  the rectangle defining the ellipse.

If  the three points are on the vertical or horizontal axis, a straight line is 
drawn. You can create a copy of  the last ellipse by holding down the Ctrl 
key (Macintosh: Option key) and clicking where you want the center.

 L2YX L1 90°A1 A2

The status line allows you to specify the X, Y coordinates of  the center 
point and the length and angle of  the sides f  the parallelogram.

3-Corner Ellipse Tool

This tool draws an ellipse inscribed in the parallelogram calculated from 
the three corners you specify.

Using the 3-Corner Ellipse tool
1. Indicate one corner of  the parallelogram defining the ellipse.

2. Indicate another corner of  the defining parallelogram.

3. Indicate the final corner of  the defining parallelogram.

If  the three points are on the vertical or horizontal axis, a straight line is 
drawn. You can create a copy of  the last ellipse by holding down the Ctrl 
key (Macintosh: Option key)  and clicking where you want the lower-left 
corner of  the parallelogram.

 L2YX L1 90°W1 W2

The status line allows you to specify the x, y coordinates of  a corner and 
the length and angle of  the sides of  the parallelogram.

Polygon Tools

These tools on the tool palette draw rectangles, inscribed polygons or 
 circumscribed polygons. Some of  the rectangle tools create single lines 
which are  individual objects or polygonal rectangles that can be  selected 
and edited as a single object. Dragging to indicate the points of  the 
polygon  creates a rubberband image.

The polygon is drawn with the current pen specifications for color, weight, 
and pattern.

Rectangle Single Lines Tool

This tool draws a horizontal or vertical rectangle, using the opposite 
 corners you specify.

Using the Rectangle tool
• Click the opposite corners of  the rectangle.
 Or:
• Drag the opposite corners of  the rectangle.

You can create a square by aligning the second point on the 45° con-
struction line. If  the two points are on the vertical or horizontal axis, a 
straight line is drawn.

You can create a copy of  the last rectangle by holding down the Ctrl 
key (Macintosh: Option key) and clicking where you want the upper-left 
corner.

A default 1-inch rectangle is draw if  you have not previously drawn a 
rectangle.

 YX W H

The status line allows you to specify the X, Y coordinates of  the first 
point, as well as the width and height of  the rectangle. Width is the 
 selected status box.

If  you want to draw a square from the center rather than  opposite 
 corners, use one of  the other polygon tools, specifying four sides.  
You can’t create a rectangle from the center.

Use the entry boxes D and 
Sides in the status line to 
change any polygon when 
first creating it.  After that, 
it becomes a series of 
 separate line objects.

You cannot change the 
Width and the Height of a 
single lines rectangle in Edit 
Objects. You must edit each 
line individually, because 
 rectangles become 4 line 
objects after you deselect 
the rectangle.
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Rectangle Corner-Center

This tool draws a horizontal or vertical rectangle as a single object, using 
the center point and one corner point of  the rectangle.

Using the Rectangle Corner-Center
• Click the center point and one corner point of  the rectangle.
 Or:
• Drag the corner point of  the rectangle (Dragging displays a  rubber 

band).

You can create a square by aligning the second point on the 45° 
 construction line.

You can create a copy of  the last rectangle by holding down the Ctrl key 
(Macintosh: Option key) and clicking where you want the center point.

A default 1-inch square is drawn f  you have not previously drawn a rect-
angle. 

 

The status line allows you to specify the X, Y coordinates of  the center 
point, as well as the angle, length and height of  the rectangle. Length is the 
 selected status box.

If  you modify the Angle in the status line, the rectangle is rotated around 
its  center point when you pres the Enter key.

Rectangle Center-Midpoint-Corner

This tool draws a rectangle as a single object, using the center point, one 
midpoint and one corner point of  the rectangle.

Using the Rectangle Center-Midpoint-Corner
• Click the center point, one midpoint for one side of  the rectangle and 

one corner point of  the rectangle (specifying the distance to the be-
fore defined axis).

 Or:
• Drag the mouse from the center point of  the rectangle to one  midpoint 

and click then the corner point of  the rectangle.

You can create a copy of  the last rectangle by holding down the Ctrl key 
 (Macintosh: Option key) and clicking where you want the  center point.

A default 1-inch square is drawn f  you have not previously drawn a rect-
angle.

 

The status line allows you to specify the X, Y coordinates of  the center 
point as well as the angle, length and height of  the rectangle. Length is the 
selected status box.

If  you modify the Angle in the status line, the rectangle is rotated around 
its center point hen you press the Enter key.

Rectangle 3 Corners

This tool draws a rectangle as a single  object specified by the  3 corners 
of  the  rectangle you indicate.

Using the Rectangle 3 Corners
• Indicate 3 corners of  the rectangle.

 Or:
• Drag the mouse from the first corner to the second corner and click 

then the third corner (specifying the distance to the before defined 
axis). 

You can create a copy of  the last rectangle by holding down the Ctrl 
key(Macintosh: Option key) and clicking where you want the first corner 
of  the rectangle.

A default 1-inch square is drawn f  you have not previously drawn a rect-
angle. 

The third point defines 
the distance from the axis 
defined by the centerpoint 
and the midpoint.

The third point defines 
the  distance from the axis 
defined by the two corner 
points.
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The status line allows you to specify the X, Y coordinates of  the first corner  
as well as the angle, length and height of  the rectangle. Length is the select-
ed status box.

If  you modify the Angle in the status line, the rectangle is rotated around 
its  center point when you press the Enter key.

Inscribed Polygon Tool

This tool draws a regular polygon where the radius of  the circum scribing 
circle determines the location of  the polygon’s vertices. The default poly-
gon is a hexagon, but you can specify the number of  sides in the status 
line. (Note: The status line shows a diameter for the circle, the standard 
way of  describing a polygon inscribed in a circle.)

Using the Inscribed Polygon tool
• Click the center of  the polygon and a point on the circumference of  

the circumscribing circle. 
 Or 
• Drag from the center of  the polygon to a point on the 

 circumference of  the circumscribing circle.

You can create a copy of  the last inscribed polygon by holding down the 
Ctrl key (Macintosh: Option key) and clicking where you want the center.

 YX 6D Sides

The status line allows you to specify the X, Y coordinates of  the center, 
the diameter of  the circle defining the polygon, and the number of  sides. 
Diameter is the default status line selection, and the default number of  
sides is six.

Circumscribed Polygon Tool

This tool draws a regular polygon for which the radius of  the circle 
 determines the midpoint of  the sides. The default shape is a hexa gon, 
but you can specify the number of  sides in the status line. (Note: The 
status line shows a diameter for the  circle, the standard way of   describing 
a polygon circumscribed around a circle.)

Using the Circumscribed Polygon tool
• Click the center of  the polygon and the midpoint of  one of  the 

sides, or 

• Drag from the center of  the polygon to the midpoint of  one of  
the sides.

You can create a copy of  the last circumscribed polygon by holding down 
the Ctrl key (Macintosh: Option key) and clicking where you want the 
center.

 YX 6D Sides

The status line allows you to specify the X, Y coordinates of  the center, 
the diameter of  the circle defining the polygon, and the number of  sides. 
The default number of  sides is 6. Diameter is the default status line se-
lection.

Spline Tools
s

The spline tools on the tool palette create NURBs (Non-Uniform Ra-
tional B-Splines) which are a superset of  Bezier curves. These splines are 
curves created by a complex mathematical formula.

NURB splines provide designers with two interrelated functions. First, 
curvature continuity remains intact when the curve is changed. Kinks 
don't develop as the spline is altered.  Second, NURB splines provide 
localized control of  a complex curve. You can isolate an area and make 
changes without affecting the remainder of  the spline.

These properties are essential in aerodynamic designs. Air mole-
cules moving over a wing surface must flow smoothly for maxi mum 
 aerodynamic lift. If  the surface does not maintain curvature continuity, 
the air molecules separate from the wing surface and cause a vacuum. 
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Such a vacuum causes an eddy as the molecules try to fill it. This disrup-
tion of  air flow increases the drag, which is not a part of  an effective 
design.

The automotive industry also wants smooth air flow to improve gas mile-
age. Complete curvature continuity also improves  styling. The appearance 
of  a car is one of  the major sales factors. The potential  buyer would 
not be impressed if  the showroom lights’ reflection on the car rippled 
and wavered. It is complete curvature continuity that makes a smooth 
 reflection. Localized control of  complex curves allows you to make mi-
nor modifications without adversely affecting the shape. For  example, if  
a new, bigger engine wouldn’t fit under a perfectly-designed hood, you 
could use a NURB spline to raise the center of  the hood without chang-
ing the basic design.

NURB splines are also valuable for injection mold designs to eliminate 
the swirl of  plastic as it is injected into the mold. Such designs provide 
better surface finishes and allow thinner cross-sections in the die.

Through-Points Spline Tool

The Through-Points Spline too draws a spline through the points that you 
place.

 

Spline is drawn through points
placed with mouse clicks

Using the Through-Points Spline tool
1. Click the points for the vectors of  the spline.

2. Double-click the last point.

 YX

The status line shows the X, Y coordinates of  each point as you go along.

Vector Spline Tool

This tool draws a spline using vectors determined by the points you spec-
ify. The Vector Spline tool uses each point that you place s the vertex of  
a vector for the spline it creates.

 

Kontrollpunkt

Konstruktionspunkt

Konstruktionspunkt Konstruktionspunkt Konstruktionspunkt

Konstruktionspunkt

Using the Vector Spline tool
1. Click the points for the vectors of  the spline.

2. Double-click the last point.

DesignFreeQ uses these vectors to calculate the control points (two 
fewer than the number of  vertices you specify). The spline is tangent to 
the first and last vectors and passes through the calculated control points.

 YX

The status line shows the X, Y coordinates of  each point as you go along.

Add Spline Control Point Tool 

This tool allows you to add another control point to an existing spline.  
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Using the Add Spline Control Point tool
Click on the spline at the desired location(s) for the new  control point(s). 

Note: To see the new control point(s), as well as the existing control points, you 
must first select the spline and then choose Show Points from the Layout menu 
(or use the Edit Objects dialog box to specify display points).

If  you intend to move a point, be sure to lock the adjacent points so you 
don’t change the slope of  he rest of  the spline.

Lock Spline Control Point Tool

This tool allows you to lock the specified points on an existing spline so 
you can change the slope between the points without affecting the rest of  
the spline.

Using the Lock Spline Control Point tool
1. Choose Show Points from the Layout menu.

2. Click the vertices you want to lock.

The Lock Spline Control Point tool is used to lock or  im mobilize 
 selected control points on an existing spline. You may then adjust the 
curvature of  the spline between the locked points without disturbing 
other areas of  the spline.

 

Locked 
Control Points

Selected Point

Drag 4-way pointer to adjust 
area between locked points

vertex

Unlocking spline control points
Use this tool and click the pointer to unlock it.

Locking more than one spline control point
You can lock more than one point by simply clicking each point.

Editing control points of a spline
1. Select the spline with the Selection tool.

2. Choose Show Points from the Layout menu. (If  the menu says 
Hide Points, you don’t need to choose it.)

3. Click on the drawing area to deselect the spline.

4. If  necessary, select Lock Spline Control Points from the Spline 
tool subpalette.

5. If  necessary, click the points you want to lock (the points on either 
side of  the point you will change).

6. Use the Selection tool to select the point you want to change.

7. Drag the point to the new location.

The dotted lines that appear tangent to the end portions of  the spline are 
tangent control arms. They allow you to adjust the curvature of  the spline 
leading up to the endpoints without moving the endpoints themselves. 
To do this, select the endpoint of  the tangent control arm and drag it to 
another  location with the 4-way pointer that appears.

Editing the end slope of a spline
1. Select the spline with the Selection tool.

2. Choose Show Points from the Layout menu. (If  the menu says 
Hide Points, you don’t need to choose it.)

3. Click in the drawing area to deselect the spline.

4. If  necessary, select Lock Spline Control Points from the Spline 
tool subpalette.

5. If  necessary, select the point you want to lock but not the endpoint.

6. Use the Selection tool to select the point at the end of  the tangent 
control arm you want to move.

7. Drag the point to a new location.

The function Lock Spline 
 Control Points locks both 
the control points and the 
end points of a spline. In 
contrast to control points 
spline endpoints are au-
tomatically unlocked after 
each modification of the 
spline while control points 
remain locked until they are 
unlocked or another tool is 
selected.

The Lock and Unlock com-
mand in the Arrange menu 
is used to prevent changes 
to objects and doesn’t affect 
spline control points. 

If you create a spline that 
crosses over itself, the  
Design Navigator will not be 
able to find that intersec
tion. This is by design.

You cannot move both 
endpoints of a spline at the 
same time. You must select 
and move the endpoints 
individually.
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 The Function [param] dialog box is displayed.
2. Enter the formula sin(t) * 20 into the x entry box in which 20 

equals the radius of  20 mm.

3. Enter the formula sin(t) * 20 into the y entry box in which 20 
equals the radius of  20 mm.

4. Enter the formula 2 * t /(2 * PI) into the z entry field in which the 
first value 2 equals the pitch of  the screw thread of  2 mm.

5. Enter the value 0 into the Start*: x entry field.

6. Enter the formula 4 * 2 * PI() into the End entry field in which the 
value 4 equals the number threads.

7. Enter the formula 4 * 8 into the Steps entry field in which the  value 
4 equals the number threads.

8. Select the option Connect points and the option Splines.

9. Click the Plot button.
 The specified number of  curve points is calculated and the helix is 

automatically plotted onto the drawing area.





Design Navigator
Snapping onto Geometry

Design Navigator Construction Lines

Permanent Construction Lines
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Design Navigator
The Design Navigator is the feature that makes DesignFreeQ unique 
among design and drafting software products. The Design Navigator 
thinks like a drafter; it automatically knows where you typically want con-
struction lines and displays them temporarily when you need them.

The Design Navigator also makes it easy to select existing points for con-
struction by displaying information about the pointer’s location in the 
drawing area. If  a Design Navigator notation is displayed when you click, the 
construction snaps onto the geometry precisely, without requiring finely 
tuned, eye-hand coordination or tedious selection of  special modifiers, 
modes, or other specialized construction tools.

Snapping onto Geometry
When the pointer is in the drawing area, it has a snap point function. The 
snap point locks onto specific points on existing objects as you move the 
pointer near them. 

The Design Navigator tells you when the snap point is on an object.

 

The Design Navigator displays information about the location of  the snap 
point. This information appears either beside the pointer or next to the 
object itself.

 

The Design Navigator tells you when the snap point has locked onto the 
points of  an object.

center 

 The center of  an arc or circle. Move the pointer across 
the arc or circle to display on for the arc or circle, then 
move the pointer near the center to display the center 
point notation.

endpoint 

 The endpoint of  lines, arcs, circles, ellipses, and splines.  

midpoint 

 The midpoint of  lines, arcs, circles, ellipses, and splines.

intersection 

 The intersection of  two lines or curves (both perma-
nent lines and the Design Navigator’s  dynamic construc-
tion lines).

quadrant 

 Quadrant points on an arc or circle displayed at 3 
o’clock, 6 o’clock, 9 o’clock, and 12 o’clock.

vertex 

 The vertices of  an ellipse, spline, or dimension point.
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Using tangents and perpendiculars
If  you press a point on an arc or circle and drag the pointer away at 
about a 45° angle, the Design Navigator locks onto the tangent. If  you 
drag away at a 90° angle the Design Navigator locks onto a perpendicular. 

Tangent  

Perpendicular  

If  you continue holding down the mouse button, the line remains tan-
gent or perpendicular while you drag the ending point around the 
object.

This is a very useful feature if, for example, you want to create a line 
from and tangent to an existing circle to the tangent point of  another 
circle.

 

Once a line is tangent to the circle, it can be dragged to the  tangent 
point on the other circle, with the tangency maintained at both ends.

 

Keyboard Snap Points
You can direct the Design Navigator to snap onto an object. For exam-
ple, you may want to start a new line from the exact center of  a circle. If  
you hold down the mouse button and press the c key on your keyboard, 
the Design Navigator finds the center of  the circle when you move the 
pointer near the center.

Important: Keyboard Snap Points are not active until you have set the first con-
struction point of  any drawing or editing tool.

Using the Design Navigator for snapping onto geometry
The following table lists the keys for finding specific points. The  desired 
point must be within the hit radius of  the pointer.

Letter  Snaps To (Align)

 c   center

 e  endpoint 

 g  grid

 i  intersection

 m  midpoint

 n  no point

 o  on

 p  perpendicular

 q  quadrant

 t  tangent

 v  vertex

 %  the percentage point set within the Snap dialog

Pressing the Spacebar or clicking the mouse releases all snap restrictions. 

Design Navigator
This command under Preferences in the Layout menu allows you to 
turn the Design Navigator on or off  and to activate the different snap 
modes of  the Design Navigator.

 

The Design Navigator locks 
onto a tangent or perpendi
cular only when the Design 
Navigator starts from the on 
notation. You cannot begin 
from a specific point, such 
as the endpoint, quadrant 
or vertex point.

Another way would be to 
reduce the detection radius 
of the Design Navigator with 
a lower number of pixels 
for the hit radius or to zoom 
in on the drawing to sepa-
rate the con struction points 
visually (see also Hit Radius 
in this chapter).
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Choosing the Design Navigator command displays the following dialog 
box: 

  

All snap modes are activated by default. If  you want to deactivate a snap 
mode you click the related check box.

If  you deactivate the Design Navigator by clicking the Design Navigator 
check box all snap modes are deactivated as well.

You can leave the dialog box open while drawing. You close the dialog by 
clicking on the Close box in the title bar.

Snap
This command in the Preferences submenu in the Layout menu sets 
specifications for the Design Navigator.

 

Hit Radius  This setting determines the detection distance in pixels. 
When the pointer is within the specified hit radius, the 
Design Navigator notations are displayed and the object is 
selected when you click the mouse. The default hit radi-
us is 12 pixels.

 If  you can’t specify locations that are close together 
because the Design Navigator snaps to an existing control 
point, you can do any of  the following:

  • Decrease the hit radius.  

  • Zoom in so more pixels separate the existing 
point and the point you want to select.

  • Lock on a point by pressing the mouse button 
and then typing the letter that represents the 
point (m for midpoint, for example).  

 If  you set the Hit Radius to zero, you disable the  single 
click selection of  the Selection tool (dragging a mar-
quee and double-clicking to select all objects will still 
work). Instead, you might consider using the Selection 
Mask in the Edit menu to specify that some objects 
 cannot be selected.

 These angles define the dynamic construction lines that 
the Design Navigator automatically uses. If  you want to 
change the orientation of  your drawing, you can change 
these specifi cations. For example, you could set these 
angles to 30°, 90° and 150° for an isometric drawing. 
The defaults are 0° (horizontal) and 90° (vertical). Use a 
semicolon to separate the values.

 To display a construction line through a point, move the 
pointer to the point to activate it (a  diamond appears); 
construction lines automatically display through the 
active point. You can have as many as eight active points. 
When you activate the ninth point, the first one in the 
 series is deactivated.

 These lines are used by the Design Navigator only when 
you are creating geometry and they are not part of  the 
list of  lines generated from the eight active points. The 
defaults are 45° and -45°. Use a semicolon to separate 
the values.

Important: Keyboard 
Snap Points are not active 
until you have set the first 
construction point of any 
drawing or editing tool.

Alignment 
Angles

It is not recommended to  
modify the Alignment Angles 
for isometric drawings in 
DesignFreeQ. Instead you 
should select an isometric 
view orientation with the 
Trackball. You find more 
information about isometric 
 drawing in the 3D Part of 
this manual.

Additional 
Creation  
Angles
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% Point  The divisions of  a line for Design Navigator notations. If  
you want to divide the line into quarters, use a 25 spec-
ification. The default is 50, which shows the midpoint 
of  lines.

 For example, entering 25 instructs the Design Navigator to 
tell you when the pointer is 25% of  the distance along a 
line as shown below.

 

Design Navigator's Construction Lines
In addition to snapping onto geometry, the Design Navigator also displays 
dynamic construction lines. The three types of  construction lines you use 
most frequently — vertical, horizontal, and 45° angle lines — display 
automatically during construction. These construction lines appear tem-
porarily to help you align geometry. Once you’ve set a point, the Design 
Navigator construction line disappears — your drawing is not cluttered 
with extraneous lines.

Dynamic construction lines extend automatically from the last point you 
created. You may want to activate other points so the Design Navigator 
displays construction lines relative to them. Simply move the pointer over 
the geometry to activate its control points, then move away horizontally 
or vertically.

Of  course, you also have the option of  creating permanent construction lines 
and other shapes, as described later in this chapter.

Using the Design Navigator’s Construction Lines 
After you have indicated the first endpoint of  a line, and you move the 
pointer horizontally, vertically, or in a 45° direction, the dynamic construc-
tion lines will appear. The figure below illustrates a 45° construction line 
relative to the endpoint of  an existing line.

 

Displaying dynamic construction lines while constructing 
geometry
1. Click a point to begin new geometry.

2. Move the pointer horizontally or vertically.
 A construction line appears through the point.

3. While the construction line is visible and the Design Navigator dis-
plays on, click the next point.

 The point is placed exactly on the construction line, even though 
the pointer wasn’t exactly on that line when you clicked. The dynamic 
construction line disappears.

Displaying dynamic construction lines with existing geometry 
1. Without pressing the mouse button, move the pointer over an 

 existing point.  
 The point notation (endpoint or midpoint, for example) shows 

that the point is active.

2. Move the pointer away from the point horizontally,  vertically, or at a 
45° angle.

 A construction line through the point is visible.

3. While the construction line is visible and the Design Navigator 
 displays on, click the desired point in the  construction.

 The point is placed exactly on the construction line, even though 
the pointer wasn’t exactly on that line when you clicked. The  dynamic 
construction line disappears.

The figure below illustrates intersecting construction lines drawn through 
two existing, active points.

If you want different 
construction line angles, 
you can change them in 
the Snap dialog box from 
 Preferences in the Layout 
menu, as described in the 
previous section.

You can have as many 
as eight active points; 
activating the ninth point 
in a  series deactivates the 
first point.
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Once you are familiar with the Design Navigator, you’ll see how much 
DesignFreeQ streamlines design and drafting tasks!

Setting new Design Navigator construction angles
You can add to or change the angles that the Design Navigator uses for dy-
namic construction lines by choosing Snap from the Preferences com-
mand in the Layout menu. Enter the construction line angles, separated 
by semicolons, into the appropriate box.

Permanent Construction Lines
In addition to the Design Navigator’s dynamic construction lines, you may 
want to create construction lines that remain displayed until you hide or 
remove them. There are two methods for creating permanent construction 
lines: strokes and the Construction command (in the Layout menu). 
When you want to get rid of  all construction lines, choose Delete Con-
structions from the Layout menu. (Everything on the Construction 
layer will be deleted.)

Stroke Construction Lines
Stroke construction lines are lines that you create with the mouse. Hold 
down the Shift and Ctrl key (Macintosh: Command key) and drag the 
mouse horizontally or vertically. Since you are working in the drawing 
area, the Design Navigator helps you place the stroke precisely.

Holding down the Shift and Ctrl key (Macintosh: Command key) changes 
the mouse pointer to the Stroke pointer ( ).

  

Drag  Result

Vertically A vertical construction line through the 
first point of  the stroke.

Horizontally A horizontal construction line through the 
first point of  the stroke. 

Using Stroke construction lines
Construction lines are as long as the dimensions of  the viewing area of  
the screen or the plot region (as designated in Drawing Size), whichever 
is larger.

For example, if  you are using the Connected Line tool, you can create a 
construction line that extends through the center of  a circle:

1. Hold down the Shift and Ctrl key (Macin tosh: Command key).

2. Move the pointer near the center of  the circle.
 The Design Navigator snaps onto the center point.

3. Drag the mouse vertically or horizontally away from the midpoint.
 The construction line appears through the center and you are still 

in the process of  creating connected lines. 

The Construction Command
Stroke construction lines are useful for creating lines through existing 
points. If  you want to create a construction line at a location other than 
an existing point or at a particular angle, you can use the Construction 
command.

Construction  Ctrl+K [Macintosh:  K]
This command in the Layout menu creates a construction line on the 
Construction layer of  the current document.

Permanent construction 
lines automatically appear 
on the Construction layer, 
not the work layer of your 
drawing. You can hide the 
Con struction layer to view 
or print the drawing without 
construction lines.

You can use strokes to 
 create construction lines 
while you are in the  process 
of using a tool. 

Stroke construction lines 
can be created only hori-
zontal or vertical. For con-
struction lines in a  different 
angle you must use the 
Construction command in 
the Layout menu.
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You can specify the angle of  the construction line or the offset from a 
reference point defined by the X, Y coordinates. The asterisk shows that 
the values can be specified by clicking or dragging the mouse; values can 
also be typed into the boxes.

Specifying the construction line angle with the mouse
1. Click the Angle box.

2. Drag a vector in the drawing area.
 The angle of  the vector line appears in the Angle box.

Specifying the construction line offset with the mouse
1. Click the Offset box.

2. Drag the offset distance in the drawing area.  

The distance you drag appears in the Offset box. Be aware that the 
 offset is determined by the angle f  the construction line as shown.

 

Specifying X, Y coordinates with the mouse
The coordinates of  the last point you specified appear in the X and  
Y boxes, but you can change them by following these instructions.

1. Click the X box.

2. Enter new coordinates.
 Or:
 In the drawing area, click the location of  the point through which 

the construction line should pass. The coordinates are entered 
 automatically for both the X and Y boxes.

Creating multiple construction lines
You can create multiple construction lines through the same point by en-
tering the angles you want separated by semicolons.

Creating parallel construction lines
You can create parallel construction lines by specifying a  single angle 
value with different offsets separated by semicolons. You can also create 
parallel lines by creating one construction line using this box, then creat-
ing new lines with the Parallel Line tool.

Creating Construction Geometry
Non-construction geometry is placed on the work layer. You can create 
temporary construction geometry, such as arcs or circles, by making the 
Construction layer the work layer, creating the geometry and switching 
to another layer to  continue your work. You can use the Construction 
pen style if  you like, but it’s not essential.

Creating construction geometry
1 Choose Layers from the Layout menu.

 

DesignFreeQ automatically 
places  construction lines 
on the  Construction layer. 
When you choose Delete 
Constructions from the 
Layout menu, every thing 
on the Construction layer 
is deleted,  regardless of the 
 object’s pen style.

Note: The distance dragged 
will always be entered in 
the Offset box as a positive 
value, regardless of the 
direction dragged.

Before you can define a 
point on the drawing area 
you have to click in the 
Entry field where the values 
should go.

Lines made with the Con-
struction pen do not go 
on the Construction layer 
unless you make that layer 
the work layer.
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2. Click Construction in the list box.

3. Click the Set Work button.

4. Create the geometry you’ll use for construction. You can use the 
Construction pen style, but any pen style is  acceptable.

5. When the construction geometry is complete, make another layer 
the work layer.

6. Close the dialog box.

7. Continue your work. 

Once you no longer need the construction geometry, choose Delete 
Constructions from the Layout menu to remove all geometry on the 
Construction layer. 

Removing Construction Lines
If  you have many construction lines and you want to delete only one or 
two of  them, select the lines you want to remove, and then choose the 
Delete command from the Edit menu or press the Back Space key. You 
can remove all the construction lines that you’ve created by choosing 
Delete Constructions from the Layout menu.

Delete Constructions
This command in the Layout menu deletes all construction lines and any 
geometry on the Construction layer. 

The Design Navigator's dynamic construction lines appear only temporarily 
and are not affected by this command. Any geometry on the Construc-
tion layer (regardless of  the pen style used) is deleted by this command.

You can retrieve deleted construction geometry within the limits of  the 
Undo command.

You can select  construction 
lines in the usual manner 
from any layer; the Con-
struction layer doesn’t 
have to be the work layer.

Since the Delete Construc-
tions command deletes all 
geometry on the Construc-
tion layer, you shouldn’t 
create anything you want to 
keep on the Construction 
layer.
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Setting the Environment 
This chapter describes how to set pen styles, units and discusses the grid. 
The last section of  this chapter tells you how to save your preferences 
for default settings and how you can customize DesignFreeQ.

Pens
The pen style determines the appearance of  lines on the screen and when 
they are plotted. If  you are using a monochrome monitor or a printer, 
all lines will be black but the weight and pattern will be visible. Any line 
thickness of  less than 0,07 mm appears one pixel wide on the screen. 
When you print or plot such lines, you can see the different weights.

You can choose from nine different pen styles in the Pen menu. This 
menu contains as well all commands to modify all pen settings.  

 

The current pen style is checked on the Pen menu. The default pen style 
is Outline—solid, black lines, 0,35 mm wide.

You can change to a different pen style in the Style submenu. 

You can change an  individual characteristic of  the current pen in the Pen 
submenus (Color, Weight and Pattern). 

Changing the current Pen
1.  Select the pen style you want to use from the Style submenu  

in the Pen menu.

All selected objects will be drawn in the new pen style, as will all  future 
lines until you end the current DesignFreeQ session or select a new pen 
style.

Pen Characteristics
The following characteristics are available from the submenus in the Pen 
menu.

 

Whenever you change the characteristic (Color, Weight or Pattern) of  a pen 
these characteristic are valid until you end the current DesignFreeQ ses-
sion or select a new pen characteristic.

Changing one characteristic of a pen style
1. Choose the pen you want to modify.

2. Choose a characteristic—color, weight, or pattern – from the 
 characteristic submenus in the Pen menu. 

To return a standard pen to its original specifications, choose a different 
pen style from the menu and then choose the  modified pen again.

All selected objects will reflect the new pen characteristic, as will all fu-
ture lines drawn until you end the current DesignFreeQ session or select 
new pen characteristics .

Changing the pen characteristics of an object without changing 
the pen
1. Select the object.

2. Choose Edit Objects from the Edit menu.

If you want to change the 
characteristic of a pen per-
manently use the Edit Style 
command from the Style 
submenu in the Pen menu. 
This command is  described 
later in this chapter.
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 The Edit Objects dialog is displayed.

3. Change the  pen characteristic in the Edit Objects dialog box.

4. Click the Apply button.
 The selected objects reflects the new pen characteristics. The char-

acteristics of  the current pen are not modified.

Colors
The Color submenu in the Pen menu contains 234 color options from a 
palette of  16.7 million colors available. 64 colors are predefined, 170 col-
ors are user definable.

You select a new color for the current pen from the Color submenu  
in the Pen menu where you find also the command to define your own 
colors.

Color
This command in the Pen menu specifies the color of  the current pen 
and any selected geometry without changing any other pen characteris-
tics.

 

You can change the color of  the current pen in the Color submenu by 
selecting a color name or by selecting a new color from the Color subpalette.

Specifying the color of the current pen by selecting a color 
name
1. Select the Color command from the Pen menu. 

The submenu appears.

2. Drag to the color you want.
 The current pen and all selected objects takes on the new color and 

the color is selected in the submenu.

3. Select more from the Color submenu, if  you want to select a differ-
ent color than one of  the seven displayed basic colors.

 The Color dialog box is displayed listing all available colors.

 

4. Choose a color name.

5. Click the  Apply button
 The current pen and all selected objects takes on the new color.
6. Click the Close button when you have modified all line colors.

Choosing the color of the current pen from the color palette
1. Select the Color command from the Pen menu. 

The submenu appears.

2. Drag to Palette in the Color submenu.  
 The Color Palette is displayed showing 64 predefined and all user 

defined colors.
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3. Drag to the color you want. 

 The current pen and all selected objects takes on the new color and 
the color is selected in the submenu.

Changing the pen color of an object without changing the color 
of the current pen
1. Select the object.

2. Choose Edit Objects from the Edit menu.
 The Edit Objects dialog is displayed.

3. Change the  pen color in the Edit Objects dialog box.

4. Click the Apply button.
 The selected objects reflects the new pen color. The color of  the 

current pen is not modified.

Define Colors 
You can define as many as 170 colors in addition to the 64 predefined 
colors.

New colors are defined with the Define command from the Color 
 submenu in the Pen menu.

  

Specifying a new color name
1. Choose the Define command from the Color submenu.
 The Define Color dialog box is displayed.

 

 The Define Color dialog box displays a list containing all color 
names that can be defined in DesignFreeQ. The list starts with the 
64 predefined colors followed by the 170 user definable colors named 
Color <65> to Color <236>.

2.  Scroll down the list and select the first undefined color number, like 
Color <65>.

3. Enter the color name (limited to 15 characters) in the Color Name 
data field.

4. Click the Rename button.
 The undefined Color <65> is renamed. 

Now we specify a color for the new color name.

Defining a color     WIN
1. Click the Define button in the Define Color dialog box.
 The Windows Color dialog box is displayed.

 

2. Click the Define Custom Color button.
 The extended Color Palette is displayed.

3. In the color palette on the right, place the cursor within the target 
cursor and drag to the area of  the color desired. Note a larger area 
of  the color is displayed in the Color/Solid box below.
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 If  desired, you can also adjust the hue, saturation, luminance, and the 
percentage of  red, green, and blue by entering your own values.

 The % of  black can be adjusted by moving the cursor over the ar-
row in the color scroll bar to the right of  the large color palette and 
drag up or down to the desired location. When you adjust this, all 
the values in Luminance, Red, Green, and Blue data fields change as 
well. Hue and Saturation do not change.

4. Click the Add to Custom Colors button.
 The defined color is displayed in the first highlighted box for cus-

tom defined colors.

5. Click the OK button.
 Die Windows Color dialog box closes and you are returned to the 

Define Colors dialog box.

6. Click the Use button in the Define Colors dialog box.
 An icon of  an eye will appear, indicating that the color will be visible 

now in the DesignFreeQ Color Palette. The new color name remains 
in the color list in the position you placed it, since the color names 
are not alphabetized.

7. Close the Define Color dialog box.

Defining a color     MAC
1. Click the Define button in the Define Color dialog box.
 The Apple HSL Color Wheel is displayed.

  

 The Apple HSL Color Wheel shows the complete color range of  all 
colors available.

2. Drag the mouse pointer in the color wheel to the area of  the color 
desired. 

 The selected color is displayed in the New box below the  Original 
box and its color  values are displayed in the boxes for hue angle, satu-
ration, and lightness. 

3. Modify the values for hue angle, saturation, and lightness. The lightness 
can be adjusted as well with the Lightness Slide bar  below the Color 
Wheel.

4. Click the More Options button.
 On the left hand side the icons for the Apple HSL-Color wheel and 

the Apple RGB Color display are displayed.

5.  Click onto the icon for the Apple RGB Color display when you want 
to specify the new color by its basic RGB Colors Red, Green and 
Blue.

 The Apple RGB Color display is displayed.

  

6.  Specify the color using thew Color Slide Bars for Red, Green  
and Blue.

 The specified color is displayed in the New box below the  Original 
box and its color values are displayed in the boxes for the colors 
Red, Green and Blue. 

7. Click the OK button.
 The Apple HSL-Color wheel or the Apple RGB Color display – depend-

ing which system was displayed– will be closed and you are  you are 
returned to the Define Colors dialog box.

The Apple Macintosh offers 
two system to define colors: 
The Apple HSL Color wheel 
and the Apple RGB-Color 
display. You can switch 
between the two systems 
or use one system as your 
default color system.

When you define a color for 
the first time the color grey 
is displayed in the Original 
color field.

The icons for the two Apple 
color systems can be hidden 
using the Fewer Options 
button.
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8. Click the Use button in the Define Colors dialog box.
 An icon of  an eye will appear, indicating that the color will be  visible 

now in the DesignFreeQ Color Palette. The new color name  remains 
in the color list in the position you placed it, since the  color names 
are not alphabetized.

9. Close the Define Color dialog box.

Saving user defined colors
User defined colors are automatically saved with the drawing as soon as 
you save the drawing using the Save command from the File menu.

To save user defined colors permanently choose the Save Preferences 
command from the Preferences submenu in the Layout menu.

Arranging the color palette 
All user defined colors are automatically displayed in the DesignFreeQ Color 
Palette when an eye symbol is displayed in front of  the color name in the 
Define Color dialog box.

If  there are any undefined colors between the last predefined color (Color 
<64>) and the last user defined color all these undefined colors are shown 
in the color palette by a cross.

If  you want to have a continuous color palette you must define all color 
continuously after the last predefined color.

Pen Weights
The Weight submenu in the Pen menu offers 8 pen weights, that are all 
user definable. This submenu contains also the Define command, that 
allows you to specify for each of  the pen weighs displayed in that menu  
a specific weight.

Weight 
This command in the Pen menu sets the pen width of  the  current pen 
and selected lines without changing any other pen characteristics.

 

Specifying a new weight for the current pen
1. Drag to Weight in the Pen menu.
 The submenu appears.

2. Drag to the weight you want.  
 The pen takes on the new weight and the weight is selected in the 

submenu.

Edit Weight
This command from the Weight submenu in the Pen menu sets the 
weights for DesignFreeQ’s lines. DesignFreeQ comes with eight pens 
with differing line weights ranging from 0.13 to 1.50 mm. Objects drawn 
in DesignFreeQ are drawn in one of  the eight available pen weights.  
With the Edit Weight command in the Pen menu, you can change the 
weight of  one of  the pens to any value between 0.00 mm to 1.50 mm.

There cannot be more than eight different pen weights in a drawing, so 
changing a pen weight in the Edit Pen Weights dialog box will change 
the weight of  every object that was drawn with that pen’s former weight. 

Editing Line Weights
1. Choose Edit Weight from the Weight submenu of  the Pen menu.
 The Edit Pen Weight dialog bx appears.

  

Any line thickness of less 
than 0,07 mm appears one 
pixel wide on the screen.  
When you print or plot such 
lines, you can see the differ-
ent weights.
The Line weight of dimen-
sion lines can be only  
modified in the Preferences 
submenu of the Dimension 
menu and should be always 
0,25 mm.

Remember that pen weights 
thinner than .007 mm will 
show up on the screen as 
one pixel thick. However, 
you should be able to see 
the difference in pen weights 
on your prints and plots.

The line weights shown in 
this submenu are  de pendent 
on the selected Units in the 
Preference Submenu. If you 
have  selected metric units, 
the line weight will be shown 
in mm instead of inches.
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2. Select the pen weight you want to change by clicking on the pen 
number. That pen’s entry box should be selected.

3. Change the pen weight by typing a new value into the entry box. 
If  no units are given with the entry, DesignFreeQ applies the unit 
specified in the Units dialog box from Preferences.

 If  the entry does not fall with in the valid range from 0 to 0,039 
Inch or 10 mm, DesignFreeQ prompts you with an alert box 
 similar to the following one.

  

4. Click OK.
 All existing lines drawn in the pen weight you edited will be changed 

to reflect the new weight, as will all future lines will be drawn in that 
weight. The new pen weights are valid until the end of  the current 
DesignFreeQ Session or you define another pen weight.

 Clicking Cancel ignores all changes made to any pen weights and 
closes the Edit Pen Weights dialog box.

Undoing a Pen Weight Edit
You cannot undo editing a pen weight with the Undo command. To 
return a pen back to DesignFreeQ’s default, you will need to enter the 
original value in the Edit Pen Weight dialog box, following the steps 
described above.

Saving edited Pen Weights permanently
Edited pen weights affect only the pen weights in the current file. To 
save the edited pen weights so that they are available in all future files, 
choose the Save Preferences command from the Preferences submenu 
of  the Layout menu.

Line Patterns
DesignFreeQ allows to specify 19 line patterns in addition to 11 pre-
defined line patterns.

Pattern
This command in the Pen menu sets the Pattern of  the current pen and 
any selected lines without changing any other pen characteristics.

 

The Pattern submenu in the Pen menu contains all defined line  patterns. 
11 different line patterns can be selected directly, for all others you have 
to display a dialog box using the More command.

Specifying line patterns in the Pattern submenu
1. Drag to Pattern in the Pen menu.
 The submenu appears.

2. Drag to the pattern you want.
 All selected objects take the new pattern and all new objects are 

drawn in this line pattern.

Specifying line patterns with the More command
1. Drag to Pattern in the Pen menu.
 The submenu appears.

2. Select the More command.
 The Line Fonts dialog window s displayed. 

Edited pen weights are 
not backwards compatible 
with previous versions of 
DesignFreeQ. Opening 
a file that contains edited 
pen weights in a previous 
version of DesignFreeQ will 
revert the pen weights back 
to their original settings.
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3. Select the pattern you want.
4. Click the Current button.
 All selected objects take the new pattern and all new objects are 

drawn in this line pattern.

Defining Line Patterns
In DesignFreeQ you can specify in addition to the 11 predefined Line Pat-
tern another 19 using the Line Editor. The Line Editor is  displayed with 
the Define Pattern command in the Pattern submenu of  the Pen menu.

 

The Define Patterns dialog box contains the following elements: 

New When you click this button, a new line pattern with the 
name User 1 is created, that you can rename using the 
Rename button. You can specify the new pattern using 
the Line editor, that you display with the Edit button.

Delete This button allows you to delete the line pattern that is 
selected in the Define Pattern dialog box. You can only 
delete user  defined line patterns. The 11 predefined Line 
patterns  cannot be  deleted.

Current This button makes the selected line pattern the current 
pattern. All selected objects take the new pattern and all 
new objects are drawn in this line pattern.

Edit This button displays the Line Editor, that allows you to 
edit the new pattern. You can edit all line patterns except 
the two predefined line patterns solid and dotted.

Rename This button allows you to rename a line pattern with the 
name entered into the Rename field.

 You can only rename user  defined line patterns. The 11 
predefined  Line patterns  cannot be renamed.

Defining Line Patterns
1. Select the Define Pattern command in the Pattern submenu in the 

Pen menu.
 The Define Patterns dialog box is displayed.

2. Click onto the New button.
 A new line pattern with the name User 1 is created.

3. Rename the new line pattern in the Rename field with a clear name. 

4. Click the Rename button.
 The new line pattern is renamed with the name you entered into the 

Rename field.

5. Click the Edit button.
 The Edit Pattern dialog box (Line Editor) is displayed.

6. Specify a pattern for the new line pattern. 

7. When you have specified the new line pattern, click the OK button.
 The dialog window will be closed and the specified pattern is saved 

as new line pattern.
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8. Click the Current button, when you want to make the new  pattern 
the current pattern.

 All selected objects take the new pattern and all new objects are 
drawn in this line pattern.

Editing Line Patterns
With the Edit Pattern command from the Pattern submenu in the Pen 
menu you can set the spacing for DesignFreeQ’s line patterns. Design-
FreeQ automatically scales line  patterns by the inverse of  the scale factor 
set in Drawing Size or Sheet Into View so that the  pattern spacing will 
be appropriate for the viewing and drawing scale of  the geometry.  Some-
times, though, you might want to set the pattern spacing independently 
of  the viewing or drawing scale, or change the pattern altogether.

The Edit Pattern dialog box lets you control the pattern spacing for line 
patterns.

In DesignFreeQ you can edit all line patterns except 2 (solid and dotted) 
of  the 11 predefined line patterns.

That means that changing, for instance, the Phantom line pattern in the 
Edit Pattern dialog box will change the pattern of  every line in the ex-
isting document that is drawn in the Phantom line pattern.

All line patterns are edited in the Line Editor that you display using the 
Define Patterns command in the Pattern submenu of  the Pen menu.

Edit Pattern
When you choose Edit Pattern from the Pattern submenu of  the Pen 
menu. The Edit Pattern dialog box appears.

 

The Edit Pattern dialog box contains the following settings:

Edit Pattern In this pull-down list you select the line pattern you 
want to change. The list box contains nine line patterns 
that can be modified.

 DesignFreeQ considers each line segment and each 
space between line segments separate Dashes, and each 
Dash has a handle, represented by a box attached to the 
vertical line extending from the end of  each Dash. One 
complete element of  the line pattern appears in the Pat-
tern Window.

Visible Length Displaying one complete element of  the line pattern re-
sults in a specific visible length of  the displayed pattern. 
The default visible length of  50 mm allows to displays all 
predefined line patterns of  DesignFreeQ. If  you want 
to create  patterns with Dashes or elements larger than 
50 mm, change the value in the Visible Length entry 
box to an appropriate number; the Pattern Window will 
scale the pattern element accordingly.

Dash Length There are two ways to change the length of  a Dash.

   Clicking the Dash handle activates it—the handle is 
now filled. The Dash’s current length appears in the 
Dash Length entry box. Entering a new value will 
change the length of  the selected Dash. 

   You can also drag the handle with the mouse. As you 
drag, the Dash’s length is updated in the Dash Length 
entry box.  Release the mouse button when the Dash is 
the length you want.

Add Using the Add button you can add a new Dash. The new 
Dash, with a length of  zero, is active; its handle is acti-
vated. You can change the length of  the new Dash by 

Pattern Win-
dow
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dragging its  handle or by typing in a value in the Dash 
Length entry box.

Remove Using the Remove button you can remove a Dash. To 
remove a Dash, select its handle and click Remove. The 
Dash is removed from the pattern element.

Revert You cannot undo a pattern edit with the Undo 
 command. To return a pattern back to DesignFreeQ’s 
default, click Revert in the Edit Pattern dialog box.

 Revert changes all the line patterns back to their de-
faults, not just the pattern selected from the Edit Pat-
tern pull-down list. A warning message is presented 
when you click Revert.

   

 Clicking Yes will change all of  the patterns back to 
DesignFreeQ’s original settings, and clicking No 
will return you to the Edit Pattern dialog box without 
 returning any patterns back to their original settings.

OK When you click OK all existing lines drawn in the line 
pattern you edited will be changed to reflect the new pat-
tern element, as will all future lines drawn in the  
line pattern. 

Cancel Clicking Cancel ignores the all changes made to any pat-
tern elements and closes the Edit Pattern dialog box.

Editing a Line Pattern
1. Choose Edit Pattern from the Pattern submenu of  the Pen menu.
 The Edit Pattern dialog box appears.

2. Select the line pattern you want to change from the Edit Pattern 
pull-down list.

3. Modify the line pattern by changing the lengths of  existing Dashes 
either by dragging its handle or by typing in a value in the Dash 
Length entry box. Add a new Dashes by clicking the Add button 
or remove dashes by selecting its handle and clicking the Remove 
 button. 

4. When the pattern element is properly defined, click OK.
 All existing lines drawn in the line pattern you edited will be 

 changed to reflect the new pattern element, as will all future 
lines drawn in the line pattern. 

 Clicking Cancel ignores the all changes made to any pattern 
 elements and closes the Edit Pattern dialog box.

Undoing a Pattern Edit
1. Click the Revert button in the Edit Pattern dialog box.
 A message is displayed warning you that clicking Revert changes all 

the line patterns back to their  defaults, not just the pattern selected 
from the Edit Pattern pull-down list.

2. Click the Yes button
 All of  the patterns are changed back to DesignFreeQ’s  original set-

tings.

Pen Styles
The following styles are the default settings of  those pens that are 
 available in the Pen menu:

Outline 

 Pattern: Solid, Weight: 0.35 mm, Color: Black.  
This is the  default pen setting.  

Visible 

 Pattern: Solid, Weight: 0.5 mm, Color: Black.

Hidden 

 Pattern: Hidden, Weight: 0.35 mm, Color: Red. 

Edited Patterns are affect 
only the patterns in the cur-
rent file. To save the edited 
pattern so that it is available 
in all future files, choose 
the Save Preferences com-
mand from the Preferences 
submenu of the Layout 
menu. 

You cannot undo a pattern 
edit with the Undo  command 
in the Edit menu.

Clicking No will return you 
to the Edit Pattern dialog 
box without returning any 
patterns back to their origi-
nal settings.
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Hidden lines are actually visible on the screen and in 
your drawing; they represent lines that would be hidden 
in  solid object.

Dash 

 Pattern: Dashed, Weight: 0.35 mm, Color: Yellow.

Center 

 Pattern: Center, Weight: 0.35 mm,Color: Green.

Phantom 

 Pattern: Phantom, Weight: 0.35 mm,Color: Cyan.

Dimension 

 Pattern: Solid, Weight: 0.25 mm, Color: Blue. 
Dimension lines are used for all type of  dimension.

Balloon 

 Pattern: Solid, Weight: 0.25 mm, Color: Green.

Construction 

 Pattern: Dotted, Weight: 0.25 mm, Color: Magenta.

Modifying Pen Styles
You can change the characteristics of  a pen the Edit Style command in 
the Pen menu.

Edit Style
This command in the Pen menu sets the characteristics for the pen 
styles.

Redefining the specification of a pen style
1. Choose Edit Style in the Pen menu.
 The Edit Style dialog box appears.

 

2. Select the pen style you want to change by pressing the Style  entry 
box. When the list of  pen styles appears, drag to the style you want 
to change.

3. Specify the characteristics (color, weight, and pattern) you want for that 
style.

4. Click the Apply button.
 The selected pen style has now the new specifications until you quit 

DesignFreeQ. When you click the Apply button all selected objects 
in the drawing area obtain the new specifications. The dialog box 
stays open so you can make changes to other pen styles.

When you edit a style, you set new specifications for future uses of  that 
pen. The specifications remain in effect for the document in which they 
are set until you change it again with the Edit Style command.

Redefining the specification of a single pen style
When you only want to modify the characteristics of  a pen as long as you 
use this pen you must proceed as follows:

1. Select the pen style you want to change

2. Specify the characteristics (color, weight, and pattern) you want for that 
style. 

When you want to restore the original characteristics of  the pen you 
select any other pen and then again the pen whose attributes you have 
modified.

Defining new Pen Styles
1. Choose the Edit Style command from Style in the Pen menu.
 The Edit Style dialog box is displayed.
2. Click the More button.
 The More ens dialog box is displayed.

The Construction line style 
doesn't create dynamic or 
permanent  Construction 
Lines. This line style uses 
the same line pattern but is  
not automatically placed 
on the Construction layer 
and can't be deleted with 
the Delete Constructions 
command from the Layout 
menu. 

You can change the default 
setting of any pen style 
by saving changes in the 
preferences file. See Saving 
Preferences later in this 
chapter.
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3. Click the New button.
 A new line with the default name Line 1 is created, that you can re-

name using the Rename button.

4. Click in front of  the name of  the new line in case you want to lock 
the line to prevent any modification.

 A lock in front of  the name is displayed. If  you want to unlock the 
line again you must click on the lock in front of  the line name.

5. If  necessary create or rename more pens. 
 The pens Dimension, Balloon, Outline and Construction are  permanently 

locked and can't be modified.

6. Close the More Pens dialog box.
7. Select the new pen by pressing the Style entry box. When the list of  

pen styles appears, drag to the new pen you want to change.

8. Specify the characteristics (color, weight, and pattern) you want for the 
new pen. 

9. Click the Apply button.
 The new pen has now the specified attributes for the current docu-

ment until you quit DesignFreeQ. When you click the Apply but-
ton all selected objects in the drawing area obtain the new specifica-
tions. The dialog box stays open so you can make  changes to other 
pen styles.

All pen attributes specified in the Edit Style dialog box are saved with the 
drawing and are still valid when the document is opened again.

Pen Indicator
You can use the Pen Indication pop-up box at the lower left of  the draw-
ing area to change the current pen.

 

Changing the current pen with the Pen Indicator
1. Press the mouse button on the Pen Indicator box. 
 The Pens menu displays listing all specified Pen Styles.

2. Drag to the Pen Style you want to make the current pen and release 
the mouse button.

 The selected pen is activated and displayed in the Pen Indicator.

Arrow Lines
With the commands Arrow at Start and Arrow at End from the Pen 
menu you can specify the placement of  Arrowheads on lines or circular 
arcs that are not a part of  dimensions. You can choose the Type of  
 arrowhead from the Arrowheads submenu of  the Pen menu. The size 
of  the arrowhead can be specified in the Arrow size submenu of  the 
Pen menu. 

Arrowheads
The Arrowheads submenu of  the Pen menu allows you to choose one 
of  eight arrowheads for arrow lines.

 

Arrowheads for dimension 
lines are defined separately 
under Preferences in the 
Dimension menu.
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The arrowhead selection is valid until the end of  the current Design-
FreeQ session. You can save the selected Arrowhead  permanently with 
the Save Preferences command from the Preferences submenu of  the 
 Layout menu.

Arrow size
The size of  an arrowhead is specified in the Arrow size  submenu of  the 
Pen menu. Choosing this command displays the following dialog box:

 

For the arrow size you can enter a factor in the Arrow size entry box. 
The default factor is 3,5. A modified arrow size is valid until the end of  
the current DesignFreeQ session.

Arrow at Start
This command in the Pen menu places an arrowhead at the beginning 
of  selected and subsequent lines and circular arcs. You can choose the 
type of  arrowhead from the Arrowheads  submenu of  the Pen menu. A 
checkmark (✓) indicates the current arrowhead setting.

 

Arrow at End
This command in the Pen menu places an arrowhead at the end of  se-
lected and subsequent lines and circular arcs. You can choose the type of  
arrowhead from the Arrowheads submenu of  the Pen menu. A check 
mark (✓) indicates the current arrowhead setting. 

Creating arrow lines or arcs
1. Select one or several lines you want to place an arrowhead at the be-

ginning or at the end.

2. Choose an arrowhead from the Arrowhead submenu of  the Pen 
menu.

3. Select Arrow at Start or Arrow at End in the Pen menu. If  you 
 select both commands arrowheads are placed at both ends of  the 
selected lines or arcs.

4. Use the Arrow size command of  the Pen menu to adjust the size  
of  the placed arrowheads.

Setting Units
DesignFreeQ is set to measure geometry in millimeters. When you 
open a new drawing you should set the precision, units, and fractional or 
 decimal specifications, to suit your needs.

Units
This command is in the Preferences submenu in the Layout menu.

 

Precision  Sets the number of  decimal places in all data fields with-
in DesignFreeQ (in Edit Objects, the Status line, and all 
Dialog boxes). The  default is 0,01.

The size of dimension ar-
rowheads is set separately 
under Preferences in the 
Dimension menu.

To save the size of an 
Arrowhead permanently you 
must choose the Save Pref-
erences command from the 
Preferences submenu 
    of the Layout menu.

When you change the units, 
existing dimensions update 
to reflect the change,con-
verting  automatically be-
tween English and metric.

Altering the precision does 
not affect any dimensions. 
The precision of dimensions 
is selected in the Preferenc-
es submenu of the Dimen-
sion menu.
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 When you choose a fractional precision, measurements 
will appear as fractions rather than decimals. You can set 
the format for fractions in the Linear submenu in the 
 Dimension menu.

 When DesignFreeQ rounds off  values it stores the 
16-digit decimal number; therefore, you can change the 
precision displayed at any time and maintain accuracy.

Inches, feet Displays measurements in English units. Measurements 
less than 6 feet appear in inches and those greater than 6 
feet appear in feet and inches.

mm, cm, meters  Displays measurements in metric units.

Leading 0 Determines whether or not the zero to the left of  the 
decimal point appears.

Trailing 0's Determines whether or not zeros to the right of  the 
decimal point are displayed. If  set, the precision deter-
mines the number of  trailing zeros.

Using the status line to specify the unit of measure
You can use the status line to specify a unit of  measure other than the 
one in effect for the document. If  the units are set to inches and you 
draw a line, you can use different units of  measure such as inches ("), 
feet ('), feet and inches (x'y"), millimeters (mm), centimeters (cm), and 
meters (m). You can also mix the units in the mathematical expression as 
long as you label the units properly-for example, 10" + 25.4 cm.

In the following example, if  the units are set to Meter, and a line is 
drawn using the value below, a line 23 cm long will be drawn when you 
press the Enter key, and the status line will show the measurement in 
meters.
 

In addition, you can use mathematical, exponential, and trigonometric expres-
sions in the status line.
 

Displaying the Grid
When the grid is visible, objects snap to the grid spacing. If  you want to 
place an object between the grid marks, you must either turn off  the grid, 
change the grid spacing, or zoom in so that the spacing is larger than the 
hit radius. The grid spacing automatically reflects the units you set in the 
Units dialog box. When you change the units, the appearance of  the grid 
spacing remains the same, and the values listed in this dialog box change 
automatically.

Grid
This command in the Preferences submenu on the Layout menu allows 
you to set the spacing of  the grid lines. You can specify the number of  
ticks (subdivisions) per unit (spacing). You can change the default set-
ting by saving changes in the preferences file.

Show Grid  Ctrl+G [Macintosh: G]
This command on the Layout menu controls the display of  the grid. The 
grid is made up of  horizontal and vertical lines of  dots. The spacing of  
the grid lines and the number of  tick marks between the intersections are 
set in the Grid dialog box which you can choose from the Preferences 
command on the Layout menu.

When the grid is visible, the Design Navigator snaps to the grid spacing. In 
other words, if  the grid is set to 25 mm spacing, you can’t construct an 
object closer than 25 mm to another object. The coordinate symbol ap-
pears a the origin location (X=0, Y=0) when the grid is visible.

 

The options Leading 0 and 
Trailing 0's set only the 
number of decimal places in 
all data fields (Edit Objects, 
Status Line, Position Indi-
cator) and in dialog boxes 
like Edit Objects, 2D Anal-
ysis etc.). Leading O and 
Trailing 0's for dimensions 
are set in the Preferences 
submenu of the Dimension 
menu.

When you make any chang-
es in the Grid dialog box, 
the grid is automatically 
displayed after closing the 
Grid dialog box.

Displaying the Grid is rarely 
required, since the Design 
Navigator offers in most 
cases a better support than 
the Grid.
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Saving Preferences
All files are saved with the settings as they are established when you 
save and close the file. The characteristics used for new files (the default 
settings) are contained in the prefs.vlm (Macintosh: DesignFreeQ Prefs). 
The file must be stored in the same directory as the DesignFreeQ appli-
cation.

Preferences
This command in the Layout menu displays a submenu for setting var-
ious specifications. Descriptions of  the items in the submenu appear 
individually in this reference section. You can change the default setting 
by saving changes in the preferences file, prefs.vlm (Macintosh: Design-
FreeQ Prefs).

Snap Use this dialog box to set the alignment angles, hit radi-
us, and other settings for the Design Navigator.

Grid This dialog box allows you to specify the spacing of  the 
grid lines. Use the Show/Hide Grid command in the 
Layout menu to turn the display of  the grid on and off.

Units This dialog box specifies the units and precision for the 
current DesignFreeQ document.

Selection Use this dialog box to set the color or blinking which 
shows that an object is selected.

Invert This commands changes the Background color (the color 
of  the drawing area from white to black).

 In this dialog box you can turn the Design Navigator On 
or Off  and activate the different snap modes of  the De-
sign Navigator.

Text Margins In this dialog box you can specify values for the Left, 
Right, Top and Bottom text margins.

AutoSave This dialog box allows the user to set a time interval for 
the program to save files. 

 In this dialog box the user can set document properties 
such as Author, User defined attributes or to automatically 
create a document Preview.

Directories This dialog box allows the user to specify directories for 
the Open, Save or Import command

 If  you have set the characteristics you like, such as units, 
pen style and dimension format, you can make those set-
tings the default setting. Choose Save Preferences from 
the Preferences submenu on the Layout menu. You 
cannot save geometry in this way; you would have to 
open the preferences file, create the geometry, and save 
the file. 

 When you select this command the Status (visible/hid-
den) and the Position of  all palettes are saved to prefer-
ences. When you restart DesignFreeQ all palettes that 
were displayed when you closed DesignFreeQ are auto-
matically reopened.

 Position and Status for the following palettes are saved 
with this command:

  •  Dimension palette
  •  Symbol palette
  •  Function palette
  •  BOM palette

 Status and Position of  these palettes are saved in 
the DesignFreeQ.ini file under the section Pal-
ettes. 

The preferences file name is prefs.vlm (Macintosh: DesignFreeQ Prefs).  
The file must be stored in the same directory as the DesignFreeQ 
 application.

If  you want to use different settings for your work, you can change 
the default settings, and then every new document opens with the set-
tings you have selected. The following specifications can be set in the 
 preferences file:

Design  
Navigator

Document 
Properties

The Save Preferences 
command saves as well 
3D Parameters that are 
discussed in detail in the 3D 
Part of this manual.

If a palette is not visible it 
could be that it was saved 
at a position outside of the 
screen. In this case you look 
for the name of the palette 
in the DesignFreeQ.ini file in 
the DesignFreeQ directory 
or folder under the section 
Palettes and enter there the 
Pixel Coordinates 20, 20. 
Then you have to restart 
DesignFreeQ.

Save  
Palettes

Save  
Preferences
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 • Pen styles
 • Text characteristics

 • Text Margins
 • Preferences settings (Snap, Grid, Units, and Selection  indicator, 

Auto Save, Document Properties and Directory settings) 
 • Grid display
 • Layer and sheet specifications
 • Work layer
 • Dimension and tolerance formats
 • Arrowhead type and display
 • Drawing size and scale
 • Zoom scale
 • Fillet radius
 • Chamfer angle and length
 • Parametric Resolve values
 • User Defined Colors
 • Visualization Parameter for 3D Models

Changing the default settings
1. Create a file which has the preferences you want.

2. Choose Save Preferences from the Preferences submenu in the 
Layout menu.

 The preferences are set for subsequent new documents.

Customization
DesignFreeQ can be customized to your personal needs by displaying 
a Floating Tool Palette, creating Macros or adding commands and 
 functions via the Function Interface. Both the Floating Tool Palette and 
Macros can be executed by Stroke commands. Customizations can also be 
made by changing the  contents of  the DesignFreeQ.ini file.

Floating Tool Palette
DesignFreeQ’s standard Tool palette is fixed at the left side of  the 
DesignFreeQ window. But you may display an additional Floating Tool 
Palette which you can drag and place anywhere on the screen.

Displaying the Floating Tool Palette
1. Press and hold the Control and Shift keys (Macintosh: Command 

key.

2. Depress the mouse button and drag the mouse pointer first down 
and then up.

  

3. Release the Ctrl and Shift keys (Macintosh: Command key).
 The Floating Tool Palette is displayed.

You can close the Floating Tool Palette by clicking the Close box in the 
upper left corner of  the Floating Tool Palette.

Macros
The Macro capability of  DesignFreeQ allows you to create macros and 
access them through menu commands, stroke commands, or key combinations 
providing an alternative way to invoke DesignFreeQ commands.

A macro automates a repetitive task by executing a group of  simple com-
mands, If  you can point and click, you can define a macro. That’s how 
easy it is!

Macro
If  you all the Macro command in the Utilities menu the following dia-
log box is displayed:

You cannot save geometry 
into the preferences file 
with the Save Preferences 
command. In this way, if you 
are working on a drawing 
and you have settings 
you want to save, you can 
choose Save  Preferences 
to save the settings but not 
the geometry. Be careful to 
use the Save Preferenc-
es command when your 
drawing contains several 
Sheets, Models, Detail 
Views and Layers. Although 
this command doesn't save 
any geometry, it saves the 
 setup of the current drawing 
as default for all future draw-
ings you create. That means 
that any new drawing will 
contain the same  number of 
Layers, Detail Views or Mod-
els as the drawing you used 
the Save Preferences com-
mand with. Therefore check 
regularly your Preference 
File. It should contain per 
default 1 Sheet, 1 Model, 
no Detail View and 4 Layers 
(Layer 1, Construction, Ki-
nematic and Dimension).
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The Macro dialog box is modeless in the sense that there are no Start 
Recording or Stop Recording buttons. Whatever action you perform 
(selecting menu items or defining strokes) will be recorded automatically 
in the relating list boxes as long as the Macro dialog box is displayed.

The Macro dialog box contains the following buttons:

New Clicking the New button adds a macro named Macro1 
to the Names list box. You can rename the macro in the 
Rename field by overwriting Macro1 with a new name 
and then clicking the Rename button.

Rename Clicking the Rename button overwrites the selected 
macro name in the Names list box with the name you 
entered in the Rename field.

Remove The Remove button will remove any selected entry from 
one of  the three list boxes.

File The File button will write all currently defined macros 
to files in the Scripts folder of  the DesignFreeQ direc-
tory. The file names are generated directly from the mac-
ro names. The files are output in such a way that when 
DesignFreeQ is subsequently started, the macros will 
be activated automatically. Macro files can be moved to 
other locations, or to other machines for use in other 
copies of  DesignFreeQ.

Run The Run button will run the macro currently selected 
in the Names list box. Macros can call other macros if  
they are in the Utilities menu. This is done by clicking 
on the relevant entry in the Utilities menu, like any 
other menu item. This feature allows a macro to call 
 another macro, which in turn could call the original mac-
ro. Such Infinite Loops are checked when an attempt is 
made to include a macro, and if  detected, an alert box is 
posted resulting in the macro not being included.

 In this list box all names of  the macros defined are dis-
played alphabetically. When one of  the items is selected 
with the cursor, the Strokes and the Commands list 
 boxes, as well as the Key and In Utilities Menu fields 
are automatically filled in with the relevant data that de-
fines the selected macro.

 The Strokes list box shows a group of  stroke com-
mands, if  any, that can run the selected macro. The 
names in this list box relate to the encoding of  the shape 
of  the stroke and you need not be concerned about 
them. It is optional to associate a stroke to define a mac-
ro.

 The Commands list box shows the set of  menu that 
define this macro. They are shown in this form: 
 MenuName; EntryName.

Key You can assign your own key combinations for a macro 
by clicking in the Key edit box and entering the key 
combination or typing it directly in the Key entry field. 
For example, enter Ctrl and F1 (by pressing the Control 
key first, keeping it depressed and pressing then the key 
F1). The Key edit box will display Ctrl F!. If  you try to 
create a Control key combination, you will not be able 
to execute the macro if  the key combination is already in 
use.

In Utilities If  you mark this option the macro name will be included 
as a menu item in the Utilities menu to access the mac-
ro directly.

Names list 
box

Strokes list 
box

Commands 
list box
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Creating a macro
1. Select the Macro command in the Utilities menu.
 The Macro dialog box is displayed

2. Click the New Button.
 The name Macro1 is displayed in the Rename field.

3. Overwrite the name if  desired.

4. Select menu commands in the order you want the new macro to exe-
cute.

 The selected commands are automatically filled in the Commands 
list box.

5. Define a Stroke command on the drawing area.
 Depress the Control and Shift keys (Macintosh: Command key) and 

drag a symbol on the drawing area you want to be associated to the 
new macro.

 That can be letters or a figure like a circle. You can not use Design-
FreeQ Standard Stroke commands like Zoom or Construction strokes, 
since they would be executed immediately. A letter and number 
combination describing the executed Stroke will be filled into the 
Stroke list box automatically. When you define a stroke, you must 
repeat it several times to define all variations of  the stroke, so 
that all possible variations are covered and can be recognized by 
DesignFreeQ.

6. Mark the In Utilities Menu option if  you want the new macro 
 included in the Utilities menu.

7. Enter a Key short cut in the Key entry field.
 Click in the Key entry box and enter the key combination or type it 

directly in the Key entry field. 

8. Close the Macro dialog box by clicking the Close box in the upper 
left corner of  the dialog box.

Editing a Macro
1. Display the Macro dialog box.

2. Select a Macro in the Names list box.

3. Rename the Macro in the Rename entry box and click the Rename 
button.

4. Redefine the Macro by executing menu items and assigning a new 
stroke equivalent to the macro.

5. Alter the Macro key combination in the Key entry box.

6. Close the Macro dialog box by clicking the Close box in the  upper 
left corner of  the dialog box.

Removing a Macro
1. Display the Macro dialog box.

2. Select a Macro in the Names list box.

3. Click the Remove button.

Running a Macro
Each Macro has a unique name and can be run in one of  four ways:

1. It can be invoked with a Control key combination.
 Subsequent typing of  that Control key combination will cause the 

associated macro to run.

2. A macro can be invoked by a family of  stroke commands you de-
fined in the Macro dialog box.

3. You can select the macro in the Utilities menu if  you marked the 
 option In Utilities Menu in the Macro dialog box.

4. You can display the Macro dialog box, select a macro in the  
Names list box and click the Run button.

 Executing a macro with the Run button is useful for testing a mac-
ro. Should it not work properly, you can highlight any dialog box 
entry and remove it by pressing the Remove button. Modify your 
macro as needed then test it again by pressing the Run button. Con-
tinue this process until your macro runs properly.
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Macro Limitations
Macros are not general programs. There are limitations as to what can be 
encoded in a macro. The following rules apply to macros.

 • Only menu items can be included in a macro.
 • A menu item might cause a dialog box to appear, but the macro 

cannot fill in the required entries.
 • There are no conditionals (like if  or ifelse) or loops (like while).
 • Subroutines are allowed in that one macro can call another 

 macro, provided the called macro is in the Extras menu and 
therefore a menu item. If  a macro calls a nested macro, which 
would end in an infinite loop, an alert box will be posted and  
the macro will be excluded from execution.

Function Interface
The Function interface allows you to add functions and commands to Design-
FreeQ. These functions can be displayed in an own palette and the added 
commands will be displayed in the Utilities menu.

DesignFreeQ is shipping already with the following additional  functions:
 • Automatic Dimensioning
 • Dimension axes
 • Text Lines
and the following commands:

 • Check Dimensions
 • Remove dots

With the function interface you can add easily functions and  commands 
that were either especially programmed for you or down loaded from the 
DesignFreeQ Web Page (www.DesignFreeQ.de).

All commands for adding functions and commands to DesignFreeQ are 
listed in the Utilities menu.

  

All functions and commands you want to bind into DesignFreeQ must 
be in the Function directory or folder of  DesignFreeQ.

Reload
This commands allows you to reload additional functions and commands 
while DesignFreeQ is already running, since only loaded functions and 
commands can be added into the Utilities menu and  displayed in the ad-
ditional function palette.

All functions and commands that are placed in the Function folder are load-
ed automatically when DesignFreeQ is launched.

If  you copy additional functions and commands into the Function  directory 
while DesignFreeQ is already running they must be reloaded using the 
Reload command in the Utilities menu.

Add Commands
When you call this command the following dialog box is displayed:

 

The Add Commands dialog box allows the following settings:

Commands  This list box contains all commands from the Function 
folder that can be added into the Utilities menu. These 
commands were automatically loaded when DesignFre-
eQ was started or reloaded using the Reload command 
when DesignFreeQ was already running.

File This field shows the file name of  the source code file for 
the selected command in the Commands list box.
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Arrows Clicking this buttons moves a command from the Com-
mands list box to the Menu list box and vice versa.

Menu This list box contains all commands that will be added 
as new menu items. 

Clear Using this commands moves all commands from the 
Menu list box to the Commands list box and removes 
all added commands from the Utilities menu.

Save Clicking the Save button adds all commands contained 
in the Menu list box into the last section of  Utilities 
menu.

 All added commands are saved permanently and are 
available each time you launch DesignFreeQ. To re-
move these commands from the Utilities menu you 
must first remove the commands from the Menu list 
box using the Clear button and click then the Save but-
ton again.

Adding commands
1. Copy the desired Source code files into the Function  directory of  

DesignFreeQ. Source code files containing commands and functions 
have the file extension .fe.

2. Select the Reload command in the Utilities menu if  you have 
 copied the source code files in to the Function folder when Design-
FreeQ was already running.

3. Select Add Commands in the Utilities menu.
 The Add Commands dialog box is displayed.

4. Move all commands you want to add into the Utilities menu from 
the Commands list box to the Menu list box using the Arrow but-
tons.

 Commands you want to remove from the Utilities menu you must 
move from the Menu item list box to the Commands list box us-
ing the Arrow buttons showing in the opposite direction.

5. Click the Save button.
 All commands contained in the Menu list box are added into the 

last section of  the Utilities menu.

Remove single commands
1. Select the Add Commands in the Utilities menu.
 The Add Commands dialog box is displayed.

2. Select the command in the Menu list box you want to remove from 
the Utilities menu.

3. Click the appropriate Arrow button.
 The selected commands are moved from the Menu list box to the 

Commands list box.

4. Click the Save button
 All selected commands are removed from the Utilities menu.

Remove all commands
1. Select the Add Commands in the Utilities menu.
 The Add Commands dialog box is displayed.

2. Click the Clear button.
 All commands are moved from the Menu list box to the Com-

mands list box.

3. Click the Save button.
 All commands are removed from the Utilities menu.

Add functions 
This command allows you to add additional functions into a separate 
function palette.

Tthe Add Functions command displays the following dialog box:

 

When you delete a source 
code file in the Function 
folder of the DesignFreeQ 
folder, the related  command 
is automatically  removed 
from the Extra menu when 
DesignFreeQ is launched 
again.
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The Add Function dialog box allows the following settings: 

Functions  The Function list box contains all function from the 
Function folder that can be added to the additional 
function palette. These functions were automatically loaded 
when DesignFreeQ was launched or reloaded using the 
Reload command when DesignFreeQ was already run-
ning.

File This field shows the file name of  the source code file for 
the function selected in the Functions list box.

Icon shows the icon of  the function selected in the Func-
tions list box.

Arrows These buttons move functions form the Functions list 
box to the two palettes and vice versa.

Palette The two radio buttons Main for Main palette and Sub 
for subpalettes allow to configure a function palette that is 
handled like the Standard Function Palette of  Design 
FreeQ.

Main Clicking the Arrow button while this radio button is 
marked moves the selected function from the Function 
list box to the Function palette and displays the related 
icon in the palette. Using his option all functions will be 
placed vertically without building any subpalettes.

   

 The palette shows always the icon of  the last function 
that was moved to the palette. You can display all func-
tion that are contained in the palette by clicking the 
icon and keeping the mouse button pressed. As long the 
mouse button is pressed all icons contained in the pal-
ette are displayed.

Sub Clicking the Arrow button while the Sub radio button is 
marked moves the selected function from the Function 
list box to the Function palette and displays the related 
icon in the palette. Using this option all functions will  
be placed horizontally creating a subpalette for the icon 
displayed in the palette.

   

 The palette shows always the icon of  the last function 
that was moved to the  palette. You can display all func-
tion that are contained in the subpalette by clicking the 
icon and keeping the mouse button pressed. As long the 
mouse button is pressed all icons contained in the sub-
palette are displayed.

Clear Using this commands clears the palette and moves all 
 commands from the Palette to the Functions list box.

Save Clicking the Save saves the generated function palette 
that can be displayed with the Show Palette command 
in the Utilities menu.

 The new function palette is saved permanently and is 
available each time you launch DesignFreeQ.

Creating an additional Function palette
1. Copy the desired Source code files into the Function folder in the 

DesignFreeQ folder. Source code files that contain commands and func-
tions have the file extension .fe.

2. Select the Reload command in the Extra menu if  you have copied 
the source code files in to the Function folder while DesignFreeQ 
was already running.

3. Select the Add Functions command in the Extra menu.
 The Add Functions dialog box is displayed.
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4. Move all functions you want to place in the palette from the Func-
tions list box to the Main or Sub palettes using the Arrow buttons.

 Using the Arrow buttons showing in the opposite direction you will 
move functions from a Palette to the Functions list box. 

5. Click the Save button.

Removing a single Function
1. Select the Add Functions command in the Extra menu.
 The Add Functions dialog box is displayed.

2. Select an icon of  a function in one of  the palettes you want to re-
move from the palette.

3. Click the appropriate Arrow button.
 The selected function is moved from the Palette list to the Func-

tions list.

4. Click the Save button.

Removing all Functions
1. Select the Add Functions command in the Utilities menu.
 The Add Functions dialog box is displayed.

2. Click the Clear button.
 All functions are moved from the palettes to the Functions list.

3. Click the Save button
 All functions are removed from the palettes.

Show Palette
This command displays the palette you have generated with the Add 
functions command in the Utilities menu. When no palette is available 
this command displays only the Title bar of  the palette.

To remove the palette you select either the Hide Palette command in the 
Utilities menu or click the Close box of  the palette.

Examples for additional Functions and 
Commands
DesignFreeQ is already shipping with some functions and examples that 
you can bind into DesignFreeQ.

These functions are not officially released and don’t go through the same 
quality control as DesignFreeQ. Further  functions can be created with 
the DesignFreeQ programming language FE (Front End) or down-
loaded from the DesignFreeQ Web Page (www.DesignFreeQ.de). Call 
your local DesignFreeQ distributor for more detailed information.

The documentation of  the functions do not describe necessarily the cur-
rent version of  a function or command. Since their functionality is perma-
nently extended there could already exist an improved version of  these 
tools and commands. Read therefore  always the related readme file of  the 
related function in the Function folder of  the DesignFreeQ folder be-
fore you bind in a function or command into DesignFreeQ.

Remove Dots
This command removes all isolated construction points from the drawing 
that were created for example by erroneous mouse clicks.

Removing dots
1.  Choose the Remove Dots command from the Utilities menu.
 All isolated construction points are removed from your drawing.

Text Lines

This functions creates horizontal Text lines.

Creating Text lines
1. Draw a horizontal line.

2. Select Show Palette in the Utilities menu.

3. Mark the line where you want to insert text using the Selection 
function in the standard Function palette.

4. Select the Text Line function.

The function icon is always 
copied as well to the sub-
palette since it is as well 
the first icon of a possible 
subpalette.

When you delete a source 
code file in the Function 
folder of the DesignFre-
eQ directory the related 
function is automatically 
removed from the Function 
palette when DesignFreeQ 
is launched again.

Before you can use this 
command you must add it to 
the Utilities menu using the 
Add Command command 
in the same menu. (See as 
well under Adding Com-
mands in this chapter).
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5. Enter in the status line the desired text.

6. Press the Enter key.
 The text is inserted into the middle of  all selected horizontal lines. 

The line segment behind the text is deleted. You can edit the text 
using the Text function in the standard Function palette.

 If  you want to move the Text within the line you have selected with 
a selection marquee the text and the endpoints of  the adjacent lines.

Automatic Dimensioning

This function dimensions automatically Lines independently from their 
angle, Circles, Ellipses and arcs.

Using Automatic Dimension
1. Draw a circle, several lines in different angles and an arc.

2. Select Show Palette in the Utilities menu.

3. Choose the Automatic Dimensioning function. 

4. Click at each object with the Automatic Dimensioning function.
 All lines are dimensioned correctly, all circles, arcs and ellipses are-

dimension with a radius dimension.

Specifying Crosshatch Patterns
DesignFreeQ offers a wide variety of  DIN and ANSI hatch patterns with 
editable pattern spacing and angle of  which You will find these hatches or-
ganized in groups such as metals, fluids etc. in the Hatch dialog box.

Adding and specifying Hatch Patterns
In addition to the hatch patterns shipping with DesignFreeQ you can 
use all hatch patterns that are compatible with the hatch format .pat of  
AutoCAD©. When you copy these hatch files into the DesignFreeQ 
folder DesignFreeQ\Scripts\Hatches the file name is auto matically 
displayed in the Crosshatch dialog box. If  the file contains more than 
one hatch pattern the name is followed by an ellipsis (...). When you dou-
ble-click the file name all patterns contained in the file are displayed. 

How to define your own hatch patterns is described under Hatches in the 
Appendix of  this manual.

Adding Plotter Fonts
In addition to the plotter fonts shipping with DesignFreeQ you can 
use all plotter fonts that are compatible with the file  format .shx of  
 AutoCAD©. When you copy these files into the Fonts folder of  the 
DesignFreeQ folder, the new fonts are displayed in the Fonts submenu 
after relaunching DesignFreeQ.

When you want to move the 
 inserted text along the line 
you must select the text in-
cluding the neighboring line 
endpoints with a selection 
marque using the Selection 
function in the standard 
DesignFreeQ tool palette
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Selecting Objects
Once you have constructed objects, you may want to make changes. One 
of  the basic rules of  DesignFreeQ says that you must first select an ob-
ject before you can edit it. Just as you first have to select a drawing tool 
from the Tool palette before you can start drawing, an object must first 
be selected before a function can be applied.

Modifying an object is always a two-step process:

 • Select the object.

 • Specify the action for the selected object.

For example, you could select a circle and then change the pen style to 
Center to indicate a bolt-hole circle.  

This chapter deals with selecting both objects and points, since they  behave 
in different ways.

Objects
A single piece of  geometry (for example a point or a line) is an object.

 

Several objects that have been grouped with the Group  command are 
also an object. For example, the four lines of  a Single Line rectangle are 
four  objects. If  you group them, DesignFreeQ treats them as a single 
object.

 

A point is an object, too. Every type of  geometry contains two or more 
points, sometimes called control points. A line has two control points, one 
at the beginning and one at the end of  the line. If  you select an  object 
and choose Show Points from the Layout menu, the points are visible 
on the selected object. 

 

Point selection is described in a section later in this chapter.

Note: Keep in mind you need to select an object and than the function.

The Starting and Ending 
point of a circle is displayed 
by the Design Navigator as 
Vertex.

If you select a point without 
 selecting the geometry it de-
fines, DesignFreeQ treats 
the point as an  object. 
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Indicating Selection
When you select an object, its appearance on the screen shows that it is 
selected, it is a specific color (such as red), it blinks, or both. DesignFre-
eQ usually displays  selections according to your monitor type, red for a 
color monitor and blinking for a monochrome monitor. You can change 
the color or turn  blinking off  and on for the selection indicator. You can 
choose both color and blinking, if  you want.   

Selection
This command in the Preferences submenu in the Lay  out menu 
 determines the appearance of  selected objects. If  you have a color 
 monitor, selected objects  appear in a Color (which you can change with 
this  setting). If  you have a monochrome monitor, selected objects blink.

If   you have a color monitor, you can also specify blinking with or with-
out color.

Indicating the Selection
1. Choose the Selection command from the Preferences submenu in 

the Layout menu.
 The Selection dialog box is displayed

   

2. Select the option Blinking and/or Color.
 To choose a color, move the pointer to the color box and click into 

the box to display the choices. Drag to the color you want and re-
lease or click the color. 

3. Click the OK button.
 Once the selection color is changed, all current and  future  selected 

items appear in the new color until you quit DesignFreeQ.

Selection Process 
Selecting an object does not affect the properties of  the object. A se-
lected object is highlighted, but this highlighting goes away once the 
object is deselected. While points and objects are selected in a similar 
way, point selection is controlled by the Selectable Points setting in the 
Edit menu. For this reason, selecting objects and selecting points are 
discussed separately.

Selection Tools

The Selection tool palette contains all tools for selecting objects. 

Objects can be selected by clicking, by dragging a Selection Marque around 
a group of  objects, by dragging a Line over objects or by drawing a Selec-
tion Polygon around objects. In the Selection tool palette you find as well 
the Tracer tool for automatically selecting boundary lines.

All Selection tools allow when pressing the Shift key to select or dese-
lect additional objects.

Selection Tool

The Selection tool on the tool palette selects one or more objects or 
points in the drawing area.

Selecting a single object
1. Click the Selection tool in the tool palette.

2. Move the pointer to an object and click.
 The object is selected, and previously selected objects are deselect-

ed.

You shouldn't use black 
for  indicating selection 
 because  many of the 
 standard pens use black 
lines. Red is a good 
choice unless you are 
 color blind, in which 
case blue may be a 
better choice.

It is not recommend to use 
the color Black to indicate 
the selection, since many 
lines are displayed in black.

Using the Save Preferences 
 command you can save the 
new settings permanently.



71

Selecting objects

Selecting multiple objects by shift-clicking
1. Click the Selection tool in the tool palette.

2. Move the pointer to an object and click.

3. Press and hold down the Shift key.

4. While holding down the Shift key, click other objects to be selected.
 The objects you clicked are selected. If  you then click one of  the 

selected objects, it is deselected.

5. Release the Shift key.

Selecting multiple objects by dragging
If  you want to select more than one object, you can drag with the mouse 
button pressed a selection marquee around the objects.

1. Click the Selection tool in the tool palette.

2. Drag a selection marquee around the objects you want to select.

 .

 All objects that lie completely inside the selection marquee are select-
ed. If  a portion of  an object is outside the region you dragged, that 
geometry is not selected but the control points of  that geometry which 
lie inside the selection marquee are selected.

If  you want to select most of  the objects within an area, you can drag a 
selection marquee to select all the objects, and then deselect the objects 
you do not want selected by holding down the Shift key and clicking 
them.

Select all Objects 
Double-clicking the Selection tool selects all objects on the drawing area. 

Selecting an object that is overlapped by another object    MAC
Occasionally, you may have geometry that overlaps other geometry. To 
select geometry underlying the object, follow  these steps:

1. Click the Selection tool in the tool palette.

2. Select the geometry on top.

3. Hold down the Shift key.

4. Hold down the Ctrl key and click the selected geometry again.
 The obscured geometry is selected.

5.  Release the Shift and the Ctrl key.

Select by Line

This tool selects one or more objects along a straight line path when you 
drag a line over the desired objects.

Selecting an object by Line
1. Choose the Select by Line tool from the Selection Tool Palette.

2. Drag a line across the objects you want to select. 

 

 The objects intersected by the line are selected and any previously 
selected objects are deselected.

 You can select/deselect additional objects by pressing the Shift key. 
You can move a copy of  the last selection by holding down the Ctrl 
key (Macintosh: Option key).



Selecting objects

72

Select by Polygon

This tool selects one or more objects when a polygon is drawn around 
them. Each object must be completely enclosed by the selection polygon 
for the object to be selected. This tool functions similarly to the Con-
nected Lines tool.

Selecting objects by Polygon 
1. Choose the Select by Polygon tool in the Selection Tool palette.

2. Click or drag to indicate the endpoints of  the line segments that 
will make up this selection polygon. The selection polygon appears 
as line segments and are selected (the default is red).

 If  you click a point and then change your mind, press the Escape 
key or choose Undo to remove the last line. Pressing the Back-
space key (Macintosh: Delete) removes the entire selection polygon.

2. Indicate the last point by double-clicking the start point of  the poly-
gon or choosing another tool.

 

 Objects completely within the selection polygon will be selected. 
Objects not completely within the selection polygon will not be se-
lected. 

 When pressing the Shift key you can select/deselect additional ob-
jects by additional polygons. It is not possible to move a copy of  
the last selection with this tool.

Tracer

This tool on the Selection tool subpalette selects  automatically boundary 
lines. The tool uses coincident endpoints and line    intersections to trace 
the perimeter of  the geometry. 

Selecting boundary lines
1.  Select the Tracer tool from the Selection Tool subpalette.

2.  Click on a boundary line.
 The tracer moves from one line to another making its selection. 

If  you have two overlapping objects as shown on next page, the tracer 
selects the perimeter of  the objects, depending on where you click.

 

If  you click on the outside of  the perimeter line, the Tracer selects the 
outer most perimeter. If  you click on the inside of  the line, the Tracer 
selects the inner most perimeter.

The crosshatching on the figures below shows the boundaries selected 
when you click the Tracer tool at the cursor locations shown.

 

Intersecting areas
If  you want to determine and isolate the overlapping part of  two 
 intersecting areas you proceed as follows:

The Tracer tool is most 
useful for selecting bound-
aries for crosshatching, for 
solid fills and for 2D Analy-
sis because it eliminates the 
need to  segment geometry.

Important: You can press 
the Escape key to stop the 
Tracer.

Important: The Tracer tool 
does not work on a 3D 
model..
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1.  Select the Tracer tool from the Selection Tool subpalette.

2.  Click on the overlapping area.
 The overlapping area is selected.

3.  Select Layer in the Layout menu.

4. Create a new layer.

5.  Select Edit Objects in the Layout menu.

6.  Select the new layer in the Layer list box and click the  Apply  button

7.  Close the Edit Objects dialog box.

8. Make the new layer in the Layer dialog box the work layer.

9.  Hide the layer that contains the overlapping object geometry.

The new layer contains now the intersecting area which you can edit like 
any other object.

Selection commands
The Edit menu contains the two selection commands Select All and 
 Selection Mask.

Select All  Ctrl+   [Macintosh: A]
This command in the Edit menu selects all objects except those on a hid-
den layer or excluded by the Selection mask. You can also double-click 
the Selection tool to select everything or use Ctrl+A (Macintosh: Com-
mand key+A) to select all objects. If  you choose Select All while using 
the Text tool, all characters in the current text area are selected.

Selection Mask
This command in the Edit menu allows you to limit selection by object 
type, layer, and color. You can only select objects that are highlighted in the 
dialog box.

For example, if  circles are not highlighted, when you choose Select All 
from the Edit menu, everything but the circles is selected. In this way, 
you can select such combinations as only blue splines or only red objects 
on a particular layer.

Using the selection mask
1. Choose Selection Mask from the Edit menu.
 The Selection Mask dialog box appears.

 

 The highlighted items respond to all selection methods and can be 
detected by the Design Navigator.

2. Click the items you want to be able to select so they are highlighted.  

While the dialog box is visible, you can select, create, and edit geometry. 
You can move the dialog box if  it covers geometry you want to work on. 
The selection mask remains in effect even after you close the dialog box 
until you select a tool.

When an item in the dialog box is not highlighted, the Design Navigator 
and all the tools cannot detect it, even though it is visible to you on the 
screen.

Deselecting 
To deselect an object, click anywhere in the drawing area where there is 
no object, or click any tool in the tool palette.

You can deselect an object that was selected in a multiple selection op-
eration. While the objects are still selected, hold down the Shift key and 
click the objects you want deselected.

Selecting Points
Selecting points differs from selecting objects because points are not 
 always visible. 

The Tracer tool creates 
a  temporary copy of the 
boundaries. Temporary 
 because it's copied to a 
temporary layer, which is 
 deleted as soon you  activate 
the Tracer tool or select a 
command other than Hatch 
or 2D-Analy sis. As long as 
the temporary boundaries 
are se lected they can be 
copied to another layer.

Select All is useful if you 
want to make a global 
change in a  drawing, such 
as changing the width of 
all lines. If you want to 
specify that only certain 
objects, layers, or colors are 
 selected you should use the 
Selection Mask command 
in the Edit menu. 

The selection mask is useful 
when you have  created a 
complex drawing and want 
to change particular groups 
of objects. You can use this 
feature to export some but 
not all geometry.

To deselect a list quickly, 
click one item in the list. 

You can select a  contiguous 
group by  drag ging or hold-
ing down the Shift key and 
clicking.

If you want to select or 
 de select non-contiguous 
items, hold down the Ctrl 
key (Mac intosh: -key) 
and click the items.
Using Windows you select 
all items in a list by dou-
ble-clicking one item in 
the list.
On the Macintosh you select 
all items in a list by pressing 
the Command key and dou-
ble-clicking one item in the 
list that is not selected.
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Being able to select points is useful in two situations: 

 • stretching selected geometry (described later in this chapter)

 • control point selection for transformations.

When you drag a selection marquee around objects, all geometry that is 
completely within the marquee is selected. If  geometry is partially within 
the marquee, only the control points  inside the marquee are selected, and 
the geometry is not selected.

Show Points
This command in the Layout menu toggles the display of  the control 
points (endpoints, midpoints, center points, and knot points) for selected 
objects. When points are displayed, you can select a point by clicking 
it. If  points are not displayed (but Selectable Points is set in the Edit 
menu), you can select a point by dragging a selection  marquee around 
the location of  the point.

To show points for an individual selection, use the Edit Objects com-
mand in the Edit menu.

 

Displaying points
1. Select the geometry.

2. Choose Show/Hide Points from the Layout menu to toggle the 
display of  points on and off.

To turn off  the point display once the points for an object are showing, 
you must select the object again and choose either Show/Hide Points 
from the Layout menu or the Control Points option in the Edit Ob-
jects dialog box.

Showing and Hiding Points with Stroke
When you hold down the Shift and Ctrl key and click an object, the 
display of  the object’s points toggles on or off. If  the points are hidden 
when you click the object, the points will be displayed.

Selecting invisible points
You can select a control point whether the points are visible or not; how-
ever, note that Selectable Points in the Edit menu must be on (display-
ing the  symbol in the menu). To select points if  points are not visible:

1. Click the Selection tool.

2. Drag a selection marquee around the location of  the point.
 The selected point displays as a square.

 

Selecting visible points
To select points if  they are visible:

1. Click the Selection tool.

2. Click the point.
 The selected point displays as a square.

Selectable Points
This command in the Edit menu gives you the ability to select points 
that aren’t displayed. When Selectable Points is not set, you cannot se-
lect points by dragging a marquee.

If  points are displayed, simply click the point to select it. If  points are 
not displayed, you can select a point by dragging a selection marquee 
around it. 

The following example illustrates the use of  Selectable Points.
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Editing Objects
Once you create an object, you can select and alter it by choosing a com-
mand or selecting a tool to edit it. This section describes the common 
editing activities you can perform on a selected object.

The chapter also compares the different methods for performing the 
same action, such as the difference between dragging a selected item 
and using the Move tool.

Editing Tools
These tools allow you to change an object physically, either  altering the 
geometry, changing the size, or changing the  location or orientation of  
the selected object. Three subpalettes on the tool palette provide these 
editing capabilities.

 

Fillet and Chamfer The Fillet and Chamfer tools round the cor-
ners of  nonparallel lines or cut them at 
straight angles, respectively.

Trim The Trim tools cut off  or extend a line to 
the boundary limit you specify. You can 
also segment a line at an intersection, or 
create corners from intersecting lines. 

Transformation The Transformation tools move, rotate, expand 
or shrink, stretch and mirror objects.

Fillet and Chamfer Tools

These tools on the tool palette construct fillets and chamfers from cor-
ners formed by nonparallel lines or curves. The fillets and cham fers are 
automatically trimmed. If  you do not want them trimmed, hold down the 
Ctrl key (Macintosh: Option key) while you are selecting the objects to 
fillet or chamfer.

All procedures in this 
chapter are described for 
single objects, they naturally 
are valid as well for several 
selected objects.
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2-Entity FilletTool

This tool constructs an arc tangent to the two objects you click.

Adding a 2-Entity Fillet
1. Click the 2-Entity Fillet tool.

2. Enter the arc radius you want in the status line. The  default radius is 
5 mm. 

3. Click the objects you want to fillet. You can also hold down the 
Shift key and click once inside the corner you want to fillet.

If  you hold down the Ctrl key (Macintosh: Option key) while you select 
the objects to fillet, the objects are not trimmed.

Fillets use the smallest arc between the selected geometry.

The status line allows you to specify the Radius of  the fillet  either  before 
or after you create the fillet.

 

3-Entity Fillet Tool

This tool constructs a fillet tangent to the three objects you choose.

Adding a 3-Entity Fillet
1. Click the 3-Entity Fillet tool.

2. Click the three objects you want to fillet.

If  you hold down the Ctrl key (Macintosh: Option key) while you select 
the objects to fillet, the objects are not trimmed.

There are no entries on the status line.

2-Entity Chamfer Tool

This tool creates a chamfer across a corner at the specified distance from 
the intersection of  two lines. The default distance is 5 mm.

Adding a chamfer
1. Click the 2-Entity Chamfer tool.

2. In the status line, enter the distance you want the chamfer from the 
corner. The default distance is 5 mm.

3. Click each line making up the corner you want chamfered. You can 
also hold down the Shift key and click once inside the corner you 
want to chamfer.

The lines are automatically trimmed or extended. If  you hold down the 
Ctrl key (Macintosh: Option key) while you select the objects to chamfer, 
the objects are not trimmed.

 

The status line allows you to specify the distance (Length) from the 
chamfer to the intersection of  the corner lines.

Angular Chamfer

This tool creates a chamfer at the specified angle and distance from the 
corner. The specified angle is the angle between the chamfer and the 
second line of  the corner. The specified length is the distance between 
the corner and the intersection of  the chamfer and the second line of  the 
corner. The default distance is 0.5 mm and the default angle is 45°.

Adding a chamfer
1. Click the Angular Chamfer tool.

2. In the status line, enter the length you want the intersection of  the 
chamfer and the second line of  the corner from the corner. The de-
fault length is 0.5 mm. 

3. In the status line, enter the angle you want between the chamfer and 
the second side. The default angle is 45°.

4. Click each line making up the corner you want chamfered. You can 
also hold down the Shift key and click once  inside the corner you 
want to chamfer.  

Before you can fillet Smart 
walls you have to ungroup 
them.

When filleting two parallel 
lines the fillet will be tangent  
to all objects only if the 
filleting radius is half the 
distance between the two 
parallel lines.

When you fillet two parallel 
lines the filleting radius has 
to be half the distance be-
tween the two parallel lines.
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The lines are automatically trimmed or extended. If  you hold down the 
Ctrl key (Macintosh: Option key) while you select the objects to chamfer, 
the objects are not trimmed.

 

The status line allows you to set the distance (Length) from the intersec-
tion as well as the angle.

Trim Tools

The Trim tools on the tool palette lengthen or shorten lines and curves. 
In general, you select the limiting object(s) before you select the tool. 
However, if  you don’t select everything you need, you can hold down the 
Shift key and click additional objects after the Trim tool is selected.

Simple Trim Tool

This tool shortens a line to the specified boundary. If  you hold down 
the Ctrl key (Macintosh: Option key) while using this tool, it becomes the 
Relimit tool.  

Trimming objects
1. Select the object that limits the trim.

2. Select the Trim tool.
 If  necessary, use Shift-Click to select more boundary objects.

3. Click the section of  the object to be discarded.

There are no status line entries. 

Relimit Tool

This tool lengthens or shortens a line to the specified  boundary. If  you 
hold down the Ctrl key (Macintosh: Option key) while using this tool, it 
becomes the Trim tool.

Relimiting objects
1. Select the object that limits the change.

2. Select the Relimit tool.
 If  necessary, use Shift-Click to select more boundary objects.

3. Click the section of  the object that you want to remain.

There are no status line entries.

Segment Tool

This tool divides a line or curve at intersections with other lines or 
curves.

Segmenting an object
1. Select the objects that limit the segmentation.

2. Select the Segment tool.
 If  necessary, use Shift-Click to select more boundary objects.

3. Click the object to be segmented.

The selected object is segmented at the boundary objects. Even though 
you can not see the segmentation on the screen, you can select parts of  
the segmented line by clicking.

If  you hold down the Ctrl key (Macintosh: Option key) while selecting the 
line to be segmented, the new segment appears in the characteristics of  
the current pen style.

There are no status line entries.

Corner Trim Tool

This tool creates a corner from the two objects you specify. Lines are ex-
tended or shortened to create the corner.  

Creating a corner
1. Click the Corner Trim tool.

Rule: Point to what you  
 want to throw away.

Rule:   Point to what you  
 want to keep.

In order to see the segmen-
tation on the screen, first 
select the boundaries and 
the object you want to 
segment and then Show 
points in the Layout menu. 
After the segmentation, the 
 endpoints of the segmented 
parts are displayed.
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2. Click each object. You can also press and hold the Shift key and 
click inside the about-to-be-created corner.

There are no status line entries.

Extending lines to a theoretical intersection
If  you want to extend a line to its theoretical intersection with another 
line, first click the line to be extended, then hold down the Ctrl key (Mac-
intosh: Option key) and click the line that is not to be trimmed.

Transformation Tools 

These tools on the tool palette move, rotate, expand or shrink, stretch and 
mirror objects. Select the object you want to transform before you select 
the Transformation tool.  

You can copy at the same time you transform objects by holding down 
the Ctrl key (Macintosh: Option key) while you specify the transformation.

When you press the Shift key you can select additional objects after you 
have selected a Transformation tool. As soon as you release the Shift key 
the transformation tool is active again.

Move Tool

This tool moves the selected objects to a new location. You can copy the 
selection by holding down the Ctrl key (Macintosh: Option key) while you 
select the objects. If  you  select more than one object, they remain in the 
same position relative to each other.

Moving objects
1. Select the object(s) to be moved.  

2. Select the Move tool.  
 If  necessary, use Shift-Click to select more objects.

3. Drag the selected object to a new location, pressing to set a 
 reference point and releasing to indicate the new location.

You can also click a reference point, then click a destination point to 
move the selected object to the new location. It is not necessary for the 
reference and destination points to be on the object you are moving.

The move is performed relative to the specified points.

 

The status line allows you to specify the X,Y distance that the selection is 
to be moved.

Rotate Tool

This tool rotates one or more objects around a specified point. You can 
copy the selection by holding down the Ctrl key (Macintosh: Option key) 
while you select the objects. If  you  select more than one object, they re-
main in the same position relative to each other.

Rotating objects
1. Select the object(s) to be rotated.

2. Select the Rotate tool.
 If  necessary, use Shift-Click to select more objects.

3. Specify the center of  rotation.

4. Drag the objects or enter an angle in the status line to specify the 
rotation.

You can also click the reference point and then click the destination point. 
It is not necessary for the reference and destination points to be on the 
object you are moving. If  they are not, the rotation is performed relative 
to te specified points.

 

The status line allows you to specify the Angle of  rotation.  

How to enlarge or shrink 
an object with the Move 
tool is described under 
Sizing objects with Tools 
in this chapter.

A positive or negative 
value entered in the 
status line determines the 
direction along the X or 
Y axis. A negative value 
moves the object to the 
left or down on the screen. 
A positive value to the 
right or up.
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Expand/Shrink Tool

This tool enlarges or reduces objects while maintaining the proportions. 
You can copy the selection by holding down the Ctrl key (Macintosh: Op-
tion key) while you select the objects. If  you select more than one object, 
they remain in the same position relative to each other.

Expanding or shrinking objects
1. Select the object(s) to be expanded or shrunk.

2. Select the Expand/Shrink tool.
 If  necessary, use Shift-Click to select more objects.

3. Click a point on the object that you want to remain stationary.

4. Drag the selected object to a new location, pressing to set a 
 reference point and releasing to indcaate the new location.

 

The status line allows you to enter the exact scale (Factor) in the status 
line.

Mirror Tool

This tool creates the mirror image of  an object or objects on the 
 opposite side of  a reference line. You can copy the selection by  
holding down the Ctrl key (Macintosh: Option key) while you select the 
 objects. If  you select more than one object, they remain in the same 
 position relative to each other.   

1. Select the object(s) to be mirrored.

2. Select the Mirror tool.
 If  necessary, use Shift-Click to select more objects.

3. Specify the reference line by clicking two locations or by dragging. 
The reference line need not be parallel to the object.

The status line has o entries.

Moving Objects with Tools
When an object is selected, move the pointer near the object until the 
Move symbol appears and drag th object to a new location.

 

Using the Design Navigator for Moving
When the pointer becomes the Move symbol, you can drag the object 
around and see the Design Navigator’s notations relative to the object’s 
location when you pressed the mouse button. 

In this way, if  you move the pointer over a control point so the Design 
Navigator activates it, you can align the object you are moving with that 
point.

  

  

Using the beginning and 
ending reference point for 
the Expand/Shrink tool is 
parti cularly useful if you 
want to change the size of 
an object relative to the size 
of another object. 

When you want to change 
the size of an object relative 
to the size of an other object 
you should click the Refer-
ence and Destination point 
instead of dragging the 
Reference point.
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Selected Move versus Move Tool
You can move objects either with the Selection tool or with the Move 
function.

Moving with the Selection Tool

The move function of  the Selection tool allows free movement of  the 
selected object.

  

To move a circle from one location to another as shown above, use the 
Selection tool and the Design Navigator to align the 90° quadrant with 
the corner of  the rectangle. The circles do not need to touch the rectan-
gle to be aligned with it.

Moving with the Move Function

The Move tool (on the Transformation subpalette) allows you to move 
the selection with reference to other geometry.

Move a 1 cm square 2 cm in the x direction and 1 cm in the y direction 
asign the following graphic:

  

1. Select the square to be moved.

2. Select the Move tool.

3. With the Move tool, click one corner of  the square when the end-
point notation is displayed.

4. Enter in the X entry box on the status line +2 and in the Y entry 
box -1.

5. Press the Enter key.
 The square is moved, similar to the graphic above.

Copying Objects with Tools
You can copy selections with the Copy command as discussed earlier 
in this section or by holding down the Ctrl key (Macintosh: Option key) 
while using the following tools:

 • Selection tool
 • Single Line tool
 • Center-Point and Opposite-Point Circle tools
 • Ellipse tools
 • Polygon tools
 • Text tool
 • Transformation tools

Copying with the Selection Tool
You can hold down the Ctrl key (Macintosh: Option key) and drag a copy 
of  the selection to a new location.

Copying with the Selection Tool
1. Click the Selection tool.

2. Select the object or objects you want copied.

3. Hold down the Ctrl key (Macintosh: Option key).

4. Drag a copy of  the selection to a new location.  

5. Release the Ctrl key (Macintosh: Option key).

A positive or negative value 
entered in the status line de-
termines the direction along 
the X or Y axis. A negative 
value moves the object 
to the left or down on the 
screen. A positive value to 
the right or up.
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Copying with the Geometry Tools
You can make copies with the following drawing tools:

 • Single Line tool
 • Center-Point and Opposite-Point Circle tools
 • Ellipse tools
 • Polygon tools
 • Text tool

Copying with the drawing tools
1. Construct the geometry you want to copy.

2. Hold down the Ctrl key (Macintosh: Option key).

3. Click a new location. The click determines the location of  the first 
point specified during the construction of  the original geometry 
(the center of  a center-point circle, for example).

4. Release the Ctrl key (Macintosh: Option key).

Copying with the Transformation Tools
You can hold down the Ctrl key (Macintosh: Option key) while using a 
Transformation tool to make a copy of  the selected geometry.

Copying with the Transformation Tools
1. Select the object you want to copy and transform.

2. Select one of  the four Transformation tools.

3. Hold down the Ctrl key (Macintosh: Option key).

4. Perform the transformation according to the directions in the mes-
sage line.

5. Release the Ctrl key (Macintosh: Option key).

 A copy is transformed and the original remains unchanged.

Copy Option versus Copy Command
Usually, using the copy option of  a geometry tool is faster than using the 
Copy and Paste commands in the Edit menu. The Copy command is 
very useful for copying to a different document or application.

Sizing Objects with Tools
Normally, you size an object with the Selection tool or the  Expand/
Shrink tool. In some cases it is useful to use the move tool for sizing 
objects.

Sizing an object with the Selection Tool
You can stretch objects by selecting a point and dragging it to a new 
location.

 

1. Be certain that Selectable Points is set in the Edit menu.

2. Click the Selection tool.

3. Drag a selection marquee around the control points that represent the 
area you want to stretch.

4. Drag the points to a new location.

Sizing an object with the Move Tool
You can also size an object with the Move tool. Using the Move tool 
 allows you to specify the distance the selected point(s) should be moved 
by specific values along the x and y direction in the status line.

To move the corner of  the rectangle in the next graphic with the Move 
tool you proceed as follows:
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1. Be certain that Selectable Points is set in the Edit menu.

2. Click the Selection tool.

3. Drag a selection marquee around the lower right corner of  the rect-
angle.

 

4. Click the Move tool.

5. Enter +1 in the X entry box and -1 in the y entry box in the status 
line.

6. Press the Enter key.
 The corner of  the rectangle is moved the distance you have speci-

fied in the status line.

 

Selected Sizing versus Expand/Shrink Tool
Dragging a control point of  a selected object changes the size of  the 
object, but it also distorts the object, changing the proportion between 
height and width.

 

The Expand/Shrink tool on the Transformation subpalette enables 
you to resize geometry while maintaining its pro portions.

 

In addition, you can specify proportions by clicking points on other ge-
ometry. For example, you can resize an object to fit within another object 
by clicking the boundary into which the resized object must fit.

Editing Commands
Four commands in the Edit menu allow you to change objects without 
changing the physical geometry. You can copy or move objects within the 
same documentation. You can also copy or move objects to other docu-
ments, even to other applications.

The Cut, Copy, and Paste commands do not alter the object’s attributes 
-the layer and pen style (color, weight, and pattern). If  you want to change 
the attributes of  an object, use the Edit Objects command in the Edit 
menu.

Cut  Ctrl+X   [Macintosh: X] 
This command in the Edit menu removes the selected objects and places 
them on the Clipboard. Each selection you cut or copy to the Clipboard 
replaces the previous Clipboard contents.

Cutting objects
1. Select the object to be cut.

2. Choose Cut from the Edit menu.
Once you cut a selection, you can paste it. You can use Cut and Paste to 
move geometry or text around the document, from one sheet to another, 
or from one document to another. You can even paste the cut selection 
into a document in a  different application.

Moving geometry with the Cut command
1. Select the objects you want to move.

2. Choose Cut from the Edit menu.

Use the Move tool for sizing 
 objects only once since the 
next values you enter in the 
status line refer not to the 
new position of the moved 
point(s), but always to the 
original one. That means if 
you  enter (in our example) 
-1 in the X entry box and +1 
in the Y entry box, the point 
is not moved back to its 
original position, but in the 
opposite direction referring 
to its original position.

The difference between the 
Cut and Copy commands 
is that cutting a selection 
removes it from the drawing 
area while a copied selec-
tion remains in the drawing 
area.

You can also erase se-
lections with the Delete 
or Backspace key or by 
choosing Delete from the 
Edit menu. Selections 
erased in this way do not 
go on the Clipboard and 
cannot be pasted. You can 
restore them, however, by 
using Undo.  
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3. Display the location where you want the selection to appear in the 
drawing area, scrolling if  necessary.

4. Choose Paste from the Edit menu.
The object appears in the center of  the drawing area on the original layer 
on which it was created or onto the work layer if  it’s from a different ap-
plication. The object is selected so you can move it, if  you want.

Copy  Ctrl+C   [Macintosh: C]
This command in the Edit menu places a copy of  the selection onto the 
Clipboard without deleting the original selection. You can paste the copy 
elsewhere in the current document or into a different document. You can 
even paste the copied selection into a document created with a different 
application.

Copying objects
1. Select the objects to be copied.

2. Choose Copy from the Edit menu.
 The selection goes on the Clipboard, and it remains in the current 

document.

Paste  Ctrl+V   [Macintosh: V]
This command in the Edit menu pastes a copy of  the Clipboard contents 
onto the center of  the drawing area. The Clipboard contents are not 
changed when you use the Paste command.

You can also paste the selection into another document or into a docu-
ment created with another application.

If  you want to create an even distribution of  geometry, you can use Lin-
ear Duplicate or Polar Duplicate in the Edit menu.

The Clipboard
The Cut and Copy commands both place a copy of  the selected object 
on the Clipboard. The Clipboard is a buffer —a temporary storage place 
that holds the last cut or copied selection. The contents of  the Clipboard 
are objects, not bitmaps.

Erasing Geometry
You can use several methods to erase objects:  

• You can select the object(s), then press the Backspace key. 

• You can retrieve what you deleted with the Undo command.

• You can undo the last eight actions.

• You can select the object(s), then choose the Delete  command from 
the Edit menu. You can retrieve what you  deleted with the Undo 
command.

• You can select the object(s), then choose Cut from the Edit menu. 
You can retrieve what you cut by using the Paste  command, as long 
as you have not cut or copied anything else.  

Delete
This command in the Edit menu deletes a selection without placing it 
onto the Clipboard. You can Undo this deletion, but you cannot paste 
what is deleted. In addition to this command, you can use the Delete or 
Backspace key to delete a selection.

Retrieving with Undo and Redo
Once an object is deleted or cut, you can retrieve it with the Undo com-
mand in the Edit menu. Undo can reverse each of  the last eight actions. 
You can use Ctrl+Z (Macintosh: Z) to issue the Undo command from 
the keyboard.  

Undo  Ctrl+Z   [Macintosh:  Z]
This command in the Edit menu reverses the last action. You can Undo 
and Redo any of  the last eight actions. For example, if  you delete an ob-
ject, you can choose Undo to restore it. You can then use Redo to return 
to the deleted version.

You can undo actions that create and edit geometry and text but not 
 actions that do not change the contents of  the drawing, such as resizing 
the window or quitting.

If you want to move an 
object from one layer to an-
other, use the Edit Objects 
command in the Edit menu.

You can also create a copy of 
an object or text box with the 
Selection tool. First select 
the object, then hold down the 
Ctrl key (Macintosh: Option 
key) and drag a copy of the 
object to a new location. 

You can copy an object us-
ing any of the Transforma-
tion tools by holding down 
the Ctrl key (Mac intosh: 
Option key) while  using 
the tool.

If the object was cut or 
copied from a DesignFre
eQ document, when it is 
 pasted, it goes on the layer 
it was on when it was cut or 
copied. A pasted selection 
retains its original attributes. 
Objects cut or copied from 
non-DesignFreeQ docu-
ments are pasted onto the 
work layer.  

The number of Undo's and 
Redo's is limited to 32.
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Redo  Shift+Ctrl+Z [Macintosh: Shift+Z]
This command in the Edit menu reinstates the last action reversed by 
Undo. You can Undo and Redo any of  the last eight editing actions.

Duplicating Objects
DesignFreeQ allows you to create multiple copies of  an object and 
 arrange them in an array along a straight line or in a  circular pattern. 

Linear Duplicate
This command in the Edit menu allows you to create an array of  copies 
along a straight line.

   

The Linear Duplicate dialog box contains the following settings:

Number Per Row The total number of  objects you want in each 
row. Be sure to include the selected object  itself  
in this  total count.  

X Length/Y Length The X Length value determines the horizontal 
length of  a row. The Y Length value determi nes 
the vertical rise of  the row. The X Length and Y 
Length can be set by entering values, or by click-
ing the mouse in the drawing area.

Total Lengths The X and Y Length is the distance from the 
selected object to the last copy. 

Step Lengths The X and Y Length is the distance from the 
selected object to the first copy.

Number of  Rows The total Number of  Rows that you want.

Total Offset The offset is the perpendicular distance  between 
the row containing the selected  object and the 
last row.

Step Offset The offset is the perpendicular distance  between 
the row containing the selected object and the 
next row.

Offset The perpendicular distance setting for the Total 
Offset or Step Offset. You can specify the Off-
set by entering a  value or by clicking the mouse 
in the  drawing area.

Using Linear Duplicate
1. Select the object to be duplicated.

2. Choose Linear Duplicate from the Edit menu.

3. Enter the number of  objects per row.

4. Specify Total or Step Lengths.

5. Click the X Length* box.

6. Move the pointer to the drawing area and drag to indicate the length 
of  the row of  copies.

 Both the X and Y values appear in the entry boxes.

7. If  you want more than one row, enter the number of  rows, and 
specify the type of  offset.

8. Enter the offset, if  any. You can use a negative number.

9. Click OK. 

An Example 
Suppose you want to illustrate six machine screws. You could draw 
 geometry, then use Linear Duplicate to copy the  geometry in an array.

If you are using a tool which 
 involves a multistep process, 
such as constructing con-
nected lines or creating a 
3-point fillet, choosing Undo 
reverts to the beginning of 
the process. Some other 
 activities can be stopped by 
pressing the Escape key.

An asterisk (*) appearing 
beside an entry field 
 indicates that you can fill 
in the box by dragging the 
mouse in the drawing area 
to indicate the length.

If you begin a duplication 
and discover that it is not 
what you want, you can stop 
the process by pressing 
the Escape key, and then 
choosing Undo to remove 
the copies from your doc-
ument.

Dragging to indicate the 
offset is particularly useful if 
you want the offset to equal 
the distance  between two 
objects.
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1. Create and select the geometry you want to duplicate.

2. Choose Linear Duplicate from the Edit menu.

3. Enter 6 in the Number Per Row box.

4. Click the Step Length button.

5. Click in the X Length box.

6. Move the pointer into the drawing area and drag across the widest 
point of  the step.

7. Click at the end of  the entry in the X Length box.

8. Type *2 to multiply the width of  the geometry by two.

9. Click OK.

  

Polar Duplicate
This command in the Edit menu allows you to copy and rotate the se-
lected geometry. When you duplicate an object in a circular array, you can 
specify the number of  duplications, the center of  the array and whether 
the objects are copied in a rotated orientation or an upright orientation.

 

When you select the Polar Duplicate command in the Edit menu the 
following dialog box is displayed:

 

The Polar Duplicate dialog box contains the following settings:

Number The total number of  objects you want. Be sure to 
 in clude the selected object itself  in this total count.

 The Center X and Y values determine the center of  the 
circular array.

Total Angle   The total number of  degrees between the center of  the 
selected object and the center of  the last copy.

Step Angle   The number of  degrees between the center of  the se-
lected object and the center of  the first copy. 

   Copies are rotated relative to the angle between the 
copies. Each single arbitrary point of  all copies have the 
same distance to the center of  the circular array. That 
means that any point of  the object can be the reference 
point.

   Copies are upright with respect to the selected object. 
This option requires a reference point.

Ref  X/Ref  Y The reference point for the Upright Objects  option.

 Ref  X and Ref  Y determine an imaginary point du-
plicated around the center, as specified. The selected 
objects are reproduced in the same  position relative to 
each imaginary point that is duplicated. With the option 
Rotated Objects the reference point has a constant 
 distance to the center of  the circular array.

An asterisk (*) appearing 
beside an entry field indi-
cates that you can fill in the 
box by dragging the mouse 
in the drawing area to indi-
cate the length.

Center X/
Center Y 

If you want to place a 
selected object three times 
in a semicircle you have to 
enter 3 for the Number and 
90° for the Step  Angle. 

Rotated 
Objects

Upright Ob-
jects
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Using Polar Duplicate
1. Select the object to be duplicated.

2. Choose Polar Duplicate from the Edit menu.

3. Enter the number of  objects in the circular array.

4. Click the Center X* box.

5. Move the pointer to the drawing area and click to indicate the center 
for the array of  copies.

 The values for Center X and Center Y appear in the entry boxes.

6. Specify Upright or Rotated objects by clicking a button.

7. If  you specified Upright, click a location for the reference point in 
the drawing area.

8. If  you do not want the copies in a complete circle, click the Total 
or Step Angle button.

9. Enter a value for the specified angle type.

10. Click OK. 

Offset
This command in the Edit menu allows you to create offsets from lines, 
arcs, circles, ellipses and splines.

 

When you select the Offset command in the Edit menu the following 
dialog box is displayed:

 

The Offset dialog box contains the following settings:

Offset Distance The offset distance is the distance away from the orig-
inal geometry that the new geometry will be created. 
For multiple offsets additional values may be entered 
manually into the Offset Distance field, separated by 
semicolons.

Ref. The X and Y values can be filled in manually or indi-
cated by a mouse click on the drawing area offset from 
the object (the Z value must be 0). The point  clicked 
determines which side of  the object the offset should be 
performed.

Clicking the Options button displays the following dialog box:

   

The Options dialog box contains the following settings:

Tolerance For Spline and Ellipse objects the offset distance is 
 approximated by a spline. By setting a  Tolerance for 
this type of  object you can  determine how accurate  
the offset is relative to its theoretical position.

Max Iteration DesignFreeQ will iterate when calculating the offset of  
Spline and Ellipse objects to improve the approximation 
the number of  times indicated in the Max Iteration 
field. The default value is 3. Setting a high value will 
 decrease performance.

Mitered Joint If  you mark this option the offset object will have 
square external corners instead of  filleted corners. This 
option is by default not selected. The radius of  the fil-
leted corners is automatically set to the offset distance. 

If you begin a duplication 
and discover that it is not 
what you want, you can stop 
the process by  pressing 
the Escape key, and then 
choosing Undo to  remove 
the copies from your doc-
ument.

The asterisk indicates that 
you may use the cursor to 
input an offset distance by 
dragging between any two 
points on the drawing area. 
The cursor must be in the 
Offset Distance field while 
dragging. 

The offset Direction is also 
filled in the respective entry 
fields when you drag the 
 offset distance since the 
vector you drag de termines 
the Offset Direction auto-
matically. 
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For instance; a box that is offset by .25 will have a fillet 
at each corner with a radius of  .25.

Grouped If  this option is marked the new offset geometry will 
be grouped when created. This option is by default not 
selected to produce ungrouped geometry.

Creating an Offset
1. Select the object you want to offset.

2. Select the Offset command in the Edit menu.

3. Click into the Offset Distance field.

4. Input an offset distance by dragging between any two points on the 
drawing area.

5. Click into one of  the Ref  entry fields.

6. Input an offset direction by dragging between any two points on 
the drawing area.

7. Click the Options button.
 Specify in the Options dialog box a Tolerance, if  needed and 

whether or not the object will be offset with mitered corners.
 The new geometry will be created as a group and will leave the orig-

inal geometry selected.

Changing the Characteristics of Objects
You can edit selected objects by either changing individual characteris-
tics, such as layer or line style, or by changing the  specifications in the 
Edit Objects dialog box.  The Edit Objects dialog box also provides 
information about the  selected object in addition to allowing you to make 
 changes.

Edit Objects
This command in the Edit menu allows you to edit selected  objects by 
changing individual characteristics, such as length, layer, or pen style, or oth-
er specifications. Changes made through this dialog box can be reversed 
with the Undo and Redo commands.

Editing objects
1. Select the object to be edited.

2. Choose Edit Objects from the Edit menu.
 The dialog box appears.

 

3. Change the information in the entry boxes.
 Double-click the entry box and type a new entry (do not press En-

ter).

4. Make any other changes you want.

5. Click the Apply button.

6. Double click the Close box in the upper left corner to close the 
Edit Objects dialog box.  

You can use Undo and Redo to reverse changes made through this 
 dialog box.

The specifications shown in this box depend on the type of   object 
 selected, and include at least the following:

 • Number (or type) of  objects
 • Lock status
 • Current layer
 • Current color
 • Current pattern

The geometry will be only 
grouped, if the Grouped 
option was checked.

You can change a single 
characteristic faster by sim-
ply selecting the object and 
changing the characteristic. 
But if you are changing sev-
eral characteristics or any 
measurements or positions, 
you should use the Edit 
Objects command. 

Many boxes have pop-up 
menus for selection. Press 
the down arrow and then 
drag to the selection you 
want.
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 • Current weight
 • Absolute coordinates for the starting point and ending point of  

the object

The measurements reflect the settings of  the Units option in the Pref-
erences submenu. If  you want to prevent changes to an object, you can 
specify locked in this dialog box, or you can select the object and choose 
Lock from the Arrange menu.

If  you are doing a lot of  editing, you may want to leave the Edit Objects 
dialog box displayed. In that way you can select the object, make the 
changes in the dialog box, click Apply, and then go on to the next object. 

If  more than one object is selected when you choose Edit Objects, only 
the common information is displayed. Entries are blank when the infor-
mation isn’t common. For example, if  you select two concentric  circles, 
the center will be displayed in the Edit Objects box but the  diameter 
box will be blank.

If  you select several objects and then choose Edit Objects, all of  the 
objects will reflect the changes you make in the dialog box. For example, 
if  you select all dimensions and change the text entry in the Edit Ob-
jects dialog box to 2, all the  dimensions will display a 2.

Moving an object to a different layer
1. Select the object(s) to be moved.
2. Choose Edit Objects from the Edit menu.
3. Click the arrow for the layer entry box.
4. Click the layer from the list.
5. Click Apply.

Arranging Geometry
The Arrange menu contains some commands that enable you to 
subdivide geometry, group geometry so it behaves like a unit and 
lock  geometry to prevent changes . In addition, this menu contains a 
 command to refresh the screen after you have changed geometry.

This menu contains also commands to sort objects on the screen. When 
using these commands objects in the  foreground will cover objects in the 
background. This feature allows to manipulate the default drawing order 
of  DesignFreeQ, that puts always that object into the foreground that 
was drawn last.

Bring to Front
This command brings a selected object into the foreground and will 
 cover all underlying objects.  When this command is selected for another 
object, the object brought into the foreground before, will go one posi-
tion backwards. This allows to sort objects specifically on the screen. If  
several sorted objects are grouped, the sorting order will be kept, even if  
the grouped object is send to front again.

Send to Back
This command sends a selected object into the background and will be 
covered by all objects lying in the foreground.  When this command 
is selected for another object, the object brought into the  background 
 before, will go one position forwards.

This allows to sort objects specifically on the screen. If  several sorted 
objects are grouped, the sorting order will be kept, even if  the grouped 
 object is send to back again.

Bringing objects to Front/Back  (Example)
1.  Draw a circle using the line color Black and a line weight of 1,5 

mm.

2.  Fill the circle with the color Yellow.

3.  Select the yellow fill area (without the black perimeter).

4. Select the Send to Back command in the Arrange menu.
 The yellow fill area is send to back and covered by the black perime-

ter circle.

  

In the Edit Objects dialog 
box you can use mathemat-
ical operators. A list of all 
allowed operators is in the 
Appendix of this manual.

You can use different units 
in each entry box like inch 
(''), feet ('), feet/inches 
(x'y''), centimeter (cm) 
 millimeter (mm) or Meter 
(m). You are also allowed to 
mix English and metric units 
as long as they are labelled 
correctly like 10'' + 25.4 cm.

The display order set with 
the Bring to Front and 
Send to Back commands is 
valid as well when selecting 
objects.

This command can be used 
as well when placing text in 
front of a filled surface.

With multiple hierarchical 
grouped objects that func-
tions only partly. 
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5. Select the circle and the fill area and choose the Group command in 
the Arrange menu.

 The yellow fill area and the circle perimeter are grouped as sorted. 

6.  Draw a rectangle using the line color Black and a line weight of 1,5 
mm.

7.  Fill the rectangle with the color Blue.

8.  Select the blue fill area (without the black rectangle line).

9. Select the Send to Back command in the Arrange menu.
 The blue fill area is send to back and covered by the black perimeter 

lines.

  

10. Select the Group command in the Arrange menu.
 The blue fill area and the perimeter lines are grouped as sorted. 

11.  Select the blue rectangle and move it partly over the yellow circle. 

12. Deselect the blue rectangle by clicking anywhere onto the drawing 
area.

 The blue rectangle in the foreground covers the yellow circle.

  

13.  Select the yellow circle.

14. Select the Bring to Front command in the Arrange menu.
 The yellow circle is brought to front and covers the blue  rectangle. 

  

Divide
This command in the Arrange menu subdivides the selected geometry 
into the specified number of  equal parts.

1. Select the object to be divided.

2. Choose Divide from the Arrange menu.

 The following dialog box appears.

 

3. Enter the number of  equal parts you want to divide the  selection 
into.

4. Click OK.

You can see the divisions when you display the points by clicking Show 
Points in this dialog box or choosing Show Points from the Layout 
menu.

Group  Ctrl+Y   [Macintosh: Y]
This command in the Arrange menu combines selected objects to 
 function as a single object.

Grouping objects 
1. Select the objects to be grouped.

2. Select Group from the Arrange menu.

Once you group geometry, you can’t edit the individual objects within the 
group unless you ungroup them.  

You can also combine groups. For hierarchical groupings, DesignFreeQ 
ungroups each group in the order in which they were combined.

If you move the group, 
all  components move 
 together. If you change 
the size of a group, the 
 individual  objects change 
pro portionally.  
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Changing the members of a group without adding a hierarchical 
level
When you want to add new geometry to an existing group, and you select 
the group and the new geometry and choose the Group command, you 
end up with a group within a group. If  you want to make a single group, 
follow these directions:

1. Select the group.

2. Choose Ungroup from the Arrange menu.
 The geometry is ungrouped with the individual objects  selected.

3. Hold down the Shift key and select the geometry you want to  
add to the group.

4. Choose Group from the Arrange menu.

You can follow a similar procedure to remove members of  a group.

Ungroup
This command in the Arrange menu separates selected grouped objects 
into their individual components.  

Ungrouping Objects
1. Select the group.

2. Choose Ungroup from the Arrange menu.
 The individual objects in a group are selected.

Lock
This command in the Arrange menu prohibits editing or movement of  
selected geometry.

Preventing accidental changes to one or more objects
1. Select the objects to be locked.

2. Choose Lock from the Arrange menu.

Although you cannot move or change a locked object, you can copy, 
group, and select it.

Preventing changes to an entire document
1. Choose Select All from the Edit menu.

2. Choose Lock from the Arrange menu.

Selected objects can also be locked or unlocked by clicking the Locked 
box in the Edit Objects dialog box.

Unlock
This command in the Arrange menu removes the lock in the selection. 
You can change and move the unlocked objects.

Unlocking Objects 
1. Select the locked object(s).

2. Choose Unlock from the Arrange menu.

Selected objects can also be locked and unlocked by clicking the  Locked 
box in the Edit Objects dialog box.

To create temporary 
groups, you can drag a 
selection marquee around 
several objects to treat 
them as a single unit 
while they are  selected.  



Text, Fills and Crosshatches
Text 

AutoText

Crosshatching and Solid Fills





97

Text, Fills and Hatches

Text, Fills and Hatches
This chapter describes the features you can use to add detail to your 
drawing: text, crosshatching and solid fills.

Text
When you want to annotate your drawing, you’ll use the Text tool to 
create a text box for entering characters from the  keyboard. You can 
create, import, and edit text on screen. You can use the Text menu to set 
the characteristics, such as font, text size, style, alignment, line spacing, and 
indentation.

Text Tool

This tool on the tool palette allows you to create and edit text on screen. 
The text you enter has the characteristics set in the Text menu.

Creating text
1. Select the Text tool from the tool palette.

2. Create a text box by dragging or by clicking two locations to place 
the opposite corners of  the text area.

 The text box which appears is as tall as a single line of  text and as 
wide as you indicate. The text cursor appears in the box, ready for 
your typing.

3. Enter the desired text from the keyboard.
 Pressing the Delete key erases characters to the left of  the cursor.

 The text you enter automatically word wraps to the next line when it 
reaches the right side of  the text box. If  you resize the text box, the 
words rewrap automatically.

Importing a text file
You can import an ASCII file that contains text you want to use in your 
drawing. For example, you can place specifications you’ve written with 
a word processor on your drawing without retyping it. The entire file is 
imported, so if  you want to use only part of  the document, create a new 
file that contains only the information you want entered on the drawing.

1. Select the Text tool from the tool palette.

2. Create a text box by dragging or clicking twice to place the 
 opposite corners of  the text area.

3. Choose Import from the File menu.
 A dialog box appears.

4. Select the text file you want to import.
 The Import dialog box appears and the Text file type is specified.

5. Click OK.
 The text file appears in the text box you created.

Editing text
1. Select the Text tool from the tool palette.

2. Move the pointer directly over the text to be edited.
 The pointer turns into an I-beam text cursor when it is over text. 

(This only occurs when the Text tool is active.)

3. Use the text cursor to select text.
 You can drag either direction to select characters, and double-click 

on an individual word to select the word.
 You may also simply click to place the text cursor within the existing 

text if  you want to add more to it.

4. Modify the selected text by choosing the appropriate  commands 
from the Text menu.

An ASCII text file is usually 
created by word processing 
software and saved as plain 
text. It usually contains only 
standard keyboard charac-
ters (letters, numbers, punc-
tuation, and spaces) without 
the formatting typically 
found in word processing 
documents.

If you want to change char-
acteristics for the entire text 
entry, use the Selection tool 
to select the text block.
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Changing the characteristics of a text block
You can change the font, text size, style, spacing, and inden tation of  a text 
block.

1. Use the Selection tool to select the text block to be changed.

2. Select the new characteristic from the Text menu.
 The selection shows the new characteristic.

Modifying text margins
1. Choose the Text Margins command from the Preferences sub-

menu in the Layout menu.
 The following dialog box is displayed.

 

2. Enter values for the Left, Right, Top and Bottom text margins.
 This values are valid for all future text placed with the Text tool 

from the Function palette. You can save these margins permanently 
using the Save Preferences command from the Preferences sub-
menu in the Layout menu. 

Moving Text
Each text object has nine snap points for the Design Navigator. These 
snap points will help you to move and/or align text with the Selection 
tool.

 

1. Choose the Selection tool from the Tool palette.

 

2. Select the text object you want to move.

3. Move the cursor over one of  the nine text snap points. The cursor 
becomes a 4-way Move symbol.

 

4. Place the 4-way Move symbol at the desired snap point using the De-
sign Navigators notations as a guide.

5. Drag the text object to the new location.

Changing the size of the text box
1. Click the Selection tool.

2. Drag a selection marquee around the right side of  the text box.

3. Drag the control points to the left or right.
 The area changes size and the text rewraps automatically.

 

Moving Text and Files into the DesignFreeQ 
drawing area (Drag&Drop)
Text can be moved directly from all programs that support OLE into the 
DesignFreeQ drawing area.

DesignFreeQ Files (documents with the file extension .vlm) will be 
 directly opened, when moved from the Windows-Explorer or from the 
Windows Desktop into the DesignFreeQ drawing area.

Dragging text into the DesignFreeQ Drawing area
1. Create text using a text editor (such as MS-Word) that supports 

OLE.

If you want to change the 
 characteristics of a word or 
 portion of a text block, use 
the Text tool to select what 
you want to change.

Selectable Points in the 
Edit menu must be active 
for selecting the control 
points of the text box.

When you want to set 
the size of the text box 
 accurately you select the 
text box with the Selection 
tool and choose the Edit 
objects command in the 
File menu. In the Width and 
Height entry boxes you can 
enter values for the box size.
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2.  Select the text and drag it with the left mouse button pressed into 
the DesignFreeQ drawing area.

3. Release the left mouse button.
 The text is placed on the DesignFreeQ drawing area at the  location 

where the mouse button was released. The text is  displayed using 
the current DesignFreeQ text font and all  paragraph formats will 
be maintained. 

Dragging DesignFreeQ Files into the DesignFreeQ Drawing area
1.  Select a DesignFreeQ File in the Windows Explorer or on the Win-

dows Desktop.

2.  Drag the DesignFreeQ File with the left mouse button pressed 
into the DesignFreeQ drawing area.

3. Release the left mouse button.
 The DesignFreeQ drawing is automatically opened in Design 

FreeQ.

Text Menu
The Text menu contains commands for changing the text font, size, and 
style, as well as the justification, spacing, and indentation.

 

Font 
This command in the Text menu changes the font for selected text or 
future text entries.

 

The fonts listed in the menu are those installed on your  computer and 
include DesignFreeQ’s plotter fonts.

The font you choose stays in effect for the current document until you 
choose another font.  

Special characters and accents are available as described in the Appendix 
of  this manual.

Extended font selection
The Font submenu can display up to 20 fonts. If  you have installed more 
than 20 fonts select More in the Font submenu of  the Text menu to get 
access to all available fonts.

Choosing More from the Font submenu brings up a dialog box  allowing 
you to specify the font, text size and text style. The text size is measured as 
point size. If  you want to specify the size in the units you have set for 
your drawing, you have to type the exact unit such as " for inch or mm 
for millimeter after the value.

1. Choose More from the Font submenu in the Text menu. 
 The  Character Format dialog bx displays:

 

2.  Select the character format. The text size is always  measured as 
point size (pt). If  you want to specify the size in another unit like in 
Millimeter, include mm with your numeric entry.

All selections made in this dialog box take effect immediately for all 
 selected text or text boxes.

A checkmark in front of a 
menu item shows the cur-
rent attribute.

Use Plotter fonts whenever 
you are creating text for 
a drawing that you intend 
to send to a plotter, since 
plotting Postscript or 
TrueType fonts take much 
more time to print or may be 
 substituted.

In addition to the plotter fonts 
shipping with DesignFreeQ 
you can use all  plotter fonts 
that are compatible with the 
file format .shx of  AutoCAD©. 
When you copy these files 
into the Fonts folder of the 
DesignFreeQ folder, the 
new fonts are displayed in 
the Fonts submenu after re-
launching DesignFreeQ. 

All menu items in the Text 
menu affect only text creat-
ed with the Text tool. Text 
attributes for dimensions are 
set in the dimension editor 
under Preferences in the 
Dimension menu.

Text can be rotated with the 
Rotate function like any 
other object in a drawing in-
cluding text using Postscript 
and True Type fonts. 
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However when you type in a value (only possible in the Size box) the 
change becomes effective only until you do another selection or  con tinue 
to work on the drawing area.

You can leave this dialog box open to assign other character formats. If  
you want to close this dialog box, you have to double-click the Close box 
in the upper left corner of  the dialog box.

The character format you specify stays in effect until you choose  another 
character format.

Printing TrueType Fonts on Pen Plotters
When you want to print TrueType Fonts on pen plotters you must  
use a WinLINE Plus Plotter Driver. Look for more information about 
WinLINE Plus in the Internet under www.winline.com.

Font Sizes and ANSI Standards
A typical font specified for 7,0 mm may produce a character that is only 
3,5 mm. The variation depends on the proportional spacing of  the font. 
If  you want a font set to exact specifications, use a Plotter font, which 
conforms to ANSI standards.

Size 
This command in the Text menu sets the font size for the selected text 
or for future text entries in the current document. The size can be spec-
ified as either points or units, as defined in the Units dialog box of  the 
Preferences submenu in th Layout menu.

 

Specifying a non-standard text size
Choosing Other from the Size submenu brings up a dialog box  allowing 
you to specify the exact text size you desire in whatever units you’ve set 
for your drawing. You can specify point size by entering pt after the value 
in the entry box; for example, if  you enter 11 pt the font size will be 11 
point.

1. Choose Other from the Size submenu in the Text menu.

  

2. Enter the size you want. The size is measured in the current units as 
set in the Preferences submenu. If  you want to specify a point size, 
include pt with your numeric entry.

3. Click OK.  
 The size you specify stays in effect until you choose another size.

Text Size and Scaling
When you scale a drawing using the Drawing Size command without the 
options keep text size and keep dimension text size after you have  added text 
and dimensions, you have to assign the correct text size again in the Text 
and Dimension menus.

This is not necessary when you add text and  dimensions after scaling or 
scale the drawing with the options keep text size and keep dimension text size 
active.

Style
This command in the Text menu sets the style (such as bold or  underline) 
for selected text or future text entries.

 

If you have selected Amer-
ican units under Units in 
the Preferences submenu 
of the Layout menu the text 
size is displayed in Point 
and Inches, when you 
have selected metric units 
it is displayed in Point and 
Millimeters. 

All items in this dialog box 
affect only text created with 
the Text tool. Text attributes 
for dimensions are set in 
the Dimension Editor under 
Preferences in the Dimen-
sion menu.

It is advisable to use the 
 Selection mask to select all 
text and dimensions in case 
you have to assign the accu-
rate text size after scaling.

A detailed description about 
text size and scaling can be 
found in Chapter 9 Basic 
Drafting.

Certain Styles are only 
available on the Macintosh, 
not under Windows.
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The style you specify stays in effect until you choose anther style. A 
check ( ) indicates the current style. You can change the default set-
ting by saving the changes in the preferences file  Prefs.vlm (Macintosh: 
DesignFreeQ Prefs) with the Save Preferences command in the Pref-
erence submenu of  the Layout menu.

Text Alignment
The four commands in the second section of  the Text menu align your 
text within the text box. The text can be aligned on the left, the right, cen-
tered in the middle, or it can be fully justified so that it is aligned with both 
left and right margins of  the text box.

If  the Text tool is active, both the selected text and future text are 
 aligned as specified, but existing text is not aligned. If  you choose this 
command when a tool other than the Text tool is active, only future text 
entries are aligned. If  a text entry is  selected when you choose this com-
mand, the selection and future text entries are aligned as specified.

Align Left
This command in the Text menu aligns the selected and future text at the 
left margin of  the text area.  

 

Align Middle
This command in the Text menu centers the selected and future text in 
the text area.

 

Align Right
This command in the Text menu aligns the selected and future text at the 
right margin of  the text area.

 

Justified
This command in the Text menu aligns both the left and right margins 
of  the selected and future text in the text area.

 

Text spacing
The Text menu has commands for single spacing, double spacing, or using a 
space and a half  between the lines o your text.

 

The check ( ) in the Text menu indicates the current line spacing.

Single Space
This command in the Text menu sets the spacing of  selected and future 
lines of  text so each line occupies one space in the text area.

When you want to set the 
text offset from the box 
boundary you have to select 
the text box with the Selec-
tion tool and choose the 
Edit objects command in 
the File menu. You can enter 
values for the text offset in 
the related boxes.

You can change the default 
setting by saving changes in 
the Preferences file.
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1-1/2 Space
This command in the Text menu changes the spacing of   selected and fu-
ture text so each line occupies one and a half  spaces in the text area.

Double Space
This command in the Text menu sets the spacing of  selected and future 
text so each line occupies two spaces in the text area.

Indentation
If  you wish to indent the text on the right or left side of  the text box, or 
if  you wish to have the first line indented, choose Indentation from the 
Text menu. 

Indentation
This command in the Text menu sets the indentation of  paragraphs for 
the selected text area as defined by the units set in the Preferences sub-
menu.

1.  Choose Indentation from the Text menu
 The dialog box appears.

 

2. Specify the indentation you want. You can use point  values if  you 
include pt in your entry.

3. Click OK.

You can specify the number of  units for any or all the choices:

First Line  Sets the number of  units for the indentation of  the first 
line of  each paragraph.

   

Left Indent  Sets the number of  units for the indentation of  the left 
margin of  each paragraph.

   

Right Indent  Sets the number of  units for the indentation of  the right 
margin of  each paragraph.

   

AutoText
The two AutoText commands TextBlocks and Forms in the Text menu 
simplify and accelerate the placing of  text blocks.

 

They allow you to define often used annotations as Standard Text that can 
be placed with only one mouse click in a drawing and to fill in and edit 
Title Blocks in a dialog box. In addition you can create your own Standard 
Drawing formats and Title Blocks or modify existing ones.

Defining Text blocks
Using the TextBlocks command you can define often used annotations 
as standard text blocks, group annotations in logical groups and place 
predefined annotations directly on the drawing area.

TextBlocks
The TextBlocks command dispays the following dialog box.
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The TextBlocks dialog box contains the following settings:

New When you click the New button a new annotation or text 
group is created depending which list item is active.

 When a annotation is selected while clicking New a new 
annotation is created for the selected group with the 
name Text 1.

 Clicking New when a text group is selected a new text 
group with the name Group 1 and a new annotation for 
the new group named Text 1 is created.

 You can overwrite the predefined names Text 1 or 
Group 1 with a more suitable name in the Rename en-
try field.

Delete When you click the Delete button the selected anno-
tation or text group is deleted. When you delete a text 
group all related annotations are deleted as well.

Rename With the Rename button you can rename the selected 
annotation or text group.

Options With the Option button you display a dialog box  listing 
 selectable attributes such as a border frame or position line 
for the selected text block and define the text style.

Extensions In the Extended dialog box you can assign an imported 
text to a selected text block.

90° When this option is marked the annotation is placed ver-
tically on the drawing area.

0° When this option is marked the annotation is placed hor-
izontally on the drawing area.

Extended  dialog box
When you select an annotation in the TextBlocks dialog box and click 
the Extended button the following dialog box is displayed:

 

In this dialog box you can assign to the selected  annotation an  extended 
text that is placed on the drawing instead of  the selected text block. You 
cannot type extended text but only imported it as ASCII-Text with the Im-
port button.

Annotations that contain extended text have a checkmark in front of   
the name.

The width of  the placed text frame equals the longest text line of  the 
imported ASCII file. Text attributes such as Text style, Text size for all text 
blocks are set in the Options dialog box.

Editing extended text
Imported text cannot be edited in the Extended Text dialog box  instead 
the original ASCII file has to be modified with a text editor.  
For an optimized organization it is recommended to place all imported 
texts in the Text folder of  the DesignFreeQ folder in where you find 
some pre-installed extended text that however is not referenced to any 
 notation.

Options dialog box
When you click the Options button while a Text block is selected the fol-
lowing dialog box is displayed:

Attributes you assign to 
selected text are not saved 
with the selected text and 
are only valid for the current 
selection.

Text that contains imported 
text has a checkmark in 
front of the text name.

ASCII Text can be created 
with any text editor. You only 
have to specify ASCII format 
when saving the text. Take 
care that there is no empty 
text line at the end of the 
ASCII text since it will be 
imported as well.

Only the directory path of 
the imported text file is 
saved with the DesignFre
eQ file, not the extended 
text itself. In case you 
cannot open the  extended 
text example shipping with 
DesignFreeQ , delete it in 
the Extended Text dialog 
box and  import it again 
from the Text folder in the 
DesignFreeQ folder.
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In this dialog box you can specify whether you want to place the annota-
tion in a border frame, with a position leader or an arrow line.

For all marked annotations you can specify the Text fonts, the Text size and 
the Text style such as bold or italic.

Creating and placing Text blocks
1.  Choose the TextBlocks command in the Text menu.

2. Create a new Text Group with a new Text Block by selecting first a 
text group and clicking then the New button. You can overwrite the 
automatically created names Group 1 and Text 1 using the  Rename 
button.

3. In order to assign to the newly created text block an extended text 
you must click the Extensions button.

 The Extensions dialog box is displayed.

4. Import an ASCII text you have created before with an text editor 
from the Text folder of  the DesignFreeQ folder into the Extend-
ed  dialog box using the Import button.

5. Click OK.
 The Extended dialog box is closed. A check mark indicates that  

the text block contains an extended text.

6. Click the Options button.

7. Specify the desired options and text attributes such as text font etc.

8. Click OK.
 The Options dialog box is closed.

9. When you place a text block with a border frame you have to drag 
a vector on the drawing area. The Starting point of  the vector defines 
the starting point of  the position line and the Endpoint of  the vector 
defines the position for the nearest corner of  the text border and 
the endpoint of  the position line.

 When you have marked the option Stand alone you click a point on 
the drawing area for the lower left corner of  the text.

 The text block is placed horizontally or vertically on the drawing area 
as soon you release the mouse button. The orientation is depending 
on the marked option   (0° or 90°)

10. Place some more text blocks or close the Text Blocks dialog box 
clicking the Close box at the upper corner of  the dialog box.

 When you select any function or command while the Text Blocks 
dialog box is open the dialog box closes automatically.

Editing Text Blocks in the drawing
Placed text blocks can be only edited using the Text function in the 
DesignFreeQ function palette, not with the TextBlocks command.

Extended texts saved in the Text folder of  the DesignFreeQ folder can 
be only edited with a Text Editor.

Title Blocks
With the Forms command in the Text menu you can fill in the title 
blocks of  all standard drawing formats that are saved in the Format fold-
er of  the DesignFreeQ folder.

As long as no standard drawing format is placed in a drawing the Forms 
command is greyed. It can be only selected if  you place a  drawing format 
with a Title block using the Import command in the File menu or the 
Sheet into View command in the Views menu.

DesignFreeQ allows you to create your own drawing formats that you 
can use with the Forms command. This procedure is described  in Chap-
ter 10 Structuring Drawings.

ASCII Text you import as ex-
tended text has not to be in 
the Text subdirectory of the 
DesignFreeQ folder but it is 
recommend for later  editing 
of the extended text.

The Arrow type for the po-
sition line you choose with 
the Arrow command in the 
Pen menu.

Die Width of the border 
frame equals the longest 
text line of the imported 
ASCII Text.

When you import a drawing 
format you have to mark the 
option unscaled in order 
to place the drawing format 
at it’s original size onto the 
drawing area. If you cannot 
see the imported drawing 
format you have to select 
the Zoom all command in 
the Arrange menu.
If you have placed by mis-
take two drawing formats 
in a drawing all entry fields 
of both title blocks are 
displayed in the Title Block 
dialog box.
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Forms
When you select this command in the Text menu a dialog box is dis-
played that contains all entry fields of  the selected drawing format.

Filling in a Title Block
1.  Place a Standard drawing formate from the Layout folder of  the 

DesignFreeQ folder using the Import or Sheet Into View com-
mand.

2. Choose the Forms command from the Text menu.
 The displayed Forms dialog lists all entry fields of  the title block.

3. Type in the desired parameters into the related entry fields. You 
don’t have to fill in all entry fields.

4. Click OK.
 The Forms dialog box is closed and all entry fields of  the selected 

title block are filled in according to your specifications. 

Editing Title Blocks
1. Select the Forms command from the Text menu. 
 The Forms dialog box is displayed.

2. Modify the entries of  the title block.

3. Click OK.
 The Title Blocks dialog box is closed and the selected title block 

modified accordingly. 

Creating Title Blocks
Before you can use the Forms command in the Text menu to fill in your 
own drawing formats you have to prepare the title blocks of  these for-
mats.

To enable DesignFreeQ to identify the title blocks all field label names 
have to be entered into the entry fields with an  @ character in front. For 
a possible entry field Scale you have first to put the label Scale in front 
of  the entry field and then type in Scale into the entry field with a @ 
character in front s shown in the following graphic:

 

In addition all label entries have to be placed on the layer TitleBlocks. 

When you call the Forms command DesignFreeQ will check if  there are 
any text entries on the layer TitleBlocks with an @ character in  front.

If  yes, all these entries are listed as labels for the entry fields in the 
Forms dialog box. When you have entered the required values and click 
OK, DesignFreeQ will substitute the original entries with the @ char-
acters in front with the text you entered. The original text attributes of  
these entries such as style, size or font are maintained.

Preparing title blocks for the TitleBlocks command
1. Open one of  your own drawing formats.

2. Select the Text function from the function palette.

3. Label all entry fields with identifiers such as Name, Date, etc. or 
modify existing labels to meet your specifications.

3. Enter in each entry field the label name you put in front of  the en-
try field with an @ character in front.

4. Assign to all text you entered including the @ character the  desired 
font, style and size using the Selection tool from the tool palette.

5. If  no layer with the name TitleBlocks exists create this layer using 
the Layer command in the Layout menu.

6.  Select all entries with an @ character in front using the Selection 
tool.

7. Choose the Edit objects command in the Edit menu and assign to 
all selected entries the TitleBlocks layer.

8. Save the drawing format.

DesignFreeQ checks not 
only the layer TitleBlocks 
for @ characters but all 
 selected text objects. All text 
found between the @ char-
acter and the first space will 
be used as label name. Text 
in front of the @ character 
and following the space 
remains unchanged and not 
substituted by the text en-
tered into the entry fields in 
the TitleBlocks dialog box. 
There are more than one 
variable allowed.

The @ character you create 
under Windows using the 
key combination Alt+64 or 
Alt+064 and on the Macin-
tosh with the key combina-
tion Option+Shift+1.
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Crosshatching and Solid fills
DesignFreeQ can crosshatch and fill any enclosed area in your drawing 
and then automatically update the crosshatching when you change the 
 dimensions of  the enclosed area. You can specify a closed area that has a 
hole or other cutout in it, and DesignFreeQ accurately excludes the hole 
area from the  crosshatching and filling.

In the Pen menu you will find two fill commands: Fill and  Solid Fill and 
two crosshatch commands: Crosshatch and Hatch. Fill creates a solid 
fill for a selection with the current pen color and Hatch crosshatches the 
selection with the current pattern. If  you want to change the patterns, 
choose  Crosshatch and specify the pattern you want to use. If  you want 
to change the default hatch pattern, make changes to the preferences file as 
described in The Basics chapter.

Crosshatch Patterns
DesignFreeQ offers a multitude of  DIN and ANSI hatch patterns, of  
which you can modify the spacing and angle. You will find these hatches 
 organized in groups such as metals, fluids etc. in the Hatch dialog  
box.

Adding and specifying Hatch Patterns
In addition to the hatch patterns shipping with DesignFreeQ you can 
use all hatch patterns that are compatible with the hatch format .pat of  
AutoCAD©. When you copy these hatch files into the DesignFreeQ 
folder DesignFreeQ\Scripts\VSG\Hatches the file name is automat-
ically displayed in the Crosshatch dialog box. If  the file  contains more 
than one hatch pattern the name is followed by an  ellipsis (...). When you 
double-click the file name all patterns contained in the file are displayed. 

How to define your own hatch patterns is described under Hatches in the 
Appendix of  this manual.

Hatch and Fill boundaries
Before you can hatch or fill an area you must select the hatch or fill boundar-
ies. You can select the boundaries with the  Selection tool or the Tracer. 
 

Specifying the Fill or Crosshatch Area
The selected objects must completely enclose the area you want to cross-
hatch or fill. For example, to crosshatch the object below, you would 
select all of  the lines making up the part, including the holes.

 

The exterior lines define the boundary for the crosshatching or solid fill. 
The two holes tell DesignFreeQ that those enclosed areas within the 
original area should not be crosshatched or filled. 

 

Hatching and Filling
Once you have selected the lines and holes, you can choose the Hatch, 
Fill, Crosshatch or the Fill command from the Pen menu and specify 
the pattern you want to use.

The best way to select a 
hatch boundary is with the 
Tracer tool. 

It is important that you do 
not select extra objects 
when you specify the cross-
hatch or fill area because 
DesignFreeQ does not 
know how to treat the extra 
objects.

In the Appendix of this 
 manual you find a rep-
resentation of all available 
hatch patterns.

You can choose the Fill 
command from the keyboard 

with Ctrl+B (Macintosh: 
B) and the Hatch command 
from the keyboard with 

Ctrl+H (Macintosh: H). 
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Crosshatch
Using this command you can select a hatch pattern. You can change the 
default hatch pattern by saving the changes with the Save Preferences 
command in the Layout menu under Preferences. 

Choosing the Crosshatch command the following dialog box is dis-
played.

 

The Crosshatch dialog box allows the following settings: 

Patterns In the Crosshatch list you select a pattern. Depending 
which option is checked DIN or ISO the Crosshatch 
list may contain subdirectories with additional hatch 
 patterns, that you can open with a mouse double-click.

Spacing In this entry field you can set the spacing of  the hatch 
pattern. If  you don't add a unit that unit is valid that you 
specified under Units in the Preferences submenu of  
the Layout menu.

Angle In this entry field you can enter a value for the angle of  
the hatch pattern.

Origin X/Y* In these entry fields you specify values for the X- and 
 Y-Coordinate of  the Hatch Origin. You can define 
these values as well by dragging the mouse on the 
DesignFreeQ drawing area. You just must click in one of  
the two entry fields and then on the intended point on 
the drawing area. As soon you release the mouse button, 
the corresponding values are automatically filled into the 
entry boxes.

Pattern box The Pattern box shows the revised pattern  exactly as it 
will be when the specified object is crosshatched. If  you 
have scaled a drawing, double click in the pattern box to 
adjust the displayed pattern.

Apply When you click Apply all selected and all future objects 
will be hatched with the settings you specified.

Adding crosshatching
1. Select the objects which represent a closed boundary. The closed 

boundary may include cutout areas such as a hole. Select both the 
outside boundary and the hole.

2. Choose Crosshatch from the Pen menu.

3. Select the pattern you want from the crosshatch list.
 The pattern you select appears in the Pattern display area as it will 

appear on the drawing.

4. Change the spacing and angle, if  you want.
 As you make changes to the angle or spacing, the pattern box shows 

the revised pattern exactly as it will be when the specified object is 
crosshatched.

5. Click Apply.

Specifying a Hatch Origin
1. Select the objects which represent a closed boundary. The closed 

boundary may include cutout areas such as a hole. Select both the 
outside boundary and the hole.

2. Choose Crosshatch from the Pen menu.

How to add and define 
your own hatch pattern is 
described at the end of 
Chapter 4 (Preferences) 
and in the Appendix of this 
manual.

To crosshatch a figure that 
is not a closed figure, you 
must add lines or segment 
lines to make a closed 
figure. In this way, you 
can crosshatch individual 
sections of the geometry. 
See Crosshatching in the 
Advanced Features section 
of the Tutorial for a step-by-
step example.
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3. Select the pattern you want from the crosshatch list (for example 
Bricks 8 in the folder Extended).

4. Change the spacing and angle, if  you want.
 As you make changes to the angle or spacing, the pattern box shows 

the revised pattern exactly as it will be when the specified object is 
crosshatched.

4. Specify in the two entry fields Origin X* and Origin Y* a value 
for the new origin of  the hatch pattern. Alternatively you can click 
first in one of  the two fields  and then in the lower left corner of  the 
hatch boundary on DesignFreeQ drawing area for the new  origin of  
the selected hatch pattern. The values are automatically filled in into 
the two Origin fields.

5. Click Apply.

 The origin of  the hatch pattern is moved accordingly.

Editing an existing crosshatch pattern 
1. Select the existing crosshatching by clicking it with the Selection 

tool.

2. Choose Crosshatch from the Pen menu.

3. Make the changes you want in the Crosshatch dialog box.

4. Click Apply. 
The crosshatching changes as you specified.

Hatch  Ctrl+H   [Macintosh: H]
This command is located in the Pen menu and crosshatches the selected 
objects using the current crosshatch pattern. If  you want to change the 
crosshatch pattern, choose Crosshatch and make your selection from the 
dialog box.

Crosshatching with the current pattern
1. Select the object you want to crosshatch.

2. Choose Hatch from the Pen menu.
 The selected area is crosshatched with the current pattern.

Solid Fill   
This command in the Pen menu fills the selection with the current pen col-
or and the fill tolerances you specified.

Creating a Solid Fill
1. Select the objects which represent a closed boundary. The closed 

boundary may include cutout areas such as a hole. Select both the 
outside boundary and the hole.

2. Choose Solid Fill fro the Pen menu.
 The Solid Fill dialog box displays:

 

3. Set a Tolerance for the fill.
 The tolerance controls how smooth the linearization is for fills  

in circles, arcs, ellipses and closed splines. Increasing the value of  Tol-
erance makes the fill smoother. The default value is 0.01. (A value 
of  0.001 will produce smoother edges than .01. This is also effected 
by Drawing Scale.)

4. Click Apply.
 The selected object is filled with the current pen color.

Changing the color of an existing solid fill
1. Select the existing solid fill by clicking it with the  Selection tool. 

2. Choose a new color from the Color pop-up menu on the Pen menu.
 The Fill color changes as you specified and will be visible as soon 

you deselect the solid fill.

You can edit hatch patterns 
with the Edit Objects com-
mand in the Edit menu.

The best way to select a 
fill boundary is with the 
Tracer tool. 

A solid filled object will 
only cover permanently its 
background if it is brought to 
front with the Bring to front 
command in the Arrange 
menu.

To change the tolerance of 
an existing fill, first select 
the fill by clicking on it. 
Choose Solid Fill from 
the Pen menu. Change the 
Tolerance and press Apply. 
You can also change the 
Tolerance in the Edit Ob-
jects dialog box.
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Fill  Ctrl+B   [Macintosh: H]
This command is located in the Pen menu and fills the selected objects 
using the current pen color and tolerance. If  you want to change the tolerance, 
choose Solid Fill and make your selection from the dialog box.

Solid filling with the current pen color and tolerance
1. Select the object you want to fill.

2. Choose Fill from the Pen menu.
 The selected area is filled with the current pattern and tolerance.
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Dimensions
The Dimension menu contains commands for displaying the palette of  
dimensioning tools and for all dimension settings.

Associative Dimensions
DesignFreeQ’s geometric dimensions are associative—when you make a 
change to the geometry, the dimension changes also.

This associativity is a tremendous time saver because dimensions auto-
matically update whenever you make a change in the geometry. You can 
even change the units from English to  Metric (one setting in the Prefer-
ences submenu in the Layout menu) and every dimension on your draw-
ing will reflect the change.

When you extend a line by selecting the endpoint of  the line and drag-
ging it to a new position the dimension changes also, because the dimen-
sion has a control point at the same position of  the line endpoint. So when 
you select the endpoint of  the line you also select the  dimension control 
point.

 

Using the Dimension Tools
DesignFreeQ’s dimensioning tools are on a separate palette which you 
can drag around the drawing area.  You select dimension tools in the 
same way you select tools from the tool palette. The first four tools have 
 sub palettes which also work like the subpalettes of  the tool palette.

Show Palette 
This command in the Dimension menu displays the dimension palette 
on screen.

 

The dimensioning tools can be used to measure either an  object or the 
area between objects. Once you have dimensioned an object (or space), 
the dimensions update when you make changes to the geometry.

The first four tools on the dimension palette have subpalettes for base 
line and chain style dimensions.

Some of  the dimensioning tools, such as the horizontal and vertical tools, 
require that two points be selected; others, such as the Radial and Diame-
tral, require only one.

Dimensions are associative 
relative to the points they 
measure. If you change the 
length of a line using Edit 
Objects, the dimension will 
not update because the 
point was not changed. To 
correct the dimension, se-
lect the dimension’s vertex 
point and drag it to the new 
endpoint of the line.
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Dimensioning objects and space
1. If  necessary, display the dimension palette.

2. Select the appropriate dimension tool.
 The dimension pointer is a smart pointer with a hot spot—the dot 

shows which side of  the object to select first. If  you select as indi-
cated by the position of  the dot, the text appears above or to the 
right of  the leader. If  you select in the opposite order, the text ap-
pears below or to the left of  the leader.

3. Click the points you want to measure.
 All settings for dimensions can be set in the dimension  editor under 

Preferences in the Dimension menu. 

4. Move the dimension to a new location if  its placement is not  where 
you want it.

5. If  you are planning to use the dimension with Parametrics, change 
the entry in the text box on the status line.

Repositioning the dimension 
When the dimension text appears, it is selected so that you can move it to 
a new location. Move the pointer to the dimension text. When the point-
er changes to the Move symbol, drag the dimension to its new location.

If  you want to move a dimension later, use the Selection tool. Click the 
dimension once, then drag it to the new location. You can also drag to 
select the dimension text or to select the entire dimension or several di-
mensions at once.

 

Using the dimension status boxes
The status boxes shown below appear when a dimensioning tool is se-
lected.
 

Text The # symbol in the text box indicates that the dimen-
sion is the actual value of  the object’s measurement. If  
you delete this symbol, the  dimension will no longer be 
associative (that is, it won’t update if  you change the ge-
ometry it measures).

 If  you are going to use Parametrics, you must delete the # 
symbol and enter values, algebraic expressions, or vari-
ables in the text box. Parametrics are described in the 
Parametrics chapter of  this manual.

 Some of  the dimensioning tools, such as the Radial 
tools, add a letter in the text status box which appears in 
the dimension itself. You can add text before or after the 
# symbol. You can enter parentheses to enclose the re-
sulting  dimension in parentheses (#), or enter # 2 Plcs 
to display the dimension followed by the text 2 Plcs. 
When you include the # symbol, Design FreeQ displays 
the measurement of  the  geometry as well as the text you 
add.

Tolerance The Upper and Lower boxes appear if  you have spec-
ified a tolerance format in the dimension editor (under 
Preferences  in the Dimension menu). You enter the 
limits for the tolerance in these boxes.

Placing dimensions automatically on a separate layer
1. Choose Preferences in the Dimension menu.

2. Select in the Layer pop-up of  the dimension editor a layer that all 
 dimensions should be placed on.

3. Close the dimension editor with a double-click on the  Control menu 
(Macintosh: Close box).

4. Dimension as usual.
 Subsequent dimensions automatically go on the dimension layer 

rather than the work layer.

Steps #4 and #5 must be 
done in order. If you change 
the entry in the text box 
and then press Enter, you 
can no longer move the 
dimension, because it will 
no longer be selected. If you 
have this problem, select the 
dimension and drag it to the 
location you want.

See as well Tolerances in 
this chapter.

For the DIN Standard the 
 Dimension layer is the 
default layer.



115

Dimensions

Adding tolerance and limits
1. Choose the desired style in the dimension editor  (under Preferences 

in the Dimension menu).

2. Dimension as usual.

3. Enter values for the upper and lower  tolerance limits in the status line 
and press Enter. It is also allowed to delete the default values and 
keep these fields empty or replace the values by text entries. The 
dimension will display always the content of  the status line.

Using fixed dimensions
If  you delete the # symbol in the text box (on the status line for a new-
ly-created dimension or in the Edit Objects dialog box) and replace it 
with other text, the entry in the text box is fixed—it does not update if  
you change the units or the size of  the geometry.

Horizontal Dimension Tools

These tools measure horizontal spaces or the distance between linear 
objects.

Horizontal Dimension Tool

This tool dimensions an object or space horizontally. Click the left point 
first, then click the right point. (Click the points in the opposite order if  
you want the dimension to display blow the objects.)

 

When the dimension text appears, you can drag it to a new location; 
when you release the mouse button, the dimension and extension lines 
are redrawn.

Horizontal Base ine Dimension Tool

This tool dimensions objects or spaces horizontally room a base point.

 

Horizontal Cain Dimension Tool

This tool dimensions objects or spaces from end-to-end, horizontally.

  

Horizontal Ordinate Dimension Tool

This tool dimensions objects or spaces horizontally room a base point.

 

When object geometry con-
tains constant dimensions 
instead of actual measure-
ments, the object geometry 
is (when selected together 
with the dimensions) au-
tomatically adjusted when 
using the Resolve command 
in the Edit menu.

Remember: to display the 
dimension number of the 
base point you have to 
click it twice: at the first 
and the last dimension 
points. 
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If  you want to display the dimension number for the base point you have 
to click the base point again after you have clicked all other dimension 
points.

Horizontal Base Cain Dimension Tool

This tool  creates a horizontal base chain dimension, displaying the rising 
distance between objects and spaces to a base point.

 

When the dimension text appears, you can drag it to a new location; 
when you release the mouse button, the dimension and extension lines 
are redrawn.

Vertical Dimension Tools

These tools measure vertical space or the distance between vertical ob-
jects.

Vertical Dimension Tool

This tool dimensions an object or space vertically. Click the top point 
first, then click the bottom. (Click the points in the opposite order if  you 
want the dimension to display to the left of  the objects.)

 

When the dimension text appears, you can drag it to a new  location; 
when you release the mouse button, the dimension and extension lines 
are redrawn.

Vertical Bas Line Dimension Tool

This tool dimensions objects or space vertical from a base point.

 

Vertical Chain Dimension Tool

This tool dimensions objects or space from end o end, vertically.

 

Vertical Ordinate Dimension Tool

This tool dimensions objects or space vertical from a base point.

If you want to display the 
dimension number for the 
base point you have to click 
the base point again after 
you have clicked all other 
dimension points.
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Vertical Base Chain Dimension Tool

This tool  creates a vertical base chain dimension, displaying the rising 
 distance between objects and spaces to a base point.

 

When the dimension text appears, you can drag it to a new location; 
when you release the mouse button, the dimension and extension lines 
are redrawn.

Oblique Dimension Tools

These tools measure space or objects, obliquely from point to point

Oblique Dimension Tool

This tool dimensions an object or space from point to point obliquely. 
Click the left point first, then click the right. (Click the points in the 
 opposite order if  you want the dimension to display below the objects.)

 

When the dimension text appears, you can drag it to a new  location; 
when you release the mouse button, the dimension and extension lines 
are redrawn.

Oblique Base Line Dimension Tool

This tool dimensions objects and spaces point to point obliquely from a 
base point. Note: The results shown reflect colienar dimension points.

 

Oblique Chain Dimension Tool

This tool dimensions objects and spaces oblique point-o-point, end-to-
end.

 

Note: The results shown 
reflect colinear dimension 
points.
Lines are colinear if they 
have a common invisible 
carrier line.
DesignFreeQ can recog-
nize colinear lines only if 
they touch at least in one 
endpoint.
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Oblique Base Chain Dimension Tool

This tool  creates a oblique base chain dimension, displaying the rising 
 distance between objects and spaces to a base point.

 

Perpendicular Dimension Tools

These tools measure an object or space perpendicular to  another line. If  
most of  your dimensions start from a line edge, you can use this tool to 
generate both horizontal and vertical dimensions.

Perpendicular Dimension Tool

This tool dimensions an object or space perpendicular to a line. Click the 
base line first, then click he object or location.

 

Perpendicular Base Line Dimension Tool

This tool dimensions between a point or object perpendicular to n exist-
ing base line.

 

Perpendicular Chain Tool

This tool dimensions between points or objects perpendicular t an exist-
ing baseline.

 

Perpendicular Ordinate Dimension Tool

This tool dimensions between a point or object perpendicular to an exist-
ing base line.

 

Note: Be certain that you 
click on the base line, not 
on the endpoint of the base 
line. When the dimension 
text appears, you can drag 
it to a new location; when 
you release the mouse 
button, the dimension and 
extension lines are redrawn.

Note: Be certain that you 
click on the base line, not 
on the  endpoint of the base 
line. When the dimension 
text appears, you can drag 
it to a new location; when 
you release the mouse 
 button, the dimension and 
extension lines are redrawn.

If you want to display the 
dimension number for the 
base point you have to click 
the base point again after 
you have clicked all other 
dimension points.
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Perpendicular Base Chain Dimension Tool

This tool creates a oblique base chain dimension, displaying the rising 
 distance between objects and paces to a base point.

 

Radial Arrow Out Dimension Tool

This tool measures the radius of  a circle, arc, or fillet with the arrow on 
the side of  the arc indicated when the arc is picked. To dimension the 
radius of  a circle, arc, or fillet click near it. If  you click outside it, the di-
mension text appears outside, and if  you click inside, it appears inside.

 

When the dimension appears the leader line is placed at the nearest 15° 
increment from the location you clicked. You can drag the text to a new 
location.

Radial Arrow In Dimension Tool

This tool measures the radius of  a circle, arc, or fillet with the arrow in-
side the geometry. To dimension the radius of  a circle, arc, or fillet, click 
near it. If  you click outside it, the dimension text appears outside, and if  
you click inside, it appears inside. Either way the arrow line starts from 
the arc center.

 

When the dimension appears the leader line is placed at the nearest 15° 
increment from the location you clicked. You can drag the text to a new 
location. 

Extended Radial Arrow In Dimension Tool

This tool measures the radius of  a circle, arc, or fillet with the arrow inside 
the geometry. To dimension the radius of  a circle, arc or fillet, click near it 
(the Design Navigator must show on). If  you click outside it, the dimension 
text appears  outside, and if  you click inside, it appears inside. Either way 
the arrow line starts from the arc center.

In contrast to the two other radial dimensions the Extended Radial dimen-
sion allows to draw the dimension line of  a large radius shortened and an-
gled. Both, the part of  the dimension line with the dimension arrow and 
the angled part of  the dimension line, point to the geometrical center.

 (Sheet Border)

When the dimension appears the leader line is placed at the nearest 1° 
increment from the location you clicked.

You can move a dimension 
arrow to a new location 
by dragging a selection 
 marquee around the control 
point at the top of the 
dimension arrow and then 
drag it to a new location.
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The leader line is always drawn to the geometrical center. To shorten and 
angle the leader line, you must first drag the dimension text to a new 
 location and  select then the end of  the dimension line at the  geometrical 
center and drag it away from the center point.

The dimension line is shortened and angled in a z-Form, where both legs 
point to the geometrical center. 

Diametrial Single Arrowhead Dimension Tool

This tool measures the diameter of  a circle. To dimension the diameter 
of  a circle, click near the circle. If  you click outside the circle, the dimen-
sion text appears outside, and if  you click inside, it appears inside.

 

When the dimension appears the leader line is placed at the nearest 15° 
increment from the location you clicked. You can drag the text to a new 
location.

Diametrial Double Arrowhead Dimension Too

This tool measures the diameter of  a circle. To dimension the diameter 
of  a circle, click near the circle. If  you click outside the circle, the dimen-
sion appears outside, and if  you click inside, it appears inside.

 

When the dimension appears the leader line is placed at the nearest  
15° increment from the location you clicked. You can drag the text to a 
new location.

Angular Dimension Tool

This tool measures the angle between two lines. To dimension an angle, 
click each line near the endpoint from which you want the angle mea-
sured. The inside angle is measured between the sides with the extension 
lines extending from the endpoints nearest the location you clicked on 
the line. The smaller angle is used.

The angle between the endpoints of  the lines is measured so you do not 
have to click these endpoints, just near them. DesignFreeQ interprets all 
mouse clicks left of  the line  midpoint as the left endpoint and all mouse 
clicks right of  the line midpoint as the right endpoint.

 

If  you dimension intersecting lines don't mix up the  intersection with the 
midpoint of  the lines.

 

If  the lines don’t meet, the angle is measured from the invisible  extension 
of  the lines. The extension appears as part of  the dimension.

Angular dimensions will 
display all angles properly if 
you keep the angles larger 
than 3 degrees. For dimen-
sions smaller than that, you 
should build the dimensions 
manually using lines and 
text objects.

The Angular Dimension tool 
will not dimension  angles 
over 180°.
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When the dimension text appears, you can drag it to a new location; 
when you release the mouse button, the dimension and extension lines 
are redrawn. 

Arc Length Dimension Tool

This tool measures the length of  an arc. To use it, you have to move the 
cursor to the arc to be measured and click on the  following points:

 • one end of  the arc, 

 • the middle of  the arc and 

 • the opposite end of  the arc (as if  you were creating a three-point 
arc). 

  

Balloon Symbol

This tool attaches a Balloon symbol to geometry, placed in the location you 
click.

 

You can enter text and the diameter of  the balloon in the Status Line.

Center Mark

This tool marks the center of  a circle, arc or fillet.

To mark the center of  a circle, arc or fillet, click near it (th Design Navigator 

must show on). 

 

Dimension Appearance
DesignFreeQ automatically creates dimensions in several specific di-
mension standards. However you can modify any standard to create your 
own dimension standard. All commands required to specify the appear-
ance of  a dimension you find in the Dimension menu. 

The Arc Length Dimension 
tool does not put witness 
lines perpendicular to the 
arc for angles less than 180 
degrees.

Like other dimensions you 
can manipulate the text by 
changing its size or font 
using the Dimension Editor. 
You can move the text by 
dragging it to the desired 
 position. 

All Balloon Symbols use as 
line style Balloon. Therefore 
you should use this line 
style as well when creating 
Balloon Symbols manually .
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All settings made in the dimension menu affect the currently selected and 
all future dimensions.
When scaling a drawing all existing dimensions are scaled as well. Only di-
mensions placed after scaling a drawing are displayed at their specified 
text size and are not adjusted to the current view scale.

Dimensions are always displayed correctly at their true size, when:

 • the option keep dimension text size in the Drawing Size dialog box 
is checked while scaling

 • a drawing is dimensioned after scaling
 • or the original text size is set after scaling.

Dimension Settings
All attributes for dimensions created with the dimension tools are set in 
the Dimension menu.

 

Linear
This command allows you to set the precision of  a dimension value and 
the format of  tolerance and limits for linear dimensions.

 

The following graphic shows the appearance of  each tolerance format if  
you entered the limits shown in the Status line.

 

To change the linear appearance of  a dimension you must first change 
the precision setting in the Units dialog box with the Units command in 
the Preferences submenu of  the Layout menu.

DesignFreeQ always calculates up to 16 decimal places independent 
from the number of  decimals places you have defined.

Linear Tolerance
This command allows you to set the precision of  a linear dimension's 
tolerance value.

 

A detailed description about 
 Scaling you find in Chapter 
9  Basic Drafting of this 
manual. 

Use the [xxx][basic] format 
for GD&T symbols.
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Angular
This command allows you to set the format for Angular dimensions.

 

The following graphic shows the appearance of  each tolerance format if  
you entered the limits shown in the Status line.

 

Angular Tolerance
This command allows you to set the precision of  a angular dimension's 
tolerance value.

 

Text
This command allows you to set the position and orientation for dimen-
sion text.

 

The default is horizontal text. The options Break-in, Over and Under 
create text aligned with in or over/under the dimension leader lines.

 

Font
This command allows you to select the font for dimension text only.

 

This command affects only dimensions. If  you want to change the font 
of  other text objects choose the Font command in the Text menu. On 
the other side the Font submenu in the Text menu has no affect on di-
mension text.

Use the [xxx][basic] format 
for GD&T symbols.
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Size
This command allows you to select the size of  dimension text.

 

This command affects only dimensions. If  you want to change the size 
of  other text objects choose the Size command in the Text menu. On 
the other side the Size submenu in the Text menu has no affect on di-
mension text.

Style
This command allows you to select the style of  dimension text.

 

This command affects only dimensions. If  you want to change the style 
of  other text objects choose the Style command in the Text menu. On 
the other side the Style submenu in the Text menu has no affect on di-
mension text.

Color
This command allows you to select the color of  dimension text.

 

This command affects only dimensions. If  you want to change the color 
of  other objects choose the Edit Objects or the Color command in the 
Pen menu.

Weight
This command allows you to select the weight of  the dimension lines.

 

This command affects only dimensions. All values shown in this sub-
menu may be different if  the available line weights have been changed in 
the Pen Weight Editor.

If  you want to change the weight of  other objects choose the Edit Ob-
jects or the Weight command in the Pen menu. The Weight submenu in 
the Pen menu has no affect on dimension lines.

Layer
This command allows you to select the layer on which dimensions are 
automatically placed.

 

This submenu list all layers that are created in DesignFreeQ. Dimen-
sions can be placed on any visible layer. If  the specified layer is hidden or 
deleted, dimension will be placed on the current work layer.
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Arrowheads
This command allows you to select the arrowheads for dimension lines 
and affects only dimensions.

 

Arrow Size
This command allows you to specify the size of  the selected arrowhead.

 

The Arrow Size dialog box allows the following settings:

Dot Size This value describes the diameter of  circular and slash arrow-
heads. This value is displayed in the current units specified in 
the Units dialog box from the Preferences menu.

Length This value describes the length of  the arrowhead as the hor-
izontal distance from its tip to the furthest extension of  the 
base.

Height This value describes the length of  the arrowhead as the ver-
tical distance of  its base.

Side This value describes the length of  the edge of  the arrow-
head.

Angle This value describes the angle of  the tip of  the arrowhead

If  you modify any value in the Length, Height, Side or Angle entry 
boxes the values of  the other entry boxes are changed accordingly.

Witness Lines
This command allows you to specify which sides of  the linear dimensions 
should have witness lines

 

A checkmark indicates the a witness line will be placed at the specified 
location. Witness Lines for existing linear dimensions can also be toggled 
on or off  in the Edit Objects dialog box.

This command affects only linear dimensions. Radial and diametrial di-
mensions are not affected by this command.

Dimension Standards
This command allows you to select the standard for your dimensions or 
to specify you own standard. Most of  the changes made in the Dimen-
sion Standard dialog box affect currently selected dimensions and newly 
created ones. Changes made in the First Offset end Next Offset entry 
fields affect only newly created dimensions.

This command displays the following dialog box:

 

Arrowheads for arrow lines 
are defined separately under 
Arrows in the Pen menu. 

When you select a new 
standard the related settings 
are shown..

You can save the selected 
standard  permanently with 
the Save Preferences com-
mand from the Preferences 
submenu of the Layout 
menu. 
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This dialog box contains the following settings:
Standard In this pull-down list you can select the standard your 

dimension should follow. The following standards are 
available: ANSI, DIN, ISO, JIS and Other. All stan-
dards can be modified and saved with the Set button. If  
you want to create your own standard you save it to the 
standard option Other in the pull-down list

 The Set button saves all modifications made to the stan-
dard selected in the pull-down list. The Default button 
reverts to the factory settings of  the selected standard.

Text Offset Here you enter the distance from the base of  the dimen-
sion text to the leader lines. A positive value places the 
text above, a negative value below and a zero value on 
the leader lines.

Gap Here you enter the distance between the dimension 
point and the witness line.

Extension This value describes the distance the witness lines ex-
tend beyond the leader lines.

Arrow leader This value describes the distance the leader lines extend 
beyond the witness lines, when the arrow lines appear 
outside of  the witness lines.

#First Offset This value describes the perpendicular distance between 
th object being dimensioned and the leader line and the 
dimension text.

 Changes to this value only affect newly created dimen-
sions.

#Next Offset This value describes the perpendicular distance between 
subsequent leader lines created in a base line dimension-
ing.

 Changes to this value only affect newly created dimen-
sions.

Leading 0's Selecting these check boxes determines whether Dimen-
sion or Tolerance values display leading zeros. Once 
selected a 0 is placed before all dimensions that are less 
than 1.

Trailing 0's Selecting these check boxes determines whether Dimen-
sion or Tolerance values display trailing zeros. Once 
selected 0's are placed after the decimal point to display 
the selected precision in the Units dialog box of  the 
Preferences submenu of  the Layout menu.

 Selecting these check boxes determines whether the di-
mension lines contain a line when the dimension arrows 
are placed outside the witness lines.

Tol. Text % This value defines the size of  the tolerance text as a per-
centage of  the normal value.

List Boxes In these fields you select from drop-down lists dimen-
sion attributes like color, style etc.

Witness lines In this drop-down list you choose if  dimensions should 
have two, one right or left or none witness lines.

Arrow ON/Off In this drop-down list you choose if  dimension lines 
should have two, one right or left or none arrowheads at 
the end.

Arrowhead In this drop-down list you choose the arrowhead style 
for dimension lines.

Clicking the OK button will save all changes made in the Dimensions 
Standard dialog box and will close the box. The Apply button will apply 
all changes made to any current selected dimension without closing the 
dialog box. The Cancel button ignores all changes made and closes the 
dialog box.

Parametric Dimensions
You must dimension objects to use the parametrics feature; you must 
specify values, variables, or expressions for each dimension. Parametrics is 
discussed in greater detail in the Parametrics chapter.

When you click the Apply 
button the new  settings are 
assigned to the  selected 
 dimensions except the two 
values you entered in the  
# fields which will affect only 
 future dimensions .

Dimension 
Lines

If you want to make these 
changes permanent you 
must choose Save Prefer-
ences in the Preferences 
submenu of the Layout 
menu. 
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Creating a parametric dimension
1. Create the dimension as usual.
 The status line displays a # symbol in the text box.  

2. Enter a value (variable or algebraic expression) in the text box.
 The dimension reflects the value or variable you entered, regardless 

of  the actual value of  the geometry you just dimensioned. 

3. Continue dimensioning as needed to define the part completely.

4. Use the parametric feature as described in the Parametrics chapter.

Converting parametric dimensions to associative dimensions
When you bring in a parameterized part with the Import command, the 
geometry is drawn as you specify, but the dimensions display the vari-
ables and expressions which defined them as symbols. You can change 
the dimensions to be associative so that they reflect the actual measure-
ments of  the geometry, even if  you change the geometry.

1. Select the dimensions.  

2. Choose Edit Objects from the Edit menu.

3. Enter a # in the Text field.

4. Click the Apply button and close the dialog box.

 The parametric variable changes to reflect the geometric actual mea-
surements

GD&T
GD&T stands for Geometric Dimensioning and Tolerancing, a  
DIN ISO 1101 and a U.S. government standard. Since this annotation 
may be new to you, this section is an overview of GD&T standards and 
 includes a brief  explanation of  the components of  a GD&T label, using 
the true position of  holes as an example.

Background
Before World War II, a single vendor did most military manufactur-
ing. However, during the war, it became a matter of  national security 
to  diversify weapons manufacturing so a single plant was not the only 
source of  a vital part. When more than one manufacturer interpreted 
specifications and blueprints, difficulties arose.

When several companies manufacture the same part, each must drill 
holes within the same tolerance for the parts to be interchangeable. Even 
though manufacturers thought they were following the tolerance specifi-
cations, the parts were not interchangeable. The problem arose from the 
order in which measurements were made.

Alignment Information
A part was usually laid on a flat surface (A) and aligned first with one 
straight edge (B), then with another (C).

 

If  one manufacturer aligned with edge B, then edge C, but another 
 aligned with edge C, then edge B, the resulting measurements would 
probably be different. The GD&T Standards tell a manufacturer the order 
of  alignment.

Bonus Tolerance
In addition to the alignment information, a manufacturer gets a bonus 
from GD&T Tolerances. In conventional drafting, the tolerance for hole 
drilling results in a square target area. For example, examine the plate on 
the left below. The positional tolerance for the hole is ±.001. The target 
area (magnified and shown on the right) is from .001 left of  the perfect 
center to .001 right of  the perfect center, and .001 above the perfect cen-
ter to .001 below the perfect center.
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GD&T provides a circular target area for the hole. First measure from 
the center in one direction by the distance o the tolerance; then measure 
the same distance perpendicular to that point.

 

You can then use the distance from the endpoint of  the second line to 
the perfect center as the radius of  a circle to create a circular target—the 
bonus tolerance.

 

In that way, the target area for the hole’s center is the area circumscribing 
the square of  standard dimensions.

The standard information (basic dimension) about the target area  appears 
in a box with a GD&T feature control frame.

 

Basic Dimensions
Since the tolerance for a dimension is in the feature control frame, 
GD&T dimensions are also basic dimensions and appear in a box. The 
value defines the theoretically perfect location and implies that the toler-
ance is in the feature control frame.

To specify the basic dimension format, choose  in the Linear and Angu-
lar submenus from the Dimension menu [xxx] (basic) format.

GD&T Feature Control Frame
Tis section discusses the GD&T Labeling of  the left hole in the plat be-
low.

 

Typically, the GD&T Feature Control Frame appears as shown below:

 

Geometric Characteristic
The first section of  the Feature Control Frame contains the geometric 
characteristic symbol. The feature control shown above describes True 
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Position—how to locate the circular target area for the hole. The possible 
characteristics are as follows:

 Straightness   The axes of  an item of  revolution or element of  
a surface is a straight line.

         
 Flatness All elements of  a surface in one plane.

         
 Roundness All points of  a surface of  revolution equidis-

tant from an axis that is intersected by a plane 
 perpendicular to that axis.

        
 Cylindriciy All points of  a surface of  revolution equidistant 

from a common axis.

         
 Profile of  Line A 3D element projected to a plane.

         
 Profile of  Surface A 3D surface projected to a plane.

         
 Angularity An axis or planar surface at a specified angle 

from another axis or datum plane.

         
 Perpendicularity An axis or planar surface at a right angle to a 

datum axis or datum plane.

         
 Parallelism An axis or planar surface equidistant along its 

length to a datum axis or datum plane.

         
 True Position A zone of  tolerance for a center axis or center 

plane.

         
 Concentriciy The axes of  all elements in a cross-section share 

a common datum axis.

         
 Symmetry The location o a feature relative to a center 

plane.
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 Runout Circular Runout

         

 Circular elements fa surface of  revolution asso-
ciated with a datum axis.

 Surface Runout

         

 Total Runout  Total Circular Runout

         

 All elements of  a surface of  revolution associat-
ed with a datum axis.

 Total Surface Runout

         

Diameter
The second section of  the feature control frame specifies whether the 
tolerance applies to a circular zone. If  it does, you should specify the di-
ameter symbol (Ø) from the pop-up menu.

Position Tolerance
The third section of  the feature control frame defines the tolerance al-
lowed under the stated conditions.

Material Condition
The fourth section of  the feature control frame provides the material 
condition for limiting the tolerance. You can use any of  three material 
conditions: Maximum, Least, and Regardless of  Feature Size.

Maximum Material Condition
Maximum Material Condition (MMC) indicates that a feature contains 
the maximum amount of  material within the specified tolerance limit. 
For drilling holes, MMC means that the drill bit is accurate—it drills the 
smallest hole. For shafts, MMC results in the largest dimension.

 

In the example above, this material condition symbol means that the 
tolerance in the Feature Control Frame (.002) applies to the location of  the 
smallest hole (.310 in this case).

As the hole size nears its upper limit (.315), the location of  the hole in-
creases from .002 to .007 (the tolerance for the location, .002, plus the 
tolerance for size, .005).

Least Material Condition
Least Material Condition (LMC) indicates that a feature contains the 
minimum amount of  material within its specified tolerance limit. For 
holes, the swept area is the largest and the drill bit drills the largest hole. 
For shafts, the tolerance is the smallest allowable dimension.

If the diameter symbol is 
appropriate for the geometry, 
you should display it. It is 
usually not used with flatness, 
roundness, cylindricity, profile 
of line or surface, angularity, 
runout or total runout.

Maximum Material Condition 
is the most commonly used 
symbol for parts.

Least Material Condition 
is most frequently used to 
control wall thicknesses of 
parts, as well as for tool 
fixtures and inspection 
gauging.
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In the example above, this material condition symbol means that the 
tolerance (.002) applies to the location of  the largest hole (.315). As the 
hole size nears its lower limit (.310), the tolerance for the location of  the 
hole increases from .002 to .007 (the tolerance for the location, .002, 
plus the tolerance for size, .005).

Regardless of Feature Size
The Regardless of  Feature Size (RFS) material condition means the tol-
erance applies regardless of  the size of  the feature (within the specified 
tolerance limit). For holes, the location tolerance is the same regardless 
of  whether the hole is the smallest or largest allowable size. For shafts, 
the roundness tolerance is the same regardless of  the shaft diameter.

In the example above, this material condition symbol in the feature 
 control frame (.002) applies to the location of  the hole whether the hole 
is at its smallest (.310) or largest (.315). This material condition would 
control an axis in space, so you probably wouldn’t use Regardless of  Feature 
Size for this hole.

Datum
The last three sections of  the frame show the alignment order to position 
the part. This is easier to see in a part which does not have perpendicular 
sides. A typical engineering drawing might appear as shown below:

 

For proper drilling alignment and measurement, this part would lie on 
a flat surface (Surface A), with Side B pushed against the first straight 
edge, and then Side C pushed against the other straight edge.

 

GD&T tells a manufacturer which surface to align first. If  you align the 
part with Side C before Side B, the holes do not line up in the same way 
as they would if  you align with Side B before Side C.

The rule for points of  contact per surface is as follows:

 Surface  Points of  contact (minimum)

 1st    3
 2nd    2
 3rd    1

Datum Material Condition
When showing a datum in a feature control frame, you also have the op-
tion of  indicating a material condition. Such a modifier should only be 
specified for a datum that is an axis or centerplane of  a feature, such as a 
hole or boss. Material Condition modifiers do not apply to planes such as 
the straight side or flat bottom of  a part.

Composite GD&T Symbols
A composite symbol uses more than one line of  the feature control 
frame to specify more than one tolerance for the same feature.
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The first line of  the feature control frame means that the hole must be 
straight throughout within a cylindrical tolerance of .003 diameter for the 
total of  its length, 3.00 inches. The second line of  the frame means that 
the hole must be straight for any 1.00 inch portion within a cylindrical 
tolerance of  .001 diameter. DesignFreeQ creates the composite frame 
automatically if  the same symbol is in Line 1 and Line 2.

Projected Tolerance Zone
This entry box of  the feature control frame specifies an area above the 
actual part where the tolerance of  a feature should still apply if  the 
feature were extended or projected into the area. For example, if  an out-
board motor has a hole in the housing, the hole has to be straight not 
only through the housing, but also down into the propeller  assembly, so 
that the drive shaft aligns properly.

  

In the motor example, the tolerance for the hole should be checked  
4 units from the actual hole.

The GD&T Label
Feature control frames are created with GD&T command in the  Dimension 
menu.

GD&T 
This command in the Dimension menu creates a label—a feature con-
trol frame for showing dimensions, alignment, and tolerances. The dialog box 
looks like a complex GD&T symbol into which you may enter the infor-
mation you need.

The GD&T label uses the plotter font so the font size corresponds to 
ANSI standards, since the sizes of  other fonts are not always consistent 
with ANSI standards. If  you want the size of  your dimensions to be the 
same as the font in a GD&T label, you must select the dimensions and 
change the font size or choose the plotter font.

The GD&T dialog box resembles a GD&T label.

 

The square boxes are pop-up menus from which you can select symbols. 
You can use a single entry, a line, or a combination of  lines as needed to 
specify the GD&T dimensions for your part.

Creating a GD&T Label
1. Choose GD&T from the Dimension menu.
 The GD&T dialog box appears.

 

2. Click a button (Stand Alone, Arrow Line, or Witness Line) to indicate 
the way you want the GD&T symbol connected to the  geometry 
you’re labeling.
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3. Enter the appropriate data to create the GD&T label.
 Two types of  entries are possible in this dialog box:

 • Selecting symbols from pop-up menus that appear when you 
press the square buttons.

  
 • Entering text in the rectangular boxes by clicking to place a text 

cursor, and then typing the entry.

4. Indicate the location of  the label. The message line displays the in-
structions you need.

 • If  you want a Stand Alone label, click the location for the up-
per-left corner of  the GD&T label.  

 • If  you want a label connected with an arrow line or witness line, 
click on the geometry you wish to label, and then click on the 
drawing area to indicate the position for the upper-left corner of  
the label.

Editing a GD&T label
Once you have created a GD&T label, you may wish to make changes.

1. Select the GD&T label you wish to edit.

2. Choose GD&T from the Dimension menu.

 The GD&T dialog box appears, displaying the current GD&T in-
formation.

3. Make the changes you want in the GD&T dialog box.

4. Click the Edit button.
 The GD&T label changes.

Using an editing short-cut with GD&T
When you are editing a GD&T label or creating a second label, you may 
want to remove every entry in Line 1 or Line 2.

1. Press the first box to display the Geometric Characteristic menu.

2. Drag to the X symbol.
 All entries in the line disappear.
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Basic Drafting
This chapter describes techniques for Printing and Scaling. There are two 
different ways to change the drawing size:

 • Zooming  
You can change the magnification of  your drawing by zooming 
in and out using  commands, zoom tools, and strokes. Zooming 
changes the visual size of  the drawing, never the physical size of  
the objects.

 • Scaling 
Scaling means to set the visual size of  the drawing to fit to the 
selected paper size when printing or plotting. Scaling too chang-
es the visual size of  the drawing, never the physical size of  the 
objects.

This chapter describes the following techniques:

 • Zooming
 • Full-scale drawing
 • How scaling affects text, dimensions, line patterns and hatch patterns 
 • Scaling commands
 • Printing or plotting drawings on standard paper sizes

Most drafters begin a project by deciding how to scale the part first. Us-
ing DesignFreeQ you create all parts at full scale (1:1).

You never  physically scale the part, instead you set the visual scale of  the 
geometry (the visual size of  the drawing) to fit to the selected paper size 
when printing or plotting the drawing.

Zooming 
DesignFreeQ gives you several ways to zoom in or zoom out on your 
 drawing.

Zoom Commands
You find four Zoom commands in the Arrange menu: Zoom In, Zoom 
Out, Zoom All and Zoom Previous. Choosing the Zoom Previous 
command takes you to the last magnification. If  you want to zoom a 
particular area, use the Stroke feature or the Magnifying tool for zooming. 
Strokes are described later in this chapter.

Zoom All  Ctrl+F  [Macintosh: F]
This command in the Arrange menu zooms in or out to make all parts 
of  the drawing visible on the screen. 

Zoom In   Ctrl+]  Macintosh: ]
This command in the Arrange menu zooms in on the center of  the 
screen by a factor of  two. You cannot specify a particular area for en-
largement.

Zoom Out  Ctrl+[  Macintosh: [
This command in the Arrange menu zooms out from the center of  the 
screen by a factor of  two. You cannot specify the area of  reduction.

Zoom Previous  
This command in the Arrange menu zooms to the previous magnifica-
tion, as many as five times.

Important: Each Zooming is 
 followed by a screen redraw. 
You can press the Pause or 
Esc key (Macintosh: only 
Esc key) to stop redrawing 
the screen.
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Zoom Tools 
Select the appropriate zoom tool from the View Control tool palette.

Using the magnifying glass tool
With the Zoom tools you drag a box around an area on the screen, so 
only that area is magnified on the screen.

1.  Select a Zoom Tool from the tool palette.

2.  With the left mouse button pressed drag a box around an area on 
the screen you want to magnify or reduce.

3. Release the mouse button.
 The content of  the dragged box is made visible on the screen.

Zoom In Tol

This tool zooms in by the specified factor. The default factor is 2. This is 
a visual rather than a physical change.

When you click in the drawing area, that position is redisplayed in the 
center of  the screen, and the drawing is enlarged by a factor of  2.

You can also drag a box around an area, so only that area is magnified.
 

The status line shows the current zoom scale. If  you enter a different 
scale, that scale takes effect when you press Enter. Pressing the Ctrl key 
(Macintosh: Option key) while using this tool causes a Zoom Out.

Zoom Out Tol

This tool zooms out by the specified factor. The default factor is 0.5. 
This is a visual rather than a physical change.

When you click in the drawing area, that position is displayed in the cen-
ter of  the screen and the drawing is reduced by a factor of  0.
 

The status line shows the current zoom scale. If  you enter a different 
scale, that scale takes effect when you press Enter. 

Pressing the Ctrl key (Macintosh: Option key) while using this tool causes 
a Zoom In. 

Pan Drawing area

This tool displays a hand icon that allows you to move the screen area 
while the mouse button is pressed. The status line contains no boxes. 

Panning a drawing area 
1. Select the Pan drawing area tool in the Views subpalette of  the 

Tool Palette. 

2.  Press the mouse button and move the content of  the screen while 
the mouse button is pressed. 

Zoom Stroke 
You can use stroke commands to zoom—magnify or reduce your draw-
ing. Stroke commands are useful because they don’t require you to get out 
of  the tool you’re using to zoom. Hold down the Ctrl and Shift key 
(Macintosh: key) and drag the pointer that appears  diagonally across 
the screen as described below. The pointer takes on the shape shown be-
low when you hold down the Ctrl and Shift  key (Macintosh: key).

Using Stroke zoom
Depending of  the stroke direction you can execute different Stroke comands:

 

Note: For Zoom In and Zoom 
Out, the size and location 
of the stroke rectangle is 
important for determining the 
result of the Zoom operation. 
For Zoom Previous, the size 
and location of the stroke 
rectangle is irrelevant. All 
cases just give the previous 
magnification.

Important: Each Zooming is 
 followed by a screen  redraw. 
You can press the Pause or 
Esc key (Macintosh: only 
Esc key) to stop redrawing 
the screen.
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Drag Diagonally Result

Upper left to lower right Zoom-in enlargement centered over the stroked 
area.

Lower right to upper left Reverses Zoom In stroke to the previous mag-
nification.

Upper right to lower left Zoom-out reduction-the current screen reduces 
to the size of  the area defined by the stroke.

Lower left to upper right Reverses Zoom Out stroke to previous magnifi-
cation.

Screen Redraws
DesignFreeQ offers several commands to control screen redraws.

Redraw Screen Ctrl+R  [Macintosh: R]
This command in the Arrange menu refreshes the screen. When you 
make changes to your constructions, the geometry may not be redrawn 
cleanly in the drawing area.  

Redrawing the screen
To redraw all of  the geometry and remove extraneous geometry and 
points, choose the Redraw Screen command from the Arrange menu.

Stopping a screen refresh  
You can press the Esc or Break key (Macintosh: key) to stop the re-
drawing of  the screen.

Important: Under Windows you should use the Break key instead of  the Esc 
key, since Windows displays the Task manager when the Redraw screen com-
mand was initiated by the key combination Ctrl+R.

The Drafting Process
When creating a drawing you have to consider several items to guarantee 
that the drawing is printed within a standard drawing format according to 
the standard drawing rules. While you don't have to follow the these sugges-
tions in order, you may want to use the following scheme until you have 
enough experience to know how each step affects the overall project.

Creating a drawing   
1. Start DesignFreeQ.
 DesignFreeQ automatically displays an Untitled document.

2. If  necessary, set the Units of  measure you want to use with the 
Preferences command in the Layout menu.

3. Use the Drawing Size command in the Layout menu to set the 
drafting scale to 1:1.

4. Construct the geometry at full size, saving the construction as you 
work. Use the Zoom commands and tools to display the part at an 
appropriate magnification so that you can see what you are doing.

5. Use the Print Setup command (Macintosh: Page Setup) in the File 
menu to set the paper size you will use for  plotting or printing.

6. Use the Drawing Size command in the Layout menu to set the 
visual scale of  your drawing to fit on the specified paper size for 
plotting or printing.

 You may specify the drafting scale, such as 1:100 or 1cm:1m for  
1 centimeter to represent 1 meter.

 If  you are not concerned about scale and you only want the final 
geometry to fit on the selected paper size, you can specify Fit to ad-
just the geometry automatically to the paper size.

7. Dimension the part and add text.

8. Import a standard drawing format with the Import command in the 
File menu from the Layout folder.

9. With the Preview Layout command in the File menu you can check 
size and orientation of  the printing area that is displayed by a gray 
border to make final adjustment if  necessary.

10. Choose Print from the File menu.

How you have to proceed if 
you added text and dimen-
sions before you scaled the 
drawing is described in the 
following sections of this 
chapter.
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 The drawing is printed or plotted on the specified printer or  plotter. 
Text and dimensions are printed in the size you specified, since they 
were added after you scaled the drawing. 

 When you have set for example the size for text and dimensions to 3,5 
mm, text and dimensions will be printed in a size of  3,5 mm. 

  

 Flange plotted with a standard drawing format including block and title.

  

 Flange plotted without a standard drawing format.

The above described procedure recommends to scale the  drawing (to 
adjust the visual scale to the specified paper size) before you add text and 
dimensions.

Of  course you can scale drawings in DesignFreeQ after you have added 
text and dimensions. But that requires that you understand the different 
techniques DesignFreeQ uses for  scaling. These procedures are de-
scribed in the following  sections of  this chapter.

Drawing at Full Scale
In DesignFreeQ you create all parts at its actual size. It doesn't matter 
whether you design a large industry building or a small detailed blueprint. 

When printing you adjust the visual scale (the view of  the drawing) to fit 
the paper you will use. The true size of  all objects saved in the Design-
FreeQ Database is never affected by scaling.

DesignFreeQ saves all objects at their true measurements, regardless of

 • which drawing scale you specify with the Drawing Size or  
the Sheet Into View command.

 • what extend you magnified the drawing with the Zoom commands.

With these commands you only change the visual size of  the objects on 
the screen or on the paper but never its true size saved in the Design-
FreeQ database.

In this way the part dimensions to its true-to-life measurements regard-
less how they are displayed on the screen or printed on the paper.

Drawing at full scale has the following advantages:

 • scaling mistakes are eliminated

 • dimensions are automatic (you must dimension manually if  you 
do not draw at full scale)

 • associative dimensions update when the object is edited  (manual 
dimensions do not)

 • the size relationship of  imported parts is compatible.

 • calculations for 2D analysis are accurate.

Creating and editing objects at full size
When you open a new DesignFreeQ document, the drawing area is a 
sheet that is infinitely large so that you can design anything at full size. 
For a simplistic example, here's how to draw and view a line 24 meters long:

1. Draw a line.
2. For the Length of  the line type 24 m  in the Length field of  the 

status line. 
 The line extends off  the screen.

3. Choose Zoom All from the Arrange menu.
 The entire 24 meter line is visible on the screen.

Zoom All magnifies or 
reduces all objects on your 
drawing to fill the screen— 
regardless of how big or 
small the objects are.
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While zooming DesignFreeQ calculates the scale required to display the 
line at its full length on the screen. When you zoom again DesignFreeQ 
doesn't use the scaled length to calculate the new scale (this would lead 
to scaling mistakes the more often you scale) but its  original true length 
saved in the DesignFreeQ database. The Zooming commands allow you to 
create accurate full-scale  drawings and display them at the magnification 
required.

Paper Size and Drawing Scale
Before you can check if  your drawing can be printed at full size on a 
specific paper format you have to specify a paper size and orientation for 
your installed printer or plotter.

Specifying the paper size
To specify a paper size you choose the Print setup command (Macintosh: 
Page setup).

Print Setup  WIN
This command in the File menu allows you to select a printer, set the 
page size, orientation, and other options.

Setting up the page  WIN
1. Select Print  Setup in the File menu.
 The following the dialog box is displayed.

 

2. Choose your printer in the Specific Printer field if  it is not in-
stalled as the Default Printer.

3. Select the paper size from the Paper Size pop-up menu.

4. Select the paper source from the Paper Source pop-up menu

5. Specify the Orientation (Portrait or Landscape).

6. Click the Option button.

 Specify in the displayed dialog box if  you want to print your draw-
ing to a printer or save it to a file.

7. Click the OK button.

Page Setup  MAC
This command in the File menu allows you to select a printer, set the 
page size, orientation, and other options. 

Setting up the page  MAC
1. Select the plotter or printer you will use. Contact Technical Support if  

you need help setting up a plotter.

 
2. Select the Page Size from the Page Size pop-up menu.

3. Specify the Orientation. 

4. Click the OK button.

Checking the View Scale
After you have specified the paper format you must check if  the  objects of  
your drawing are too large or too small in  re lation to the  selected paper 
format and if  its view has to be scaled to fit on the  specified  paper size.

The Preview Layout command in the File menu allows you to check the 
size ratio between the objects and the specified paper size. 

In case your printer is not 
listed in the list of available 
printers you must first install 
your printer under Windows. 
A detailed description how 
to install a printer under 
Windows can be found in 
the Windows Reference 
Manual.
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Preview Layout
This command in the File menu displays the printing area of  the selected 
paper at its true size and selected orientation. If  you have not specified a 
printing/plotting size, he default size is used. 

  
If  the drawing does not fit into the displayed rectangle representing the 
printing area of  the selected paper size, you must scale the  drawing.

Printing/Plotting region
The printing/plotting region is displayed when choosing the Preview Lay-
out command and the Drawing size command.

With both commands a gray rectangle appears in the drawing area. This 
rectangle represents the printing/plotting region of  the page so you can see 
how your drawing fits the paper size.

The plotting region is smaller than the actual page size because most printers 
and plotters cannot plot to the edge of  the paper. If  you want to see the 
plottable outline all the time, click the Always Display button.

 
When the boundary of  the printing/plotting region appears, you can 
drag the boundary rectangle around the drawing area.

When you choose the Preview Layout command again or select any tool 
from the tool palette the Printing/plotting region disappears.

By the size relationship between the existing object geometry and the 
displayed printing/plotting region you can check  visually if  you have to scale 
the view of  your drawing. To do so you have to know how the different 
elements of  a drawing such as geometry, text, line patterns behave while scal-
ing, this described in the next section.

Scaling Drawings
Whenever the  created object geometry is too large or too small in rela-
tion to the specified paper format drawings must be scaled.

Scaling affects elements of  a drawing differently. While scaling Design-
FreeQ distinguishes between the following elements: 

 • object geometry
 • hatch patterns
 • line patterns
 • text
 • dimensions

For scaling you can use the Drawing Size command in the Layout menu 
or the Sheet Into View command in the Views menu. Since both com-
mands affect elements of  a drawing the same way while scaling the fol-
lowing sections describe only scaling with the Drawing Size command.

Scaling Object geometry 
Let's assume that a drawing exists only of  object geometry  created with 
solid lines.

In that case you can see the result of  the scaling only by the changed size 
of  the paper format represented by a gray rectangle in the drawing area 
for the printing/plotting region of  the page.

If  the gray rectangle for the page size isn't visible you can't see the re-
duced or increased size of  the object geometry caused by the scaling 
command, since the size of  the individual objects didn't change in rela-
tion to each other but only in relation to the paper size.

If the gray boundary repre-
senting the page size is not 
visible after scaling choose 
Zoom all while the Drawing 
Size dialog box is displayed.

The printing/plotting region 
is displayed filling the 
screen with the Origin (0,0) 
placed in the center of the 
page. If you cannot see your 
drawing on the screen you 
select the Zoom All com-
mand in the Arrange menu.

If the gray boundary 
 representing the page size 
is not visible after scaling 
choose Zoom all while the 
Drawing Size dialog box is 
displayed..
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Scaling Line patterns and Crosshatch patterns
When you use hatches and dashed lines in a drawing, the line dashes and 
hatch patterns are displayed at their true size.

When these line dashes are very small in relation to the remaining object 
geometry (size of  object geometry in meters and size of  line dashes in milli-
meters) you can't identify these line dashes on the screen before scaling, 
since they are displayed at actual size.

When you scale the drawing the object geometry is scaled while the dash-
es of  the lines and hatch patterns keep their true size. Therefore line and 
hatch patterns change size in relation to each other.

When you reduce the view scale of  the drawing the size of  the object ge-
ometry is reduced in relation to the dashed lines with the result that line 
and hatch patterns are now visible on the screen and on a print out.

Scaling Text and Dimensions
If  your unscaled construction is very large or very small compared to 
the size of  added text and dimensions you have to scale the view of  the 
drawing.

While scaling DesignFreeQ distinguishes if  the options

 • Keep Text size

 • Keep Dimension Text size

are checked or not. When both options are checked text and dimensions 
are not scaled and keep the size you have assigned in the Text menu or 
in the Dimension Editor. With these options checked the size of  the 
object geometry will be increased or reduced in relation to text and dimen-
sions.

However when you scale a drawing without having these options checked

 • text and dimensions are scaled
 • text and dimensions that you add after scaling are not scaled and 

displayed at true size.

This feature allows you to scale text and dimensions if  necessary. 

Options Keep Text size and Keep Dimension Text size
The options Keep Text size and Keep Dimension Text size are only 
available with the Drawing Size command not with the Sheet Into View 
command.

Therefore you must when scaling a drawing using the Sheet Into View 
command, select after scaling all text and dimensions and assign again 
the original text size in the Text or Dimension menu.

This procedure is necessary since DesignFreeQ scales existing text and 
 dimensions with the same scale factor as the object geometry and keeps 
text size and dimension text size only for future text and dimensions which 
are added after scaling.

Text and dimensions you place after scaling will be  displayed at true size 
even if  the options Keep Text  Size and Dimension Text Size are active or 
scaling was executed with the Sheet Into View command.

Plotter Fonts
When you are using a plotter, and the text should be displayed at its 
accurate size, you should specify a plotter font for text and dimensions 
on your drawing, since all other fonts are proportional and may differ in 
their appearance slightly from the assigned size. 

You can also  specify different text styles (such as italic or bold) for plotter 
fonts in the Text menu and generate special characters and accents as 
 described in the Appendix of  this manual.

Scaling Rules
While scaling the different elements of  a drawing behave as follows:

 • object geometry is always scaled
 • line and hatch patterns are never scaled
 • text and dimensions are not scaled if  the options keep text size and 

keep  dimension text size are active.
 • text and dimensions are always scaled if  the options keep text size 

and keep dimension text size are not checked.

In case the dashed or 
dotted line patterns are not 
displayed correctly because 
the scale factor is too large 
or too small you can adjust 
the line pattern using Edit 
Pattern the command in the 
Pen menu.

Remember: Lines with 
dashed or dotted line pat-
terns and Hatch patterns are 
never scalded in DesignFre
eQ but always displayed at 
their true size.

It is advisable to use the 
Selection mask to select all 
text and dimensions in case 
you have to assign the accu-
rate text size after scaling.

All Plotter Fonts available 
with DesignFreeQ are listed 
in Appendix A of this Refer-
ence Guide.
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To keep text and dimensions at a constant size while scaling and  having the 
options keep text size and keep dimension text size not checked you have to:

 • add text and dimensions after scaling 
  or 
 • you must select all text and dimensions and assign their text size again.

Scaling Commands
If  your unscaled construction is very large or very small compared to the 
size of  the specified page format you have to adjust the view scale of  
your drawing to fit the selected paper size. To do this you can use

 • the Drawing Size command in the Layout menu
  or
 • the Sheet Into View command in the Views menu.

The Drawing Size command with its options Keep Text Size and Keep Di-
mensions Text Size offers the better control for text and dimensions when 
scaling.

Whereas the Sheet Into View command imports  automatically a stan-
dard drawing format and scales a drawing at the same time, but doesn't 
keep the text size when scaling.

Drawing Size
This command in the Layout menu allows you to see the size of  the 
maximum plotting/printing area relative to the drawing and to specify the 
scaling of  the drawing so it fits the paper size and orientation set by the 
Print Setup command (Macintosh: Page Setup).

When you choose the Drawing Size command the following dialog box 
is displayed:

 

The Drawing Size dialog box allows the following settings:

 When you check this option the rectangle for 
the  printing/plotting region is always displayed 
at its true size in the drawing area even if  the 
Drawing Size dialog box is closed.

Keep Text Size When this option is checked text is not scaled 
but keeps the text size set before scaling.

 When this option is checked dimensions are not  
scaled but keep the text size set before scaling 
under Preferences in the Dimension menu.

Drawing Scale In the Scale box you enter a scale factor for your 
drawing specifying the ratio between the printed 
and the true size of  your drawing.

 To specify a scale you can press the arrow be-
side the Scale box and drag to one of  the stan-
dard ratios from the menu or enter real values, 
such as 1cm: 1m, which is converted to 1:100 by 
DesignFreeQ.

Fit When you click this button the drawing is scaled 
to fit the printing region of  the specified paper 
size. The calculated scale factor is displayed in 
the Scale box and the Drawing Size dialog box 
stays open.

Apply When you click the Apply button the drawing 
is scaled according to the selected factor and 
you can see the specified scaling on the drawing 
area. The Drawing Size dialog box stays open.

Before you choose the 
Drawing Size command 
in the Layout menu, you 
should use zoom out until 
your drawing fills half the 
screen size.

Always display 
Page Bounds

Keep Dimension 
Text Size
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OK When you click the OK button the drawing is 
scaled according to the specified scale factor. 
The Drawing Size dialog box is closed and 
the rectangle of  the printing region disappears 
on the screen when the  option always display 
Page Bounds is not checked.

Setting up the drawing size using the Drawing Size command
1. Choose Drawing Size from the Layout menu.
 The Drawing Size dialog box is displayed.
 With the dialog the gray rectangle for the printing/plotting region is 

displayed at its true size on the drawing area. When the boundary of  
the printing/plotting region appears, you can drag the boundary rectan-
gle around the drawing area.

 

2. Specify the scale ratio. 
 You can press the arrow beside the Scale box and drag to one of  

the standard ratios from the menu or double-click the Scale box and 
enter a scale (the ratio) you want to use. You can enter real values, 
such as 1cm:1m, which is converted to 1:100 by DesignFreeQ.

 If  you don’t need a specific scale, you can click the Fit button to 
scale the drawing to fit the paper. 

3. When text and dimensions should keep their true size choose the 
options Keep Text Size and Keep Dimension Text Size. If  you 
don't select these options you have to adjust text and dimensions after 
scaling.

4. When you want to control the scaling on the screen click the Apply 
button.

 The drawing is scaled and the Drawing Size dialog box remains 
open. The geometry itself  does not change scale; it only changes 
visually, not physically.

5. If  you want to print multiple sheets and tape them  to gether, follow 
the directions for Tiled Printing described later in this chapter. 

6. Click OK.

Setting up the drawing size using the Sheet Into View command
For scaling a drawing you can use as well the Sheet Into View command 
in the Views menu. The Sheet Into View command imports automati-
cally a standard drawing format and scales a drawing at the same time to 
fit into a view window placed within the drawing format. The Sheet Into 
View command does not keep the text size when scaling.

1. Create the object geometry.

2. Choose Zoom All from the Arrange menu.
 The screen is filled with the object geometry.

3. Choose the Sheet Into View command from the Views menu.
 The Sheet Into View dialog box is displayed.

4. Enter a Scale factor for the drawing into the Scale box. This Scale fac-
tor should correspond with the selected paper size.

5. Click OK.
 The whole object geometry is scaled and displayed in an indepen-

dent view window.

6. Add Text and Dimensions.
 Text and dimensions are placed unscaled at true size.
 Since the options Keep Text Size and Keep Dimension Text Size are not 

available with the Sheet Into View command you must  select all 
text and dimensions and assign their text size again.

The Cancel Button on the 
Drawing Size dialog box 
doesn't abort changes if a 
Fit or Apply are applied 
first.

If you want to change the 
Page orientation of the dis-
played page boundary you 
have to use the Print Setup 
Command (Mac intosh: Page 
Setup).

You find a detailed descrip-
tion of the Sheet Into View 
command in the Chapter 10 
Structuring Drawings.

It is advisable to use the 
Selection mask to select all 
text and dimensions in case 
you have to assign the accu-
rate text size after scaling.
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Printing or Plotting a Drawing
DesignFreeQ prints and plots on most printers and plotters supported 
by your computer. After you have followed the  manufacturer's instruc-
tions for installing and setting up the printer or plotter, you can size your 
drawing for the paper you will be using.

Print Ctrl+P   [Macintosh: P]
This command in the File menu prints or plots the current document as 
specified in Print Setup (Macintosh: Page Setup).

The area printed or plotted is the portion that fits on the page size when 
the origin (0,0) is placed in the center of  the page. Use the Drawing 
Size command from the Layout menu to reposition the print/plot region.

By repositioning the printing/plotting region it is possible to print only part 
of  a drawing, since the only part that is printed is the part that lies with-
in the printing region.

Plotting to a file
You can plot to a file rather than to a plotter or printer. In that way, you 
don't have to have a plotter attached to your com puter, you can have 
someone else plot the drawing without  having a copy of  DesignFreeQ 
on the plotter's computer.

The type of  plotter you choose when you are setting up the page deter-
mines the format of  the plot file. For example, if  you choose a Post-
Script printer, the file format will be Encapsulated PostScript; and the 
HPGL language is used when you select Hewlett Packard plotters. The 
computer that finally plots the file must have an application  compatible 
with the file format of  your printer or plotter.

Plotting to a file under Windows
1. Choose Print command in the File menu.
 The Print dialog box is displayed.

 

2.  Mark the Print to file option.

3.  Click OK.
 The Print to file dialog box is displayed.

4. Enter a name for the print file.

5. Click OK.
 The drawing will be printed to file and saved under the name you 

specified.

Plotting to a file on a Macintosh computer
1. Choose Chooser from the Apple menu.

2. Select a printer or plotter from the Chooser list.
 A message appears telling you to confirm settings in Page Setup in 

the File menu.

3. Click Continue.

4. Click Setup in the Chooser dialog box.

5. Specify the printer and options you want to use.

6. Choose Print from the File menu.

7. Click the File button in the lower-right corner of  the Print dialog 
box.

8. Enter the file name and click OK.
 The drawing will be printed to file and saved under the name you 

specified.

The Print Setup command 
(Macintosh: Page Setup) 
allows to change the current 
plotter or printer and to set 
options such as Paper Size 
and Paper Orientation.

If you want to use Design
FreeQ drawings in a Text 
Editor or Layout program the 
EPS file format is recom-
mended, since it offers the 
best quality and allows to 
scale the graphic after plac-
ing without any quality loss. 
How to create an EPS file 
is described in Chapter 11 
DesignFreeQ Documents.
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Tiled Printing
If  you are using a printer rather than a plotter, you may want to tape 
pages together to get a larger drawing than laser printers allow.  Specify 
the layout for those pages by choosing Drawing Size from the Layout 
menu.

1. Choose Drawing Size from the Layout menu.

2. Specify the number of  pages across for the final drawing.

3. Specify the number of  pages down for the final drawing.

4. Specify the order for printing the pages (across then down or down then 
across).

 

5. Click the Fit button.
 The drawing will be scaled to fit to the number of  pages you speci-

fied.

6. With the mouse button pressed reposition the displayed rectangles 
representing the number of  pages you specified to cover these ob-
jects you want to print.

7. Click  OK.
 Your drawing is scaled to fit the number of  pages and layout, as you 

have specified.
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Structuring Drawings
DesignFreeQ provides the following features to structure drawings:

 • Layers
 • Sheets
 • Associative Detail Views
 • Models

These tools allow you to use DesignFreeQ individually for your design 
tasks. Especially the combination of  Sheets, Views and Models add a great 
amount of  flexibility to the design process.

Layers
Layers are particularly useful in helping you view and plot  complex draw-
ings. For example, when you dimension a part, the dimensions can be 
placed on a separate layer which you can display or not, as your needs 
require. Layers allow you to plot different versions of  the same document 
for quick and easy  specialized blueprints.

• You can hide the dimension layer to exhibit the idea of  a design  
to a planning team and show the dimensions when presenting the 
drawing to engineers.

• You can hide some drawing components when you plot. For exam-
ple, you can hide the construction layer so that construction lines 
and geometry don’t plot, but they remain in the drawing ready for 
use when you want to alter it.

• You can construct different layouts using one layer as the basis. For 
example, you can use a floor plan and then construct the  electrical 
and plumbing plans on different layers. In that way, you can turn off  
one layer (the electrical plan, for instance) and print the other (the 
plumbing plan) with the floor plan.

DesignFreeQ allows you to have up to 256 visible or hidden layers in 
your drawing. Layer names are limited to 79 characters.

Layers  Ctrl+L   [Macintosh: L]
This command in the Layout menu allows you to create, delete, and rename 
layers, as well as set layer specifications. The work layer is the  active lay-
er—the layer on which the current construction is created.

The visible layers are indicated in the list box by a checkmark and a dot 
indicates the work layer.

 

Construction Lines  Construction lines automatically go on the 
 construction layer.  

Dimensions If  you create a dimension layer, all  dimensions 
 added after you create the layer go on the 
 dimension layer.

You can edit any geometry or text that is visible, regardless of  which 
layer it is on. If  you want to make some geometry unselectable but still 
visible, use the Selection Mask command in the Edit menu.  

Since the DXF format sup-
ports only 31 characters you 
should limit layer names to 
31 characters to guarantee 
a smooth DXF Export.

Note: You cannot hide or 
delete a layer that is the cur-
rent (active) work layer.

DesignFreeQ includes 
a Construction layer, a 
 Dimension layer and a 
TitleBlocks layer by  default 
with each drawing.

Layers are often described 
as transparent films. But 
actual they are just another 
method to group objects. 

Note: The Construction 
layer will automatically 
 accept all  Construction 
 lines created with stroke 
commands or with the 
 Construction dialog box. All 
lines of “construction” line 
type created with the Single 
Line tool will go onto the 
current work  layer. 
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You can use layers for complex drawings so you can hide some objects to 
simplify the drawing visually or print only  specific parts of  the drawing. 
You can think of  visible layers as transparent pages and  hidden layers as 
invisible pages. Although you cannot see objects on hidden layers, they 
do  exist. The layer must be visible for you to select objects on the layer. 
For example, if  there are objects on a hidden layer and you choose Se-
lect All, then delete all  objects, those objects on the hidden layer are not 
deleted.

You can also specify the selectability of  layers with the Selection Mask 
command in the Edit menu.

Creating a new layer
Click New to create another layer. You can name the layer by typing the 
name in the Rename entry box and clicking Rename. You can have as 
many as 256 layers.

Renaming a layer
1. Select the name of  the layer from the list box.

2. Type the new name.

3. Click the Rename button.

Deleting a layer
1. Select the name of  the layer from the list box.

2. Click the Delete button.
 Caution: The layer and everything on that layer is deleted; however,  

a warning appears before this happens.

Making a layer the work layer
1. Select the name from the list.

2. Click the Set Work button.
 The layer must be visible before you can make it the work layer.

Using the layer box to specify a different work layer
You can use the pop-up layer box at the lower left of  the drawing area 
to specify a different layer as the work layer.  

1. Press the mouse button on the box and the menu displays.

2. Drag to the layer you want to be the work layer and release the 
mouse button.

Hiding a layer
1. Click the layer(s) you want to hide in the list.

2. Click the Hide button.
 The visible mark beside the layer name disappears.

Displaying a hidden layer
1. Click the layer(s) you want to make visible in the list.

2. Click the Show button.
 A visible mark appears next to the layer's name in the list.

Determining how many objects are on a layer
1. Choose Selection Mask from the Edit menu.

2. Select the desired layer from those listed in the center box.

3. Choose Select All from the Edit menu.

4. Choose Edit Objects from the Edit Menu.
 The number of  objects is listed at the top of  the  dialog box.

5. Close the Selection Mask and Edit Objects dialog boxes.

Using colors with layers
Many CAD drawings show different components in different colors. 
When you specify a different color for a layer, the layer remembers 
the color so that if  you add geometry to a layer later, the new geometry 
appears in the same color as the last  geometry constructed on that layer. 
In this way, you can use the Visible pen in red on one layer, green on 
another layer, and so on.

1. Select Layers from the Layout menu.

2. Create a new layer and rename it Outline green, indicating you 
always want to use the pen style Outline with a green color on this 
layer.

You can also type a name 
and click New.

Layer names are limited to 
79 characters. Since the 
DXF format supports only 31 
characters you should  limit 
layer names to 31 charac-
ters to guarantee a smooth 
DXF Export.

You can’t hide the work 
layer.

Layers facilitate color 
specific wiring diagrams 
or electrical and plumbing 
blueprints.

Note: Layers can be saved 
as Preferences along with 
specified colors.
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3. Make the layer Outline green current.

4. Select Outline in the Style submenu from the Pen menu.

5. Change the pen color from Black to Green by selecting Green in 
the Color submenu from the Pen menu.

6. Draw a circle.
 The circle is created with the green color.

7. Select the Single line tool.

8. Make Layer 1 current.

9.  Draw a line
  The line is created in black (the default color for the Outline pen 

style).

10. Select the Rectangle tool.

11. Make Layer Outline green current and draw a rectangle. 
 The rectangle is created in green.

A Layer Example
Layers are like transparent sheets that you can turn on and off. This 
feature is particularly useful for designs with several variations of  a com-
ponent. A common use of  layers is to draw the different floor plans and 
plumbing and wiring plans for a building on different layers. The follow-
ing examples show simplified drawings using lyes.

   

   

In order to print or plot the layers, simply use the Layers  dialog box to 
turn on the layers you want to print and turn off  all other layers. When 
you can see what you want to print on the screen, choose Print from the 
File menu.

Using Smart Walls with layers
You can also observe how smart walls function in these examples. The 
interior walls on Layers 2 and 3 overlay the  exterior walls of  the foun-
dation. 

Layer Groups
Layer Groups are particularly useful for viewing and plotting different 
 layers of  a complex drawings. For example, the document described in 
the Layers section that shows the floor plan of  a house might have sev-
eral layers illustrating the plumbing layout and several layers illustrating 
the electrical plan. The plumbing layers can be shown in the Plumbing 
Layer Group but hidden in the Electrical Layer Group.  Similarly, the elec-
trical layers are shown in the Electrical Layer Group but hidden in the 
Plumbing Layer group. To create a print to go to the electrical contractor, 
you can simply make the Electrical Layer Group be the work group. This 
will show the layout of  the house with the electrical plan contained on 
various electrical layers but not the plumbing information which is on the 
hidden plumbing layers. Rather than having to Show or Hide numerous 
individual layers, you only have to select a single Layer Group to get the 
format that is desired.

Layer Groups
The Layer Groups command in the Layout menu extends the function-
ality of  layers by creating Layer Groups.

A Layer Group records, stores, and displays layer settings—which layers 
are shown and which layers are hidden, as well as which layer is the work 
layer. This lets you show and hide different layers quickly by selecting a 
single Layer Group rather than setting the attributes of  numerous individ-
ual layers.

Note: Smart walls merge 
only on the same layer; 
therefore, the interior walls 
are not merged with the 
exterior walls and walls on 
Layer 2 are not merged with 
walls on Layer 3.



Structuring Drawings

154

When you select the Layer Group command from the Layout menu the 
following dialog box is displayed:

 

The Layer Groups dialog box lists the layer groups on the left and the 
individual layers on the right. Visible layers for the selected (highlighted) 
Layer Group are indicated in the Layer list by the Eye Symbol, just as 
they are in the Layers dialog box.

Visibility can be toggled by clicking the Eye Symbol, or at the location 
where the Eye Symbol should be for hidden layers.

The work layer of  the selected group is set by double-clicking on the de-
sired layer from the Layer list and is indicated by a checkmark.

Layers that are created after a Layer Group has been defined are included 
in the group but are not visible.

The current set of  visible layers and the work layer need not correspond 
to any layer group; thus, it is not necessary that a Layer Group be desig-
nated as the “work” group. 

Setting a work group simply changes the model’s current layer settings 
to those of  the specified Layer Group. Also, if  a Layer Group is designated 
the work group and layer attributes are subsequently  modified—either by 
the Layer dialog box or by changing the work layer in the Layer Indica-
tor pull-down list—the Layer Group loses its “work” status.

A check mark by a Layer Group indicates that the current settings in the 
Layer dialog box match those of  the  indicated Layer Group. This is only 
valid just after displaying the Layer Group dialog box.

The Layer Group dialog box allows the following settings:

New This button creates a new Layer Group, called Group1, 
Group2, Group3, etc., by default.  Use the Rename 
button to rename the Layer Group with an appropriate 
name. You can have up to 256 Layer Groups in a single 
file.

Delete This button deletes the selected (highlighted) Layer 
Group.

Set Work This button sets the currently selected (highlighted) 
group as the work group. This changes the layer set-
tings for the current model to those specified by the 
layer group.

Rename This button renames the currently selected (highlighted) 
group with the name in the  Layer Group entry box.

Creating a Layer Group
1. Click New. A new Layer Group appears in the group list. It records 

the current layer settings and displays these settings in the Layers 
list.

2. Change the layer settings as desired. Visible layers are indicated 
by the Eye Symbol and can be hidden by clicking on the symbol.  
Hidden layers can be made visible by clicking in the location where 
the Eye Symbol would be. The work layer is indicated by the check 
mark and can be set by double-clicking on the desired layer.

Renaming a Layer Group
1. Select the desired Layer Group from the Group list.

2. Enter a new name in the Layer Group entry box.

3. Click Rename.

Deleting a Layer Group
1. Select the desired Layer Group from the Group list.

2. Click Delete.

Making a Layer Group the work group
1. Select the desired Layer Group from the Group list.

2. Click Set Group.  

Deleting the work group, 
which is indicated by a 
check mark, deletes the 
group from the list, but the 
layer settings remain in ef-
fect until they are changed.

Only visible layers can be 
made the work layer within a 
Layer Group.

There must be at least 
one Layer Group created 
before you can use any of 
the buttons other than New 
or change any settings for 
any layers.

You can also activate a 
Layer Group by double- 
clicking the name of the 
Layer Group.
The active Layer Group is 
indicated by a checkmark. 
When you open the Layer 
Group dialog and no Layer 
Group is indicated by a 
checkmark, the current 
work layer set in the Layer 
dialog box doesn't match the 
setting of the last activated 
Layer Group.
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 This changes the layer settings for the current model to those speci-
fied by the layer group. These settings are shown in the Layers list.

Changing the layer settings of a Layer Group
1. Select the desired Layer Group from the Group list.

2. Change the layer settings as desired.
 Visible layers are indicated by the Eye Symbol and can be hidden 

by clicking on the symbol. Hidden layers can be displayed in the lay-
er group by clicking in the location where the Eye Symbol should 
be. The work layer is indicated by the check mark and can be set by 
double-clicking on the desired layer. The new settings  automatically 
replace the old settings.

Sheets
A Sheet is an infinite planar area. DesignFreeQ allows you to have mul-
tiple opaque sheets within a drawing. A drawing can be a simple part or 
a complex assembly, and you can organize related geometry on as many 
sheets as the scope of  the project calls for.

You can have as many sheets as you want but only one sheet can be 
visible at a time—the active sheet. You activate a sheet with the Current 
command in the Sheets dialog box in the Views menu.

If  you have multiple sheets, imagine them arranged as a stack of  sheets 
behind your computer screen. If  you make a sheet current you bring it to 
the front. That is why you can see only one sheet at a time—the current 
sheet.

 

Using Sheets
Sheets are DesignFreeQ’s equivalent to pieces of  paper you use with a 
 drawing board.

Every document contains automatically Sheet 1.

Sheets
This command in the Views menu allows you to create, delete, rename 
sheets and set the work sheet. Th checkmark ( ) in the list of  sheets 
 indicates the work (or current) sheet.

 

You may want to use several sheets to create related components and 
associated detail views. With the drafting board you use a new sheet of  
paper for a project; with DesignFreeQ you create a new sheet.

Creating a new sheet
Click New to create another sheet. You can name the sheet by typing the 
name in the Rename entry box and clicking the Rename button.

Renaming a sheet
1. Select the name of  the sheet from the list box.

2. Type the new name.

3. Click the Rename button.

Deleting a sheet
1. Select the name of  the sheet from the list box.

2. Click the Delete button.

When you delete a sheet you delete only the sheet including all Detail 
Views, but not the geometry displayed on the sheet.

A check mark by a Layer 
Group shows the active 
Layer Group and indicates 
that the current settings in 
the Layer dialog box match 
those of the indicated Layer 
Group. 

In DesignFreeQ one sheet 
is always Current—the 
active sheet which cannot 
be deleted.

The name of the active 
sheet (Document Name: 
Sheet Number) is only 
 displayed in the Title Bar if 
more than one sheet exists.

Whenever you want to print 
a part related to one project 
separately, create a new 
sheet.

You can also type a name 
and then click the New 
button.

Note: The current sheet 
cannot be deleted. 

Detail Views are described 
later in this chapter.
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DesignFreeQ handles Models and Sheets separately. The geometry you 
create is the model—what you see on the sheet is only an image (view) 
of  that model. So when you delete the sheet you delete only the Sheet 
View or Detail View of  the model, but not the geometry (model) itself. 
You can display the deleted geometry any time on another sheet using the 
 Models command in the Views menu.

Making a sheet the current sheet
1. Select the name from the list.

2. Click the Current button.

Models
Models are composed of  the geometry you are creating. Even if  it looks 
like the geometry is created directly on the sheet, it is not. What you see 
on the sheet is only an image of  that model. The model itself  is created 
in an infinite three-dimensional area we call Model space.

Projected Model Image
The image you see on the sheet is the projected Sheet View of  the mod-
el picked up by the Sheet Camera which is aligned parallel to the sheet 
and looking from a top view, t the model.

 

When you use the Zoom commands in the Arrange menu or the Zoom 
tools from the Tool palette you change the view scale of  the model by 
zooming the Sheet Camera like you would with a video camera.

Multiple Models
There are two different ways to create models:

 • with the Sheets command in the Views menu
  or
 • with the Model command in the Views menu.

When you create a new sheet, DesignFreeQ automatically creates a new 
blank model where you can create geometry.

Models
This command in the Views menu allows you to specify models and 
switch between models to project them on the current sheet. You can 
display a single model on more than one sheet, but you can only see one 
model at a time on each sheet without using detail views.

 

Creating a new model
Click New in the Models dialog box to create another model. You can 
name the model by typing the name in the Rename entry box and click-
ing the Rename button.  

Renaming a model
1. Select the name of  the model from the list box.

2. Type the new name.

3. Click the Rename button.

See Models in the next 
section of this chapter for 
more information on how 
 models work.

Any combination of geom-
etry such as lines, arcs, 
circles, dim en sions, text, 
etc. you create with any 
of the creation tools in the 
Tool palette or any tools in 
the Dimension palette is 
a Model.

It may be difficult to imagine 
that when you draw in 
DesignFreeQ two-dimen-
sional geometry, that this 
geometry is created in a 
three dimen sional Model 
Space. It is easier to think 
of that model space as a 
thin pane of glass where 
all geometry is created. An 
image of everything that is 
placed on that pane of glass 
is continuously projected on 
the current sheet.

You can also type a name 
and then click the New 
 button.
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Making a model the current model
1. Select the name from the list in the Models dialog box

2. Click the Set Work button.

Deleting a model
1. Select the name of  the model from the list box.

2. Click the Delete button.

When you delete a model, you delete all of  the geometry making up that 
model.

Relationship between Sheets and Models
When you create a new model with the Model command, a new model is 
created without creating a new sheet. So it is possible to have more mod-
els than there are sheets. You can only look at one model at a time in any 
view (sheet view or detail view). So it is also possible to have a model that is 
not displayed in any view. And you can have a single model displayed in 
many views at the same time.

When you make a Model current in a sheet view, it is like the Sheet cam-
era is moved to the new model. When you make a Sheet current, the 
Sheet camera is moved to the related model whose image is projected to 
that sheet.

 

Creating a new Model with the Sheets command
1. Select Sheets in the Views menu.
 The Sheet Dialog box displays.

2. Select Models in the Views menu.
 The Model Dialog box displays. 

3. Since the Model dialog box is placed at the same location on 
the screen, move it to another location so you can see both dialog 
boxes.

 

 Now you can see that a new drawing in DesignFreeQ has one 
Sheet and one Model by default. The checkmark in each dialog box 
shows that Sheet 1 and Model 1 are current.

4. Display the Sheets Dialog box and click New to create a new sheet.
 You see also that a new model automatically appears in the Models 

Dialog box (Model 2).

 

5. Make Sheet 2 current by highlighting it and clicking Current.
 If  you have any geometry on Sheet 1, it disappears and a blank 

screen comes up. Also, the check mark moves from Sheet 1 to 
Sheet 2 and the check mark also moves automatically from Model 
1to Model 2.

Note: You cannot delete 
the current model. A model 
which is still associated to 
a sheet cannot be deleted. 
As long it is related to a 
sheet the Delete button in 
the Models Dialog box is 
greyed out.
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 Model 2 automatically becomes current because Sheet 2 is related 
to Model 2. So if  you make Sheet 2 current on the screen, then 
Model 2 has to be current as well.

 Sheet 2, now displayed on the monitor, is blank because nothing has 
yet been added to Model 2. As soon as you begin to draw, all geom-
etry is automatically added to Model 2 since Model 2 is the current 
model space.

Associative Views
Views allow you to enlarge or reduce all or part of  the geometry for both 
viewing and printing. This visual change of  the view does not affect the 
actual measurement of  the geometry (the model). There exist two types 
of  views in DesignFreeQ: the Sheet View and Detail Views.

Sheet View  The Sheet View shows the object geometry on the 
 current sheet at the scale you set with the Drawing Size 
command in the Layout menu. The Sheet View is the 
default view when you launch DesignFreeQ. The Sheet 
View is picked up by the Sheet camera and projected on 
the current sheet. The Sheet View is  infinite. It has no 
boundaries.

Detail Views A detail view is created with either the Detail View tool 
on the tool palette or by the Sheet Into View command 
in the Views menu. Detail Views are always displayed 
in a view window.

These two different views are easily to identify on the screen:

 • Each item displayed inside a view window is a Detail View.
 • The area outside (and underneath) all detail view windows is the 

Sheet View.

Creating Detail views using the Detail View tool 
DesignFreeQ allows you to create associative Detail Views. These Detail 
Views are always placed in a view window and are associative so that 
when you modify geometry in any view, all views of  that geometry reflect 
the change. There are three deliberate exceptions to this associativity, in 
line with standard drafting practice:

 • Dimensions
 • Crosshatching
 • Text 

They are view dependent and appear only in the view in which they were 
created.

In the illustration below, the detail view shows a 2 : 1 enlargement of  
the side notch. Dimensions, text and hatches are displayed only on the sheet 
where they were created.

 

View Windows can be created in DesignFreeQ in two different ways: 

 • manually with the Detail View tool 
  or 
 • automatically with the Sheet Into View command in the Views 

menu 

Regardless of the method 
you use to create a View 
Window, they all behave the 
same way. 
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Detail View Tool

The Detail View tool on the View Control subpalette of  the Tool Palette 
creates a detail view of  the designated area of  your drawing. The detail 
view is associative so that when you modify the geometry, the detail view 
reflects the change.

Creating an associative detail view
1. Select the Detail View icon from the View Control subpalette.

2. Enter a Scale for your detail vie in the status line.

 

3. Use the pointer to drag a rectangle around the area of  your drawing 
that you want placed in the detail view. This rectangle becomes the 
window frame.

4. Position the pointer in the center of  the detail view window frame 
and drag the window to a clear area on your drawing.

Activating/deactivating detail views
A Detail View is made active by clicking inside the view window. An active 
detail view displays its title bar and Detail View pull-down menu.

 
A view must be active for you to work in it. Either a detail view is active 
or the sheet view is active, but only one can be active at a time.

You deactivate a Detail View by clicking in the drawing area away from all 
detail views. In order to draw on the sheet it must be active. 

Placing a Detail view on a separate Sheet
1. Create a detail view on the current sheet.

2. Select the Cut command in the pull-down menu of  the detail view.

3. Choose the Sheet command in the Views menu and create a new 
sheet (Sheet 2) using the New command in the Sheet dialog box.

4. Active Sheet 2 by clicking the Current button. 

5. Choose the Insert command in the Edit menu to place the detail 
view onto Sheet 2.

 The detail view is placed on Sheet 2 and is associatively  connected 
to the object geometry on Sheet 1.

View Window 
The view window includes a Title bar, Size box and pull-down menu only 
when the detail view is active.

 
You can drag the view around by the title bar and resize the win dow by 
dragging the size box.

The Detail View menu provides options for manipulating the view.

 
Properties The Properties option allows you to change the view 

scale and define the locations of  its corners.

   

You may also create the 
rectangle by clicking to 
place the diagonally- 
opposite corners.

When a view window dis-
plays a title bar the view 
window is active. When the 
view window has no title 
bar, the underlying sheet 
is active.

Don't use the Cut command 
in the Edit menu, since it 
cuts the geometry and not 
the detail view.

The left graphic shows a 
Detail View window for Win-
dows, the right graphic for 
the Apple Macintosh.

How to create a non-as-
sociative detail view is 
described at the end of this 
chapter. 
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Cut The Cut option allows you to remove the view from 
the sheet and place it on the Clipboard. This is useful for 
placing views on a different sheet. Use the Paste com-
mand from the Edit menu to paste the cut view window.

Copy The Copy option allows you to place a copy of  the view 
window on the Clipboard. This is useful for pasting mul-
tiple identical views onto one or more sheets. Use the 
Paste command from the Edit pull-down menu to paste 
a copy of  the view window.

Delete This option deletes the active window and makes the 
sheet active. It does not delete geometry.

Pan This command allows you to move the geometry inside 
the view window. A hand icon appears which you can 
use to drag the contents of  the window. When you re-
lease the mouse button, the Pan function ends.

   
Resize The Resize option allows you to drag a new view win-

dow. This function differs from dragging the window 
borders. With the Resize command, you do not have to 
change each border individually since you define a new 
window that is substituted for the original one.

Changing the view scale
When you are trying to fit a view or group of  views in a drawing format, 
you may have to scale a view.

1. Choose Properties from the Detail Views menu.

2. Specify the scale you want and click OK.

Zooming within a view
1. Click inside the view to make it active.  

2. Hold down the Shift key (Macintosh: Ctrl key).

3. Choose the Zoom command you want from the Arrange menu.  
 The geometry inside the view is zoomed.

Scrolling within a view
1. Click inside the view to make it active.  

2. Hold down the Shift key (Macintosh: Ctrl key) and move the scroll-
bars.

 The geometry inside the view is moved.

Bring To Front
This command in the Views pull-down menu brings the specified view to 
the front of  the stack of  views.

Bringing a specified view to the front
1. Select the view.

2. Choose Bring To Front from the Views menu.

This command counteracts the Auto Front command, so when you click, 
you select objects in the view rather than activating another view.  

Send To Back
This command in the Views pull-down menu sends the specified view to 
the back of  the stack of  views.

Bringing a specified view to the back
1. Select the view.

2. Choose Send To Back from the Views pull-down menu.

This counteracts the Auto Front command, so when you click, you acti-
vate another view rather than selecting objects.

Auto Front
The Auto Front command in the Views menu overrides the Bring To 
Front or Send To Back settings. When this setting is in  effect, you can 
simply click on a view to bring it to the front and make it  active. 

All commands from the 
Arrange pull-down menu 
work inside the view when 
you hold down the Shift key 
(Macintosh: Ctrl key) while 
 choosing from the menu. 

All scrollbar functionality 
can be used inside the view 
when holding down the Shift 
key (Macintosh: Ctrl key) 
while moving the scrollbars. 

This command only works 
for views.



161

Structuring Drawings

Handling overlapping views
The view control commands in the Views menu allow you to control the 
active view. When you have overlapping views, you can think of them as 
a stack where only the top view can be active. If the Auto Front com-
mand is turned on and you click a view it comes to the top of  the stack 
and you can work in it. This may cause some problems when you click 
an object in the top view to select it, but an underlying view is activated 
instead.

To remedy this situation, turn off  the Auto Front command. Select the 
view you want to work in and choose Bring To Front from the Views 
menu. The objects in the view you brought to the front remain on top, 
even when you click a different view visible in the top view’s space.

Draw View Boundaries
This command in the Views menu shows the boundaries of  all inac-
tive views. This boundary will be printed if  you leave it  displayed when 
you choose the Print command. If  you want to print the view without 
boundaries deactivate Draw View Boundaries in the Views menu.

 

How Detail Views work
When you create a detail view with the Detail View tool on the Tool pal-
ette or the Sheet Into View command in the Views menu, you see the 
same model through a second camera—the Detail View Camera.

The Detail View camera behaves like the Sheet Camera except it 
 displays its view of  the model in a View window on the sheet.

 

All views displaying the same model are associative. For example, when 
you change the geometry on the sheet, the geometry in the view window 
changes, and vice versa.

When you have several views displaying the same model they have to be 
associative, because no matter which view is active—the Sheet View or 
any Detail View—you are always editing the same model.

Creating Views using the Sheet Into View 
command
The Sheet Into View command places all the geometry on a sheet 
including dimensions, text, hatching, and fills into one view window (the 
front) at the scale you specify.

 

Sheet Into View
When you choose the Sheet Into View command the following dialog 
box is displayed:
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The Sheet Into View dialog box allows the following settings:

Layout In this pull-down list you can select a paper size with 
view(s) in a standard drawing format.

Scale In this entry field you can enter a scaling ratio, such as 
1: 8, a size ratio such as 1cm:1m or a factor. Factors 
 greater than 1 enlarge all objects in the views and factors 
less than one reduce all objects.

Cancel This button closes the Sheet Into View dialog box 
without executing the Sheet Into View command.

OK When you click the OK button, all geometry on the 
sheet including dimensions, text, hatching, and fills is 
placed into one or several view windows at the scale you 
specify.

Using Sheet Into View
1. Draw the geometry

2. Delete all existing Detail View windows.

3. Choose Sheet Into View from the Views menu.
 A dialog box is displayed.

4. Choose the drawing format and the number of  views you want from 
the Layout list.

5. Enter the scaling value in the Scale box. 

6. Click OK.

7. Select Zoom All in the Arrange menu to see the results.

The geometry is scaled and the views are laid out as specified. If  you 
specify a drawing format, it is imported into the view and scaled appro-
priately for the drawing size you have specified with the Drawing Size 
command in the Layout menu.

Scaling Views
The Scale you specify in the Sheet Into View dialog box changes the 
view scale property of  that view only in relation to the object geometry 
on the sheet. It can be modified using the Properties command in the 
Detail View menu or using the Zoom tools.

When you use the Drawing Size command in the Layout menu to scale 
the entire drawing for printing the specified relation ship between the  
Detail View and the Sheet remains unchanged.

Recovering from an erroneous Sheet Into View
If  you mistakenly invoked the Sheet Into View command and do not 
want your geometry in a view, use Undo to recover. If  this is not done 
immediately, you must use the following method to manually back out.

1. Select all object geometry including text, dimensions and hatch patterns.

2. Choose the Group command in the Arrange menu.

3. Delete all view windows on the current sheet by choosing Delete 
from the View window menu of  each view.

4. Make Model 1 in the Model dialog box the current model for the 
sheet.

5. Delete Model 2.

How the Sheet Into View command works
The view window created with the Sheet Into View behaves like any 
view window created with the Detail View tool.

Although both view windows behave the same, the Sheet Into View in-
cludes three auto matic steps which are not  performed when you  create a 
view window with the Detail View tool.

The Sheet Into View command

 • creates an additional Model (blank or containing a standard 
 drawing format if  selected).

In the Layout list you find 
as well Design Layouts 
called as Design 3 or Draft 
4. These Design Layouts 
are only used for designing 
in 3D. More about Design 
Layouts you find in the 3D 
Section of this  manual.
You can add your own 
formats to this list or modify 
the layouts provided to meet 
your needs is described in 
the next section.

Important: If you want to 
keep the existing detail 
views you must import the 
drawing format.

You can undo a Sheet 
Into View command using 
the Undo command in the 
Edit menu. But the Undo 
command works only if 
it is invoked immediately 
after the Sheet Into View 
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 • moves the Sheet camera to that model (blank or with the 
 drawing format) to display it on the current sheet

 • puts all geometry including text, dimensions, hatching, and fills on 
the current sheet into one or several view windows and displays 
it at a specific scale within the drawing format you have selected.

   

Drawing Formats
You cannot only modify all drawing formats in the Layout folder of  the 
DesignFreeQ directory but create as well your own drawing formats and 
design layouts.

Drawing formats contain the border line of  the drawing, the cutting line and a 
Title block for entries such as name or scale of  the drawing.

Drawing formats have to be created for each paper format such as A, B, C 
or D and for both paper  orientations Portrait and Landscape.

All drawing formats you find in the Layout folder of  DesignFreeQ are 
 designed for Plotter devices, where the Cutting lines correspond exactly with 
the dimensions of  the selected paper format (for example 30 x 40 inch 
for the D Format) and the Border line is  offset inside by 1/2 inch according 
to the ANSI standard.

When you want to use these plotter formats for your laser printer you 
have to adjust them to the printing area of  your printer, that could differ 
from printer to printer.

The Standard Drawing Formats shipping with DesignFreeQ contain in 
addition to the drawing  format detail views that may display with the Sheet 
Into View command the content of  a drawing at different view angles 
and scale factor.

Placing Drawing formats 
There are two different ways to place Standard Drawing Formats:

 • with the Import command in the File menu
  or
 • with the Sheet Into View command in the Views menu. 
Since placing a drawing format using the Sheet Into View command is 
described in the previous section the following task describes how that is 
done using the Import command.

Importing Drawing Formats
1. Scale the drawing using the Drawing Size command in the Layout 

menu.
2. Mark the option Always display Page bounds in the displayed 

Drawing Size dialog that allows you to compare the true size of  the 
drawing with the displayed printing area of  the drawing format.

3. Activate the current sheet by clicking on it with the Selection tool, 
in case your drawing contains any detail views.

 The window boundaries are displayed by dotted lines to indicate that 
the next step is executed on the current sheet and not within a detail 
view.

4. Choose the Import command of  the File menu.
 The Import dialog box is displayed.

5. Open the folder Layout and select the drawing format you want.

You can add your own 
formats to this list or modify 
the layouts  provided to meet 
your needs is described in 
the next section.

How you create your own 
drawing formats for your la-
ser printer is  described later 
in this chapter.

In the Layout folder you 
find as well Design Layouts 
called Design 3 or Draft 
4. These Design Layouts 
are only used for designing 
in 3D. More about Design 
Layouts you find in the 3D 
Section of this  manual.

The Drawing size command 
displays the printing area of 
the selected paper size at 
its true size on the drawing 
area. You can change the 
paper format using the Print 
Setup command (Macintosh: 
Page format) in the File 
menu.
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6. Click the Open button.

7. Mark the option unscaled in the displayed dialog box.

8. Click the OK button.
 The Drawing Format is imported onto the current sheet. The 

 imported drawing format is grouped.

9. Now you can drag the drawing format on the sheet until all objects 
lie within the drawing format.

In case the size of  the imported drawing format is to small or to large to 
frame the entire drawing you can scale the content of  the drawing.

Modifying Drawing Formats 
All drawing formats provided in the Layout folder can be modified to 
meet your needs. When you want to add new formats is recommended to 
modify existing ones and save them under a different name.

Creating Drawing formats for Laser printers
1. Open a drawing format in the Layout folder of  the DesignFreeQ 

folder.
2. Save the drawing under a new name.

3. Select the Drawing Size command in the Layout menu.
 The Drawing Size dialog box is displayed.

4. Mark the option Display always Page Bounds.
 The Printing area of  your active Laser Printer is displayed as a gray 

rectangle.

5. Click OK.
 The Drawing Size command is closed.

6. Mark the grouped drawing format on the drawing area and ungroup 
with the Ungroup command in the Arrange menu.

7. Adjust the border lines of  the drawing format until they are exactly  
aligned with the displayed gray rectangle for the printing area of  
your laser printer.

8. Delete all cutting lines since they are not required for print outs on a 
laser printer.

9. In case you want only to import the modified drawing format and 
not to use it with the Sheet Into View command you may delete the 
existing detail views.

 To delete a detail view by selecting the Delete command in the 
menu of  the detail view.

10. Hide the TitleBlocks Layer.
 All Text Entries are hidden.

11. Select the complete drawing format using the Select all command 
in the Edit menu and group the format using the Group command 
in the Arrange menu.

12. Activate the layer TitleBlocks.

13.  Save your work.

Adding formats to the Sheet Into View dialog box list 
You can create your own drawing formats and add them to the list in the 
Sheet Into View dialog box.

1.  Start a new document.

2. Select the Detail View tool and create a view window. 

3.  Display the Model Dialog box and create a new model.

4. Click on the sheet to activate it.

5. Select Model 2 in the  Model dialog box and make it the current 
model by clicking the Current button.

6. Click in the view window to activate it and make Model 1 the 
 current model in the Model dialog box.

7. Click on the sheet to activate Model 2.

8. Create the drawing format at a scale 1:1 or import one of  the 
 s tanding formats and modify it.

9.  Save the drawing with a proper name in the Layouts folder of  
DesignFreeQ.

You can ignore the number 
of  detail views since they 
are only important when 
using the Sheet Into View 
command.

Important: If the rectangle 
is displayed vertically you 
have to change the paper 
orientation with the Print 
Setup command (Macintosh: 
Page format) in the File 
menu and call the Drawing 
Size command again. 

Tip: It is recommended to 
keep at least one detail view 
in a drawing format, since that 
allows you to use this format 
with the Sheet Into View com-
mand. The Import command 
ignores all detail views.

Important: Text entries with 
an @ character in front must 
not be grouped since then 
the TitleBlocks command 
cannot identify these entries 
as title entries (See as 
well under AutoText in this 
Manual).

Drawing formats that should 
be used with the Sheet Into 
View command must have 
at least 1 Detail View into 
which all  object geometry 
can be placed. Without any 
detail view the Sheet Into 
View command doesn't work 
 correctly.

You can as well import a 
drawing formats containing 
one or several detail views, 
since the Import command 
ignores all detail views.
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 The file name is listed in the Layout list field when you next time 
select the Sheet Into View command.

Combining Sheets, Views and Models
Sheets, Views and Models are directly related to each other and are interact-
ing permanently unnoticed from the user. 

For most of  your daily work, it is not necessary to know anything about 
the relationship between Sheets, Views and Models. But for some tasks it 
is helpful to understand this relationship since it offers elegant solutions 
that were not possible without the combined power of  this features.

Using the relationship between Sheets, Views and Models makes it easy to:

 • create detail views of  an object that is not associative to the 
 original model.

 • create customized drafting layouts or
 • recover from an erroneous Sheet Into View command.

The first section of  this chapter explained the use of  Sheets, Views and 
Models. Each is a simple and straight forward operation. In the graphics 
you could see the environment, how sheets, views, and models are set up in 
DesignFreeQ. What you still need to know is the exact definition of  all 
engaged components and the rules that describe how they are interacting.

Virtual Design Environment
The environment in DesignFreeQ for handling all geometry you create 
can be described by five components:

 • Sheets

 • Models

 • Views with

  - Cameras and 
  - Projectors.

First, you have to know that all geometry you create is not created direct-
ly on the sheet you see on your computer screen but somewhere outside 
of  the sheet in an infinitely large three-dimensional work space (Model 
space). All geometry is *placed here as separated models. You only see 
on your sheet images, or views of  these models.

Sheets
A sheet is an infinite 2D planar area that displays an image of  one or 
more models. The image of  a model is picked up either by the Sheet 
camera and projected onto the sheet (the Sheet View) or by a Detail View 
camera and projected into a view window which is resting on the sheet 
(the Detail View).

• Sheets are arranged behind each other so you can see only one at a 
time.

  

• You can create as many sheets as you want, but with each sheet you 
automatically create a blank model, similar to the drafting board 
when you start with a clean sheet.

• Independent of  how many models exist, you can delete all sheets 
but one—the current sheet—since DesignFreeQ needs at least one 
sheet to display the models even if  they are blank.

• When you delete a sheet, all Detail Views resting on that sheet are 
deleted.

On the drawing board you 
start a new drawing with a 
blank sheet like in Design-
FreeQ. Only DesignFreeQ 
needs a blank Model to dis-
play a blank Sheet view.
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• You can display as many Detail Views as you want on one sheet but 
only one sheet (Sheet View) at a time.

• When you change the current sheet, the related model is always acti-
vated. You can change this relation only by assigning another model 
to that sheet.

Models
A Model is a collection of  geometry, dimensions, text, fills and  hatching. 
Models are placed in an infinite three-dimensional area. A model can be 
blank (then we call it Model space) just as it is when you launch Design-
FreeQ and look at a blank sheet. Images of  models are picked up by ei-
ther the Sheet camera or by Detail View cameras and projected on the sheet. 
The view of  the Sheet camera is called a Sheet View and the views of  the 
Detail cameras are called Detail Views.

• You can create and delete as many models as you want.
• Models exist independent from the sheets and views.
• When you change the current model, you move the related camera. 

The camera you move depends on what is active—the sheet or the 
detail view. If  the sheet is active, the Sheet camera is moved to the 
current model, if  the detail view is active then th related Detail view 
camera is moved.

 

Views
Views are the images picked up by cameras and projected on sheets. 
DesignFreeQ has two types of  views—the Sheet View and Detail Views. 

Detail Views
• Detail Views are picked up by Detail View cameras and always dis-

played in a view window which rests on the sheet. They have bound-
aries and display only a limited view of  the model. 

 You can create as many views as you want and move or copy and 
paste them to different sheets. 

 When you delete a Detail View the Detail View camera is deleted. 
When you delete a sheet which contains a Detail View, the Detail 
View is deleted also since the Detail View is resting on the sheet.

• You can place views from different models on one sheet, but each 
view can display only one model at a time.

Sheet View
• There is only one Sheet View for each sheet. The Sheet View is an 

infinite view picked up by the Sheet camera and displays everything on 
the sheet outside of  all view windows. 

 The Sheet View cannot be deleted and needs at least one sheet to dis-
play its view. 

 Since the Sheet View, like the Detail View, can display only one model 
at a time, you have to use Detail Views to show more than one model 
on a sheet. 

• To activate a Detail View you have to click in the view window,  
to activate the Sheet View you have to click on the sheet outside of  
all detail views. If  the model dialog box is displayed, the related 
model will be highlighted.

Cameras and Projectors
There are two type of  cameras—one Sheet camera and as many Detail View 
cameras as you create detail views.

You change the current 
model by selecting a model 
in the Models dialog box 
and click the Current button.

The Drawing Size command 
changes only the plot scale 
but not the scale factor of 
the Sheet view. Even if the 
view is scaled to fit the pa-
per format the scale factor 
remains 1:1 since the real 
size of the geometry is not 
affected.
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• The Sheet camera is permanently installed as default and displays its 
view via the sheet projector on the sheet. 

 To move the Sheet camera you have to perform a model change either 
by the Models command or by the Sheets command where the 
Sheet camera is moved automatically to the related model.

• Detail View cameras display their views via Detail View projectors in 
view windows which rest on the sheet. 

 You can install as many Detail view cameras as you want even if  each 
one is looking at one model. You install Detail view cameras by creat-
ing Detail views either by the Detail View tool from the Tool palette 
or with the Sheet Into View command.

 You can move Detail View cameras to another model by performing a 
model change when the view window is active.

• Both cameras, the Sheet camera and a Detail View camera can look only 
at one model at a time.

Using Sheets, Views and Models
We listed a lot of  rules in the sections above and they all describe in 
common the same fact that DesignFreeQ administrates geometry (mod-
els), views and sheets separately. That has a lot of  advantages. The most 
impressive example is if  you delete a sheet displaying geometry the ge-
ometry is not lost since you have not deleted the related model.

The following examples show how to use the combination of  Models, 
Sheets and Views for your daily work.

Recovering from deleting a sheet displaying geometry
To restore the geometry displayed on a sheet you deleted  unintentionally, 
proceed as follows:

1. Select Sheets in the Views menu.

2. Click New to create a new sheet.

3. Click Current to activate the new sheet and draw some geometry.

4. Make another sheet active by highlighting a different sheet in the 
Sheets dialog box and click the Current button.

5. Close the Sheets dialog box and select Models in the Views menu.

6. Search for the before-displayed geometry by activating each Model 
followed by a Zoom All command until the previous geometry is 
displayed on the new sheet.

Identifying Models
If  you do not know which view is displaying which model, open the 
Models dialog box. When you click on the drawing area, the check mark 
moves to the model displayed on the sheet. If  you click in a view win-
dow, the check mark moves to the model displayed in the detail view.

Creating a non-associative detail view
You may want a detail view that is not associative; that is, when you make 
changes to the original geometry, the geometry in the view does not 
change.

1. Create a detail view on an open space containing all geometry you 
want to be non-associative.

2. Use the Selection tool to click inside the view to  activate it.

3. Drag a selection marquee around all of  the geometry inside the 
original view.

 The geometry inside the view is selected.

4. Choose Copy from the Edit menu.

5. Choose Models from the Views menu.

6. Click the New button to create a new model (by default, model 2).

7. Click the Current button to make the new model the current model 
in the new view.

 The geometry in the detail view disappears.

8. Choose Paste from the Edit menu.
 The geometry is pasted into the new detail view, but it is no longer 

associative, since it is part of  a different model.

When you change the sheet 
the Sheet camera is moved 
to the selected sheet and 
automatically displays it at 
the view scale which was 
current when the sheet was 
last changed.

This procedure is very 
useful if you have to iden-
tify models and sheets for 
renaming.
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Displaying several components on one sheet.
Sheets, Views and Models are very helpful to display several components of  
a part created by different drafters on one sheet. The following simple 
example shows how to perform this task:

1. Open a new document.

2. Draw an ellipse.

3. Save the drawing as Ellipse.vlm.

4. Open a new document and draw a rectangle.

5. Select Sheet Into View in the Views menu.

6. Choose the Layout Top View, set the Scale to 1 and click OK.

 

 You now have one Sheet with one view window showing the Rect-
angle (Model 1). The Sheet camera is aligned to Model 2 (created 
with the Sheet Into View command) displaying a blank model space 
on the sheet.

7.  Make the sheet active by clicking on it and draw a circle.

8.  Select Sheet Into View (the sheet still active) and choose Top View 
again with the Scale factor 1.

 

 Now you have one Sheet with two view windows, one displaying 
the rectangle (Model 1) and one displaying the circle which became 
Model 2. The Sheet camera is moved to the new Model 3 and an 
empty model space is displayed on the sheet.

9. Activate the sheet by clicking on it and select Import in the File 
menu.

10. Select the file Ellipse.vlm and click OK.
 The ellipse is imported on the current sheet and added to Model 3 

which was active when you performed the Import command.

 

11. Arrange the two view windows around the ellipse and rearrange the 
rectangle and the circle with the Zoom commands in the Arrange 
menu like in the following graphic.
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12. Activate the sheet and deactivate the command Show View Bound-
aries in the Views pull-down menu.

 

In order to select overlap-
ping view windows, Auto 
Front must be deactivated, 
as it is described in the 
Viewing Geometry chapter. 
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DesignFreeQ Documents
This chapter describes the handling and administration of  Files (in 
DesignFreeQ called drawings) and the data exchange with other pro-
grams.

Using Documents
A document is a DesignFreeQ file. Whenever you open DesignFreeQ, 
or choose New from the File menu, a new  document appears in its win-
dow.

Working with multiple Documents
In DesignFreeQ you can open and edit several drawings  simultaneously. 
Each Drawing is displayed in its own window that can be reduced to an 
icon near the lower-left  corner of  the DesignFreeQ work space. To 
close, move or resize a  drawing you use the control buttons in the title 
bar of  each window.

    

Windows
The Windows submenu in the Views menu shows the names of  all the 
open DesignFreeQ documents. To bring a document to the front, that is 
covered by another document,  select its name from the Windows sub-
menu.

Components of a Document
A drawing can be a simple part or a complex assembly. Each Drawing 
has one or more Sheets, like the sheets of  paper in a set of  blueprints, 
and each Sheet is made up of  Layers which can be hidden or displayed as 
needed.

 

The first part of  this chapter discusses using the File commands for open-
ing, importing, exporting and saving files. Printing and plotting documents is 
described in the Basic Drafting chapter.
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Opening drawings
The File menu contains the Open and New command to open a draw-
ing. With New you create a new drawing while the Open  command 
opens an existing drawing.

New  Ctrl+N  [Macintosh N]
This command in the File menu creates a new DesignFreeQ document. 
The new document has no name (the title bar shows Un titled 1), and is 
set with the default options, such as pen style or grid display.

If  you open more than one new document, the subsequent documents 
are numbered  sequentially until you name them by saving.

Open  Ctrl+O [Macintosh O]
The Open command in the File menu opens an existing document, that 
was created with DesignFreeQ. This document can be created by cur-
rent or earlier versions of  DesignFreeQ. The document appears in the 
drawing area maintaining the same settings as the last time you saved it. 
If  you made any changes to the default settings, such as editing pen styles 
or hiding  layers, those changes  remain in effect.

The Open dialog box allows you to specify the document you want and 
lets you change directories or folders if  necessary.

Opening a document   WIN
1. Choose Open from the File menu.

 The Open dialog box appears.

2. Display in the Look in pop-up menu the appropriate Folder contain-
ing the document you want to open.

3. Select in the file type you want to open from the File Type pop-up 
menu.

 The list box displays all files of  the selected type available in that 
folder.

4. Click the File name you want to open in the list box.
 If  you  double-click on the file name, the document is opened with-

out  clicking the Open button.
5. Click the Open button.

Opening a document   MAC
1. Choose Open from the File menu.
 The Open dialog box appears.

2. Open the appropriate Folder containing the document you want to 
open.

3. Click the File name you want to open in the list box.
 If  you double-click on the  file name, the document is opened with-

out clicking the Open button.
5. Click the OK button.

Recent File List
Another way to access files that have been opened recently is through the 
Recent File List that appears in the File menu after the Exit command. 
This list contains the names and paths of  the most recent files that have 
been opened by DesignFreeQ.

To open a file from the Recent File List, simply select the file from the 
File menu. If  the file has been moved since it was last used and the path 
is no longer accurate, DesignFreeQ will ask you to locate the file by 
providing the standard Open dialog box.

Saving a Drawing
You can save a drawing by choosing either Save or Save As from the 
File menu. The file is stored in the folder you specify.

Save  Ctrl+S  [Macintosh S] 
This command in the File menu saves the current DesignFreeQ  document 
to its original folder. If  you want to save it to a different  folder or with a 
different name, choose Save As.

If  you choose the Save  command and the document has not been saved 
 previously, the Save As dialog box appears automatically, allowing you to 
name the document and specify the folder in which to save it.

A detailed description how 
to open files you find also 
in the User Manual for the 
Operating system of your 
computer.

The name of the sheet is 
only displayed in the Title 
Bar if more than one sheet 
exists.

Note: Use the Import 
command if you want to use 
drawings of other format 
types, such as DXF or IGES, 
or if you want to bring in 
ASCII text.

The default setting is 
DesignFreeQ files.

The number of files con-
tained in the Recent File 
List can be set for Windows 
in the DesignFreeQ.ini file 
and in the Recent.lst file 
for the Macintosh. For more 
information, consult the 
Customization section in 
the Setting the Environment 
chapter.
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If  you have named and saved the document before, a brief  message ap-
pears when you choose Save, and the program pauses while it updates 
the information.

Save As
This command in the File menu saves the current document. A dialog 
box appears so you can name the current document, give it a different 
name, or save it to a different folder.

Saving a document with a different name WIN
1. Choose the Save As command from the File menu.
 The Save as dialog box appears.

2. If  necessary, display a different folder.

3. Type the name you want to use in the File name box.

4. Select the type of  file you want to save the drawing as in the Save 
as type dialog box.

5. Either press Return or click Save.

Saving a document with a different name MAC
1. Choose the Save As command from the File menu.
 The Save as dialog box appears.

2. If  necessary, display a different folder.

3. Type the name you want to use in the File name box.

4. Either press Return or click Save.

Making a backup
You should make a backup of  your work in case you make many changes 
and want to go back to the original version. You can use  
the Save As command in the File menu and save the file with another 
name or use the AutoSave feature described in the next section. 

Auto Save
This command in the Preferences submenu of  the Layout menu directs 
DesignFreeQ to save a backup copy of  your work periodically. If  your 
com puter hangs up for any reason, the work you did up to the last Auto 
Save will be recoverable.

Selecting the AutoSave command displays the following dialog box:

 

In the AutoSave dialog box you can turn AutoSave On or Off  and  specify 
the time interval (in minutes) between AutoSaves.

At the specified interval, DesignFreeQ creates an AutoSave file with the 
base of  the original file name and a .SAV extension in the same  directory 
or folder as the original file. AutoSave prompts users for a file name 
before  creating an AutoSave file for untitled documents (created by using 
the New command from the File menu). If  you supply a file name, this 
file name will be associated with the document and the AutoSave file. If  
you Cancel, AutoSave will skip that document, but the prompt will ap-
pear again at the next AutoSave interval. Files opened with the READ 
ONLY attribute are also Auto Saved.

Setting up AutoSave
1. Select Auto Save from the Preferences submenu of  the Layout 

menu.  
 The Auto Save dialog is displayed.

2. Switch AutoSave ON or Off.
 The default setting is Off.

3. Specify the time interval for AutoSaving in minutes.
 The interval can be from 1 to 60 minutes; the default setting is 15 

minutes. An interval of  0 or less is equivalent to turning Auto Save 
off.

4. Click OK.

Note: You should save 
frequently. Even though 
your drawing  appears on 
the screen, it is not stored 
on the disk until you save it. 
Hours of work can be lost 
because of a power failure. 
It is also important to save 
before  performing any intri-
cate, multistep manoeuvre. 
In that way, if the result is 
not exactly what you had 
hoped, you can abandon 
the file by closing it without 
saving.

The default setting is 
DrsignFreeQ file.

It’s also possible that your 
 company makes periodic 
backups of your folders, and 
you can go back to a previ-
ous version that way. 

If you want to save these 
settings permanently you 
have to Save Preferences 
in the Preferences  submenu 
of the Layout menu.
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 If  AutoSave is ON your work will be saved automatically for the 
time interval you specified. 

Closing Documents
DesignFreeQ provides the Close and the Quit command in the File 
menu to close documents. If  you want to close a drawing without ending 
DesignFreeQ you must use the Close command. Selecting the Quit 
command closes all open drawings and ends DesignFreeQ.

Close  Ctrl+F4 [Macintosh:  W]
This command in the File menu closes the current DesignFreeQ doc-
ument (the one displayed in the top window). If  other DesignFreeQ 
documents are open, they remain open when you close the current doc-
ument. If  you have made any changes since you last saved the current 
document, the Save dialog box allows you to save the changes. You can 
close the document with or without saving the changes.

You can also close the document by double clicking the Control Menu 
button (Macintosh: Close box) at the upper left corner of  the title bar.

Quit  Ctrl+Q  [Macintosh:  Q]
This command in the File menu closes DesignFreeQ. If  you have made 
changes since you last saved, the Save dialog box allows you to save the 
changes. If  you have more than one document open, an alert message 
allows you to save unsaved documents.

Data Exchange
DesignFreeQ like any other Computer program saves its data using its 
own native file format, that can be identified by the file extension .vlm. 
Even though all programs have native file formats that are not compati-
ble to each other, it is possible to transfer data using neutral interchange 
formats such as IGES or DXF that standardize the data exchange. When 
you want to read a file of  a non-compatible file format it is called Im-
porting files, when you want to save a file in a non-native format type it 
is called Exporting files.

Limitations 
Even if  it is often advertised that programs can directly read and write 
file formats of  competing products, you should be aware that importing 
files is always limited since the exchange is done through standardized 
file formats such as DXF and IGES that can offer only a compromise 
 between the two file formats used.

These filters cannot transfer features specific to one application such as  
DesignFreeQ Smart walls into another application where these features 
are unknown. Smart walls for example would be exported as a group of  
simple lines, all smart wall features known in DesignFreeQ would be 
lost.

Importing drawings
The import feature of  DesignFreeQ allows you to use  existing drawings 
from DesignFreeQ or other applications  within a DesignFreeQ docu-
ment.

The following file types can be imported
VLM DesignFreeQ native file format, that is fully compatible 

with the Vellum file format.  Displayed option: DesignFreeQ 
Files; File name extension: *.vlm.

TXT ASCII text file. Displayed option: Text Files; File name ex-
tension: *.txt.

Spline This option allows to import Spline coordinates. DesignFreeQ 
creates then automatically a spline on the drawing area. File 
name extension: *.txt.

PICT The Macintosh graphics file format which uses object-orient-
ed bitmaps or resolution independent graphics. [Macintosh 
only]

WMF Windows Metafile Format. An interchange format used by 
the Windows clipboard  for graphics  commands. Displayed op-
tion: MetaFile; File name extension: *.wmf. [Windows only]  

It is also possible to import 
 documents of native format 
type.

Drawings created with 
DesignFreeQ on the 
Macintosh don't have to be 
imported but can be read 
using the Open command in 
the File menu.
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BMP Microsoft Windows Bitmap file format. The file name ex-
tension .bmp is automatically appended to the file name. 
Displayed option: Bitmap; File name extension: *.bmp  [Win-
dows only].

EPS Encapsulated PostScript Format, a data format for  PostScript 
 printers or for the import in  PostScript compa tible applica-
tions. DesignFreeQ supports the EPS Format of  the Adobe 
 Illustrator and compatible EPS Formats.  Displayed option: 
EPS/AI; File name extension: *.eps.

DXF/DWG AutoCAD Data eXchange Format of  AutoCAD. Selecting this 
format in the Import dialog box and clicking the  displayed 
Options button, you can choose from the AutoCAD Formats 
BDXF, DXF, DWG and Versions 10, 11, 13, 14 and 2000. File 
name extension: *.dwg or *.dxf.

DXF12 AutoCAD Data eXchange Format of  AutoCAD. Selecting this 
format in the Import dialog box and clicking the  displayed 
Options button, you can choose from the  AutoCAD Formats 
BDXF, DXF, DWG and Versions 12. File name extension: 
*.dwg or *.dxf.

IGS IGES 4.0 Initial Graphics Exchange Specification, format to 
standardize the exchange of  graphics. Displayed  option: 
IGES; File name extension: *.igs.

Import
This command in the File menu imports a document from DesignFre-
eQ or  another application into DesignFreeQ and places it in the current 
model. When you select the Import command the names of  documents 
DesignFreeQ can read are displayed in a dialog box that works like the 
Open dialog box. When you select a document in this dialog box and 
click the Open  button, DesignFreeQ detects the format of  the docu-
ment and displays the  Import  dialog box:

 

In the Import dialog you can specify the following Import options.

Grouped Imports the geometry grouped so it is a single 
unit in the DesignFreeQ document.

Geometry Only Brings in only the geometry, leaving any text, 
dimensions and crosshatching behind.

Onto Work Layer The imported geometry is placed on the work 
layer rather than the layer on which it was 
originally created.

Unscaled The geometry is adjusted to correspond to the 
scale set by the Drawing Size command. If  
Unscaled is specified, the imported  geometry 
is not scaled.

Importing a document WIN
1. Choose Import from the File menu.
 A dialog box appears similar to the Open dialog box.

2. Select the file type you want to import from the Files of  Type pop-
up menu.

 The list box shows all files of  the selected type available in that di-
rectory.

3. Double-click the File name you want to import.
 The Import dialog box appears.

4. Specify any import options you want. 
 If  you have set a scale in drawing size, you should click the Un-

scaled option so that the geometry or drawing format you are 
bringing in is scaled the same as the geometry in the drawing. 

Using the DWG/DXF Import 
option you can specify in 
a DXF configuration file 
additional import options 
such as color handling, line 
patterns, line weights or 
text fonts. More information 
about this configuration file 
you find in the Appendix of 
this manual.

You can ungroup the im-
ported geometry with the 
Ungroup command in the 
Arrange menu.

MAC
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5. Click OK.
 The file appears in the drawing area. If  you want to save the file in 

its original format after editing, you must choose the Export com-
mand from the File menu.

Importing a document MAC
1. Choose Import from the File menu.
 The Open dialog box is displayed.

2. Select the file you want to import.
 The Import dialog box appears.

3. Specify any import options you want.
 If  you have set a scale in drawing size, you should click the Un-

scaled option so that the geometry or drawing format you are 
bringing in is scaled the same as the geometry in the drawing.

4. Click OK.
 The file appears in the drawing area. If  you want to save the file 

in its original format after editing, you must choose the Export 
 command from the File menu.

Importing DWG/DXF files
Important: When you import a DWG or DXF file, the geometry is constructed 
according to the units set in Preferences when you choose the Import command. 
Be sure to set the appropriate units before you import DWG or DXF geometry.

1. Choose Import from the File menu.
 A dialog box appears similar to the Open dialog box.

2. Select the file type DXF from the Files of  Type pop-up menu.

3. Select the DXF file you want to import and click OK.
 The Import dialog box is displayed.

4. Select the option DXF.

5. Click OK.
 The DXF/DWG Options dialog box is displayed.

 

6. Specify the required options.

 When you choose the option Dimension as geometry, all dimen-
sions are imported as geometry objects, if  not they are imported as 
dimensions.

7. Click OK.
 DesignFreeQ begins creating the imported file on the drawing area.

Important Tips for importing DWG/DXF Files
• When you import a DWG or DXF file, the geometry is  constructed 

according to the units set in Preferences when you choose the 
Import command. Be sure to set the appropriate units  used in the 
AutoCAD File before you import DWG or DXF geometry.

• When you import a DWG or DXF file, the Drawing Scale in the 
DesignFreeQ Drawing size dialog box in the Layout menu must be 
set to 1:1 to make sure that the imported drawing is correctly scaled.

• DesignFreeQ supports only 256 layers. If  you have a DWG or 
DXF file containing more than 256 layers, all geometry on the addi-
tional layers will  automatically be placed on the current work layer 
in DesignFreeQ. If  you don’t want this to happen, reduce the num-
ber of  layers to a maximum of  256 in the application you will be 
creating the  DWG or DXF file in.

• When you get, after importing a DWG or DXF File into Design-
FreeQ, geometry not contained in the original AutoCAD file, you 
must purge any unnecessary blocks using the PURGE command in 
AutoCAD before exporting the file.

• If  the file doesn't open correctly you should mark the  options Onto 
Work Layer and Dimensions as Geometry in the Import dialog 
box and import the file again.
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Importing ASCII text from another document
1. Choose Import from the File menu.
 A dialog box appears similar to the Open dialog box.

2. Select the file name you want to import.

3.  Click OK.
 The Import dialog box is displayed.

4. If  Text is not selected, mark the Text option.

5. Click the OK button.  
 The text appears in a text box in the drawing.

Importing Splines
When you import a text file that contains the coordinates for a spline 
DesignFreeQ will create the spline according to the  imported coordi-
nates.

1. Select Import from the File menu.
 A dialog box appears similar to the Open dialog box.

2. Select a text file that contains the coordinates for the spline.
 The Import dialog box is displayed.

3. Specify the import option Spline.

4. Click the OK button.
 DesignFreeQ begins creating the Spline.

Creating a text file for importing a spline
1. Use a text editor, word processor or spreadsheet to create a text file.

2. Input X, Y and Z values for your spline coordinates.
 The text file should be tab or space separated. Each line ends with a 

return. Line feeds after each return should have no effect.
 The text file should conform to the following columnar format:
  1 1 0
  2 2 0
 You are allowed to specify decimal coordinates as well:
  1.33 1.1 0
  2.4 2.5 3.5678
 Be sure that you do a Return after the last coordinate, if  not 

DesignFreeQ will not import the coordinates specified in the last 
line.

3. Save the file as Text only and import into DesignFreeQ to create 
the spline.

Exporting a Drawing
Occasionally, you may need to save a document in a format other than 
the DesignFreeQ format so you can use it with other application soft-
ware. All settings for the export of  drawings are specified either auto-
matically or by option buttons in the respective Export dialog windows 
displayed when exporting a file.

The following file types can be exported
DesignFreeQ Document  DesignFreeQ's native file format.  

File extension: *.vlm.

VellumPro/CAD/Sketch  This format is used by the CAD Program 
Vellum. File name extension: *.vlm.

Text ASCII characters. This option is available 
only if  the Text tool is the active tool. 
File name extension: *.txt.

Bitmap Microsoft Windows Bitmap file, an inter-
change format specifically used for pixel 
graphics. File name extension: *bmp. 
[Windows only]

PICT The Macintosh graphics file format which 
uses  object- oriented bitmaps or resolution 
independent graphics  [Macintosh only].

MetaFile The format is used by the Windows Clip-
board, an  interchange format specifically 
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used for graphics commands. The preci-
sion equals the computer screen  precision 
and exports  graphics as vectors and pixel 
as represented on the screen. File name 
extension: *.wmf  for the 16 bit Window 
version or *.emf  for the 32 bit Window 
version. [Windows only].

PNG Portable Network Graphics-Format, a graph-
ic format  mainly used for distributing 
Internet graphics. File name extension: 
*.png.

DXF/DWG AutoCAD Data eXchange Format of  Auto-
CAD. Selecting this format in the Import 
dialog box and clicking the displayed Op-
tions button, you can choose from the Au-
toCAD Formats BDXF, DXF, DWG and 
Versions 10, 11, 13, 14 and 2000. File name 
extension: *.dwg or *.dxf.

DXF12 AutoCAD Data eXchange Format of  Auto-
CAD. Selecting this format in the Import 
dialog box and clicking the displayed Op-
tions button, you can choose from the Au-
toCAD Formats BDXF, DXF, DWG and 
Versions 12. File name extension: *.dwg or 
*.dxf.

EPS/AI Encapsulated PostScript Format, a data 
format for PostScript  printers or for the 
export in PostScript compa tible applications. 
DesignFreeQ supports the EPS Format of  
the Adobe Illustrator and compatible EPS 
Formats. File name extension: *.eps.

IGES IGES 4.0. Initial Graphics Exchange Specifica-
tion, format to standardize the exchange of  
graphics. File name extension: *igs.

Export
This command in the File menu saves a document in the format you 
specify.

Exporting a document
1. Choose Export from he File menu.
 The Save as dialog box appears.

 

2. Enter the desired file name.

3. Select the desired file type.
4. Set the required options.
 Depending on the selected export file type you can set several op-

tions, that are described in the next section of  this chapter.

5. Click the Save button.
 The file is saved with the specified file name, file type and export 

 options.

Export option for the available file types
Depending on the selected export format you can set several options:
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Only selected If  you wish to export only  selected objects on the 
screen, rather than the entire document, mark the  option 
Only Selected.

Precision For some formats you can set the number of  decimal 
places to specify the precision of  the exported data.

Options The following formats allow to display a dialog box by 
clicking the Options button in which you can set addi-
tional export options.

  Metafile The following export option are available:

   

 You can choose from the  following Metafile Formats: 
WMF (16 bit Windows Version), EMF  (Enhanced 
Metafile File: 32 bit Windows Version), EMF a Aldus 
specific EMF-Format. In addition you can specify the 
Width and Height of  the graphic in Pixel units. These 
values specify the quality (resolution) of  the graphic for 
the print out. The higher the resolution specified the 
better the print out quality. 

  PNG The following export option are available: 

   

 In this dialog window you can specify the Width and 
Height of  the graphic in Pixel. These values specify the 
quality  (resolution) of  the graphic for the print out. The 
higher the  resolution specified the better the printout 
quality.

  Bitmap The following export option are available: 

   

 In this dialog window you can specify the Width and 
Height of  the graphic in Pixel. These values specify the 
quality  (resolution) of  the graphic for the print out. The 
higher the  resolution specified the better the print out 
quality.

  DWG/DXF The following export option are available: 

   

 In this dialog window you can select the AutoCAD 
Formats DWG, DXF, DXB and Versions 10, 11, 13, 14 or 
2000.

 In addition you can specify, if  you want to export all 
hatches ungrouped.

 Always when on the current sheet 2 or more models are 
displayed in detail vies, the following dialog box is  dis-
played:

For best possible transla-
tions see DXF Configuration 
in the Appendix of this 
manual.
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 In this dialog window you select either an additional 
model with its corresponding detail views or flatten all 
views to export them all.

Converting Files
DesignFreeQ can not only import and export files but also convert files 
 directly between different file formats.

Convert
This command in the File menu starts the Convert batch translator 
which allows you to import and export multiple files in an unattended 
mode. It imports all files of the same type from one folder and saves these 
files in the selected format into a destination folder.

Th Convert command displays the following dialog box:

 

In the Convert dialog you can specify the following Convert options.

Draw each File If  you mark this option you will see each file during 
the conversion process. If  this option is not selected, 
DesignFreeQ will open a blank drawing window, per-
form the conversion, close the blank window and repeat 
the process for each file in the folder.

 For large drawings or large  quantities of  drawings turn-
ing off  Draw each file will speed up the operation.

Converting multiple files
1. Create two folders.
 One folder will be used to store the original files (the FilesIn 

 folder), the other folder will store the converted files (the FilesOut 
folder).

2. Copy all files you want to convert into the FilesIn folder.

3. Select the Convert command from the File menu.
 The Convert dialog box appears.

4. Select the file type you are translating from in the Input File For-
mat list.

5. Select the file type you are translating to in the Output File Format 
list.

6. Mark the option Draw each file, if  wanted.
7.  Click OK.
 The Open file dialog box displays.

8. Open the folder (FilesIn) that contains the files to convert.

9. Select a single file and click Open.
 The selected file must be of  the same type as was selected for Input 

File format or DesignFreeQ will generate an error message.

10. Select a destination folder (FilesOut) for the translated files or 
 create a new one.

 Specify a new extension to identify the converted files (it is reason-
able to use the standard file type extension like .dxf for DXF files 
or .igs for IGES files.

The Convert dialog box 
contains all file formats that 
can be converted by the 
Windows or Macintosh ver-
sion of DesignFreeQ.
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DesignFreeQ will convert every file from the Input folder that is of  the 
same type.

If  you select a DesignFreeQ file in the Input folder, and requested con-
vert to DXF, DesignFreeQ will convert every DesignFreeQ file in that 
folder to DXF, and place those DXF files in the Output folder you se-
lected. If  the folder also contains IGES files, they will not be translated.
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Parametrics
DesignFreeQ's integrated parametrics feature allows you to create 
geometry without regard to its actual measurements. When you resolve 
geometry parametrically, you specify values for the dimensions and 
DesignFreeQ  redraws the geometry to your specifications. The follow-
ing are examples of  parts well-suited to parametric definition:

 • Containers that vary in size according to the needs of  the prod-
uct line.

 • Hydraulic pistons that vary in size because of  the duty loads.

 • Valves that vary according to the diameter of  the pipes to which 
they are attached.

In its simplest form, parametrics allows you to create a shape and then 
specify the exact measurements.

Of  course, parametrics can be much more complex when you use vari-
ables, as you will see later in this chapter. While creating geometry is 
straightforward, when a part becomes complex, parametric dimensioning 
requires some skill and comprehension of  how DesignFreeQ treats 
 geometry.

For a deeper understanding of  how Parametrics works we recommend 
therefore to study the Parametric chapter in the Tutorial.

Using Parametrics
The parametric mechanism is point-driven. It locates the points and then 
connects them with the appropriate geometry, much like the childhood 
activity of  connect-the-dots. It is not unlike drawing with a compass, trian-
gle, and T-square.

To begin, determine where the endpoints are and then draw lines to 
connect the points. Or you might figure out where the center of  an arc 
should be, where the arc begins and ends, and use a compass to  connect 
the points. 

The DesignFreeQ folder 
 contains a folder of symbols 
that use parametrics. You 
might retrieve a few of the 
symbols using the Symbol 
command in the File menu 
to become  familiar with how 
parametrics works. 
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Basic Rules
1. Define the geometry completely.
 • Each object must relate to another object.
 • Dimensions must define every aspect of  the geometry. 

(The geometry may be overdimensioned according to standard 
drafting practice.)

 • Do not include extraneous text as part of  a dimension.  
(A single # is acceptable. The parametric mechanism recognizes 
R # to mean "a radius, measuring the real value of  the geome-
try.")

2. Keep it simple. 
 If  the part is complex, construct small segments, resolving as you 

go, solving any parametric problem before proceeding.

3. Return to the original part between tests. 
 Use the Undo command to revert to the original state of  the para-

metric part between tests. In this way, you won’t introduce an un-
wanted constraint.

4. Consider the following assumptions made by the parametric 
mechanism:

 a Horizontal and vertical lines maintain their orientation.
 b Connected lines remain connected.
 c * A construction point on the geometry of  another object (not 

on a construction point of  this object) remains connected to this 
geometry or its theoretical (mathematical) extension.*

 d Lines tangent to arcs or circles remain tangent (if  there is an end-
point at the tangency point).

 e Colinear lines remain colinear if  they overlap or share endpoints.
 f * Each parametric construction must contain at least one hori-

zontal or vertical line or alternatively a horizontal or vertical dimen-
sion.*

5. Be aware of  the relationships that the parametric mechanism 
cannot recognize:

 • Parallel lines may not remain parallel.
 • Perpendicular lines may not remain perpendicular.
 • Symmetrical geometry may not remain symmetrical.

Using the parametric mechanism you create objects covering a wide 
range of  validity due to their variable dimensions. This general validity 
expires whenever you assign true values to an object and transform it 
to a defined shape and size. Due to the rules of  parametric this precise 
shape cannot be reverted to its original state under certain circumstances. 
Therefore return always to the original part between tests.

Creating Parametric Objects
When approaching the problem of  resolving geometry, evaluate it as 
though you were going to draw it on paper. Remember the assumptions 
and requirements for geometric relationships as outlined in the previous 
Basic Rules section.

Parametric Dimensions
The essence of  parametrics is in the dimensions. The dimensions may 
be the actual value (which you get by default), a constant which is not 
the actual value, a single variable, or an algebraic expression involving 
constants, variables, mathematical operators, functions, and conditional 
operators.  

Constants are specific numeric values, such as specifying a radius as .25 
(inch). Variable expressions may be as simple as a single letter such as L 
(for length), or a mathematical expression such as 2 * Dia (where Dia 
may be the diameter). The arithmetic operators are addition (+), sub-
traction (-), multiplication (*), division (/), mod (the remainder  after 
division—%), and exponentiation (**).  See the Appendix for a list of  
functions and conditional operators.

However you choose to specify the dimensions, they must define all 
geometry and any relationships that exist between different parts of  the 
geometry.

Extraneous Text is explained 
in the Dimensions chapter.

See as well Assumptions Involv-
ing Tangency in this chapter. 

Lines are colinear if they 
have a common invisible 
carrier line. DesignFreeQ 
can recognize colinear  lines 
only if they touch at least in 
one endpoint.

Perpendicular lines remain 
only perpendicular if they 
have an  horizontal or verti-
cal orientation.

* For rules c and f each 
exist a  special case. See as 
well under Introduction in 
the Parametric chapter of 
the Tutorial.
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Creating parametric dimensions
1. Construct the geometry.

2. Display the dimension palette and choose the appropriate dimen-
sioning tool.

 The status line displays a # symbol in the text box to show that the 
dimensions are entered as actual measurements.

3. Click the geometry to dimension as usual.
 The Text entry box in the status line is highlighted.

4. Type whatever expression, variable, or constant you want to use for 
the dimension, and press Enter. If  you want the actual value to be 
used, do not change the # symbol in the text box. The expression 
you type replaces the # symbol.

 

Using conditional expressions in parametrics
You can use the conditional operators as parametric dimensions.  Create 
the dimension as usual and enter the conditional expression as text in the 
status line.

The example below shows a conditional ifelse expression.

 

When the above ifelse statement is resolved, the rectangle with the larger 
value (L1 or L2) will touch the L3 rectangle.

 

The length represented by the ifelse expression equals L1 because L1 is 
greater than L2. 

 

The length represented by the ifelse expression equals L2 because L2 is 
less than L1.

Resolving the Parameters
Once you have constructed the geometry and added parametric dimen-
sions, use the Resolve command in Edit menu to specify the values for 
the  variables and redraw the geometry.

Resolve
This command in the Edit menu allows you to redraw geometry auto-
matically to fit specified dimensions. This parametric feature enables you 
to draw a geometric shape without regard to measurements and then 
have DesignFreeQ redraw the same shape to the values you specify.

Variables are case-sensitive:  
D is not the same as d.

Using an ifelse condition 
the  variable is set to the 
first value if the condition 
is true and it is set to 
the second value if the 
 condition is false.

The Resolve command 
cannot resolve ellipses and 
splines, unless the ellipse 
or spline is contained in 
a group.
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Using the Resolve command with parametrics
1. Create the geometry.

2. Dimension all geometry by using variables, constant values, and 
expressions. (You must dimension the essential, related geometry 
so DesignFreeQ cannot  can reconstruct the geometry. Note that 
DesignFreeQ cannot identify parallel or colinear lines.)

 • Select the appropriate dimensioning tool.
 • Click the geometry to be dimensioned.
 • Enter an expression (such as 1.5, x, x+3*y) in the text box in the 

status line.
 • Press Enter.

3. Select the geometry and dimensions to be resolved.

4. Choose Resolve from the Edit menu.

5. If  necessary, enter the values you want to assign to the variables.
 You can enter mathematical expressions, fractions, and decimals in 

the entry boxes of  the Resolve dialog box. You can use different 
units as long as you are specific, for example 2’6".

6. Optional step: If  you want to anchor a point on the geometry at a 
particular location, click the point. The point remains in the same 
location after you resolve the geometry. An example appears later in 
this section.

7. Click the OK button.  
 If  the parametric dimensions defined the geometry properly, the 

geometry is redrawn as you specified. The dimensions remain as 
variable expressions.  

If  DesignFreeQ cannot resolve the parametrics, a message box displays 
information about the problem. The Parametric Problems section later in 
this chapter describes typical problems you may encounter. If  you have 
not given all of  the dimensions required to draw the geometry, the ge-
ometry is divided into unrelated groups. The missing information deter-
mines how the groups relate to one another.

An alert box shows how many groups exist. To see each group, click the 
Next button. Examine the groups shown to determine why the position 
of  each one is not relative to any other. A group consisting of  a single 
point is particularly telling. (This investigation can require some clever 
thought because the solution may not be obvious.)

Specifying Parametric Variables in a Text File
If  you frequently use parametrics which contain many variables, you can 
create a text file to specify the variables and avoid entering them in the 
Resolve dialog box each time you resolve the parametrics.

Create a text file which alternates the variables and the values, using 
white space (Spacebar, Tab, or Return) between entries. DesignFreeQ 
cannot assumes the first entry is a variable and the second is the value for 
that variable. Your text file might look like the examples below (or any 
 other arrangements).

 

Using a text file for parametric variables
1. Create the text file using any word processor or spreadsheet and 

saving it as Text only.

2. In DesignFreeQ select the geometry and parametric dimensions.

3. Choose Resolve from in the Parametrics submenu of  the Edit 
menu.

 The Resolve dialog box displays.

  If you use a spreadsheet 
like  Microsoft Excel for 
 creating that text file you 
have to type in each cell 
the variable name and the 
value separated by a white 
space and export it as text 
file. If your text file contains 
more  variables and values 
than you need to resolve 
the geometry, DesignFreeQ 
automatically imports only 
the needed variables and 
values.
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4. Click File to specify the values for the variables automatically.

5. Select the text file name.
 The variables and values are read from the file.

6. Specify an anchor point, if  you want one. 

7. Click OK.
 The geometry is resolved accordingly. 

Anchoring the Geometry
You can anchor the geometry by clicking the anchor point when the Re-
solve dialog box appears. For example, in the 2D Tutorial, you used para-
metrics to create the side view.

 

If  you were using this side view as parametric geometry, you would want 
to anchor the upper-right corner so that it remains aligned with the front 
view after resolution.

Changing the Dimensions to Actual 
Measurements
Once you resolve parametric geometry, the dimension notations continue 
to show variables and constants. If  you want the geometry to reflect the 
actual measurements, you have two options. You can edit the dimensions 
or save the geometry as a symbol. Follow these steps to change a re-
solved parametric dimension to a real value:

1. Choose Selection Mask from the Edit menu.

2. Highlight the four dimension types in the box on the left.
 Only dimensions are selectable.

3. Choose Select All from the Edit menu.
 All dimensions are selected.

4. Choose Edit Objects from the Edit menu.

5. Change the entry in the text box to a # symbol.

6. Click Apply.

7. Close the Edit Objects and Selection Mask dialog boxes.

8. Click the Selection tool to cancel the effect of  the Selection Mask.    

Parametric Drafting
This section describes how to modify standard drafting practices to ac-
commodate parametrics. It describes three examples with three topics to 
illustrate how to define parametric geometry completely.

Remember:

1. Define the geometry completely.

 • Dimension all geometry 
 • Relate all geometry
 • Do not include extraneous text

2. Return to the original part between tests.

Dimension All Geometry
Centerlines require consideration if  they are to be resoled properly.

 

If you want different formats 
for different types of di-
mensions, select each type 
separately.

PROBLEM

If  you create the circle shown on the left with 
two centerlines, parametrics can  resolve the 
circle but not the centerlines  because the end-
points of  the lines are not defined.

SOLUTIONS

If  you look at this problem as a connect-the-dots problem, you can see that 
the centerlines have no dots to define them.
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1.  You can construct the center-
lines so their endpoints are on 
the circle, as shown here.

2.  You can include dimensions for the 
centerlines. The dimensions should be 
variables based on the diameter of  
the circle so when you specify the 
diameter of  the circle, the center-
lines are drawn relative to the diam-
eter.

Relate All Geometry
All parts of  the geometry must be related. 

 PROBLEM 

Both squares could be drawn by the 
parametric mechanism, but there is no 
way to determine their relative positions.

SOLUTION

You can add a constraint line 
and dimension between the 
squares to connect the dots.   

If you want different formats 
for different types of di-
mensions,  select each type 
separately.

ADDITIONAL TIPS

1. The added dimension is an example of  using a constant value. Of  
course, you could have entered a variable expression such as x+y for 
the constraint line.

2. Constraint lines are ordinary lines usually drawn with the Single 
Line tool. They can be any line style, but they should be different 
from the lines of  the regular geometry. The Construction line style 
is a good choice.

3. If  you place the constraint line and dimension on a layer (named 
Constraints), you can hide that layer when you plot the drawing.

No Extraneous Text
You must dimension all geometry because the parametric mechanism 
does not understand text and cannot detect symmetry.

Each dotted line style 
(like the line style of the 
Construction line) will be 
hidden, when a symbol is 
placed or printed. Therefore 
you should use this line 
style for all invisible parts of 
an object.

PROBLEM  

If  you dimension the radius of  a  
filleted corner of  a rectangle as  
R .25 4 PLCS to indicate four fillets, 
the parametric mechanism doesn't un-
derstand 4 PLCS and doesn't know the 
corners are symmetrical.

SOLUTION

Dimension each fillet.

 

Return to the Original Part between Tests
If  you resolve parametric geometry more than one time, you can intro-
duce unintentional constraints.

 

PROBLEM 

If  you first resolve this geometry by specifying 
that R is half  the measurement of  X (R=X/2), 
the resolved geometry would appear as shown 
in thelower illustration.
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Pay attention to single 
points! Remember, the 
parametric  mechanism con-
nects the dots. Frequently, 
one constraint or dimension 
can solve several problems 
at once. 

The Undo  command is al-
ways available for any of the 
previous eight actions.

You would now be able to resolve this geometry 
only with the same X value of  R * 2 because 
the undimensioned line is vertical, and according 
to the basic rules, vertical lines remain vertical.

If  you tried to use a value for R or X other than the R = X/2 relation-
ship, the parametric mechanism would display this problem message:

SOLUTION  

Use the Undo command to return to 
the original shape. You could also solve 
this problem by changing the geometry.

Parametric Problems
This section illustrates problems you may encounter when you resolve 
parametric geometry. It provides examples and shows you what caused 
the problem and how to solve it.

When you resolve parametric geometry, problems which prevent resolu-
tion appear in a message box, stating the type and number of   instances 
of  the problems.

 

When a message appears, the problematic geometry appears as thick 
lines and individual dots. The lines indicate the geometry that the para-
metric mechanism can draw. Dots indicate unknown points. When you 
click the Next button, the next problem is shown. Examination of  the 
relationships between the problems can help you discern what  
must be done.

Geometry Overconstrained 
The basic rules say that you must define all geometry and relate every 
object to some other geometry within the parametric definition. When 
geometry is overconstrained, it is related in more than one way, so the 
geometry's specifications could be resolved to more than one answer.

PROBLEM  

The diameters of  the circles indicate the 
relationship between the circles adequately 
because the centerline remains horizontal and 
the circles are tangent to each other. The 
length variable causes the problem because 
the length between the centers of  the cir-
cles may not correspond to the sizes of  the 
connected circles. Note: The centerline begins 
and ends at the centers of  the circles.

SOLUTION  

Delete the Length dimension.

Unrelated Groups
If  you do not give enough dimensions, the parametric mechanism will 
find two or more groups of  geometry, each of  which is well-defined in 
 itself, but no related to each other. 

 

PROBLEM 

A simple example of  this problem is 
illustrated on the left, where the short 
vertical line is not related to the rest of  the 
geometry. When you try to resolve this 
geometry, you get an Unrelated group 
problem message.
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The first unrelated group appears in bold black lines. Click the Next but-
ton to highlight the second group.

 

This problem is like the two squares shown earlier. Only one group could 
be drawn. The parametric mechanism does not know how to relate the two 
groups.

SOLUTION  
You must decide how you want to re-
late the groups. Usually, you have many 
 options to accomplish this. One alter-
native is to ad the dimension W/3.

   

Unrelated Groups where One Group is a Single 
Point
A single point as an unrelated group is like a neon sign saying, The problem is 
right here!  

PROBLEM

The Resolve problem 
 message may display a single 
point, such as the point on 
the left hole of  this exam-
ple. That point is the end-
point of  the circle.

SOLUTION

On closer examination, you 
can see that the circle is not 
dimensioned. Therefore, 
the solution is to dimension 
the circle.

 

Another Unrelated Group

 

PROBLEM 

In this illustration, the height of  the right side 
of  the part is dimensioned. You  assume that 
the height dimension applies to the right and 
left side. The parametric mechanism does not 
make that assumption.

SOLUTIONS 

There are three possible solutions to this problem:

1. You can dimension the height on the left.
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2. You can draw a  constraint line to close the opening. 

3. You can dimension the height from the top of  the 
left line to the bottom of  the right line. While this 
is not good drafting practice, it is very useful for 
parametric symbols.

Assumptions Involving Tangency
The parametric mechanism can identify tangent points but not he tangen-
cy of  geometry.

SOLUTIONS

Here are three possible solutions to the problem:

3.   Divide the line into two seg-
ments which join at the tan-
gent point.

PROBLEM 
The endpoints of  the lower line that is tan-
gent to and ends at the circle can be deter-
mined. However, the upper line is tangent to 
and extends beyond the circle and cannot be 
defined without more  information.

1.   Draw a constraint line from the 
center of  the circle to the 
point of  tangency for the line 
that extends beyond the circle, 
as illustrated here.

2.   Use the Rotate tool on the 
Transformation subpalette 
to move the endpoint of  the 
circle to the tangent point 
of  the line that extends be-
yond the circle.

Pay attention to single 
points! Remember, the 
parametric mechanism con-
nects the dots. Frequently, 
one constraint or dimension 
can solve several problems 
at once. 

Relationships Involving Symmetry
If  you create geometry with a mirrored copy, the parametric mechanism 
cannot resolve and maintain the symmetry without more information.

PROBLEM 

The problem message shows three unrelated 
groups: the trapezoid on the left and the two 
rightmost corners.

   

 

If  parametrics swings an arc of  the radius H1 and 
H2, it doesn’t know where the point is supposed 
to be on the arc. The point has a distance but no 
direction unless a angle dimension is added. 
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SOLUTION 

Single points that are considered a group pro-
vide a clue to the solution. In this example, 
the parametric mechanism does not know 
where those points are, relative to the orig-
inal trapezoid. You can solve the problem 
by adding a constraint line and angle dimension 
between that line and the mirror line.

Complex Parametric Drafting
This section illustrates two complex examples of  parametric drafting. 
These examples combine the information provided in this chapter so you 
can see how to use the parametric mechanism.

Example—Departures from Standard Drafting
This example illustrates the parametric drafting practices that differ from 
standard drafting practices. The first illustration is the side view of  an 
adapter without dimensions so yo can see its shape clearly.

.

Here is the side view with typical 
dimensions added.

The illustration shows the side view with 
added constraint lines.

The next illustration shows the side view 
with numbered constraint lines.

1.   The centerline does not extend beyond 
the geometry.

2.   Constraint lines define the edges of  
the groove.  Parametrics does not 
recognize non-touching colinear lines.

3.   Constraint lines connect the end-
points of  the upper and lower halves 
to relate the geometry. Parametrics 
does not recognize no-touching colinear 
lines.

4.   Four dimensions are added to relate 
the geometry to the centerline. Para-
metrics doesn’t recognize non-touch-
ing colinear lines.

Additional Tips:
1. You should place the 

additional information on 
a separate layer so you 
can hide the layer when 
you plot the drawing.  

2. If you use a yellow 
pen (which is hard to 
see against a white 
background) you won’t 
confuse the additions 
with the actual geometry.  
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The illustration below shows the completed parametric drawing.

  

Example—Keep It Simple or Testing as You Go
When you have unconnected multiple views, the parametric mechanism 
can’t determine the relationships between them.

The coin chute example below describes the parametric drafting of  three 
views.

 

You can dimension these views according to standard drafting practice, 
as shown.

 

Section 1
Parametric Drafting
1.   Construct and resolve one section 

at a time. Solve any problems with 
his bracket before moving on.

2. Add a centerline between the holes to 
maintain alignment.

3. Add a line connecting the lower 
edges of  the flanges to keep the 
lines colinear.

The section below would resolve without problems, so you could go on 
to the next section.

 

Once this view resolves properly, you can add the side view.

Section 2

Parametric Drafting
1.   Add constraint lines to connect 

the geometry between sections.

2.   Add a dimension to specify the distance between the sections.  
(See the two boxes problem earlier in this section.)
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3.   Add extra thickness (T) dimensions since all geometry must be de-
fined.

  

Section 3

 

 This is the completed parametric drawing.

 

Parametrics and Grouped Objects
You can create many objects and then group them and treat them as a 
single parameterized object. There must be a framework on which the 
group sits. Dimension between two control points on the framework and 
then resolve the framework; the group changes accordingly, shrinking or 
expanding proportionately to the distance between the control points.

Parametric Drafting 
1.  Dimension each fillet, as explained 

earlier.

2. Relate this section to the rest of  the 
geometry.

3. Add a dimension to specify the dis-
tance between the sections.

Three sections are related as shown below.

 You can create a spline and 
group it.

 Then create a framework line 
between the endpoints and 
dimension the line.

 When you resolve for the 
length of  the line (L), the 
spline changes accordingly.
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Using parametrics and grouped geometry
1. Create the geometry to be parameterized.

2. Select the geometry.

3. Choose Group from the Arrange menu.

4. Create a framework on which the grouped geometry sits.

5. Dimension between two control points. You can use only one variable 
per group.

6. Select the framework, the dimension, and the group.

7. Choose Resolve from the Parametrics submenu of  the Edit menu.

8. Enter the value for the distance between the control points.

9. Click OK.

Rigid Links
You can group geometry into a rigid body and then attach the rigid body 
to parametric geometry in at least two points. When you resolve the 
parametric geometry, the rigid body will undergo the same geometric 
transformation.

The following example shows a real-life example of  using parametrics 
with grouped objects. Begin with a basic shape that resolves properly, as 
shown in the part below. Then add the thread groups. When you  resolve 
the part, the threads also resolve.

 

In the next example, you can see the usual method of  parametric  drafting 
followed by an example showing how using parametrics with groups can 
simplify making changes to the part.

 

Showing how using parametrics with groups can simplify making changes 
to the part.

 

Triangle Link
For a final example of  using parametrics with groups, see how a triangle 
becomes the foundation for three different groups of  a rod and piston. 
Begin with a parametric triangle that resolves with one variable, the angle A.

 

Then, create the geometry below and group it into three separate groups.

 

If you include a dimension 
as part of the group, the 
dimension will change when 
you resolve the group. It will 
not be used as part of the 
parametric solver.
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Once the groups are linked to the parametric geometry (two control points 
of  the group match two endpoints of  the line), you can resolve the tri-
angle and the groups will change accordingly.

 
               Resolved geometry where A = 45°

          

               Resolved geometry where A = 15°

Symbols
Creating Symbols

Placing Symbols
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Symbols
DesignFreeQ offers powerful functions for creating and  handling sym-
bols. All symbol commands are listed in the  Symbols  submenu of  the 
File menu.

The following section describes how to create and place symbols and the 
con figuration of  Symbol Libraries.

Creating Symbols
In DesignFreeQ you can place any drawing as a symbol and open any 
symbol as drawing. 

DesignFreeQ distinguishes between:

 • Simple Symbols, 
which have neither parametric dimensions nor underlying value 
tables,

 • Parametric Symbols,  
with editable dimensions,

  and

 • Symbol Libraries,  
that contain parametric symbols with underlying value tables.

The following sections describe how to create the different type of  
 symbols using a simple rectangle.

Creating simple symbols
Objects with fixed dimensions are called simple or fixed symbols.

1. Draw a rectangle with a width of  2 inch and a height of  1 inch.

2. Dimension the rectangle using the Horizontal and Vertical dimen-
sion tools.

 

When you place a fixed symbol in a drawing with the Symbol... command, 
it is placed with its dimensions. These dimensions are fixed and can not 
be modified once the symbol is placed.

Defining the Insertion point of a Symbol
When you place a symbol in a drawing the Insertion point of  the symbol is 
placed at that location you first clicked onto in the drawing area.

To define the Insertion point of  a symbol you proceed as follows:

1. Create the object.. 

2. Place one control point at the origin (0,0,0) to specify the Insertion 
Point of  the symbol.

 

In the Preview window of  all symbol dialog boxes the Insertion point of  a 
symbol is shown as a small black triangle.

A new document has its 
origin (0,0,0) in the center 
of the screen. To see the 
origin on the screen you 
must display the Grid. If you 
don't place a Control Point 
into the origin, the most 
left Construction Point is 
automatically used as Inser-
tion point.
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Creating parametric symbols 
Objects with editable dimensions (using variables) are called Parametric 
Symbols. 

1. Draw a rectangle at a any size.
2. Dimension the object according to the rules of  parametric.
 In our example we overwrite the #-Symbol in the Status line with 

the variables Width and Height.

 

3. Test the rectangle using the Resolve command in the Edit menu to 
be sure it resolves properly.

4. Save the symbol.

When you place a parametric symbol in a drawing it is placed without all 
dimensions that contain a parametric variable. The dimensions of  para-
metric symbols can be modified after the symbol is placed in a drawing 
using the Edit objects command in the Edit menu.

Creating invisible Symbol parts
For all elements of  an objects that should not appear with the symbol 
when it comes into a document, you must use pens with the line  pattern 
dotted. For invisible dimensions you must modify the line  pattern after 
placing the dimensions using the Edit objects command in the Edit 
menu, since dimensions always use a solid line pattern.

Creating smart symbols
The Architect folder of  the Symbols folder contains smart symbols for 
doors and windows. Smart windows and doors are smart because they 
contain a smart wall segment. When you add one of  these symbols to a 
smart wall, it breaks into the wall in the location you specify.

1. Choose a pen with the line pattern dotted in the Pattern  submenu 
from the Pen menu.

2. Draw a smart wall thicker than the maximum thickness you expect 
to use and only as long as the final symbol will be.

3. Choose a pen style for the visible elements of  the symbol. 

4. Draw the visible parts of  the symbol.

 

5. Save the symbol.

Creating Value Tables for Parametric Symbols
When you place a parametric symbol in a drawing all parametric variables 
are listed in the Symbols dialog box. Instead of  entering the final values 
into the related entry fields you can create underlying value tables that 
allow you to select predefined values for a  selected symbol.

For that it is necessary to create a value table for each parametric symbol 
in a text editor or spreadsheet. Save the value table as an ASCII file under 
the name of  the related symbol with the file extension .txt. (For the Mac-
intosh you must create the file extension to .txt as well.) The file must be 
saved in the same folder as the related symbol.

Value tables may not only contain parametric variables but also user-de-
fined attributes as material or order number that can be extracted in a Bill of  
Materials.

If you want to study the 
composition of a parametric 
symbol, you should open 
one of the parametric 
 symbols shipping with 
DesignFreeQ in Symbols 
folder.

Important: DesignFreeQ 
can extract the current 
values of parametric di-
mensions for BOM tables 
only when they start with a 
Capital letter. Therefore you 
should create only paramet-
ric variables that start with a 
Capital letter.

Each dotted line style 
(like the line style of the 
Construction line) will be 
hidden, when a symbol is 
placed or printed. Therefore 
you should use this line 
style for all  invisible parts of 
an object.

When you want to study a 
Smart Symbol open one 
of the Door symbols in the  
Architect folder of Design
FreeQ.
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It is optional to specify values for the two required labels PartID and 
Quantity at the beginning of  each table, since these attributes are 
 automatically assigned to each  symbol for a possible BOM extraction.

Labels for additional user-defined attributes as Material have to be de-
fined after the labels for the defined variables.

Since these user defined attributes are not automatically attached to a 
symbol they must be assigned when creating the symbol using the Sym-
bol Attributes tool.

Creating value tables
1. Create a Norm part at a scale of  1:1.

2. Dimension the part using parametric variables.

3. Choose the Attribute command in the BOM submenu from the 
Modules menu.

 The Attribute dialog box is displayed.

4. Define all attributes such as material that you would need for a BOM. 
5. Choose Show Palette in the BOM submenu.
 The Attribute Tool Palette is displayed.

6. Assign the defined attributes using the Symbol Attribute tool.

7. Save the part under a appropriate name.

8. Note the names of  all variables used for the part on a piece of  pa-
per.

9. Open a text editor  such as Notepad or SimpleText. 

10. In the first line, enter the two labels PartID and Quantity followed 
by all parametric variables you have noted for your norm part and 
finally all user-defined attributes you have assigned to the part.

 All entries must be separated by a TAB stop. At the end of  the line, 
you must hit the Enter (Windows) or Return (Macintosh) key.

11. In the next line enter the respective values for the norm part. All 
values have to be separated by a TAB stop as well.

12. Enter the values line by line for all norm parts pressing the Enter or 
the Return key after each line. Your table should look similar to the 
following graphic after all values entered.

 

13. Save the table as an ASCII file with the file extension .txt under the 
name and in the same folder you have saved the norm part.

When you now place a symbol with an underlying value table using the 
Insert command or the Symbolmanager all predefined norm parts from 
your newly created part family are listed and can be selected.

Editing value tables
1. Open the value table with the file extension .txt in the original Text 

Editor or Spreadsheet you used to create the table.

2. Modify the table.

3. Save the table as ASCII file (text only and carriage returns) under its 
original name.

4. Important: Delete the file with the same name that has the file  extension 
.var. It is in the same folder as the norm part with the file extension .vlm and 
the value table with the file extension .txt.

Placing Symbols
For placing symbols you use the Insert command from the submenu 
Symbols in the File menu.

The Insert command allows to place any DesignFreeQ drawing and any 
norm part as a symbol. 

If you don't specify a value 
for the Quantity, the default 
value 1 is automatically 
assigned.

In your value tables it is 
allowed to use units such as 
mm, cm, Inch etc. to have 
the correct dimensions for 
your symbols independent 
from the units set for the 
DesignFreeQ document.

Important: Don't define the 
 attributes PartID and Quantity 
since they are assigned to the 
symbol automatically with the 
 underlying value table. 

Important: It can take a 
while when you open  a 
symbol with an underlying 
value table for the first time 
since DesignFreeQ has to 
convert the ASCII table in 
an own format with the file 
 extension .var.

How to use the Symbol 
Attribute Tool is described 
in the Geometric Analysis 
chapter in this manual.
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Insert
Choosing this command from the Symbols submenu in the File menu 
displays the following dialog box:

 

The Symbols dialog box allows the following settings:

Preview window The Preview window shows a picture of  the 
selected symbol  including all its dimensions.

Variables For parametric symbols this list contains entry 
fields for all variables defined for the symbol.

To place the symbol in your drawing click or drag a vector on the draw-
ing area. If  you click, the symbol is inserted in the location you click, in 
its original orientation. If  you drag, the starting point of  the dragged 
vector specifies the Insertion point for the symbol and the  direction of  the 
dragged vector indicates the orientation. 

When you click OK the symbol is placed at the current scale of  the draw-
ing.

Placing a symbol
1. Choose the Insert command from the Symbols submenu.
 The File open dialog box is displayed.

2. Select the symbol file you want to use and click the Open button.
3. Enter a value for each parametric dimension5. Click the OK but-

ton.
4. Drag a vector on the drawing area for the insertion point and the Ori-

entation of  the symbol.
 In the Symbol dialog box a black triangle indicates the Insertion Point 

of  the symbol.

5. Click OK.
 The geometry resolves and appears in the current drawing at the lo-

cation you clicked and sized as you specified. The inserted symbol is 
grouped and selected.

Placing a symbol with its parametric dimension
If  you want to bring a symbol including its parametric dimensions into 
the current document you must use the Import command in the File 
menu. The symbol is placed at its original size in the current document. 
If  you select the symbol including its dimensions you can resolve it us-
ing the Resolve command from the Parametrics submenu in the Edit 
menu.

Editing parametric Symbols
If  you want to edit parametric Symbols you must use the Edit Objects 
command in the Edit menu.

If you want to enlarge part 
of the displayed symbol, 
bring the mouse pointer 
over the area of interest 
and press the left mouse 
button. As long as you keep 
the mouse button pressed 
the clicked area will be 
magnified.

Geometric Analyses
2D Analysis

Bill of Materials
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Geometric Analyses
After you have constructed your geometry, you may want to do some 
analysis for either engineering purposes or for the production of  your 
design part. DesignFreeQ includes a 2D Analysis feature as well as a Bill 
of  Materials feature. This chapter is divided into two sections to discuss 
these areas.

2D Analysis
The 2D Analysis provides sectional properties for the selected geometry, 
a feature that is useful for many calculations related to design and draft-
ing.

2D Analysis
This command in the Layout menu displays the statistics on the selec-
tion—the length of  the perimeter, the enclosed area, the center of  gravity 
(centroid), and moments of  inertia. The selection must be a closed figure.

When you select the 2D Analysis command the following dialog box is 
displayed:

 

The 2D Analysis dialog box allows the following settings:

Tolerance A setting to determine the accuracy of  calculations for 
curved objects. The smaller the tolerance is, the higher 
the accuracy will be. The default value is 0.01. You can 
change the value by entering a new number. 

 The 2D Analysis mechanism analyses arcs, circles,  ellipses, 
and splines as straight line segments that  deviate from the 
true curve by no more than the stated tolerance value. 
The smaller the number, the greater the  accuracy; how-
ever, the greater the accuracy, the longer the calculation 
time.

Weight Per Area A multiplier used to determine the actual weight of  a 
part of  constant thickness defined by a selected bound-
ary. The Weight of  the part is the product of  the Area 
multiplied by the Weight Per Area.

 The default entry is 1. You can change the value by en-
tering a new number.  You can find the proper  number 
for this entry in a handbook published by most material 
vendors, particularly for sheet steel and aluminum. Enter 
the weight for the thickness of  the proposed material 
and click the Calculate button.

Perimeter The length of  all segments which define the selected 
boundary. This is the only value that is calculated if  the 
boundary of  an object (such as a Spline or an Arc) is not 
closed.

Area The surface area enclosed by the selected boundary.

 For circles, arc, and other curves, the accuracy is depen-
dent upon the tolerance setting.

Weight The product of  the Area multiplied by the Weight Per 
Area.

It is also possible to de-
termine the length of not 
enclosed objects such as 
Splines or Arcs. (See as 
well under Perimeter in this 
section of the manual.)

Note that this Tolerance 
 value has no effect on the 
precision of the resultant 
values. The precision of the 
result is set using the Units 
command under Preferen-
ces in the Layout menu.

For circles, arcs, and other 
curves, the accuracy is de-
pendent upon the tolerance 
setting. 
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Xc
Yc

(0,0)

Y

X

Centroid
(Xc,Yc)

Area

Centroid X The X coordinate of  the center of  mass defined by the 
selected boundary.

Centroid Y The Y coordinate of  the center of  mass defined by the 
selected boundary.

Inertia IXX The moment of  inertia about a central X-X axis which 
is parallel to the X-axis.

  IXX = ƒ(y-Yc)2dA

Inertia IYY The moment of  inertia about a central Y-Y axis which is 
parallel to the Y-axis.

  IYY = ƒ(x-Xc)2dA

Inertia IXY The moment of  inertia about a centroid.

  IXY = ƒ(x-Xc)(y-Yc)dA

Performing 2D Analysis
1. Select the geometry that defines a closed boundary. You may want 

to use the Tracer tool to select the perimeter.

2. Choose the Construction command from the Layout menu.

 The Construction dialog box is displayed, the analysis is  performed 
and the values are displayed in the dialog box.

3. If  necessary, enter changes for the Tolerance and Weight per Area 
values.

4. Click the Calculate button.
 The analysis is recalculated and the new values are displayed in the 

dialog box.

Calculations
DesignFreeQ calculates the values for 2D Analysis before the dialog 
box  appears. If  you make a change in the Tolerance or the Weight Per 
Area, you must click the Calculate button to recalculate the statistics.

The 2D Analysis mechanism evaluates the boundary in the same way the 
crosshatching mechanism does; for example, DesignFreeQ considers a 
 circle inside a bounded area to be a hole. Crosshatching does not fill the 
hole and 2D Analysis does not include the area of  the  circle in the area 
calculation.

Displaying the centroid
1. Select the geometry defining the part.

2. Choose the 2D Analysis command from the Layout menu.
 The 2D Analysis dialog box is displayed.

3. Choose the Construction command from the Layout menu.
 The Construction dialog box is displayed.

4. In the Angle box in the Construction dialog box, enter 0;90.  
(Be certain to separate the numbers with a semicolon.)

5. Enter the value for Centroid X displayed in the 2D Analysis  dialog 
box into the X box of  the Construction dialog box.

6. Enter the value for Centroid Y displayed in the 2D Analysis  dialog 
box into the Y box of  the Construction  dialog box.

7. Press the Enter key.
 The intersection of  the two displayed construction lines show  

the centroid of  the  selected part.

The closed figure is an area 
that could be crosshatched.  
If you are in doubt about 
the area, simply crosshatch 
the geometry to see if it rep-
resents the area you want 
to analyze. 
Once you crosshatch the 
area and you see that your 
selection is correct, you can 
choose Undo to remove 
the crosshatching and still 
maintain the selection. 
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3D Basics
The process of  moving from 2D to 3D geometry creation is relatively 
seamless, since DesignFreeQ offers a smooth transition from 2D to 3D. 
All of  the tools someone would use to create 2D geometry in DesignFre-
eQ would also be used to create 3D geometry.  However,  there are some 
tools, features, and concepts that are specific to 3D such as:

 • the Setting of  the 3D environment, 
 • the concept of  Work Planes,
This chapter covers the setup of  the three-dimensional work space, mul-
tiple model views and the derivation of  two-dimensional draftings from 
these 3D Models.

3D Models
Two-dimensional draftings exists mainly of  the geometry that makes up 
the edges of  an object plus some additional informations such as Hatches, 
Text and Dimensions.

In three-dimensional design, objects that define only the edges of  a part 
are called Wireframe models. But Wireframe Models are only one type of  
models used in 3D. In principle exist three different model types:

Wireframe Models define only the edges of  a part, but not the 
surfaces covering the frame or the volume 
contained in a model.

Surface Models define all surfaces that cover the frame of  
a model. Surface Models can be shaded for 
visualization and their hidden lines can be re-
moved for a more clear  representation of  the 
model.

Solid Models define objects including their surfaces and 
volume. It is possible to add and subtract sol-
id models or create model sections.

In DesignFreeQ three-dimensional modeling capabilities are limited to 
Wireframe Models.

Model Visualizations or 
Hidden line Removal is not 
possible with Wireframe 
Models.
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Three-dimensional Work Space
Basically you create three-dimensional objects in DesignFreeQ the same 
way you create two-dimensional draftings. The only difference is that you 
do not work on a flat area such as a sheet of  paper but in an infinitely 
large three-dimensional work space (with x-, y- and z-axes) in the memo-
ry of  your computer.

When you open a new drawing in DesignFreeQ an empty drawing area 
is  displayed representing a infinite large drawing sheet. The default view 
for each new drawing is the Top view. You are looking down on top of  
the x-, y-plane.

 

z

x

y

To create 3D objects we have to specify in addition to the width and the 
length of  an object the height along the z-direction, which is coming toward 
us, away from the screen. To see what we are drawing in the z-direction we 
must rotate the image.

 

As we already know is what we see on the screen not the model itself  but 
only an image of  the model, projected by the Sheet camera onto the cur-
rent sheet. The default Top view aligns the Sheet Camera parallel to the 
sheet onto the x-,y-plane.

 

When we now rotate the view using the on-screen Trackball or one of  the 
View commands we don't rotate the displayed object geometry (that stays 
fixed, even if  you get the opposite impression on the screen) but the 
Sheet Camera around the model. The rotated image of  the model is than 
projected onto the sheet and therefore called Sheet view.

Model Views
As long as no Detail Views exist, the Sheet View can be rotated unre-
stricted. As soon as Detail Views (picked up by Detail View Cameras) are 
projected into View windows, views can be rotated only within these view 
windows. It is not possible any more to rotate the Sheet View that is now 
rigidly fixed and parallel aligned to the sheet in the Top View.

 

Note: Rotating a view does 
not change the orientation 
of the work plane. (See as 
well under Work Planes in 
Chapter 16 3D Modeling).

Once you create a detail 
view the Sheet View be-
comes fixed, because the 
Sheet Camera remains now 
stationary in the original x,y 
(world) orientation. You, then 
will not be able to change 
the view of the sheet as long 
as Detail Views are placed 
on the sheet.
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You can rotate views infinitely variable using the on-screen Trackball or 
choose one of  the Standard views from the Views submenu in the Views 
menu.

Rotate views infinitely variable
For rotating views manually DesignFreeQ provides a Trackball, that can 
you can display with the Show Trackball command in the Views menu.

Show/Hide Trackball
This command in the Views menu toggles he display of  the Trackball on 
the screen.

Rotating the active view
1. Choose the Show Trackball command from the Views menu.

  

2. Drag the pointer on the Trackball to rotate the view.
 The model rotates as you drag. The model rotates around the center 

of  the active view or sheet. The movement of  the pointer on the 
trackball corresponds to a fulcrum. The location where you press 
the mouse button becomes the fulcrum and the movement of  the 
mouse rotates the model around that fulcrum point. What you see 
on the screen responds to the view of  the Sheet Camera or  Detail 
View Camera.

Rotating Views
This feature enables you to lock the Trackball along two screen axes so 
you can rotate the view of  your geometry around the third screen axis.

  

Rotating the Screen view with the Trackball vertically
When pressing the Shift key and dragging the cursor on the Trackball up 
or down, the geometry will rotate around the screen x-axis  (vertically).

Rotating the Screen view with the Trackball horizontally
When pressing the Ctrl key (Macintosh: Option key) and dragging the 
cursor on the Trackball left or right, the geometry will rotate around the 
screen y-axis  (horizontally).

Rotating the Screen view with the Trackball circular
When pressing the Shift+Ctrl keys (Macintosh: Command key) and drag-
ging the cursor on the Trackball in a circular motion, the  geometry will 
rotate around the screen z-axis  (circular).

Selecting Standard Views
DesignFreeQ provides the following predefined, orthogonal standard 
views that offer a perfect environment for creating 3D wireframe  models:

Top View of  the x,y plane from above.

Bottom View of  the x,y plane from below.

Front  View of  the x,z plane from the front.

Back View of  the x,z plane from the back.

Right View of  the y,z plane from the right.

Left View of  the y,z plane from the left.

The screen axes are differ-
ent from the axes of your 
geometry unless you set 
your view to Top with the 
Trackball menu. This makes 
the screen axes the same as 
the axes of the block.

The Trackball can be 
dragged around the screen.

While rotating a view with 
the Trackball a Triad symbol 
is temporarily displayed at 
the  origin, illustrating the 
orientation of the x, y, and 
z axis and the Work Plane. 
See as well under Triad in 
Chapter 16.
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Isometric The view of  the axes is rotated as shown:

          

Dimetric The view of  the axes is rotated s shown:

           

Trimetric The view of  the axes is rotated as shown:

          

Trackball View menu
The Trackball has a pull-down menu for specifying a Standard View of  the 
current view window or the sheet, if  there are no view windows.

Selecting a Standard View with the Trackball menu
1. Move the pointer to the current view name displayed at the bottom 

of  the Trackball menu.

2. Press the mouse button.
 The Trackball menu is displayed.

  

3. Drag the pointer to the view orientation you want to display and 
release the mouse button.

 The current view orientation is updated.

Views
This command in the Views menu displays the view orientation  submenu 
so that you can set the orientation of  the active view or the sheet as long 
as there are no detail views.

 

Defining Views
There are several possibilities to define views: 

 • using the Define View command in the Views menu.
 • using the Unfold View command in the Views menu.
 • using the Flatten View command in the Views menu.
 • using the View the Plane command in the Views menu.

With the Trackball you can 
rotate the view in an active 
view window or the Sheet 
view as long as there are no 
detail views.
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Define View
This command in the Views menu allows you to define auxiliary view 
orientations or change the standard view orientations such as the Top 
View.

All views defined additionally using the Define View command are 
 automatically included into the Views submenu and can be selected  
from the Trackball menu. 

Choosing the Define View command displays the fllowing dialog box:

 

The Define View dialog box allows the following settings:

View list This list window contains all defined views. A check-
mark indicates the active view, a locked checkbox any 
locked view. To redefine a view the locked checkbox has 
to be clicked off.

New The New button displays the Redefine View dialog box 
where you can specify a new view. When you click the 
OK button the dialog box is closed and the new view is 
added to the views list. You can rename the new view 
 using the Rename button.

Delete This button deletes the selected view in the views list. 
Locked views and the active view cannot be deleted.

Redefine The Redefine button displays the Redefine View  dialog 
box where you can redefine the selected view. Locked 
views and the active view cannot be redefined.

Set View This button makes the selected view the active view. The 
active view is indicated by a checkmark.

Rename Using this button you can rename any selected view. 
Locked views and the active view cannot be deleted.

Activating a View Orientation
1. Select the view you want to activate in the Define View dialog box.

2. Click the Set View button. 

Renaming a View Orientation
1. Select the view you want to rename in the Define View dialog box.

2. Enter the new name in the Rename field.

3. Click the Rename button. 

Locking/Unlocking a View Orientation
1. Select the view you want to lock or unlock in the Define View  dialog 

box.

2. Click on the Lock symbol to unlock a view and click once in front 
of  a view name in the views list to lock the view. If  the view was 
locked the Lock symbol will be removed, if  it was unlocked the lock 
symbol will be displayed.

Deleting a View Orientation
Select the view orientation to be deleted from the Views list and click 
the Delete button.

New/Redefine
When you click the New or the Redefine button the Redefine View 
 dialog box is displayed:

 

The Redefine View dialog box displays always the location of  the cur-
rent view. The current view can be any selected view from the Views list 
or any view specified using the on-screen Trackball.

The Standard Views can-
not be changed unless 
the  locked  checkbox is 
clicked off.

How to define a view is 
 described in the next New/
Redefine section of this 
chapter.

How to redefine a view is 
described in the next New/
Redefine section of this 
chapter.

You can select as well a 
view in the Views submenu 
of the View menu.

Locked views and the  active 
view cannot be renamed.

Locked views and the  active 
view cannot be  deleted.
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The Redefine View dialog box allows the following settings:

Normal* In these entry fields you specify the Normal (90°) line of  sight 
by dragging a vector on the drawing area. The direction you 
indicate with the dragged line for the Normal line of  sight 
corresponds with a vector coming toward you, away from 
the screen, when the view is active.

   

Up* In these entry fields you specify by dragging a vector on the 
drawing area which side of  an object in the future view will 
show upwards. The dragged vector for the Up direction of  
the Line of  Sight is always rectangular to the Norma line of  
sight.

   

OK When you click the OK button the Redefine View dialog 
box is closed. If  the dialog box was opened using the New 
button, a new view with the name View 1 will be added  
to the Views list. If  the dialog box was opened using the 
Redefine button, the selected is redefined. 

Defining or Redefining a View
You can use one of  two methods to specify the orientation of  the axes 
of  a view:

By example
1. Manipulate the view orientation manually with the Trackball.

2. Select the Define View command in the Views menu.
 The Define View dialog box is displayed.

3. Select a view and click the Redefine button, if  you want to  redefine 
the view with the current values, or click the New button, if  you 
want to create a new view based on the current values.

 The Redefine View dialog box is displayed showing the values of  
the current view on the screen.

4. Click the OK button.
 The Redefine View dialog box is closed and the selected view is re-

defined or a new view is created with the name View 1, that can be 
renamed using the Rename button.

By definition
1. Select the Define View command in the Views menu.
 The Define View dialog box is displayed.

2. Select a view and click the Redefine button, if  you want to  redefine 
the view with the current values, or click the New button, if  you 
want to create a new view based on the current values.

 The Redefine View dialog box is displayed. The Normal Line of  
Sight specification is highlighted.

3. Drag a vector with the mouse to indicate the Normal Line of  Sight.
 The Up entry boxes become selected.

4. Drag a vector with the mouse to indicate the Up direction of  the 
Sight.

5. Click the OK button. 
 The Redefine View dialog box is closed and the selected view is re-

defined or a new view is created with the name View 1, that can be 
renamed using the Rename button.

When you drag the vector 
for the Normal Line of Sight, 
know that the vector from 
the beginning point, points 
directly at you, not away 
from you. So when this new 
view is activated, the normal 
vector points out of the 
screen, not into it.
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Designing in multiple Views
As soon as you place any detail view, you can only change the view ori-
entation within a view window, but not the view orientation of  the sheet, 
that is then rigidly fixed in the Top view. Therefore it makes sense to de-
sign three-dimensional  models using  multiple view windows, that allow 
you to view the  geometry from different view angles simultaneously.

  Vellum

The geometry within view windows is associative, since they are display-
ing all the same model. When you make a change in one  window, the 
change effects the model and therefore the geometry in all views. There 
exist two different methods for creating 3D wireframe models:

1. Start the model creation on the drawing sheet and add views later 
using the Detail View tool for editing and viewing the model from 
different angles.

2. Use a so called View Layout from the beginning and create the  model 
in different view windows simultaneously.

Using the first method you open a new drawing and create the geometry 
on an empty sheet. With the Trackball or one of  the View commands you 
can rotate your model and edit it from different angles as long as you 
have not created any  detail view windows.

As soon as you place a detail view windows on the sheet, the Sheet View 
is fixed in the Top view, while the detail views can display different view 
orientations of  your geometry.

 

This method has the disadvantage that the Sheet View of  your geometry 
may overlap the view windows on the sheet. To avoid this problem you 
could assign the sheet to a new model by creating a new Model 2 using 
the Model command from the Views menu, clicking then on the sheet to 
activate it and making finally Model2 the current model.

 

Something similar, but more elegant is to load a View Layout using the 
Sheet into View command in the Views menu, since the Sheet into 
View command creates automatically a new model, projects it on the cur-
rent sheet and puts all geometry into one or more view windows.

View Windows are de-
scribed in detail in Chapter 
10 Structuring Drawings.

A View Window is nothing 
else than the projection of 
a detail view on the current 
sheet picked up by a View 
Camera at a particular 
 angle. If the option Draw 
View  Boundaries in the 
Views menu is active, the 
boundaries of all in active 
views is shown by a dot-
ted line. The active view  
 displays  always its title bar. 

You could create as well 
a new Sheet and copy all 
detail views onto the new 
sheet to get a clear view on 
the view windows. To copy 
a detail view from Sheet 1 
to Sheet 2, to you must cut 
the detail views using the 
Cut command from the View 
Window menu, activate then 
Sheet 2 in the Sheet dialog 
box and paste the detail 
views onto Sheet 2  using 
the Paste command from 
the Edit menu.
Models, Sheets and Views 
are  described in detail in 
Chapter 10 Structuring 
Drawings.
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View Layouts
View Layouts allow you to create 3D models simultaneously in several 
view windows without having the geometry displayed on the current 
sheet at the same time.

There are two View Layouts optimized for 3D Design: Design 4 and 
Draft 4. Both layouts are stored in the Layout folder in the DesignFre-
eQ folder and can be loaded with Sheet into View command.

Design 4  [Design4.vlm]
This layout contains four views. The Trimetric View is scaled as spec-
ified in the Sheet into View dialog box and the other three views are 
scaled to 5% of  the Trimetric view.

 

Draft 4  [Draft4.vlm]
This layout creates four full-scale views scaled as  specified in the Sheet 
into View dialog box: Top, Font, Right and Trimetric.

 

Creating View Layouts
All view layouts available from the Sheet into View dialog box are indi-
vidual DesignFreeQ drawing files stored in the Layouts folder in the 
DesignFreeQ folder.

If  you want to create your own layout, simply edit one of  the existing 
drawings in the Layouts folder, or create a new drawing and save it in  
the Layouts folder. The file name then will appear automatically in the 
pull-down menu in the Sheet into View dialog box.

Creating custom View Layouts
The easiest way to create customized layouts is to edit existing ones.

1. Open a layout file in the Layouts folder using the Open  command  
in the File menu.

2. Save the file under a different name before you do any changes.

3. Customize the layout to your needs by modifying the Number, Size, 
Scale or View Orientation of  the view windows.

4. Save the modified layout in the Layouts folder.

5. Select the Sheet into View in the Views menu.

6. The new layout appears automatically in the pull-down menu in the  
Sheet Into View dialog box.

Another way to create your own layout is to design it in a new  document.

1. Open a new document using the New command in the File menu.

2. Create a view window with the Detail View function.

3. Make the current sheet active by clicking anywhere outside the view 
window on the sheet.

4. Create a new model using the Model command in the Views menu.

5. Make the new Model 2 the current model in the Models dialog box.

The Layout folder contains 
besides View Layouts as 
well Standard Drawing 
formats that you can import 
or load using the Sheet into 
View command.

The geometry within view 
windows is associative, 
since they are displaying all 
the same model. When you 
make a change in one view 
window, the change effects 
the model and therefore 
the geometry in all views. 
Important: Hatches, Text 
and Dimensions are view 
dependent and appear 
only in the views they were 
created in.

The Flatten View command 
in the Views menu, that is 
described in a later section 
of this chapter, allows you to 
cancel the asso ciativity ex-
isting between the  displayed 
view windows.

You might look at one of 
the files in the Layouts 
folder to see how it is set 
up. Be sure not to make any 
unwanted changes to these 
layout files.
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6. Copy the view window as often as you want with the Copy com-
mand in the View Window menu and the Paste command in the 
Edit menu.

7. Set each view window to the desired view orientation with the 
Views commands in the Views menu or in the Trackball menu.

8.  Select the Properties command in the detail view window’s  control 
menu to scale each view window.

9. Save the new layout under a proper name in the Layouts folder.

Unfold View
The Unfold View command in the Views menu allows you to create a 
view orientation from the active view window by specifying a line about 
which to unfold the new view orientation.

 

By specifying a line you define a 90°-plane along that line, which is com-
ing toward you away from the screen. This plane is folded by 90° and 
creates the new view orientation from the active view.

 

Unfolding a View
1. Select the Unfold View command in the Views menu.

2. Click the endpoints of  the line to unfold on.
 The active view window shows the view unfolded 90° from the line 

you specify.

View the Plane
This command in the Views menu rotates the view orientation in the 
 active view window to match the work plane. The view changes so the 
work plane becomes horizontal on the screen. The y-direction of  the 
work plane becomes vertical, and the z-direction of  the work plane be-
comes the line of  sight, coming directly out of  the screen.

To leave this view orientation, select a view from the Trackball menu or 
the Views submenu, or use the Trackball for free rotation.

Editing Views without editing the Model
The geometry within view windows is associative. When you make a 
change in one window, the change affects the model and therefore the 
geometry in all views. In the drafting phase of  the design process, you 
may want to edit the geometry in one view window without  making the 
same changes to the model. 

You can accomplish this by using the called Flatten View command on 
the Views menu. When you flatten a view, the geometry is taken out of  
the view and placed back on the sheet, where it is no longer  associated 
with the model. In this way, you can make changes to the geometry with-
out changing the model or other views. 

Note: You should use the 
Unfold View  command only 
in a view  orientation which 
is aligned  parallel to an 
 object face. If you use it in 
a differently aligned view 
(object face is not parallel to 
the screen) this command 
will work correctly, but the 
result will be  unpredictable 
in most cases.

You don’t need an actual 
line, you can as well drag 
a vector.
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Flatten View
This command places a projection of the visible geometry in the active 
view window onto the sheet at full scale. When the view is flattened, all 
overlapping lines of  equal length and all lines parallel to the line of sight 
are removed. The geometry is no longer associated with the model.  If  
you make changes to the flattened geometry, those changes do not affect 
the model. If  you make changes to the model, the  flattened  geometry is 
not changed.

When you flatten a detail view, you are flattening only what is visible 
within the detail view window. Objects partly visible in a view window 
will be clipped, objects outside of  a view window will be ignored.

Text and Crosshatching are treated like geometry by this command. Dimen-
sions will no longer update if  you make a change to the 3D  model since 
the flattened geometry is disassociated, but they will change if  you alter 
the flattened geometry. 

Also if  you dimension your geometry after it is flattened, you will have 
to enter the desired values because DesignFreeQ will simply read the 
length of  the projected flat lines. If  you want to keep the dimensions, 
copy the view and flatten the copy, or group the geometry with the 
 dimensions, then flatten the view.

If  the following message displays, The current view and the draft view 
have the same model, you must change the model on the sheet. Click 
the sheet, outside all views, then create a new model using the Models 
command in the Views menu, then click Current to activate the new 
model, and then flatten the view again.

Flatten a View
1. Select a view window.

2. Choose the Flatten View command in the Views menu.
 A dialog box displays a warning message. Since flattening disassoci-

ates the current view from the model, you are given this opportunity 
to be certain you have selected the view you want to flatten and that 
you really want to flatten the selected view.

 All dimensions in the view are deleted because the 3D dimensions 
would not be correct in 2D geometry. 

3. Click the OK button.
 The geometry is placed on the sheet at full scale.

Flatten all views
Often Detail views and the Sheet view show different models. When 
 exporting drawings only one model can be exported, therefore detail 
views can get lost. 

This can be avoided with the Flatten all Views command.

When you select this command the following dialog window is displayed: 

 

This note warns you that all detail views will be disassociated from the 
model and therefore will loose their associativity.

When exporting a drawings with more than one model, using the export 
formats EMF, WMF, PNG, DXF/DWG  you will automatically be of-
fered to flatten all views if  you want to export all detail views.

Creating 2D Working Drawings
Even though DesignFreeQ allows to create 3D Models intuitively, it has 
not eliminated the need for drafting. While modifying, storing, and shar-
ing models are the basis of  computer design, drafting is still essential. 
DesignFreeQ makes drafting painless. You can produce finished draw-
ings for proposals, planning, and patents quickly and efficiently.  

You can create one model, choose a single command, and voilá— a fur-
view layout, scaled perfectly!

Important: If you flatten a 
view containing a surfaced 
model displayed in the 
hidden line mode, not only 
the visible object edges will 
be flattened but the original  
geometry as well.
The visible edges will be 
placed on the current layer 
while the  original geometry 
will be placed on the layer 
Wireframe. The layer Wire-
frame will be  automatically 
created and hidden. It 
must be  displayed for the 
 dimensioning of circles, 
since it is not possible to 
dimension the visible edges 
but only the original geom-
etry. See as well under Di-
mensions in 3D in Chapter 
16 3D Modeling.

When exporting DXF/DWG 
Files not all views have to 
be flattened, since several 
views are automatically de-
tected during export and a 
dialog box with correspond-
ing  options will be displayed.  
See as well Exporting DXF/
DWG-Files in this manual.
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You can create two-dimensional draftings of  a 3D model by importing a 
Standard Drawing Format or by loading a Standard Drawing Format with one 
or more views using the Sheet into View command.

Placing a 3D Object in a Standard Drawing Format
1. Create the 3D Object on the Sheet or using a View Layout with one 

or more views.

2. Import a Standard Drawing Format from the Layouts folder in the 
DesignFreeQ folder using the Import command in the File menu. 
Mark the option unscaled in the Import Option dialog box so the 
 drawing format is imported at its original size.

3. Align the geometry within the view windows and the view windows 
within the drawing format according to the standard drawing rules.

4. Flatten a view in case you want to edit the geometry in that view 
window without modifying the geometry in the other view  windows.

5. Dimension the geometry on the sheet or in the view windows.

Since each view is associated with the model all changes made in one 
view will be reflected in the other views. The same is not true for Text, 
Dimensions, Crosshatching and Fills.

Creating a 2D Drafting using the Sheet into View command
1. Create the 3D Model on the Sheet.

2. Load a Standard Drawing Format with one or more views using the 
Sheet into View command in the Views menu.

3. Align the model within the view windows and the view windows 
within the drawing format according to the standard drawing rules.

4. Flatten a view in case you want to edit the geometry in that view 
window without modifying the geometry in the other view  windows.

5. Dimension the geometry on the sheet or in the view windows.

Since each view is associated with the model all changes made in one 
view will be reflected in the other views. The same is not true for Text, 
Dimensions, Crosshatching and Fills.

The following Standard Drawing Formats are available in the 
 Layouts folder for the use with 2D Draftings:

 A4 Portrait & 4 Views A1 Portrait & 4 Views 
 A4 Landscape & 4 Views A1 Landscape & 4 Views 
 A3-Portrait & 4 Views A0 Portrait & 4 Views 
 A3 Landscape & 4 Views A0 Landscape & 4 Views 
 A2 Portrait & 4 Views A2 Landscape & 4 Views

The object geometry on the sheet will be placed in four views (Top, Front, 
Right and Trimetric) within a Standard Drawing Format (A4, A3, A2, A1, 
A0).

As soon as you place a 
detail view windows on the 
sheet, the Sheet View is 
fixed in the Top view, while 
the detail views can display 
 different view orientations of 
your geometry.
How to import a drawing for-
mat is described in Chapter 
9 Basic Drafting.

It is recommended to delete 
all existing detail views 
before using the Sheet into 
View command.
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3D Modeling
This chapter provides all information you need for modeling three-di-
mensional objects:

 • Work Planes
 • Design Process
 • 3D Construction Tools
 • Rules for 3D Construction

Work Plane
In traditional 3D computer-aided design, you work as though you have 
propped a piece of  glass on one of  the faces of  the model and draw on 
that. Every time you want to work on a different plane, you have to pick 
up your glass and carry it to the new position. With DesignFreeQ, you 
can move around inside the model and draw  wherever you want.

Generally, all you have to worry about is the design, not moving the piece 
of  glass. Due to the Design Navigator the work plane in DesignFreeQ is 
rarely used. But when it’s required you only have to specify the orientation 
of  the work plane but not its position like in conventional CAD-programs.

The Design Navigator keeps tabs on the angles and intersections for you 
in all three dimensions. It identifies the plane of  an object automatically 
as soon as it snaps on one of  the objects construction points. Therefore 
you can, if  geometry exists, draw relative to the identified plane.

Also for objects you create with tools requiring three construction points 
such as the 3-Point Circle tool or Tangent-Point Circle tool, the orien-
tation of  the work plane must not be changed

 

When a tool creates geom-
etry from two points, the 
geometry will lie on a plane 
parallel to the work plane. If 
the tool uses three points to 
define the geometry, the ge-
ometry will be on the plane 
defined by the three points.
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Only if  you are creating geometry that is not parallel to the current work 
plane, and if  you are using a tool that requires only two points for creation, 
such as the Center-Point Circle, Rectangle, or 2-Point Ellipse, you 
need to modify the orientation of  the work plane to properly place the 
geometry. The exception to this rule are Lines and NURB Splines, that 
can be created independent from the orientation and location of  the cur-
rent work plane.

 

Differences between Work Plane and Views
When you change the orientation of  the Work Plane, the View orientation 
remains unchanged. The view orientation specifies the viewing angle, the 
direction you look at your geometry, while the orientation of  the work 
plane determines the plane on which you create your geometry.

But rotating a view can bring the work plane into a position that makes it 
impossible to create any geometry on it

 

The command Set Plane to Screen, that keeps the Work Plane always par-
allel to the Screen while rotating a view and the command View the Plane 
that aligns the View parallel to the Work Plane help to avoid this problem.

Displaying the Work Plane
When you open a new drawing in DesignFreeQ, the default  orientation 
of  the work plane is Top. You can display a Triad symbol on the screen 
to control the  orientation and position of  the work plane.

Show/Hide Triad
This command displays the Triad symbol in the upper-left corner of  the 
screen or active view window to illustrate the orientation of  the x, y, z 
axis and the work plane.

 

The Work Plane is represented by an open triangle within the three axes x, y 
and z. The displayed orientation of  these axes is depending on the select-
ed view orientation.

If  you have not created a detail view, the triad symbol displays in the up-
per-left corner of  the sheet. Once a view window is created, it displays 
in the upper-left corner of  the active view window, since the sheet view 
cannot be rotated any more; it remains stationary in the World Coordinate 
System at the Top orientation.

The Triad symbol also temporarily displays at the origin when you  rotate 
the view orientation manually with the trackball.

The Triad displays the principle of  the Right-Hand Rule—a memory 
aid for the relative directions of  the positive axes. With your right palm 

If you want to see the Triad 
at the Origin (0,0,0), set the 
Grid Spacing to 0 in the 
Preferences submenu in 
the Layout menu.
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upturned, the Thumb (X) points right, the Index Finger (Y) points 
straight ahead, and the Middle Finger (Z) points up. If  you move your 
hand to indicate the x- and y-axes, you can easily see the direction of  the 
-axis.

 

Selecting Standard Planes
DesignFreeQ offers several commands to define the orientation of  the 
work plane and three predefined Standard Planes to choose from. The 
three Standard Planes are predefined as follows:

Front x- ,z Plane

Right y- ,z Plane

World (Top) x- ,y Plane
 Orientation and Origin of  World plane was specified to-

gether with the Model Space. The World (Top) plane is the 
default plane for any new drawing and can not be modi-
fied.

Planes
This command in the 3D menu displays the Planes submenu so that 
you can set the current work plane. Standard work planes (Top, Right and 
Front) are always displayed, as well as any temporary plane you have gener-
ated and any planes you have created with the Define Plane command in 
the 3D menu.

Setting the Work Plane
1. Select the Planes command in the 3D menu.
 The Planes submenu is displayed:

  

2. Select one of  the displayed planes.
 The work plane in the sheet or active view window is rotated as 

specified, and the work plane name is checked in the submenu.

Often it is useful to align the view with the current work plane using the 
View the Plane command in the Views menu.

Specifying the position of the work plane
In conventional CAD-programs you have to specify both the Orien tation 
of  the work plane and its exact Location along the z-axis.

In DesignFreeQ you need only to specify the Orientation of  the work 
plane. Once that is done, then all planes parallel to that orientation act 
equally as the current work plane, e.g. the Design Navigator identifies the 
Location of  the work plane automatically.

 

Another way to explain the relationship presented in the graphics above, 
is to remember the role of  the Design Navigator. For new  geometry to be 

If you have used other com-
puter applications, you may 
be familiar with the terms 
World Coordinate System 
and User Coordi nate Sys-
tem. The World (Top) work 
plane of DesignFreeQ is 
equivalent to the World Co-
ordinate  System  and any 
nonstandard, temporary 
work plane is equivalent to 
the User Coordinate System.

If you create a work plane 
with the 3-Point Plane 
command it is named Temp 
and will exist only for the 
duration of the current 
DesignFreeQ session. You 
can rename the Temp work 
plane with the Define Plane 
command to make it perma-
nent. There can be only one 
plane called Temp Plane in 
a document. If another plane 
is created using the 3-Point 
Plane command without 
changing the name of the 
first, the new Temp Plane 
replaces the old one.

To display the Grid with 
Origin select Show Grid in 
the Layout menu.
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placed on the same plane, you need to brush over that “old” geometry 
to wake up one of  its control points like midpoint or endpoint. Design-
FreeQ will then use retain this plane information as you  create the new 
geometry.

If  no object exists or no geometry is referenced for plane information, 
DesignFreeQ places the new object geometry onto the work plane at the 
 origin.

Moving the origin
When you open a new drawing the Origin of  the Drawing is identical with 
the absolute origin of  the World Coordinate System (0,0,0). To  display 
 relative coordinates in the Position Indicator you can move the origin of  
the work plane using the Set Origin command. With the 3-Point Plane 
command you move the origin of  the current work plane and change its 
orientation.

 

As soon as you select the World (Top) plane again from the Planes 
 submenu of  the 3D menu you return to the World Coordinate System and 
move the origin of  the work plane to absolute zero (0,0,0).

Set Origin
This command sets a new origin for the current work plane.

Specifying a new origin
1. Choose the Set Origin command from the 3D menu.

2. Click in the drawing area to indicate the location for the new origin.
 The origin of  the current work plane is moved while the orientation 

of  x, y and z axes remains the same.  

Setting a new Work Plane
When using certain tools you have to define a work plane other than the 
standard planes. For example, if  you want to create an object on an an-
gled face, using a tool that defines an object by only two points.

You can define a new plane with two commands on the 3D menu: 
3-Point Plane and  Define Plane. With the 3-Point Plane command 
you set a new work plane, that you can name and save using the Define 
Plane command.  

3-Point Plane
This command in the 3D menu sets a temporary work plane by simply 
indicating the Origin and the horizontal (X) and vertical (Y) directions.

 

Specifying a temporary Work Plane
1. Choose the 3-Point Plane command from the 3D menu.

2. Click in the drawing area to indicate the point you want for the Ori-
gin of  the new work plane.

3. Click a point to define the positive x-axis.

4. Click a point to define the positive y-axis.
A temporary work plane is created and named TempPlane. The work 
plane is moved, but the view does not change.

If  you do not name the new plane with Define Plane, it will be  replaced 
by the next 3-point plane you specify and will be removed from the list of  
available planes when you quit DesignFreeQ.

Relative Coordinates also 
called User Coordinates are 
very useful if you want to 
draw relative to  existing ob-
jects. The Set Origin com-
mand allows you to move 
the Coordinate Reference 
Point to another location.

The current position of the 
origin will be only visible 
when the Grid is displayed 
using the Show Grid com-
mand in the Layout menu.

You just must follow the 
directions on the Message 
Line when using the 3-Point 
Plane command.

Be aware that modifying 
the  orientation of the work 
plane doesn’t automatically 
mean that you will work 
on a visible face. The view 
orientation must be adjusted 
accordingly. 
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Define Plane
Allows you to define a new work plane, name a temporary plane, or change 
a standard plane. Standard planes cannot be changed unless you click off  
the lock icon.

If  you change any of  the standard planes, you can always revert to the 
World Plane (Top Plane) to return to the original orientation.

When you select the Define Plane command from the 3D menu the fol-
lowing dialog box is displayed:

 

The Define Plane dialog box contains the following items:

Planes List This list box contains all defined planes. The work  plane 
is indicated by a Checkmark, all locked planes by a Lock 
icon. Locked planes must be unlocked for editing by 
clicking the lock icon.

New Clicking this button displays the Redefine Plane  dialog 
box, that allows you to define a plane. As soon as you 
click the OK button the dialog box is closed and the new 
plane Plane 1 is added to the Planes List. Using the Re-
name button you can give the plane a more appropriate 
name.

Delete This button allows you to delete a selected plane. 
Locked planes and the current work plane can not be 
deleted.

Redefine Clicking this button displays the Redefine Plane  dialog 
box, that allows you to redefine the selected plane.

Set Work This button allows you to make a selected plane the 
Work Plane. The work plane is indicated by a Checkmark.

Rename This button allows you to rename a selected plane in the 
Rename box.  Locked planes and the current work plane 
can not be renamed.

Selecting the Work Plane
1. Select the plane you want to make the work plane in the Define 

Plane dialog box.

2. Click the Set Work button.

Renaming a plane
1. Select in the plane you want to rename.

2. Overwrite the name with anew name in the Rename box.

3. Click the Rename button.

Locking/Unlocking a plane
1. Select the plane you want to lock/unlock in the Define Plane dialog 

box.

2. Click the Lock icon to unlock the plane or in front of  the name to 
lock the plane.

 If  the name was locked the Lock icon disappears, if  it was  unlocked 
the lock icon is displayed in front of  the name.

Deleting a plane
Select the plane you want to delete in the Define Plane dialog box and 
click the Delete button.

New/Redefine
If  you click the New or Refine button in the Define Plane dialog box 
the Redefine Plane dialog box is displayed:

 

How to define a plane is de-
scribed in the section New/
Redefine.

How to redefine a plane is 
 described in the section 
New/Redefine.

You can select the Work 
Plane also from the Planes 
submenu in the 3D menu.

You cannot rename the 
World (Top) plane, all locked 
planes and the current Work 
Plane.

You cannot delete the World 
(Top) plane, all locked  planes 
and the Work Plane.

You cannot edit the World 
(Top) plane, all locked 
planes and the Work Plane.
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The Redefine dialog box displays always the definition values of  the 
current work plane, either of  a selected Standard Plane or of  a Temporary 
Plane.

The Redefine dialog box contains the following elements:

Origin* These entry boxes display the coordinates for the Origin of  
the work plane. You can type in new values or indicate the 
new location of  the origin with a mouse click on the drawing 
area.

Right* The Right entry boxes display values for the direction of  the 
x axis. You can type in new values or indicate the new direc-
tion of  the x axis with the mouse on the drawing area. 

Up* The Up entry boxes display values for the direction of  the 
y axis. You can type in new values or indicate the new direc-
tion of  the y axis with the mouse on the drawing area. 

OK Clicking the OK button closes the Redefine dialog box and 
— in case the Redefine dialog box was displayed using the 
New button — a new plane is added to the Planes list in the 
Define dialog box.

 In case the Redefine dialog box was displayed using the 
Redefine button the orientation of  the selected plane is re-
defined.

Specifying a new work plane
Two different methods exist for defining a plane:

By a temporary plane
1. Define a temporary plane using the 3-Point Plane command.

2. Select the Define Plane command in the 3D menu.
 The Define Plane dialog box is displayed listing the temporary plane 

in the Planes list box.

3. Select the TempPlane in the Planes list box and rename the plane 
in the Rename entry box.

4. Click the Rename button.

5. Click the OK button.
 The Define Plane dialog box is closed and the new plane is  

added to the Planes submenu in the 3D menu.

By definition
1. Select the Define Plane command in the 3D menu.
 The Define Plane dialog box is displayed. 

2. Click the New button.
 The Redefine Plane dialog box displays and the Origin specifica-

tion is already highlighted.

3. On the drawing area, click the location for the new origin.
 The first Right entry box is selected.

4. Click a location on the positive x-axis on the drawing area.
 The first Up entry box is selected.

5. Click a location on the positive y-axis on the drawing area.

6. Click the OK button. 
 The Redefine Plane dialog box is closed and the new plane is de-

fined and added to the Planes submenu in the 3D menu. You can 
rename the new plane named Plane 1 using the Rename button in 
the Define Plane dialog box.

Redefining a plane
Two different methods exist for redefining a plane:

By a temporary plane
1. Define a temporary plane using the 3-Point Plane command.

2. Select the Define Plane command in the 3D menu.
 The Define Plane dialog box is displayed listing the temporary  plane 

in the Planes list box.

3. Delete the plane of  which you want to change the orientation.

You can modify the Origin 
and the Orientation of any 
plane except the World 
(Top) Plane.
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4. Select the TempPlane in the Planes list box and rename the plane 
with the name of  the deleted plane in the Rename entry box.

5. Click the Rename button.

5. Click the OK button.
 The plane is redefined and the Define Plane dialog box is closed.

By definition
1. Select the Define Plane command in the 3D menu.
 The Define Plane dialog box is displayed. 

2. Select the plane of  which you want to change the orientation.
 If  necessary, click the Lock icon to unlock the plane. 

3. Click the Redefine button.
 The Redefine Plane dialog box displays and the Origin specifica-

tion is already highlighted.

4. On the drawing area, click the location for the new origin.
 The first Right entry box is selected.

5. Click a location on the positive x-axis on the drawing area.
 The first Up entry box is selected.

6. Click a location on the positive y-axis on the drawing area.

7. Click the OK button. 
 The Define Plane dialog box is closed and the plane is redefined as 

indicated.

Set Plane to Screen
This command sets the work plane to be coincident with the screen, 
where the Origin of  the plane is in the Center of  the screen; the x-axis is 
coincident with the Width of  the screen and the y-axis is coin cident with 
the Height of  the screen. This sets the Work Plane to match the screen in 
all views which is  particularly useful when you are moving from view to 
view while drafting.

The Design Process
In DesignFreeQ you can create three-dimensional wireframe models. 
You can  view them from different angles and export them as wireframe 
models. For the creation of  wireframe models you proceed as follows:

• You create the three-dimensional wireframe model. With the help 
of  the Design Navigator you can design this model as easy as isomet-
ric drawing on a drafting board. We design the model in a three- 
dimensional work space using one or several view windows, to ob-
serve multiple view orientations while we are modeling.

• Optionally you can easily derive from the 3D model two-dimen-
sional draftings for  manufacturing containing several views on a 
drawing format with dimensions and notations.

First we will look at the additional tools and features that are specific to 
3D.

3D Features and Tools 
All of  the tools you would use to create 2D geometry in DesignFreeQ 
would also be used to create 3D geometry. However, there are some tools 
and features that are exclusive to 3D. One of  the most important features 
in 3D again is the Design Navigator.

3D Design Navigator
The Design Navigator is unique to DesignFreeQ and makes Design-
FreeQ easy to use in 3D because it thinks like a designer. It displays 
temporary  construction lines, provides information about existing 
 geometry, and displays notations of  the relationship between new and 
existing  geometry and it does this in three dimensions. The following are 
 examples of  the alignment notations for x, y, and z axes:

align: z A dynamic construction line along the z axis, perpendic-
ular to he work plane. 

You cannot redefine the 
standard work planes 
(Front and Right) without 
un locking them. You can 
never redefine the World 
(Top) plane, which was 
established from the original 
orientation of the  model 
space.

The Set Plane to Screen 
 command creates a tem-
porary plane that you can 
name using the Define 
 Plane command. The Set 
Plane to Screen  command 
sets not only the plane in 
the active view, but in all 
existing views (including all 
Detail Views) parallel to the 
screen.
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align: x A dynamic construction line along the x axis, par-
allel to he work plane.

   

align: y A dynamic construction line along the y axis, par-
allel to he work plane. 

   

align: 45° A dynamic construction line along the 45° angle, 
parallel to the work plane.

   

Isometric Drawing with the Design Navigator
With the help of  the Design Navigator 3D design becomes as easy 
as isometric drawing on a DesignFreeQ. The only thing we have 
to change is the view orientation so that we can see all three direc-
tions at once. In the following example we will chose a trimetric view:

  

1. Choose Trimetric from the View Mode submenu in the 
Views menu.

 The view and with it all temporary construction lines of  the 
Design Navigator will be aligned trimetrically.

2. Select the Connected Line tool from the Line subpalette on 
the Tool palette.

3. Begin by clicking in the middle of  the drawing area and move 
the pointer straight down along the align: z construction line 
about 2 cm and click.

 

4. Move the pointer along the align: x construction line about 2 
cm and click.

 

5. Continue clicking connected lines until your drawing appears 
as below:
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6. Move the pointer until the intersection notation appears and 
click.

 

7. Continue clicking according to th following pictures. 

 

8. Draw the three unconnected line with the Single Line.

  

In this small example you could see that 3D design with DesignFreeQ is 
as easy as isometric drawing only faster and more precise.

Extruding and Revolving of Objects
The two commands Extrude and Revolve in the 3D menu, allow you 
to create a 3D model from 2D geometry. The Extrude command adds 
depth to a 2D object, while the Revolve command copies and rotates a 
2D object to provide three dimensions.

        

      A 2D part is extrude to a 3D model.

                 

 A circle is rotated with the Revolve command to create a torus.

Extrude
This command adds depth to a 2D object. When you select the Extrude 
command from the 3D menu the following dialog box is  displayed:

 

The Extrude dialog box contains the following elements:

Direction In the entry fields dx, dy and dz you specify the number 
of  units for the Height of  the 2D object and the Direction 
(x, y, or z axis) in which the 2D object is to be extruded.
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 You can enter either positive or negative numbers to in-
dicate the units and direction, or you can drag the mouse 
to specify the distance and direction of  the extrusion.

Important: It is possible to indicate the extrusion values by dragging a vector 
on the drawing sheet in an Isometric or Trimetric view. Therefore you should 
always switch to one of  these views before  extruding any 2D object. Don’t forget that 
the extrusion angle between the extrusion vector and the current work plane must be 
always greater 0.

Extruding objects
To create the following bracket by extruding a basic 2D shape you have 
to proceed as follows:

  

1.  Select the Top view from the Views submenu in the Views menu.

2. Draw the side of  the bracket using th Connected Line tool.

  

3. Select the geometry if  it is not already selected.

4. Select Trimetric from the Views submenu in the Views menu.
 The side view of  the bracket is aligned trimetrically.

  

5.  Choose the Extrude command from the 3D menu.
 The Extrude dialog box is displayed.

6. Click in one of  the direction entry fields and drag then with the 
mouse a vector along the z axis in the drawing area to indicate the 
direction and distance of  the extrusion.

  

 The values dragged for the direction and the distance of  the  extrusion 
are automatically entered into the Direction boxes.

7. Overwrite the length of  the vector dragged in the dx box with 
the desired height of  the bracket. (Positive and negative values are 
 allowed.)

8. Click the OK button.
 he object is extruded.

  

Tip: Before you extrude any 2D geometry you should consider which face of  the 
object shows the most detail and whether the extrusion will be uniform or not if  some 
portions of  the part do have different dimensions. Depending on these considerations 
you should draw the 2D geometry.

Revolve
The Revolve command copies and revolves a 2D object into a 3D object 
around a specified revolution axis.

When you select the Revolve command from the 3D menu the following 
dialog box is displayed:

As default the x and y are 
on the current work plane 
and  z is  perpendicular 
to that plane.  In the Top 
view the positive z axis is 
extending toward you and 
the negative z axis away 
from you with the screen as 
 origin. This is not necessary 
relative to the original x, y, 
and z axis that were used 
when the geometry was 
constructed. Therefore you 
should always align the 
current work plane with that 
side of the object you want 
to be extruded.

All values you enter, use 
the current units set in the 
Preferences submenu of 
the Layout menu.
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The Revolve dialog box contains the following elements:

Sweep Angle In this field you enter the number of  degrees (Sweep 
Angle) for the revolution.

# of  Steps In this field you enter the number of  copies or  divisions.

Origin* In these entry fields you enter the coordinates for the 
Startpoint of  the Revolution axis.

Axis* In these entry fields you enter the coordinates for the 
Endpoint of  the Revolution axis.

Revolving objects
To revolve a 2D object into a 3D object you begin by drawing half  of  the 
object on n axis for revolving.

  

1. Draw the geometry to be revolved as n the following graphic.

  

2. Select the geometry if  it is not already selected.

3. Choose the Revolve command from the 3D menu.
 The Revolve dialog box is displayed.

4. Specify the Sweep Angle (360°) for the revolution.

5. Specify the number of  copies (2) in the # of  Steps entry field.
6. Click the Origin (Startpoint) of  the revolution axis.

7. Click the other end (Endpoint) o the revolution axis.

  

 The selected geometry is now revolved around the axis as specified, 
according to the right hand rule of  revolution.

Right-Hand Rule of Revolution
The direction of  revolution is determined by the Right-Hand Rule of  Revo-
lution which states: if  that the thumb is pointed toward the positive Axis 
of  Revolution, the revolution will be in the same direction in which the 
fingers are curled.

  

You indicate the Axis of 
 Revolution also by double 
clicking the Origin box and 
dragging a vector for the 
direction of the Revolution 
axis in the drawing area. 
The length of the vector is 
unimportant. The values 
of the dragged vector are 
 automatically entered into 
the Origin and Axis entry 
fields.

Important: Normally the # 
of Steps should be 2. Only 
when the Sweep Angle is 
360° you should enter 3 or 4 
for the # of Steps.

You indicate the Axis of 
 Revolution also by double 
clicking the Origin box and 
dragging a vector for the 
direction of the  Revolution 
axis in the drawing area.



3D Modelling

238

Rotating Objects
In DesignFreeQ you can not only rotate the view orientation to view the 
geometry from any angle, but also objects in relation to other objects.

Object Rotation
The Object Rotation command in the 3D menu allows you to rotate 
 geometry around any axis you specify.

The Object Rotation command displays the following dialog box:

 

The Object Rotation dialog box contains the following elements:

Rotate Angle In this field you specify the angle you want to rotate the 
geometry.

Origin* In these entry fields you enter the coordinates for the 
Startpoint of  the Rotation axis.

Axis* In these entry fields you enter the coordinates for the 
Endpoint of  the Rotation axis.

Copy When you select this option a copy of  the geometry  
will be rotated.

Apply When you click the Apply button the geometry will be 
rotated as specified and you can select another object 
for next object rotation.

Rotating objects
With the Object Rotation command you rotate geometry in relation to 
other objects.

1. Select the geometry you want to rotate.

2. Choose the Object Rotation command from the 3D menu.
 The Object Rotation dialog box is displayed.

3. Enter the angle you want to rotate the geometry into the Rotate 
Angle data field.

4. Click the Origin (Startpoint) of  the rotation axis.

5. Click the other end (Endpoint) of  the rotation axis.
6. Select the Copy option, if  you want to rotate a copy of  the selected 

object.
7. Click the Apply button.
 The object is rotated around the specified axis.

8. Select the next object for rotation or close the Object Rotation dia-
log box.

3D Construction Rules
For many of  the DesignFreeQ Drawing Tools and Commands certain rules 
must be observed

Drawing Tools in 3D
All DesignFreeQ Drawing tools behave in a three-dimensional work space 
according to certain rules. When you know these rules you can create any 
object geometry using these tools.

Lines Single, Connected and Parallel Lines have no 
3D restrictions.

 Tangent lines pulled off  a curve, circle or spline 
will be tangent if  created in the same plane as 
the curve, circle or spline.

Arcs Center-Point Arcs will be drawn parallel to the 
work plane.

 3-Point Arcs and Tangent-Point Arcs will be 
in the plane designated by the three points de-
fining the arc.

You indicate the Axis of 
Rotation also by double 
 clicking the Origin box and 
dragging a vector for the 
direction of the Rotation axis 
in the drawing area. The val-
ues of the dragged vector 
are automatically entered 
into the Origin and Axis 
entry fields.

You also can indicate the 
Axis of Rotation by double 
clicking the Origin box and 
dragging a vector for the 
direction of the  Rotation axis 
in the drawing area.

The Tracer tool does not 
work with 3D objects.

Tangent lines tangent only 
to one object can be created 
only with objects on the 
work plane at the origin 
(See as well Specifying the 
position of a work plane 
in this chapter). Tangent 
lines tangent to two objects 
can be created on any 
work plane as long as both 
objects are on the same 
work plane.
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Circles Center-Point Circles and Opposite-Point Cir-
cles will be drawn parallel to the work plane.

 3-Point Circles will be drawn in the plane des-
ignated by the three points defining the circle.

 Tangent Circles will be in the plane of  the two 
 defining entities.

Ellipses 2-Point Center Ellipses and Opposite-Point 
Ellipses will be drawn parallel to the work 
plane.

 3-Point-Center Ellipses and 3-Corner Ellips-
es will be drawn in the plane designated by the 
three points defining the ellipse.

Rectangles All rectangles and polygons will be created parallel 
to the work plane.

Splines Splines have no 3D restrictions.

Fillets and Chamfers Fillets and Chamfers are constructed in the plane 
 defined by the selected entities.

Editing Objects in 3D 
The Simple Trim tool, the Relimit tool and the Segment tool work in-
dependent from the current work plane as in 2D.

The Transformation tools behave as follows: 

Move Object geometry can be moved in any direction.

Rotate Selected geometry can be rotated around a spec-
ified point parallel to the z axis of  the current 
work plane.

Expand/Shrink Object geometry can be scaled in any direction.

Stretch Object geometry can be stretched in any direc-
tion.

Mirror Selected geometry can be mirrored parallel to 
the current work plane along a specified mirror 
axis.

Text and Dimensions
Text and Dimensions will be always created on the current work plane of  
the active view. Therefore you should set the work plane to correspond 
to the view before you begin adding text or dimensions in a view.

 

Dimensioning in 3D
All linear dimensions are placed parallel to the current work plane. All 
other dimensions behave as follows: 

Point to Point Point to Point dimensions are placed parallel to the 
current work plane.

Perpendicular Perpendicular dimensions are created in the plane 
of  the baseline.

Radial and Diametrial Radial and Diametrial dimensions are created in the 
plane of  the arc, circle or fillet.

Angular Angular dimensions are created in the plane of  the 
two lines whose angle is measured.

GD&T GD&T dimensions, Welding and Surface symbols are 
placed parallel to the current work plane.

Hatches and Solid Fills
Hatches and Fills are placed parallel to the current work plane only in that 
view in which they were crated. In other words hatches and fills will be 
only displayed correctly when you can look at the hatch or fill along the z 
axis of  the plane.

Before you rotate an 
object it is recommended 
to define a plane with the 
3-Point Plane command 
perpendicular to the  plane 
where the rotation point 
is located.

Another elegant method for 
dimensioning 3D objects is 
to align the face of the ob-
ject you want to dimension 
parallel to the screen and 
then to use the Set Plane to 
Screen command.

The Tracing tool does  
not work with three-dimen-
sional objects.
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Parametrics in 3D
The parametric feature works in 3D with some restrictions. You might 
consider its functionality as 2½ D since it functions properly in all  planes 
parallel to the current work plane.

The parametric mechanism has two phase:

1. In the first phase, parametrics ignore the z coordinates of  the  selected 
geometry and resolves the geometry as it does in 2D. Any  dimension 
that is not wholly in a plane parallel to x, y plane is also ignored. In 
other words, the x and y coordinates are resolved and the z coordinates 
are not changed.

2. In the second phase, parametrics adjust the z coordinates, as neces-
sary. All linear dimensions parallel to the z axis are  examined and 
every point in the selected geometry is considered to define a plane 
parallel to x, y plane. The dimensions in the z direction  define the 
required distance between the planes. Unlike the first phase, in the 
second phase parametrics is very tolerant of  missing dimensions. If  
the dimensions do not completely define the distance between any 
two planes, then the distance is not changed.

In Phase II any line or arc that does not lie in a plane parallel to the x, 
y plane is modified appropriately because the defining points are adjusted 
by parametrics and the line or arc is changed accordingly. This includes 
all lines parallel to the z axis and any oblique lines at any angle to all 
three axes.

Note that parametrics deals with all geometry in the current work plane 
coordinates. Consequently, it is a good idea to set up a view that looks 
down the z axis of  the work plane onto the x, y plane. In this way, you 
can see what the first phase of  the operation „sees“. This is particularly 
useful if  you encounter problems resolving parametric  geometry.

Errors in parametrics are shown in bold lines drawn in the x, y plane and 
independent of  the z values of  the highlighted lines. The easiest way to 
see this is to look down the x, y plane by choosing the View the Plane 
command from the 3D menu.

In the following drawing the first phase of  parametrics will deal with 
only four dimensions W, L, L/2 and L/4. In the second phase the H 
and H/3 dimensions are evaluated.

  

Be aware that if you get 
errors back, the highlighted 
lines and points are drawn 
right on the work plane, 
even though the geometry 
may not be drawn on the 
work plane.

The L/4 dimension was cre-
ated with the Horizontal Di-
mension tool, even though 
the dimensioned points have 
different z values. The H 
and H/3 dimensions were 
 created with the Vertical 
 Dimension tool while the 
work plane was set to the 
y, z plane.
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Appendix A: Operators and Units
This appendix describes mathematical and conditional operators.

Mathematical Operators
Many entry boxes accept mathematic, trigonometric, and exponential op-
erators in the form:

   funcName (arg1; arg2; . . . ; argN)

Operator Example

Addition 3+0,5 = 3,5

Subtraction 3-0,5 = 2,5

Multiplication 3*0,5 = 1,5

Division 3/0,5 = 6

Square Root sqrt(2) = 1,4142...

Parenthetical 3/(4+(1/0,5)) = 0,5

Scientific Notation 4e-3 = 0,004

Exponentiation exp(2;7) = 128

Sine of  Angle sin(30) = 0,5

Cosine of  Angle cos(60) = 0,5

Arctangent  atan(1;1) = 45 (°)

Log (Base 10) log(100) = 2

Natural Log (Base e) ln(2) = 0,6931

Remove Fractional Part truncate(1,4142) = 1

Absolute Value abs(-2) = 2

Smallest Larger Integer ceiling(1,4142) = 2

Largest Smaller Integer floor(1,4142) = 1

Negative Value neg(2) = -2

Round round(1,41) = 1

Random Number rand() = (random number)

Math operators are case-sensitive; so be sure to type them in lower case 
when you use them. You can use these operators to edit objects, make 
entries in the status line, and specify values in dialog boxes.

For divisions also a colon 
may be used instead of 
a slash.
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Conditional Expressions
Conditional expressions are particularly useful with Parametrics when an 
expression depends on a condition. For example, a flange might depend 
on the diameter of  a pipe but should never be smaller than some mini-
mum size. You can use two function forms of  conditional  expressions, 
ifelse and RNG (range).

 ifelse (condition; expression1; expression2)
Condition The result of  a boolean expression:

 = = equals

 != not equals

 >  greater than

 >= greater than or equals 

 <  less than

 <= less than or equals

 && logical and

 || logical or

 !  logical not 

expression1 The value of  the ifelse function if  the con-
dition is true.

expression2 The value of  the ifelse function if  the con-
dition is false.

The following examples show boolean expressions and an ifelse 
 statement:

Length > 5 The length is greater 5.

(L<3) || (W>=2) Either the length is less than 3 or the 
width is greater than or equal to 2.

3*ifelse ((A>B); A; B) Evaluate three times the maximum of  the 
variables A and B, returning 3*A if  A is 
larger than B and 3*B if  B is larger than A.

The range function is a more general form of  conditional expression.

 RNG (T; V1; N1; V2; N2; V3; N3; ... Vi; Ni; V, +1)

In this function, the first argument (T) is tested against every N value in 
the other arguments and returns the value (V) that lies between the two 
N values that bracket T. Each of  the test N values must be greater than 
the preceding N.

For example, the expression 

RNG (A; -1; 10; 0; 20; 1) returns  -1  if  A < 10

  0  if  10 <=  A<20

  1  if  A >=  20

Units of Measure
You can use different units of  measure such as inches ("), feet ('),  inches 
and feet (x'y"), millimeters (mm), centimeters (cm), and meters (m). You 
can also mix the units in the mathematical expression as long as you label 
the units properly—for example, 10" + 25.4 cm.

Nanoseconds
DesignFreeQ is well suited for computer hardware design, such as dia-
grams of  timing devices. For example, you can draw in nanoseconds (a 
billionth of  a second). 

Designs which include nanoseconds typically consist of  wave forms made 
of  horizontal and vertical lines which mimic the functions of  a timing 
device.

1. Specify Millimeters as the unit of  measure in the Units submenu 
of  the Preferences command in the Layout menu.

2. Choose Grid from the Preferences submenu.

3. Set the grid spacing to 34 and the number of  subdivisions to 2. 
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 A megahertz is approximately 34 nanoseconds and this becomes the 
base cycle, with two tick-marks for drawing half  cycles.

4. Turn on the Grid.

5. Use the Connected Line tool to draw the wave form of  the desired 
specifications.

6. Use the Stretch tool to stretch the wave form to half  and full cy-
cles.  

Using parametrics for wave forms.
You can use parametrics to speed up this process, as illustrated below. 
The dotted lines are constraint-lines.

 

Decimal Indicators
DesignFreeQ can handle both American and European decimal entries in 
the status line (24,5 or 24.5).

You can place the constraint 
lines on another layer and 
hide them if you want.
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Appendix B:  Special Characters 
You can use special characters and accents which are available with your 
computer. Usually these characters are described in the user  manual of  
your Operating System.

Special Characters for Microsoft Windows
You can enter many special characters from the keyboard. If  necessary, 
 unlock the keypad with the Num Lock key, and then hold down the Alt 
key and enter the numeric code for the character you want.

The character appears in the current font (including DesignFreeQ's 
Plotter font). The codes are listed in the Microsoft Windows User's Guide.

You can as well use the Windows Charset in the Accessories submenu of  
the Start menu to insert special characters into DesignFreeQ.

 Examples:  ° = Alt  0176

    Ø = Alt  0216
    ø = Alt  0248
    ± = Alt  0177
    © = Alt  0169

Special Characters for Macintosh-Computer
Many symbols and characters are available from the keyboard. To see the 
characters associated with a particular font, choose Key Caps from the 
Apple menu and select the font from the Font Menu. When you press 
the Command, Option, Shift, or Control key or combinations of  these 
keys, the keyboard graphic changes to show which characters are avail-
able.

In addition of  those characters you see in Key Caps, you can use 
the Option key to generate international accents in the current font, 
 including DesignFreeQ's Plotter font.

 Accent Key Combination

 é Option/e then letter to be accented

 è Option/~ then letter to be accented

 ñ Option/n then letter to be accented

 ô Option/t then letter to be accented

 ü Option/u then letter to be accented

The following list includes common symbols which are available in  
all fonts:

 Accent Key Combination

 ° Option/Shift 8

 ø Option O (letter or number)

 ± Option/Shift =

The ANSI-Code you enter 
must have 4 digits. If the 
code exists only of 3 digits 
you must place a leading 0, 
since the four digit code 
         0216 
doesn't have the same 
 result as 
         216.
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Appendix C: Data Interfaces
This appendix contains additional information on the data interfaces 
 already described in the manual.

DWG/DXF Interfaces
In general, it is recommended that you show all your layers before you 
export from DesignFreeQ or any other CAD package so that you know 
what objects are exporting.

• DesignFreeQ will always export only the current model. If  your 
file  contains  Detail Views, flatten them with the Flatten View 
 command found in the Views menu. If  you have dimensions  already 
in the  detail view and the view scale is set to 1, you can group the 
 dimensions and geometry together before flattening the view. This 
will bring the dimensions across to the current model for Export.

• The Export Thick Lines as 2D Polylines option in Design-
FreeQ's DXF Options dialog will convert all lines into Polylines. 
These come into AutoCAD as individual polylines and will not be 
 joined. To convert these lines (or any group of  lines you choose) 
to joined Polylines, use the PEDIT command in the command line 
of  AutoCAD, select the lines, and joint them with the JOIN com-
mand.

• AutoCAD doesn't accept any & character in a layer name.  Rename 
therefore all layers having a & character in their name. Otherwise 
AutoCAD will not import the file and generate an  error message 
 instead.

• In case line patterns are disorted (too big or too small) in AutoCAD 
after importing a DesignFreeQ DXF File, change the  AutoCAD 
variable LTSCALE to a smaller number to display the line patterns 
at an  appropriate scale.

• In case that after importing a DesignFreeQ DXF File into Auto-
CAD the  arrowheads of  some angular dimensions are  displayed in 
AutoCAD in the wrong direction (pointing towards the text rather 
than  towards the extension lines), execute the DIM command in 
 AutoCAD, select the affected dimensions, and use the UPDATE 
command to display the arrowheads.  

DXF Configuration Files
The two configurations files DXFVEL.CFG (Import) and VELDXF.
CFG (Export) allow you to set additional parameters for  colors, line  
 patterns, line weights and fonts. These two configurations files work like 
filters considering all  parameters specified in these files when importing 
or  exporting DXF- and DWG-Files. Both configuration files must be in 
the DesignFreeQ folder. Before modifying any of  these files you should 
read the related readme files VELDXF.TXT and DXFVEL.TXT for Win-
dows and DXF Doc and DXF-Info for the  Macintosh. Both files are ASCII 
Files that can be modified using any  simple Text Editor.

How exporting affects some objects
It is difficult to exchange data between different  graphics programs be-
cause each program defines geometric objects  differently. Even though 
the DXF/DWG and IGES formats standardize this exchange, some 
 objects do not transfer exactly. The following  table tells you what to 
 expect when you export DesignFreeQ objects.

DesignFreeQ   DXF/DWG
Hatches Hatches are exported as groups, except the 

 option  Ungroup hatches is active, then they 
are converted in  normal lines. 

Detail views All detail view will be exported, as long as not  
more than two models are displayed in Design-
FreeQ. In addition the selected AutoCAD Ver-
sion must  support  Modelspace and  Paperspace 
(Version 11 or higher). If  not all detail views must 
be flattened. 

If there are any problems 
with your exported DXF 
files you should use before 
creating any DXF file the 
Remove Dots, Check 
 Dimension and Select 
 Duplicates commands in 
the Utility menu. 

If these  commands are not 
listed in the Utility menu, 
they first must be added to 
this menu  according to the 
Customization section in 
chapter 4 of this  manual. In 
addition you should read the 
text files SelCopy.txt, Anti-
Dot.txt and Check Dim.txt in 
the Function folder in the 
DesignFreeQ  directory.  

The Sheet View will be 
 exported into the AutoCAD 
Paperspace and all  Detail 
Views into the AutoCAD 
Modelspace.
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Ellipses Ellipses are exported into AutoCAD Version 13 
or higher. For all previous versions  ellipses  are 
 approximated by line segments.

Fonts Fonts that are defined in the DXF Configuration 
files are maintained. 

GD&T GD&T frames will be correctly represented by 
lines and text, but cannot be edited any more, 
since they will be  exported as grouped block. 

Surface Symbols Surface symbols will be correctly represented by 
lines and text, but cannot be edited any more, 
since they will be  exported as grouped block. 

Welding Symbols Welding symbols will be correctly represent-
ed by lines and text, but cannot be edited any 
more, since they will be  exported as grouped 
block. 

Layer Layer will be maintained.

Locked Objects Objects are transferred correctly, but unlocked.

Sheets Each sheet must be exported separately. 

NURB-Splines NURB Splines are exported using AutoCAD 
Version 13 or higher. For all previous ver-
sions  NURB-Splines  are  approximated by line 
 segments.

Smart Walls Smart walls will be represented by simple lines.

Text Multi-line text in a text frame is exported as 
separate text lines.

Tolerances Tolerances are exported using AutoCAD  Version 
13 or higher. In all previous versions tolerances 
will go lost, but the dimensions are maintained. 

Models Since AutoCAD supports only one Modelspace,  
only one model can be exported from Design-
FreeQ into  AutoCAD. If  in DesignFreeQ  
2 or more models are  displayed in detail views on 
the current sheet, all views must be  exported. 
This will be automatically checked when 
 exporting  DWG/DXF-Files.  

DesignFreeQ IGES
Crosshatching The crosshatching is converted to symbol 

 representation.

Detail  views The view is lost but the dimensions 
and text are retained.

Diameter dimension The leader style may change.

Fonts Fonts are not maintained.

GD&T symbol The feature control frame is converted 
to a group of  non-GD&T geometry.

Surface symbol The Surface symbol is converted to 
  symbol  representation.

Welding symbol The Welding symbol is converted to 
  symbol  representation.

Grouped geometry The geometry is retained but it is no  longer 
grouped.

Layers The layers are lost but the geometry is 
 retained.

Locked geometry The geometry is retained but it is no  longer 
locked.

Multiple sheets Each sheet must be exported individually.

Radial dimensions The leader style may change.

If there are any problems 
with your exported IGES 
files you should use 
before creating any DXF 
or IGES file the  Remove 
Dots, Check Dimension 
and  Select Duplicates 
 commands in the Utility 
menu. 

In case these  commands 
are not listed in the Utility 
menu, you must add them to 
this menu as it is described 
in the Customization section 
in chapter 4 of this  manual.) 
In addition you should read 
the text files SelCopy.txt, 
AntiDot.txt and Check Dim.
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Smart walls The double lines are converted to symbol 
 representation.

Text A multiple line note becomes many single 
lines.

NURBs NURB Splines are  supported.
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Appendix D:  Plotter Fonts
You can use with DesignFreeQ all TrueType and PostScript Fonts 
available on your computer. In addition DesignFreeQ offers own Plotter 
Fonts that are listed below:

 

On the Macintosh 
only the font Plotter is 
 available.

The Windows version of 
DesignFreeQ contains in 
the Fonts subdirectory in 
the DesignFreeQ folder 
sample files that show for 
each character the  related 
ANSI Code. 

In addition to the plotter 
fonts   shipping with Design
FreeQ you can use all 
 plotter fonts with the .shx 
Format. You just must  copy 
these .shx files into the 
Fonts subdirectory of the 
DesignFreeQ folder. See as 
well in the Text chapter of 
this manual.
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Appendix E: Crosshatch Patterns
DesignFreeQ offers a multitude of  associative DIN and ANSI hatch 
patterns, of  which you can modify the spacing and angle. You will find these 
 hatches  organized in groups such as metals, fluids etc. in the Hatch dialog 
box. All hatch patterns contained in this library are listed below.
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Specifying Hatch Patterns
You specify your own hatch patterns by creating and binding in hatch de-
scription files into DesignFreeQ.

Hatch patterns are defined by hatch pattern lines, that are running through 
a defined origin and are endless repeated at a defined offset distance. 

Hatch  pattern lines are infinitely long. Each Hatch pattern line may contain 
single pattern elements to  create dashed or dotted pattern lines. A Crosshatch 
pattern has as well an infinite size and a hatched geometry shows only 
part of  this pattern like a detail window.

Creating Hatch description files
To bind in your own hatch pattern into DesignFreeQ you must save the 
Hatch description files as ASCII files into the DesignFreeQ folder

 ..\Scripts\ VSG\ Hatches

A Hatch description file can contain the description of  one or several cross-
hatch patterns. 

The file name of  a Hatch description file is displayed in the Crosshatch di-
alog box of  DesignFreeQ, if  it is copied in the folder mentioned above. 
The file extension of  this ASCII file must be always 

 *.pat 

Without this file  extension DesignFreeQ is not able to identify this file 
and cannot display the crosshatch patterns described in this file.

To create a Hatch description files you can use any Text Editor such as Note-
Pad for Windows or SimpleText for the  Macintosh.

Pattern Definitions
A Hatch description file contains several sections. The following  example 
explains the file structure describing a simple pattern at a  specific  angle:

 ;;

 ;;  DesignFreeQ

 ;;  Definition Angle Hatch Pattern

 ;;

 *ANGLE, Angle steel

 0, 0,0, 0,.275, .2,-.075

 90, 0,0, 0,.275, .2,-.07

Each file starts with a Comment line, that is indicated by a semicolon (;) 
before each comment.

All lines starting with a semicolon are  ignored by DesignFreeQ when 
interpreting the pattern description.

The Comment line is followed by the Header line that starts with an 
 asterisk (*)  followed by the pattern name and a pattern description. Name 
and Description must be separated by a comma (,)or a space ( ).

The Crosshatch dialog box of  DesignFreeQ shows only the name not 
the description. 

The name must be unique in the file. If  it isn't DesignFreeQ uses the 
first  pattern it finds by that name.

The length of  the Header line is limited to a maximum of  80 characters 
for Name, Comma and Description.

The header line is followed by the Hatch data. Every line of  data uses the 
same format:

  angle, x-origin, y-origin, x-offset, y-offset, [, dash1, ...] 

Angle  defines the angle that this line of  hatch pattern data is 
displayed at. O means that the hatch line is drawn hori-
zontally. 90 means that the line is drawn vertically.

Comma  separates the numbers.

x-origin  The first line of  the hatch pattern passes through this 
x-coordinate.
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y-origin  The first line of  the hatch pattern passes through this  
y-coordinate.

x-offset  defines the distance between line segments; the gap dis-
tance. You only use this parameter to specify the offset 
for vertical or diagonal lines (To specify the distance 
 between dashes, use the dash1 parameter. In most hatch 
patterns, the x-offset has a value of  0.0; however, even 
though this parameter is rarely used, it is not optional.

y-offset  defines the vertical distance between repeating lines; this 
parameter is used by every hatch pattern.

Dash1  You can use one or more dash1 parameters to define 
dashes in the hatch pattern line. The dash1 parameter 
is optional and not required for solid lines. A positive 
 number, such as .25 defines the length of  a dash. A dot 
drawn by the hatch pattern is defined by the value 0. But 
to be sure that dots will be printed by any type of  print-
er it is recommended to define for dots a very short 
dash1 parameters close to 0.

Tips on creating Pattern Codes
Each line of  code applies to a single pattern segment. The two lines of  
data in our example represent a hatch pattern with two lines.

There is no limit to the number of  data lines for hatch pattern defini-
tions. But complex patterns can take a long time to draw on the screen.

You cannot specify a weight or width for hatch pattern lines. The work 
around is to define two or more very closely spaced lines.

A pattern line consists of  straight lines  and dots. You cannot specify 
arcs, circles and other round elements in a hatch pattern file. To  simulate 
circular elements, use a series of  very short dashes.

To make it easier to read your hatch pattern code use tabs and spaces to 
format the code into nice columns like this:

 Angle x,y-origin x,y-offset 
dash codes  

 37.5, 0,0, 1.123,1.567 
1,-0.5,2,-0.5

The hatch description file 

 Extended.pat 

shipping can be modified for the creation of  your own patterns.

You find this file in the DesignFreeQ folder 

 ..\Scripts\ VSG\ Hatches
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Appendix F: DesignFreeQ.ini
The DesignFreeQ.ini file contains all default settings DesignFreeQ 
uses for any new drawing. The DesignFreeQ.ini file is an ASCII text file 
that can be opened and edited with any text editor.

To make changes to the DesignFreeQ.ini file open it from any text 
 editor and make the desired changes. Save the file as a text file. The next 
time DesignFreeQ is launched it will take account for the new setting 
made in the DesignFreeQ.ini file.

The DesignFreeQ.ini file contains the following sections:

[User]
This section contains the Name of  the registered user and the  registered 
company

 Name= 
 Company=

Both names will be automatically entered when installing DesignFreeQ.

 [Defaults]
In this section you can enter the Path and Name for the DesignFreeQ 
Preferences file Prefs.vlm as follows:

 PrefFile=c:\Programs\DesignFreeQ\prefs.vlm

You only should specify a path for the Preferences file in case you don't 
want to use the Preferences file in the DesignFreeQ folder.

Creating a individual Preference files for a Network version
When you want to create an individual Preference file for each user of  a 
DesignFreeQ network version you proceed as follows:

1. Create on the Network Server a folder (for example named 
 Preference) for all Preference files.

2. Create folders for each user in this folder.

3. Copy the files DesignFreeQ.ini and Prefs.vlm in each folder. 

4. Specify in each DesignFreeQ.ini file in the Default section the 
Path for the Preference file for the specific user:

  PrefFile=d:\Preferences\Smith\prefs.vlm

 where Preferences in this example is the name of  the general 
 Preferences folder and Smith the folder name of  one user.

5. Select the DesignFreeQ Program Icon on the Windows Desktop. 

6. Press the right mouse button and select Properties in the  displayed 
menu.

7. Enter in the Target entry box behind DesignFreeQ.exe the path 
for the DesignFreeQ.ini file for the respective user as follows:

 C:\Programs\DesignFreeQ\DesignFreeQ.exe /i:d:\Preferenc-
es\Smith\  DesignFreeQ.ini

;FILE LOCKING
 FileLock=ON 

When File Locking is activated (= on) all users can access a file in a net-
work, but only the user who opened the file first has the right to save this 
file. For a single user license File Locking should be  deactivated (=off).

File Locking works only if  there exists a file named public.key on the 
File Server on the network. This Public.key file can be created with any 
text editor. The Public.key file can be even empty, it should be only 
placed in the main directory of  the File Server.

;DISPLAYED FONTS
This section let you specify the number of  fonts that will be displayed 
in the Font submenu from the Text menu. Fonts that do not show up in 
this menu can be accessed in the Other dialog box.

If  you specify

 MaxFonts=30
a maximum number of  30 fonts will be displayed.
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;SCREEN
This option let you set the size of  the screen that DesignFreeQ opens 
to.

 Screen=FULL

opens to a maximized window.

 Screen=Standard

opens to the standard size, which is almost maximized, but with room 
for icons at the bottom. If  no value is specified, the screens opens to the 
standard size.

[RecentFiles]
The maximum number of  files that can be displayed in the Recent File List 
at the end of  the File menu is 8. 

 Files=6

[Symbol]
This section contains the path of  the Symbol folder relative to the 
DesignFreeQ folder

 VStandard=Symbols

All further paths specified describe the absolute paths for the symbol 
palettes in case you added them to the Utility menu using the Add com-
mand in the Utility menu.

 VMech=C:\Programs\DesignFreeQ\Symbols\Engineering 
VArch=C:\Programs\DesignFreeQ\Symbols\Architecture

[SymTab]
This section contains the position of  the Parameter dialog box that you 
can open in the Symbols dialog box.

 LISTBOX=[ 80 140 356 358]

[Palettes]
This section contains all palettes available in DesignFreeQ. Behind each 
 palette name the position of  the palette is specified and in a second sec-
tion if  the palette is visible or not (true/False): 

 Misc=190 80 
 Windows=100 275 
 Drawing=130 275 
 Bom=30 350 
 Dimension=10 345 
 Functions=30 440

 MiscVisible=false 
WindowsVisible=false 
DrawingVisible=false 
BomVisible=true 
DimensionVisible=false 
FunctionsVisible=false
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Index
Symbole
2D analysis  209
2D Analysis

Undo command  210
2-Entity Chamfer tool  80
2-Entity Fillet Tool  80
2-point center ellipse tool  23
3-corner ellipse tool  24
3D

3D-Models  213
construction rules  238
defining views  216
design process  233
editing objects  239
extrude [command]  235
features and tools  233
isometric drafting  234
multiple views  219
parametrics  240
revolve [command]  236
right-hand rule  228
rotating objects [command]  238
standard views  215
trackball  215
triad  228
two-dimensional drawings  222
view layouts  220
work plane  227
workspace  214

3-Entity Fillet Tool  80
3-point arc tool  20
3-point center ellipse tool  23
3-point circle  22
3-point plane  230
@ character  105
% point  36
# symbol  114

A
add commands  60
add functions  61
add spline control point tool  27
alignment angles  35
alignment (text)  101
analyses  209
angular chamfer tool  80
angular dimensions  120
arc length dimension tool  121
arc tools  20
arranging objects  92
arrows

arrow at end (command)  54
arrow at start (command)  54
arrowheads  53
arrow size  54
lines  53

ASCII  176
associative detail views  158
associative dimensions  113
asterisk  89
Auto Front  160
automatic dimensioning  64

autosave  56
autosave [command]  175
autotext  102

B
backups  175
back [view]  215
balloon (line style)  52
balloon symbols  121
bitmap  179
bmp  177
bottom [view]  215
bring to front [command]  92
bring to front [views]  160

C
center [Design Navigator]  33
center (line style)  52
center mark dimension  121
center-point arc tool  20
center-point circle tool  22
centimeter  55
centroid  210
chamfer tools  79
circle tools  21
clicking  14
clipboard  87
close (command)  176
color  44

color palette  47
fills  106
line  44
pen  44
with layers  152

conditional expressions  244
connected lines tool  18
constants  115
constraint lines  192
construction (command)  37
construction lines  36

creating construction geome-
try  38

dynamic  36
parallel  38
permanent  37
removing  39
strokes  37

construction (line style)  52
convert [command]  182
copy

copy (command)  87
objects with tools  84

corner trim tool  81
crosshatch  106

adding patterns  106
boundaries  106
crosshatch [command]  107
defining patterns  106
hatch (command)  108
origin  107
patterns  106, 251
specifying pattern  64
specifying patterns  252

customization
add commands  60
add functions  61
function interface  60
macros  57

cut (command)  86
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D
dash (line style)  52
data exchange  176
data interfaces  247
decimal indicators  245
default settings  57
define plane [command]  231
delete (command)  87
delete constructions (com-

mand)  39
design 4  220
DesignFreeQ.ini  254
Design Navigator

additionacreation angles  35
alignment angles  35
construction lines  36
DAssistant  34
dynamic construction lines  36
hit radius  35
permanent construction 

lines  37
perpendiculars  34
% Point  36
snap filter  35
snap points  33
stroke construction lines  37
tangents  34

Design Navigator (command)  34
detail views  158

non-associative  167
diagrams  244
dimensions

and status boxes  114
angular  120
arc length dimension  121
associative dimensions  113
automatic  64
balloon symbols  121
center mark  121
decimal indicators  245
diametral  120
dimension editor  122
extended radial arrow in  119
fixed  115
GD&T  127
horizontal  115
keep dimension text size  143
layer  114, 151
line style  52
oblique  117
parametric  188
perpendicular  118
radial  119
repositioning  114
settings  121
setting units  54
show palette  113
# symbol  114
text  114
tolerances  114
tools  113
vertical  116

dimetric [view]  216
directories [preferences]  56
divide (command)  93
documentation  9
documents  173

autosave  175
backup  175

close  176
convert  182
export  180
import  177
new  174
open  174
recent file list  174
save  174

draft 4  220
drafting

at full scale  140
creating a drawing  139
drawing size  144
process  139

drafting aids  15
drag&drop  98
dragging  14
drawing area  15
drawing formats  163

importing  163
modifying  164

drawing scale  141
drawing size (command)  144
drawing techniques  14
drawing tools  17
duplicating objects  88
dwg  177, 247
dxf   177, 247
dynamic construction lines  36

E
editing commands  86
edit objects (command)  91
edit pattern [command]  50
edit style (command)  52
ellipse tools  23
endpoint [Design Navigator]  33
eps  146, 177
erasing objects  87
expand/shrink tool  83
export  180
expressions  244
extended radial arrow in dimension  119
extrude [command]  235

F
feet  55
files

autosave  175
backups  175
close  176
convert  182
export  180
import  177
new  174
open  174
open by drag&drop  99
printing to  146
recent file list  174
save  174

fillet tools  79
fills  106

fill (command)  108
flatten all views [command]  222
flatten view [command]  222
floating tool palette  57
fonts  99

adding plotter fonts  64
forms  105
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front [view]  215
full scale  140
function interface  60
function plotters  29

G
GD&T  127
grid  55

preferences  56
group (command)  93

H
hidden (line style)  51
hit radius  35
horizontal dimensions  115
hpgl  146

I
ifelse  189, 244
igs  177
import  177

dxf  configuration  247
text file  97

inches  55
indentation (text)  102
inertia  210
inscribed polygon tool  26
intersection [Design Navigator]  33
invert [preferences]  56
isometric drawing  35
isometric [view]  216

K
keyboard snap points  34

L
layers

and color  152
and smart walls  153
construction  151
counting objects  152
dimensions  114, 151
example  153
hidden  152
layer groups  153

leading 0 (units)  55
left [view]  215
line

arrows  53
characteristics  43
color  44
defining pen styles  52
editing styles  52
editor  50
pattern  48
pen indicator  53
styles  43
tools  17
weight  47

linear duplicate (command)  88
lock (command)  94
lock spline control point tool  28

M
macros  57
message line  15
MetaFile  179

meters  55
midpoint [Design Navigator]  33
millimeters  55
mirror tool  83
models  156
model space  166
more (text command)  99
mouse

clicking  14
dragging  14
smart pointer  15

move tool  82

N
nanoseconds  244
new (command)  174

O
objects  69

counting  152
erasing  87
overlapping  71

oblique dimensions  117
offset (command)  90
OLE  98
open (command)  174
operators and units  243
opposite-corner ellipse tool  23
opposite-point circle tool  22
origin

crosshatch pattern  107
outline (line style)  51
overconstrained geometry  193
overlapping objects  71

P
palettes  56
pan tool  138
paper size  141
parallel construction lines  38
parallel lines tool  19
parametrics  187

anchoring geometry  191
arithmetic operators  188
basic rules  188
changing dimensions to actual 

measurements  191
colinear lines  197
complex drafting  196
conditional expressions  189
constants  188
constraint lines  192
dimensions  188
drafting  191
extraneous text  192
grouped objects  198
ifelse  189
in 3D  240
mathematical expression  188
overconstrained geometry  193
problem messages  193
problems  193
resolve [command]  189
rigid links  199
single points  194
# symbol  189
symbols  204
symmetry  195
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tangency  188, 195
testing  192
triangle link  199
unrelated groups  193
variables  188
variables as text file  190

paste (command)  87
pattern  48
pen

arrows  53
characteristics  43
color  44
editing line styles  52
pattern  48
pen indicator  53
styles  43
weight  47

permanent construction lines  37
perpendicular dimensions  118
perpendiculars  34
phantom (line style)  52
pict  176
planes

3-point plane  230
define plane [command]  231
moving the origin  230
planes [command]  229
Redefine Plane  232, 233
set plane to screen [com-

mand]  233
standard planes  229
temp plane  230
triad  228
work plane  227

plot scale  166
plotter fonts  143, 250
plotting  146
PNG  180
points

displaying  74
selectable points (com-

mand)  74
selecting invisible points  74
show points [command]  74

polar duplicate (command)  89
polygon tools  24
postscript  250
precision (units)  54
preferences

autosave  56
DesignFreeQ.ini  254
dimensions  121
directories  56
grid  56
invert  56
nits  56
palettes  56
saving  56
selection  56
setting units  54
snap  56
text margins  56

pref.vlm  56
preview layout (command)  142
print

drawing size  144
page setup (command)  141
preview layout (command)  142
print (command)  146

printing/plotting region  142
print setup (command)  141
tiled  147
to a file  146
TrueType Fonts on Pen Plotters  100

Q
quadrant [Design Navigator]  33
quit (command)  176

R
radial dimensions  119
recent file list  174
rectangle tools  24
redo (command)  88
redraw screen (command)  139
registration  10
relimit tool  81
remove dots [command]  63
resolve [command]  189
revolve [command]  236
right-hand rule  228
right [view]  215
rotate tool  82
rotating objects [command]  238
rules

3D construction rules  238
right-hand rule  228
right hand rule of  revolution  237
scaling  143

S
save (command)  174
scaling

drawings  142
drawing scale and paper size  141
drawing size  144
full scale  140
line patterns and crosshatch pat-

terns  143
object geometry  142
rules  143
text  100
text and dimensions  143
views  162
view scale  141

segment tool  81
selection

indicating  70
intersecting areas  72
invisible points  74
of  overlapped objects  71
points  73, 74
preferences  56
selectable points (command)  74
select all (command)  71, 73
select by line  71
select by polygon  72
selection (command)  70
selection mask (command)  73
selection tool  70
tracer  72

send to back [command]  92
send to back [views]  160
set plane to screen [command]  233
Sheet camera  165
sheet into view [command]  161
sheets  155
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sheet view  156, 158
show grid (command)  55
show palette [command]  63
show points (command)  74
shrink tool  83
simple trim tool  81
single line tool  17
size (text)  100
Sketch  179
smart pointer  15
smart wall tool  19
snap (command)  35
snap points

keyboard  34
solid fills  106

boundaries  106
fill (command)  108

solid models  213
spacing text  101
special characters  246
spline [import]  176
splines

editing  28
locking  28
tools  26
unlocking  28

standard views  215
status line  16

altering geometry  16
and dimensions  114
and drawing tools  16
creating additional geometry  16
creating geometry offset  17
creating new geometry  17

stretch tool  83
stroke commands

stroke construction lines  37
zooming  138

style
text  100

surface models  213
symbols  203

balloons  121
insertion point  203
invisible parts  204
libraries  206
parametrics  204
placing  205
# symbol  114
value tables  204
wall symbols  20

T
tangent-point arc tool  21
tangent-point circle tool  22
tangents  34
text  97

adding fonts  64
alignment  101
autotext  102
@ character  105
drag&drop  98
extended font selection  99
font  99
forms  105
importing  97
indentation  102
keep text size (option)  143
margins  56, 98

move  98
non-standard size  100
plotter fonts  143, 250
scaling  100
size  100
spacing  101
special characters  246
style  100
text blocks  102
text lines [command]  63
title blocks  104

thickness (line)  47
through-points spline tool  27
tiled printing  147
title blocks  104
tolerance dimensions  114
tools

arcs  20
chamfer tools  79
circles  21
copying objects  84
detail view tool  159
dimension tools  113
drawing tools  17
editing tools  79
ellipses  23
expand/shrink Tool  83
fillet tools  79
floating tool palette  57
function plotters  29
lines  17
mirror tool  83
move tool  82
panning  138
pölygons  24
rectangle  24
rotate tool  82
segment tool  81
selection  70
sizing objects  85
splines  26
stretch tool  83
text  97
text tool  97
transformation  82
trim tools  81
zooming  138

top [view]  215
tracer  72
trackball  215

view menu  216
trailing 0's (units)  55
transformation tools  82
triad  228
trimetric [view]  216
trim tools  81
truetype  250
txt  176

U
undo (command)  87
unfold view [command]  221
ungroup (command)  94
units  243

combining  244
decimal indicators  245
inches, feet  55
leading 0  55
mm, cm, meters  55
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nanoseconds  244
precision  54
preferences  56
settings  54
trailing 0's  55
units (command)  54

unlock (command)  94

V
vector spline tool  27
VellumPro  179
vertex [Design Navigator]  33
vertical dimensions  116
views  158

associative detail views  158
bring to front  160
defining 3D views  217
detail view tool  159
draw view boundaries  161
flatten all views [command]  222
flatten view [command]  222
layouts  220
multiple  219
plot scale  166
properties  159
scaling  162
scrolling within a view  160
send to back  160
sheet view  158
standard views  215
tools  138
unfold view [command]  221
view scale  160
view the plane [command]  221
zooming in detail views  160

view scale  141, 160
view the plane [command]  221
visible (line style)  51
vlm  176

W
walls

and layers  153
smart wall tool  19
symbols  20

wall symbols  20
weight  47
wireframe models  213
wmf   176
work plane  227

Z
zoom

commands  137
panning  138
stroke commands  138
tools  138
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